Personnalisation de l’IDECustomizing the IDE

Visual Studio pour Mac peut être personnalisé de plusieurs façons, permettant aux utilisateurs de développer des applications dans un environnement qui répond à leurs besoins en matière d’efficacité et d’esthétique.Visual Studio for Mac can be customized in a variety of ways, allowing users to develop apps in an environment that meets their needs for both efficiency and aesthetics. Cet article explore les différentes façons dont Visual Studio pour Mac peut être adapté à vos besoins.This article explores the variety of ways that Visual Studio for Mac can be adapted to suit your needs.

Thème foncéDark theme

Vue du thème foncé

Vous pouvez basculer entre les thèmes de Visual Studio pour Mac en accédant à Visual Studio > Préférences... > Environnement > Style visuel et en sélectionnant le thème de votre choix dans la liste déroulante Thème de l’interface utilisateur, comme illustré dans l’image suivante :You can switch themes in Visual Studio for Mac by browsing to Visual Studio > Preferences... > Environment > Visual Style and selecting your desired theme from the User Interface Theme drop-down, as illustrated in the following image:

Sélection du thème foncé

LocalisationLocalization

Visual Studio pour Mac est localisé dans les 14 langues suivantes, ce qui lui permet d’être accessible à un plus grand nombre de développeurs :Visual Studio for Mac is localized in the following 14 languages, enabling it to be accessible to more developers:

  • Chinois - ChineChinese - China
  • Chinois - TaïwanChinese - Taiwan
  • TchèqueCzech
  • FrançaisFrench
  • AllemandGerman
  • AnglaisEnglish
  • ItalienItalian
  • JaponaisJapanese
  • CoréenKorean
  • PolonaisPolish
  • Portugais - BrésilPortuguese - Brazil
  • RusseRussian
  • EspagnolSpanish
  • TurcTurkish

Pour changer la langue affichée par Visual Studio pour Mac, accédez à Visual Studio > Préférences... > Environnement > Style visuel et sélectionnez la langue de votre choix dans la liste déroulante Langue de l’interface utilisateur, comme illustré dans l’image suivante :To change the language displayed by Visual Studio for Mac, browse to Visual Studio > Preferences... > Environment > Visual Style and select your desired language from the User Interface Language drop-down, as illustrated in the following image:

Sélection de la langue

Informations sur l’auteurAuthor information

Le panneau d’informations sur l’auteur vous permet d’ajouter des informations pertinentes sur vous-même, comme votre nom, votre adresse de messagerie, le propriétaire du copyright de votre travail, votre entreprise et la marque déposée :The author information panel allows you to add relevant information about yourself such as your name, email address, the copyright owner for your work, your company, and trademark:

Modifier la section Informations sur l’auteur

Ces informations sont utilisées pour remplir les en-têtes de fichier standard, par exemple une licence, que vous pouvez ajouter aux nouveaux fichiers :This information is used to populate standard file headers, such as a license, that you might add to new files:

Options d’en-tête standard

Les champs Nom et E-mail sont utilisés dans les validations effectuées via la gestion de versions dans Visual Studio pour Mac.Populated Name and Email fields will be used in any commit that is made through Version Control in Visual Studio for Mac. Si vous n’avez pas rempli ces champs, Visual Studio pour Mac vous invite à le faire quand vous essayez d’utiliser la gestion des versions.If you have not populated these fields, Visual Studio for Mac will prompt you to do so when you try to use Version Control.

Combinaisons de touchesKey bindings

Les combinaisons de touches vous permettent d’adapter votre environnement de développement afin de vous déplacer plus efficacement dans Visual Studio pour Mac.Key bindings allow you to adapt your development environment so that you can move more efficiently throughout Visual Studio for Mac. Il fournit des combinaisons de touches courantes dans de nombreux IDE répandus, comme Visual Studio (Windows), ReSharper, Visual Studio Code et Xcode.It provides familiar key bindings for many popular IDEs, such as Visual Studio (Windows), ReSharper, Visual Studio Code, and Xcode.

Les combinaisons de touches peuvent être définies en accédant à Visual Studio > Préférences... > Environnement > Combinaisons de touches, comme illustré dans l’image suivante :Key bindings can be set by browsing to Visual Studio > Preferences... > Environment > Key Bindings, as illustrated by the following image:

Définir des combinaisons de touches

À partir d’ici, vous pouvez rechercher des combinaisons de touches, afficher les combinaisons en conflit, ajouter de nouvelles combinaisons et modifier les combinaisons existantes.From here you can search for key binding combinations, view conflicting bindings, add new bindings, and edit the existing bindings.

Disposition de l'espace de travailWorkspace layout

L’espace de travail de Visual Studio pour Mac se compose d’une zone de document principale (normalement l’éditeur, l’aire du concepteur ou le fichier d’options), entourée de panneaux complémentaires, qui contiennent des informations utiles pour l’accès et la gestion des fichiers d’application, pour le test et pour le débogage.Visual Studio for Mac's workspace consists of a main document area (normally the editor, designer surface, or options file), surrounded by complimentary pads that contain useful information for accessing and managing application files, testing, and debugging.

Disposition de l'espace de travail

Affichage et organisation des panneauxViewing and arranging pads

Quand vous ouvrez une nouvelle solution ou un nouveau fichier dans Visual Studio pour Mac, vous pouvez noter la présence de certains panneaux dans l’espace de travail, notamment le panneau Solution, Structure du document et Erreurs :When you open any new solution or file in Visual Studio for Mac, you should notice some pads in the workspace, including the Solution Pad, Document Outline, and Errors:

Panneaux Solution

Visual Studio pour Mac fournit des panneaux contenant des informations supplémentaires, des outils et des aides à la navigation, tous accessibles en sélectionnant l’élément de menu Afficher > Panneaux et en choisissant un panneau à ajouter :Visual Studio for Mac provides pads containing additional information, tools, and navigation aids, all of which can be accessed by browsing to the View > Pads menu item and selecting a pad to add it:

Sélectionner un nouveau panneau

Les panneaux peuvent aussi être ouverts automatiquement par différentes commandes, comme la commande Rechercher dans les fichiers (Maj+Cmd+F), qui ouvre un panneau flottant avec les résultats de la recherche.Pads may also be opened automatically by various commands, such as the Find in Files (Shift + Cmd + F) command, which opens a detached pad of search results.

Les panneaux peuvent être déplacés et organisés tout au long de votre flux de travail, de la façon la plus pratique pour vous.Pads can be moved and arranged throughout your workflow in whatever way is most useful to you. Par exemple, ils peuvent être ancrés sur n’importe quel côté de l’éditeur de document, adjacents à un autre panneau, au-dessus ou en dessous d’un autre panneau ou sous la forme d’un ensemble de panneaux à onglets qui vous permettent de passer rapidement de l’un à l’autre.For example, they can be docked on any side of the document editor, adjacent to another pad, above or below another pad, or as a set of tabbed pads enabling you to quickly switch between them.

Pour les panneaux fréquemment utilisés, vous pouvez également les détacher entièrement de la fenêtre de Visual Studio pour Mac et créer une fenêtre distincte pour ces panneaux.For frequently used pads, you can also completely detach a pad from the Visual Studio for Mac window, and create a separate window for that pad.

Les panneaux peuvent être masqués et fermés grâce aux commandes de bascule situées dans le coin supérieur droit de chaque panneau :Pads can be hidden and closed by the toggles in the top-right corner of each pad:

Masquage et fermeture des panneaux

Les panneaux masqués automatiquement sont ancrés sur les côtés de l’espace de travail, ce qui les rend facilement accessibles quand ils sont nécessaires.Auto-hidden pads are docked to the sides of the workspace making them easily accessible when they are required. Le fait de passer le pointeur de la souris sur le panneau l’affiche à nouveau, et il redevient masqué dès que la souris et le focus du clavier le quittent.Hovering over the pad will display it again, and it will be hidden when the mouse and keyboard focus leaves it.

Organisation des dispositionsOrganizing layouts

Les panneaux qui sont affichés à un moment donné dépendent du contexte actif.The pads that are displayed at any time are dependent on the current context. Par exemple, quand vous utilisez le concepteur visuel, les panneaux des outils et de la grille de propriétés sont les plus importants ; lors du débogage, il est pratique d’avoir les panneaux du débogueur pour afficher la pile et les variables locales.For example, when using the visual designer, the toolbox and property grid pads are most important; when debugging, it is useful to have the debugger pads for viewing the stack and locals.

L’état des panneaux ouverts est représenté par une disposition.The state of the open pads is represented by a layout. Vous pouvez changer les dispositions manuellement via le menu Affichage, comme illustré dans l’image suivante, ou elles changent elles-mêmes automatiquement quand vous exécutez une action, comme déboguer ou ouvrir un fichier Storyboard :The layouts can be switched manually through the View menu, as illustrated in the following image, or it is switched automatically when you carry out an action, such as debugging, or opening a Storyboard:

Sélection de nouvelles dispositions

Il n’existe qu’une seule disposition active à un moment donné, et toute modification apportée à une disposition, comme ajouter ou repositionner un panneau, change seulement la disposition active.There is always one active layout and any change you make in a layout, such as adding or repositioning a pad, will only change the active layout. Quand vous fermez Visual Studio pour Mac, les modifications que vous avez apportées ne seront pas enregistrées.Once you close Visual Studio for Mac, the changes you have made will not be saved.

Cependant, il est possible de créer une nouvelle disposition en utilisant l’élément de menu Afficher > Enregistrer la disposition active....However, it is possible to create a new layout by using the View > Save Current Layout... menu item. Ceci ajoute votre disposition actuelle au menu et vous permet de la sélectionner à tout moment :This will add your current layout to the menu so that you can select it at any time:

Enregistrer la disposition active

Prise en charge de l’édition côte à côteSide-by-side editing support

Visual Studio pour Mac vous permet d’ouvrir des éditeurs de texte côte à côte, ou d’avoir un éditeur dans une fenêtre flottante détachée.Visual Studio for Mac allows you to open text editors side-by-side, or to have an editor as a detached floating window.

Le mode 2 colonnes peut être activé via l’élément de menu Afficher, en sélectionnant Afficher > Colonnes de l’éditeur > 2 colonnes, ou en faisant glisser l’onglet d’un éditeur sur un des bords de la zone de l’éditeur :2-column mode can be enabled through the View menu item by selecting View > Editor Columns > 2 columns, or by dragging an editor tab to one of the edges of the editor area:

Mode deux colonnes côte à côte

Les onglets de l’éditeur peuvent être déplacés en dehors de la zone du document pour créer une fenêtre d’éditeur flottante.Editor tabs can be dragged out of the document area to create a floating editor window. Cette fenêtre flottante prend aussi en charge les éditeurs côte à côte et peut contenir plusieurs onglets d’éditeur :This floating window also supports side-by-side editors, and can contain several editor tabs:

Créer une fenêtre

Deux colonnes côte à côte avec des onglets supplémentaires

Pour revenir à un seul éditeur ouvert, sélectionnez Afficher > Colonnes de l’éditeur > 1 colonne.To revert to a single open editor, select View > Editor Columns > 1 column.