Bien démarrer avec la création de jeux à l’aide de Unity dans Visual Studio pour MacGetting started building games with Unity in Visual Studio for Mac

Unity est un moteur de jeu qui vous permet de développer des jeux en C#.Unity is a game engine that enables you to develop games in C#. Cette procédure pas à pas montre comment commencer à développer et à déboguer des jeux Unity à l’aide de Visual Studio pour Mac et de l’extension Outils Visual Studio pour Mac pour Unity à côté de l’environnement Unity.This walkthrough shows how to get started developing and debugging Unity games using Visual Studio for Mac and the Visual Studio for Mac Tools for Unity extension alongside the Unity environment.

L’extension Outils Visual Studio pour Mac pour Unity est une extension gratuite, installée avec Visual Studio pour Mac.Visual Studio for Mac Tools for Unity is a free extension, installed with Visual Studio for Mac. Elle permet aux développeurs Unity de tirer parti des fonctionnalités de productivité de Visual Studio pour Mac, notamment l’excellente prise en charge d’IntelliSense et les fonctionnalités de débogage, entre autres.It enables Unity developers to take advantage of the productivity features of Visual Studio for Mac, including excellent IntelliSense support, debugging features, and more.

ObjectifsObjectives

  • Découvrir le développement Unity avec Visual Studio pour MacLearn about Unity development with Visual Studio for Mac

PrérequisPrerequisites

Public concernéIntended Audience

Ce labo s’adresse aux développeurs qui connaissent C#. Une expérience approfondie n’est toutefois pas nécessaire.This lab is intended for developers who are familiar with C#, although deep experience is not required.

Tâche 1 : création d’un projet Unity de baseTask 1: Creating a basic Unity project

  1. Lancez Unity.Launch Unity. Connectez-vous si nécessaire.Sign in if requested.

  2. Cliquez sur Nouveau.Click New.

    Bouton New (Nouveau) dans Unity

  3. Définissez Project name (Nom du projet) sur « UnityLab » et sélectionnez 3D.Set the Project name to "UnityLab" and select 3D. Cliquez sur Créer un projet.Click Create project.

    Capture d’écran de la création d’un projet

  4. Vous êtes maintenant face à l’interface par défaut de Unity.You're now looking at the default Unity interface. Elle comporte, à gauche, la hiérarchie de la scène avec les objets de jeu, au milieu, une vue 3D de la scène vide, en bas, un volet de fichiers de projet et, à droite, l’inspecteur et les services.It has the scene hierarchy with game objects on the left, a 3D view of the blank scene shown in the middle, a project files pane on the bottom, and inspector and services on the right. Bien sûr, l’interface ne se limite pas à cela, mais ce sont là quelques-uns des composants les plus importants.Of course, there's a lot more to it than that, but those are few of the more important components.

    Interface de Unity vide

  5. Si, en tant que développeur, vous découvrez Unity, sachez que tout ce qui s’exécute dans votre application existe dans le contexte d’une scène.For developers new to Unity, everything that runs in your app will exist within the context of a scene. Un fichier de scène est un fichier unique qui contient toutes sortes de métadonnées sur les ressources utilisées dans le projet pour la scène actuelle et ses propriétés.A scene file is a single file that contains all sorts of metadata about the resources used in the project for the current scene and its properties. Quand vous empaquetez votre application pour une plateforme, l’application résultante est une collection d’une ou plusieurs scènes ainsi que tout code dépendant de la plateforme ajouté par vos soins.When you package your app for a platform, the resulting app will end up being a collection of one or more scenes, plus any platform-dependent code you add. Vous pouvez avoir autant de scènes que vous le souhaitez dans un projet.You can have as many scenes as desired in a project.

  6. La nouvelle scène comporte simplement une caméra et une lumière directionnelle.The new scene just has a camera and a directional light in it. Une scène nécessite une caméra pour les éléments qui doivent être visibles et un écouteur audio pour les éléments qui doivent être audibles.A scene requires a camera for anything to be visible and an Audio Listener for anything to be audible. Ces composants sont attachés à un GameObject.These components are attached to a GameObject.

  7. Sélectionnez l’objet Main Camera (Caméra principale) dans le volet Hierarchy.Select the Main Camera object from the Hierarchy pane.

    Objet Main Camera mis en évidence dans le volet Hierarchy

  8. Sélectionnez le volet Inspector à droite de la fenêtre pour consulter ses propriétés.Select the Inspector pane from the right side of the window to review its properties. Les propriétés de la caméra incluent les informations de transformation, l’arrière-plan, le type de projection, le champ de vision, etc.Camera properties include transform information, background, projection type, field of view, and so on. Un composant Audio Listener (écouteur audio) a également été ajouté par défaut, qui se charge essentiellement de restituer le flux audio de la scène à partir d’un microphone virtuel attaché à la caméra.An Audio Listener component was also added by default, which essentially renders scene audio from a virtual microphone attached to the camera.

    Volet de l’inspecteur

  9. Sélectionnez l’objet Directional Light (Lumière directionnelle).Select the Directional Light object. Cet objet fournit une lumière à la scène afin que les composants tels que les shaders sachent comment effectuer le rendu des objets.This provides light to the scene so that components like shaders know how to render objects.

    Objet Direction Light (Lumière directionnelle) mis en évidence

  10. Utilisez l’ Inspector , qui inclut des propriétés d’éclairage courantes, telles que le type, la couleur, l’intensité et le type d’ombre.Use the Inspector to see that it includes common lighting properties including type, color, intensity, shadow type, and so on.

    Consultation des propriétés dans le volet Inspector

  11. Il est important de souligner que les projets dans Unity sont légèrement différents de leurs équivalents dans Visual Studio pour Mac.It is important to point out that projects in Unity are a little different from their Visual Studio for Mac counterparts. Sous l’onglet Project en bas, cliquez avec le bouton droit sur le dossier Assets (Ressources) et sélectionnez Reveal in Finder (Révéler dans le Finder).In the Project tab on the bottom, right-click the Assets folder and select Reveal in Finder.

    Action de contexte pour révéler dans le Finder

  12. Les projets contiennent les dossiers Assets (Ressources), Library (Bibliothèque), ProjectSettings (Paramètres du projet) et Temp , comme vous pouvez le voir.Projects contain Assets , Library , ProjectSettings , and Temp folders as you can see. Toutefois, le seul dossier qui s’affiche dans l’interface est le dossier Assets (Ressources).However, the only one that shows up in the interface is the Assets folder. Le dossier Library (Bibliothèque) est le cache local pour les ressources importées ; il conserve toutes les métadonnées des ressources.The Library folder is the local cache for imported assets; it holds all metadata for assets. Le dossier ProjectSettings (Paramètres du projet) stocke des paramètres que vous pouvez configurer.The ProjectSettings folder stores settings you can configure. Le dossier Temp est utilisé pour les fichiers temporaires de Mono et Unity pendant le processus de génération.The Temp folder is used for temporary files from Mono and Unity during the build process. Il existe également un fichier solution que vous pouvez ouvrir dans Visual Studio pour Mac (en l’occurrence, UnityLab.sln ).There is also a solution file that you can open in Visual Studio for Mac ( UnityLab.sln here).

    Ressources dans le Finder

  13. Fermer la fenêtre Finder , puis revenez à Unity.Close the Finder window and return to Unity.

  14. Le dossier ressources contient toutes vos ressources (art, code, audio, etc.). C’est maintenant vide, mais chaque fichier que vous ajoutez à votre projet est ici.The Assets folder contains all your assets-art, code, audio, etc. It's empty now, but every single file you bring into your project goes here. Il s’agit toujours du dossier de niveau supérieur dans l’ éditeur Unity.This is always the top-level folder in the Unity Editor. Toutefois, veillez à ajouter et à supprimer des fichiers uniquement par le biais de l’interface de Unity (ou avec Visual Studio pour Mac) ; n’utilisez jamais le système de fichiers directement.But always add and remove files via the Unity interface (or Visual Studio for Mac) and never through the file system directly.

    Dossiers des ressources dans Unity

  15. Le type GameObject est au cœur du développement dans Unity, car presque tout en dérive, notamment les modèles, les lumières, les systèmes de particules, etc.The GameObject is central to development in Unity as almost everything derives from that type, including models, lights, particle systems, and so on. Ajoutez un nouvel objet Cube à la scène par le biais du menu GameObject > 3D Object > Cube.Add a new Cube object to the scene via the GameObject > 3D Object > Cube menu.

    Objet Cube dans la scène

  16. Jetez un coup d’œil aux propriétés du nouveau GameObject  ; comme vous pouvez le voir, il a un nom, une étiquette, un calque et une transformation.Take a quick look at the properties of the new GameObject and see that it has a name, tag, layer, and transform. Ces propriétés sont communes à tous les GameObjects.These properties are common to all GameObjects. En outre, plusieurs composants ont été attachés au Cube pour fournir les fonctionnalités nécessaires, notamment un filtre de maillage, un collider en forme de boîte et un renderer.In addition, several components were attached to the Cube to provide needed functionality including mesh filter, box collider, and renderer.

    Propriétés de l’objet de jeu

  17. Renommez l’objet Cube , qui porte le nom « Cube » par défaut, en « Enemy ».Rename the Cube object, which has the name "Cube" by default, to "Enemy". Veillez à appuyer sur Entrée pour enregistrer la modification.Make sure to press Enter to save the change. Il s’agira du cube de l’ennemi dans notre jeu simple.This will be the enemy cube in our simple game.

    Propriété permettant de renommer l’objet Cube

  18. Ajoutez un autre objet Cube à la scène en suivant le même processus que ci-dessus, puis nommez cet objet « Player ».Add another Cube object to the scene using the same process as above, and name this one "Player".

    Renommer le second objet Cube

  19. Attribuez à l’objet player l’étiquette « Player» également (consultez le contrôle déroulant Tag (Étiquette) juste en dessous du champ du nom).Tag the player object "Player" as well (see Tag drop-down control just under name field). Nous allons l’utiliser dans le script de l’ennemi pour aider à localiser l’objet de jeu player.We'll use this in the enemy script to help locate the player game object.

    Étiquetage de l’objet player

  20. Dans la vue Scene , éloignez l’objet player de l’objet enemy sur l’axe des Z à l’aide de la souris.In the Scene view, move the player object away from the enemy object along the Z axis using the mouse. Vous pouvez effectuer un déplacement le long de l’axe des Z en sélectionnant le cube par sa face rouge et en le faisant glisser le long de la ligne bleue.You can move along the Z axis by selecting and dragging the cube by its red panel toward the blue line. Étant donné que le cube réside dans un espace 3D, mais qu’il ne peut être déplacé que sur un plan 2D, l’axe le long duquel vous effectuez le glissement est particulièrement important.Since the cube lives in 3D space, but can only be dragged in 2D each time, the axis on which you drag is especially important.

    Vue de la scène montrant le cube

  21. Déplacez le cube vers le bas et vers la droite le long de l’axe.Move the cube downward and to the right along the axis. Cette action met à jour la propriété Transform.Position dans l’ Inspector.This updates the Transform.Position property in the Inspector. Pour faciliter les étapes ultérieures dans le labo, veillez à effectuer le glissement vers un emplacement de la même manière qu’illustrée ici.Be sure to drag to a location similarly to what's shown here to make later steps easier in the lab.

    Déplacement d’un cube le long de l’axe

  22. Vous pouvez maintenant ajouter du code pour gérer la logique de l’ennemi afin qu’elle poursuive le joueur.Now you can add some code to drive the enemy logic so that it pursues the player. Cliquez avec le bouton droit sur le dossier composants dans la fenêtre projet et sélectionnez créer > script C#.Right-click the Assets folder in the Project window and select Create > C# Script.

    Action de contexte de script C#

  23. Nommez le nouveau script C# « EnemyAI ».Name the new C# script "EnemyAI".

    Script C#

  24. Vous pouvez attacher des scripts aux objets de jeu. En l’occurrence, faites glisser le script qui vient d’être créé vers l’objet Enemy dans le volet Hierarchy.To attach scripts to game objects drag the newly created script onto the Enemy object in the Hierarchy pane. Cet objet utilisera désormais les comportements définis dans ce script.Now that object will use behaviors from this script.

    Mise en évidence de l’ajout d’un script à un objet de jeu

  25. Sélectionnez File > Save Scenes (Fichier > Enregistrer les scènes) pour enregistrer la scène actuelle.Select File > Save Scenes to save the current scene. Nommez-la « MyScene ».Name it "MyScene".

Tâche 2 : utilisation des outils de Visual Studio pour Mac pour UnityTask 2: Working with Visual Studio for Mac Tools for Unity

  1. La meilleure façon de modifier du code C# consiste à utiliser Visual Studio pour Mac.The best way to edit C# code is to use Visual Studio for Mac. Vous pouvez configurer Unity afin qu’il utilise Visual Studio pour Mac en tant que gestionnaire par défaut.You can configure Unity to use Visual Studio for Mac as its default handler. Sélectionnez Unity > Preferences.Select Unity > Preferences.

  2. Sélectionnez l’onglet outils externes . Dans la liste déroulante éditeur de script externe , sélectionnez Parcourir , puis sélectionnez applications/Visual Studio. app.Select the External Tools tab. From the External Script Editor dropdown, select Browse and select Applications/Visual Studio.app. Vous pouvez aussi sélectionner simplement l’option Visual Studio , si elle est déjà présente.Alternatively, if there's already a Visual Studio option, just select that.

    Onglet External Tools (Outils externes) dans les préférences

  3. Unity est maintenant configuré pour utiliser Visual Studio pour Mac pour la modification des scripts.Unity is now configured to use Visual Studio for Mac for script editing. Fermer la boîte de dialogue Unity Preferences.Close the Unity Preferences dialog.

    Visual Studio sélectionné dans les préférences

  4. Double-cliquez sur EnemyAI.cs pour l’ouvrir dans Visual Studio pour Mac.Double-click EnemyAI.cs to open it in Visual Studio for Mac.

    Ressource Enemy sélectionnée dans Unity

  5. La solution Visual Studio est simple.The Visual Studio solution is straightforward. Elle contient un dossier Assets (Ressources) (le même que celui dans le Finder ) et le script EnemyAI.cs créé précédemment.It contains an Assets folder (the same one from Finder ) and the EnemyAI.cs script created earlier. Dans les projets plus complexes, il est probable que la hiérarchie diffère de celle que vous voyez dans Unity.In more sophisticated projects, the hierarchy will likely look different than what you see in Unity.

    Fenêtre de solution dans Visual Studio pour Mac

  6. EnemyAI.cs est ouvert dans l’éditeur.EnemyAI.cs is open in the editor. Le script initial contient simplement des stubs pour les méthodes Start et Update.The initial script just contains stubs for the Start and Update methods.

  7. Remplacez le code initial de l’ennemi par le code ci-dessous.Replace the initial enemy code with the code below.

    public class EnemyAI : MonoBehaviour
    {
        public float Speed = 50;
        private Transform _playerTransform;
        private Transform _myTransform;
    
        void Start()
        {
            var player = GameObject.FindGameObjectWithTag("Player");
            if (!player)
            {
                Debug.LogError(
                    "Could not find the main player. Ensure it has the player tag set.");
            }
            else
            {
                _playerTransform = player.transform;
            }
            _myTransform = this.transform;
        }
    
        void Update()
        {
            var moveAmount = Speed * Time.deltaTime;
            _myTransform.position = Vector3.MoveTowards(_myTransform.position,
                _playerTransform.position, moveAmount);
    
            if (_myTransform.position == _playerTransform.position)
            {
                _myTransform.position = Vector3.back * 10;
            }
        }
    }
    
  8. Examinons rapidement le comportement simple de l’ennemi qui y est défini.Take a quick look at the simple enemy behavior that is defined here. Dans la méthode Start , nous obtenons une référence à l’objet player (par son étiquette) ainsi que sa transformation ( transform ).In the Start method, we get a reference to the player object (by its tag), as well as its transform. Dans la méthode Update , qui est appelée pour chaque image, l’ennemi se déplace vers l’objet player.In the Update method, which is called every frame, the enemy will move towards the player object. Les mots clés et les noms utilisent un codage de couleurs pour faciliter la compréhension de la base de code dans Visual Studio pour Mac.The keywords and names use color coding to make it easier to understand the codebase in Visual Studio for Mac.

  9. Enregistrez les modifications apportées au script de l’ennemi dans Visual Studio pour Mac.Save the changes to the enemy script in Visual Studio for Mac.

Tâche 3 : débogage du projet UnityTask 3: Debugging the Unity project

  1. Définissez un point d’arrêt sur la première ligne de code dans la méthode Start.Set a breakpoint on the first line of code in the Start method. Vous pouvez cliquer dans la marge de l’éditeur au niveau de la ligne cible ou placer le curseur sur la ligne et appuyer sur F9.You can either click in the editor margin at the target line or place cursor on the line and press F9.

    définition du point d’arrêt dans Visual Studio pour Mac

  2. Cliquez sur le bouton Start Debugging (Démarrer le débogage) ou appuyez sur F5.Click the Start Debugging button or press F5. Cette action génère le projet et l’attache à Unity en vue du débogage.This will build the project and attach it to Unity for debugging.

    bouton Démarrer dans Visual Studio pour Mac

  3. Retournez à Unity et cliquez sur le bouton Run (Exécuter) pour démarrer le jeu.Return to Unity and click the Run button to start the game.

    Bouton d’exécution dans Unity

  4. Le point d’arrêt doit être atteint et vous pouvez maintenant utiliser les outils de débogage de Visual Studio pour Mac.The breakpoint should be hit and you can now use the Visual Studio for Mac debugging tools.

    accès au point d’arrêt dans Visual Studio pour Mac

  5. Dans la fenêtre variables locales , localisez le pointeur This , qui fait référence à un objet EnemyAI .From the Locals window, locate the this pointer, which references an EnemyAI object. Développez la référence ; vous pouvez alors parcourir les membres associés, tels que Speed.Expand the reference and see that you can browse the associated members like Speed.

    Fenêtre variables locales dans Visual Studio pour Mac

  6. Supprimez le point d’arrêt de la méthode Start de la même façon que vous l’avez ajouté : cliquez dessus dans la marge ou sélectionnez la ligne et appuyez sur F9.Remove the breakpoint from the Start method the same way it was added-by either clicking it in the margin or selecting the line and press F9.

    Suppression d’un point d’arrêt dans Visual Studio pour Mac en cliquant dessus

  7. Appuyez sur F10 pour ignorer la première ligne de code qui recherche l’objet de jeu Player à l’aide d’une étiquette en guise de paramètre.Press F10 to step over the first line of code that finds the Player game object using a tag as parameter.

  8. Placez le curseur de la souris au-dessus de la variable player dans la fenêtre de l’éditeur de code pour voir ses membres associés.Hover the mouse cursor over the player variable within the code editor window to view its associated members. Vous pouvez même développer la superposition pour voir les propriétés enfants.You can even expand the overlay to view child properties.

    fenêtre de débogage dans l’éditeur de Visual Studio pour Mac

  9. Appuyez sur F5 ou sur le bouton Run (Exécuter) pour continuer l’exécution.Press F5 or press the Run button to continue execution. Retournez à Unity pour voir le cube de l’ennemi s’approcher à plusieurs reprises du cube du joueur.Return to Unity to see the enemy cube repeatedly approach the player cube. Vous devrez peut-être ajuster la caméra s’il n’est pas visible.You may need to adjust the camera if it's not visible.

    Exécution de la scène dans Unity

  10. Retournez à Visual Studio pour Mac et définissez un point d’arrêt sur la première ligne de la méthode Update.Switch back to Visual Studio for Mac and set a breakpoint on the first line of the Update method. Il doit être atteint immédiatement.It should be hit immediately.

    Suppression d’un point d’arrêt dans Visual Studio pour Mac

  11. Supposons que la vitesse est trop rapide et que nous voulons tester l’impact de la modification sans redémarrer l’application.Suppose the speed is too fast and we want to test the impact of the change without restarting the app. Recherchez la variable Speed dans la fenêtre Autos (Automatique) ou Locals (Variables locales) et remplacez-la par « 10 » , puis appuyez sur Entrée.Locate the Speed variable within the Autos or Locals window and then change it to "10" and press Enter.

    Ajustement des variables dans la fenêtre des variables locales

  12. Supprimez le point d’arrêt et appuyez sur F5 pour reprendre l’exécution.Remove the breakpoint and press F5 to resume execution.

  13. Retournez à Unity pour voir l’application en cours d’exécution.Return to Unity to view the running application. Le cube de l’ennemi se déplace maintenant à un cinquième de la vitesse d’origine.The enemy cube is now moving at a fifth of the original speed.

    Fenêtre Unity avec l’application en cours d’exécution

  14. Arrêtez l’application Unity en recliquant sur le bouton Run (Exécuter).Stop the Unity app by clicking the Play button again.

    Arrêt de l’application Unity

  15. Retournez à Visual Studio pour Mac.Return to Visual Studio for Mac. Arrêtez la session de débogage en cliquant sur le bouton Stop (Arrêter).Stop the debugging session by clicking the Stop button.

    Arrêt de la session de débogage dans Visual Studio pour Mac

Tâche 4 : exploration des fonctionnalités Unity dans Visual Studio pour MacTask 4: Exploring Unity features in Visual Studio for Mac

  1. Visual Studio pour Mac fournit un accès rapide à la documentation Unity au sein de l’éditeur de code.Visual Studio for Mac provides quick access to Unity documentation within the code editor. Placez le curseur quelque part sur le symbole Vector3 dans la méthode Update et appuyez sur ⌘ Command + '.Place the cursor somewhere on the Vector3 symbol within the Update method and press ⌘ Command + '.

    Sélection de la méthode dans l’éditeur de Visual Studio pour Mac

  2. Une nouvelle fenêtre de navigateur s’ouvre sur la documentation de Vector3.A new browser window opens to the documentation for Vector3. Fermez la fenêtre du navigateur quand vous êtes satisfait.Close the browser window when satisfied.

    Fenêtre de navigateur ouverte sur la documentation

  3. Visual Studio pour Mac fournit également des assistances qui permettent de créer rapidement des classes de comportement Unity.Visual Studio for Mac also provides some helpers to quickly create Unity behavior classes. Dans l’ Explorateur de solutions , cliquez avec le bouton droit sur Assets (Ressources), puis sélectionnez Add > New MonoBehaviour (Ajouter > Nouveau MonoBehaviour).From Solution Explorer , right-click Assets and select Add > New MonoBehaviour.

    Action de contexte Nouveau MonoBehaviour

  4. La classe créée fournit des stubs pour les méthodes Start et Update.The newly created class provides stubs for the Start and Update methods. Après l’accolade fermante de la méthode Update , commencez à taper « onmouseup ».After the closing brace of the Update method, start typing "onmouseup". À mesure que vous tapez, la fonctionnalité IntelliSense de Visual Studio cerne rapidement la méthode que vous envisagez d’implémenter.As you type, notice that Visual Studio's IntelliSense quickly zeros in on the method you're planning to implement. Sélectionnez-la dans la liste de saisie semi-automatique proposée.Select it from the provided autocomplete list. Elle renseigne un stub de méthode pour vous, y compris tous les paramètres.It will fill out a method stub for you, including any parameters.

    IntelliSense dans Visual Studio pour Mac

  5. Dans la méthode OnMouseUp , tapez « base .»Inside the OnMouseUp method, type "base." pour voir toutes les méthodes de base à appeler.to see all of the base methods available to call. Vous pouvez également explorer les différentes surcharges de chaque fonction à l’aide de l’option de navigation entre les pages dans l’angle supérieur droit du contrôle suspendu d’IntelliSense.You can also explore the different overloads of each function using the paging option in the top-right corner of the IntelliSense flyout.

    exploration des surcharges dans Visual Studio pour Mac

  6. Visual Studio pour Mac vous permet également de définir facilement de nouveaux shaders.Visual Studio for Mac also enables you to easily define new shaders. Dans l’ Explorateur de solutions , cliquez avec le bouton droit sur Assets (Ressources), puis sélectionnez Add > New Shader (Ajouter > Nouveau Shader).From Solution Explorer , right-click Assets and select Add > New Shader.

    nouvelle action de nuanceur dans Visual Studio pour Mac

  7. Grâce au traitement complet des polices et des couleurs, le format du fichier d’un shader est facile à lire et à comprendre.The shader file format gets full color and font treatment to make it easier to read and understand.

    Mise en évidence de la syntaxe

  8. Retournez à Unity.Return to Unity. Comme vous pouvez le constater, dans la mesure où Visual Studio pour Mac utilise le même système de projet, les modifications apportées à un des deux endroits sont automatiquement synchronisées avec l’autre.You'll see that since Visual Studio for Mac works with the same project system, changes made in either place are automatically synchronized with the other. Maintenant, il est facile d’utiliser systématiquement le meilleur outil pour la tâche.Now it's easy to always use the best tool for the task.

    Panneau des ressources dans Unity

RésuméSummary

Dans ce labo, vous vous êtes initié à la création d’un jeu avec Unity et Visual Studio pour Mac.In this lab, you've learned how to get started creating a game with Unity and Visual Studio for Mac. https://unity3d.com/learnPour en savoir plus sur Unity, consultez.See https://unity3d.com/learn to learn more about Unity.