Aide dans Outil R pour Visual StudioHelp in R Tools for Visual Studio

L’aide R est intégrée directement à la fenêtre interactive de Visual Studio.Help for R is integrated directly into the interactive window in Visual Studio. Chaque fois que vous utilisez la commande ?, comme dans ?mtcars, une rubrique d’aide issue de la documentation R s’affiche dans une fenêtre Visual Studio :Whenever you use the ? command, such as ?mtcars, help from the R documentation appears in a Visual Studio window:

Fenêtre d’aide dans Visual Studio

Conseil

À l’instar des autres fenêtres dans Visual Studio, vous pouvez réorganiser et ancrer la fenêtre d’aide comme bon vous semble.The help window, like all others in Visual Studio, can be arranged and docked however you like. Consultez Personnaliser les dispositions de fenêtres dans Visual Studio.See Customize window layouts in Visual Studio.

Pour ouvrir les résultats de l’aide dans un navigateur, sélectionnez le menu Outils R > Options et affectez à la propriété Navigateur de l’aide R la valeur External.To open help results in a browser, select the R Tools > Options menu and set the R Help Browser property to External. Consultez Options.See Options.

Pour lancer une recherche dans l’aide, utilisez la commande ?? suivie du terme de recherche.To search help, use the ?? command followed by the search term. Utilisez des guillemets si le terme de recherche contient des espaces :Use quotes if the search term contains spaces:

??"Motor Trend"

Résultats d’une recherche dans l’aide

La fenêtre d’aide comprend également un champ d’entrée de recherche qui vous permet de lancer directement des recherches dans la documentation R :The help window also has a search input field through which you can conduct further searches in the R documentation directly:

Résultats d’une recherche dans l’aide effectuée au moyen du champ d’entrée

Recherche dans l’aide intégréeIntegrated help lookup

Les développeurs recherchent souvent de l’aide sur les noms de fonctions, les datasets et d’autres éléments dans la documentation R.Developers often search the R documentation for help on function names, datasets, and other elements. Les outils R pour Visual Studio (RTVS) simplifient le processus en intégrant des fonctions de recherche directement dans l’éditeur et les fenêtres interactives.R Tools for Visual Studio (RTVS) streamlines the process by integrating help lookups directly into the editor and interactive windows.

  • Appuyez sur F1 pendant une opération de saisie semi-automatique pour générer une liste de rubriques d’aide correspondant à la sous-chaîne.Pressing F1 during an auto-complete operation produces a list of help results that match the substring.
  • Cliquez avec le bouton droit sur un terme de recherche (comme une fonction) et sélectionnez la commande Aide sur pour ouvrir la rubrique d’aide de cette fonction.Right-clicking a search term (like a function) and selecting the Help on command opens help for that function. Vous pouvez également appeler Aide sur pour n’importe quelle sélection.You can also invoke Help on for any selection.

    Appel de l’aide par le biais du menu contextuel

Conseil

Pour ouvrir l’aide intégrée dans un navigateur, sélectionnez Outils R > Options et affectez à Navigateur web (F1) la valeur External.To open integrated help in a browser, select R Tools > Options and set F1 Web Browser to External. Consultez Options.See Options.

Outre la documentation R, les développeurs consultent souvent StackOverflow quand ils écrivent du code.In addition to searching in the R documentation, developers often search StackOverflow while writing code. RTVS simplifie également ce processus.RTVS streamlines that process as well. Cliquez avec le bouton droit sur un terme ou une sélection et sélectionnez la commande Rechercher sur le web (Ctrl+F1). Visual Studio ouvre une fenêtre avec les résultats de la recherche limités à StackOverflow :Right-click a term or a selection, select the Search web for command (Ctrl+F1), and Visual Studio opens a window with search results scoped to StackOverflow:

Résultats d’une recherche web dans Visual Studio

Vous pouvez modifier la chaîne de portée ajoutée, R site:stackoverflow, à l’aide de l’option Outils R > Options > Chaîne de recherche web (F1) :You can change the appended scoping string, R site:stackoverflow, through the R Tools > Options > F1 Web search string option:

Changement de l’option de chaîne de recherche web (F1)

Si vous préférez afficher les résultats dans un navigateur, modifiez l’option Navigateur web (F1) comme décrit dans Options.If you prefer to show results in a browser, change the F1 Web Browser option as described on Options.