Bien démarrer avec Outils R pour Visual StudioGetting started with R Tools for Visual Studio

Après avoir installé Outils R pour Visual Studio (RTVS) (voir Installation), vous pouvez rapidement vous faire une idée de ce que ces outils ont à offrir.Once you have R Tools for Visual Studio (RTVS) installed (see Installation), you can quickly get a taste of the experience that those tools provide.

Créer un projet RCreate an R project

  1. Démarrez Visual Studio.Start Visual Studio.
  2. Choisissez Fichier > Nouveau > Projet. (Ctrl+Maj+N)Choose File > New > Project... (Ctrl+Shift+N)
  3. Sélectionnez « Projet R » sous Modèles > R, donnez au projet un nom et un emplacement, puis sélectionnez OK :Select "R Project" from under Templates > R, give the project a name and location, and select OK:

    Boîte de dialogue Nouveau projet pour R dans Visual Studio (RTVS dans VS2017)

  4. Une fois le projet créé, les fenêtres suivantes sont visibles :Once the project is created, you see the following windows:

    • L’Explorateur de solutions Visual Studio, situé à droite, comprend une solution qui contient votre projet.On the right is Visual Studio Solution Explorer, where you see your project inside a containing solution. (Les solutions peuvent contenir un nombre quelconque de projets de types différents ; pour plus d’informations, consultez Projets).(Solutions can contain any number of projects of different types; see Projects for details.
    • Un nouveau fichier R (script.R), situé en haut à gauche, vous permet de modifier le code source avec toutes les fonctionnalités d’édition de Visual Studio.On the top left is a new R file (script.R) where you can edit source code with all of Visual Studio's editing features.
    • La fenêtre R Interactive, située en bas à gauche, vous permet de développer et de tester votre code de manière interactive.On the bottom left is the R Interactive window in which you can interactively develop and test code.

Note

Vous pouvez utiliser la fenêtre R Interactive si aucun projet n’est ouvert (et même si un type de projet différent est chargé).You can use the R Interactive window without having any projects open, and even when a different project type is loaded. À tout moment, sélectionnez Outils R > Fenêtres > R Interactive.Just select R Tools > Windows > R Interactive at any time.

Explorer la fenêtre interactive et IntelliSenseExplore the Interactive Window and IntelliSense

  1. Pour vérifier que la fenêtre interactive fonctionne, tapez 3 + 4 et appuyez sur Entrée pour afficher le résultat :Test that the interactive window is working by typing in 3 + 4 and then Enter to see the result:

    Fenêtre R Interactive dans Visual Studio 2017 (VS2017)

  2. Entrez une commande un peu plus compliquée, par exemple ds <- c(1.5, 6.7, 8.9) * 1:12, puis entrez ds pour afficher le résultat :Enter something a little more complicated, ds <- c(1.5, 6.7, 8.9) * 1:12, and then enter ds to see the result:

    Autre exemple interactif pour R dans Visual Studio

  3. Tapez mean(ds). Notez que, dès que vous tapez m ou me, la fonctionnalité IntelliSense de Visual Studio propose des options de saisie semi-automatique.Type in mean(ds) but notice that as soon as you type m or me, Visual Studio IntelliSense provides auto-completion options. Après avoir sélectionné la saisie semi-automatique désirée dans la liste, appuyez sur Tab pour l’insérer. Vous pouvez changer de sélection à l’aide de la souris ou des touches de direction.When the completion you want is selected in the list, press Tab to insert it; you can change the selection with the arrow keys or the mouse.

    Apparition d’IntelliSense quand vous entrez du code

  4. Une fois la saisie de mean terminée, tapez la parenthèse ouvrante ( et notez l’aide en ligne que vous propose IntelliSense pour la fonction :After completing mean, type the opening parenthesis ( and note how IntelliSense gives you inline help for the function:

    IntelliSense affichant de l’aide pour une fonction

  5. Terminez la saisie de la ligne mean(ds) et appuyez sur Entrée pour afficher le résultat ([1] 39.51667).Complete the line mean(ds) and press Enter to see the result ([1] 39.51667).

  6. La fenêtre interactive est intégrée à l’aide. Par exemple, entrez ?mean pour afficher de l’aide pour cette fonction dans la fenêtre Aide R de Visual Studio.The Interactive window is integrated with help, so entering ?mean displays help for that function in the R Help window in Visual Studio. Pour plus d’informations, consultez Aide dans les outils R pour Visual Studio.For details, see Help in R Tools for Visual Studio.

    Fenêtre d’aide R dans Visual Studio

  7. Certaines commandes, telles que plot(1:100), ouvrent une nouvelle fenêtre dans Visual Studio quand la sortie ne peut pas être affichée directement dans la fenêtre interactive :Some commands, such as plot(1:100), open a new window in Visual Studio when the output can't be displayed directly in the interactive window:

    Affichage d’un tracé dans Visual Studio

La fenêtre interactive vous permet également de passer en revue votre historique, de charger et d’enregistrer des espaces de travail, d’attacher un débogueur et d’interagir avec des fichiers de code source au lieu d’effectuer des opérations de copier-coller.The interactive window also lets you review your history, load and save workspaces, attach to a debugger, and interact with source code files instead of using copy-paste. Pour plus d’informations, consultez Utilisation de la fenêtre interactive R.See Working with the R Interactive Window for details.

Découvrir les fonctionnalités de modification du codeExperience code editing features

En utilisant brièvement la fenêtre interactive, vous avez pu découvrir des fonctionnalités de modification de base, comme IntelliSense, qui fonctionnent aussi dans l’éditeur de code.Working briefly with the interactive window demonstrates basic editing features like IntelliSense that also work in the code editor. Si vous entrez le même code que précédemment, les invites de saisie semi-automatique et IntelliSense affichées sont les mêmes, mais la sortie n’est pas visible.If you enter the same code as before, you see the same auto-completion and IntelliSense prompts, but not the output.

Le fait d’écrire du code dans un fichier .R vous permet de voir tout votre code à la fois, ce qui facilite l’apport de modifications mineures et l’affichage rapide des résultats en exécutant le code dans la fenêtre interactive.Writing code in a .R file lets you see all your code at once, and makes it easier to make small changes and then quickly see the result by running the code in the interactive window. Notez aussi qu’un projet peut contenir autant de fichiers que vous le souhaitez.You can also have as many files as you want in a project. Quand le code se trouve dans un fichier, vous pouvez également l’exécuter pas à pas dans le débogueur (comme nous le verrons plus tard dans cet article).When code is in a file, you can also run it step-by-step in the debugger (discussed later in this article). Ces fonctionnalités s’avèrent utiles quand vous développez des algorithmes de calcul et que vous écrivez du code pour manipuler un ou plusieurs datasets, surtout quand vous souhaitez examiner tous les résultats intermédiaires.These capabilities are helpful when you're developing computational algorithms and writing code to manipulate one or more datasets, especially when you want to examine all intermediate results.

Par exemple, les étapes suivantes créent un petit extrait de code pour explorer le théorème central limite (Wikipédia).As an example, the following steps create a little code to explore the Central Limit Theorem (Wikipedia). (Cet exemple est tiré du livre R Cookbook de Paul Teetor.)(This example is adapted from the R Cookbook by Paul Teetor.)

  1. Dans l’éditeur script.R, entrez le code suivant :In the script.R editor, enter the following code:

    mu <- 50
    stddev <- 1
    N <- 10000
    pop <- rnorm(N, mean = mu, sd = stddev)
    plot(density(pop), main = "Population Density", xlab = "X", ylab = "")
    
  2. Pour afficher rapidement les résultats, sélectionnez tout le code (Ctrl+A), puis appuyez sur Ctrl+Entrée ou cliquez avec le bouton droit et sélectionnez Exécuter en mode interactif.To quickly see the results, select all the code (Ctrl+A), then press Ctrl+Enter or right-click and select Execute In Interactive. Tout le code sélectionné est exécuté dans la fenêtre interactive comme si vous l’aviez tapé directement. Le résultat s’affiche dans une fenêtre de tracés :All the selected code is run in the interactive window as if you typed it directly, showing the result in a plot window:

    Affichage d’un tracé dans Visual Studio

  3. Pour une ligne unique, appuyez simplement sur Ctrl+Entrée à tout moment pour l’exécuter dans la fenêtre interactive.For a single line, just press Ctrl+Enter at any time to run that line in the interactive window.

Conseil

Nous vous recommandons d’apporter des modifications et d’appuyer sur Ctrl+Entrée pour exécuter rapidement le code. Vous pouvez aussi sélectionner tout votre code avec Ctrl+A, puis appuyer sur Ctrl+Entrée.Learn the pattern of making edits and pressing Ctrl+Enter (or selecting everything with Ctrl+A and then pressing Ctrl+Enter) to quickly run the code. Sur des opérations identiques, vous obtiendrez de meilleurs résultats qu’avec la souris.Doing so is much more efficient than using the mouse for the same operations.

Par ailleurs, vous pouvez faire glisser et déplacer la fenêtre de tracés à l’extérieur du cadre de Visual Studio et placer tout autre élément désiré sur votre écran.In addition, you can drag and drop the plot window out of the Visual Studio frame and place it whenever else you want on your display. Vous pouvez ensuite redimensionner la fenêtre de tracés à la taille souhaitée, puis l’enregistrer dans un fichier image ou PDF.You can then resize the plot window to the dimensions you want and then save it to an image or PDF file.

  1. Ajoutez quelques lignes de code pour inclure un second tracé :Add a few more lines of code to include a second plot:

    n <- 30
    samp.means <- rnorm(N, mean = mu, sd = stddev / sqrt(n))
    lines(density(samp.means))
    
  2. Appuyez une nouvelle fois sur Ctrl+A et sur Ctrl+Entrée pour exécuter le code, et obtenir le résultat suivant :Press Ctrl+A and Ctrl+Enter again to run the code, producing the following result:

    Tracé double mis à jour dans Visual Studio

  3. Le problème, c’est que le premier tracé détermine l’échelle verticale et qu’il ne reste pas assez de place pour le second (avec lines).The problem is that the first plot determines the vertical scale, so the second plot (with lines) doesn't fit. Pour corriger ce problème, nous devons définir le paramètre ylim sur l’appel plot. Cependant, pour bien faire, nous devons ajouter du code pour calculer la valeur verticale maximale.To correct this problem, we need to set the ylim parameter on the plot call, but do so that properly we need to add code to calculate the maximum vertical value. Le fait de procéder ligne par ligne dans la fenêtre interactive est peu pratique, car nous devons réorganiser le code pour utiliser samp.means avant d’appeler plot.Doing this line-by-line in the interactive window is inconvenient because we need to rearrange the code to use samp.means before calling plot. Cependant, dans un fichier de code, nous pouvons apporter facilement les modifications appropriées :In a code file, though, we can easily make the appropriate edits:

    mu <- 50
    stddev <- 1
    N <- 10000
    pop <- rnorm(N, mean = mu, sd = stddev)
    
    n <- 30
    samp.means <- rnorm(N, mean = mu, sd = stddev / sqrt(n))
    max.samp.means <- max(density(samp.means)$y)
    
    plot(density(pop), main = "Population Density",
        ylim = c(0, max.samp.means),
        xlab = "X", ylab = "")
    lines(density(samp.means))
    
  4. Appuyez sur Ctrl+A et sur Ctrl+Entrée une nouvelle fois pour afficher le résultat :Ctrl+A and Ctrl+Enter again to see the result:

    Tracé double mis à jour dans Visual Studio, mis à l’échelle correctement

L’éditeur offre bien d’autres fonctionnalités.There's more you can do in the editor. Pour plus d’informations, consultez Modification du code, IntelliSense et Extraits de code.For details, see editing code, IntelliSense, and code snippets.

Débogage de votre codeDebugging your code

L’un des atouts de Visual Studio est son interface utilisateur de débogage.One of the key strengths of Visual Studio is its debugging UI. Bâti sur cette fondation solide, RTVS ajoute des éléments d’interface utilisateur novateurs comme l’explorateur de variables et la visionneuse de table de données.RTVS builds on top of this strong foundation and adds innovative UI such as the Variable Explorer and Data Table Viewer. Ici, nous allons examiner succinctement le débogage.Here, let's just take a first look at debugging.

  1. Pour commencer, utilisez la commande de menu Outils R > Session > Réinitialiser pour réinitialiser l’espace de travail actuel et effacer tout ce que vous avez fait jusqu’à présent.To begin, reset the current workspace to clear everything you've done so far by using the R Tools > Session > Reset menu command. Par défaut, toutes les actions que vous réalisez dans la fenêtre interactive sont ajoutées à la session active, celle-ci étant ensuite utilisée par le débogueur.By default, everything you do in the interactive window accrues to the current session, which is then also used by the debugger. La réinitialisation de la session vous permet de démarrer la session de débogage sans données préexistantes.By resetting the session, you ensure that the debugging session starts with no pre-existing data. Toutefois, la commande Réinitialiser n’affecte pas votre fichier source script.R, car celui-ci est géré et enregistré en dehors de l’espace de travail.The Reset command, however, doesn't affect your script.R source file, because that's managed and saved outside of the workspace.

  2. Dans le fichier script.R créé dans la section précédente, définissez un point d’arrêt sur la ligne qui commence par pop <-. Pour cela, placez le signe insertion sur cette ligne et appuyez sur F9, ou sélectionnez la commande de menu Déboguer > Point d’arrêt.With the script.R file created in the previous section, set a breakpoint on the line that begins with pop <- by placing the caret on that line and then pressing F9, or selecting the Debug > Toggle Breakpoint menu command. Sinon, cliquez simplement dans la marge de gauche (ou gouttière) de cette ligne où se trouve le point d’arrêt rouge :Alternately, simply click in the left-hand margin (or gutter) for that line where the red breakpoint dot appears:

    Définition d’un point d’arrêt dans l’éditeur

  3. Lancez le débogueur avec le code dans script.R. Pour cela, trois options s’offrent à vous : sélectionnez le bouton Fichier de démarrage source dans la barre d’outils, sélectionnez l’élément de menu Déboguer > Fichier de démarrage source ou appuyez sur F5.Launch the debugger with the code in script.R by either selecting the Source startup file button on the toolbar, selecting the Debug > Source startup file menu items, or pressing F5. Visual Studio entre en mode débogage et démarre l’exécution du code.Visual Studio enters its debugging mode and starts running the code. Toutefois, il s’arrête sur la ligne où vous avez défini le point d’arrêt :It stops, however, on the line where you set the breakpoint:

    Arrêt sur un point d’arrêt dans le débogueur Visual Studio

  4. Durant le débogage, Visual Studio vous permet d’avancer dans votre code ligne par ligne.During debugging, Visual Studio provides the ability to step through your code line by line. Vous pouvez aussi effectuer un pas à pas détaillé dans les fonctions, effectuer un pas à pas principal sur celles-ci ou encore effectuer un pas à pas sortant pour accéder au contexte d’appel.You can also step into functions, step over them, or step out of them to the calling context. Ces fonctionnalités, ainsi que d’autres, sont disponibles dans le menu Déboguer, le menu contextuel dans l’éditeur et la barre d’outils de débogage :These capabilities, along with others, can be found on the Debug menu, the right-click context menu in the editor, and the Debug toolbar:

    Barre d’outils de débogage dans Visual Studio

  5. Quand l’exécution est arrêtée au niveau d’un point d’arrêt, vous pouvez examiner les valeurs des variables.When stopped at a breakpoint, you can examine the values of variables. Recherchez la fenêtre Automatique dans Visual Studio et sélectionnez l’onglet dans la partie inférieure nommé Variables locales.Locate the Autos window in Visual Studio and select the tab along the bottom named Locals. La fenêtre Variables locales affiche les variables locales au niveau du point actif dans le programme.The Locals window shows local variables at the current point in the program. Si vous êtes arrêté sur le point d’arrêt défini précédemment, vous pouvez constater que la variable pop n’est pas encore définie.If you're stopped on the breakpoint set earlier, you see that the pop variable isn't yet defined. Utilisez maintenant la commande Déboguer > Pas à pas principal (F10) pour afficher la valeur de pop :Now use the Debug > Step Over command (F10), and you see the value for pop appear:

    Fenêtre Variables locales dans Visual Studio

  6. Pour examiner des variables dans des portées différentes, notamment la portée globale et les portées de package, utilisez l’Explorateur de variables.To examine variables in different scopes, including the global scope and package scopes, use the Variable Explorer. L’Explorateur de variables vous permet également de passer à une vue tabulaire composée de colonnes pouvant être triées et d’exporter les données dans un fichier CSV.The Variable Explorer also gives you the ability to switch to a tabular view with sortable columns and to export data to a CSV file.

    Vue développée de l’Explorateur de variables

  7. Vous pouvez soit continuer à exécuter pas à pas le programme, soit sélectionner Continuer (F5) pour l’exécuter jusqu’à sa complétion (ou jusqu’au point d’arrêt suivant).You can continue stepping through the program line by line, or select Continue (F5) to run it to completion (or the next breakpoint).

Pour aller plus loin, consultez Débogage et Explorateur de variables.To go deeper, see Debugging and Variable Explorer.

Étapes suivantesNext steps

Dans cette procédure pas à pas, vous avez pu découvrir les bases des projets R. Vous avez aussi appris à utiliser la fenêtre interactive, à modifier du code et à déboguer dans Visual Studio.In this walkthrough you've learned the basics of R projects, using the interactive window, code editing, and debugging in Visual Studio. Pour explorer d’autres fonctionnalités, consultez les articles suivants, ainsi que ceux figurant dans la table des matières :To continue exploring more capabilities, see the following articles as well as articles shown in the table of contents: