Options des Outils R dans Visual StudioR Tools for Visual Studio options

Les paramètres sont accessibles par l’intermédiaire du menu Outils R > Options, ou par l’intermédiaire de Outils > Options et en faisant défiler la page jusqu’à Outils R :Settings are accessed through the R Tools > Options menu, or through Tools > Options and scrolling to R Tools:

Boîte de dialogue Options pour les Outils R

Les options et paramètres propres à R sont accessibles à l’aide des méthodes ci-dessous.Options and settings specific to R are accessed using the methods below. Vous devez cocher la case Afficher tous les paramètres située au bas de la boîte de dialogue Options pour que toutes ces sections apparaissent.You must select the Show all settings box at the bottom of the Options dialog box for all of these sections to appear.

  • Options de mise en forme de code (consultez Options de l’éditeur) : menu Outils > Options, puis sélectionnez Éditeur de texte > R > Mise en forme.Code formatting options (see Editor options: Tools > Options menu, then select Text Editor > R > Formatting
  • Options Linting (consultez Linting) : menu Outils > Options, puis sélectionnez Éditeur de texte > R > Lint.Linting options (see Linting): Tools > Options menu, then select Text Editor > R > Lint
  • Options avancées de l’éditeur (décrites dans cet article) : menu Outils > Options, puis sélectionnez Éditeur de texte > R > Avancé.Advanced editor options (described in this article): Tools > Options menu, then select Text Editor > R > Advanced
  • Options comportementales (décrites dans cet article) : menu Outils R > Options ou Outils > Options, puis faites défiler jusqu’à Outils R.Behavioral options (described in this article): R Tools > Options menu, or Tools > Options, then scroll to R Tools.

La commande Outils R > Paramètres de science des données affecte aussi plusieurs paramètres différents dans Visual Studio globalement.The R Tools > Data Science Settings command affects also a number of different settings in Visual Studio overall. Cette commande est décrite dans la section suivante.This command is described in the next section.

Outils R > Paramètres de science des donnéesR Tools > Data Science Settings

L’élément de menu Outils R > Paramètres de science des données configure l’IDE de Visual Studio avec une disposition optimisée pour les besoins des scientifiques des données.The R Tools > Data Science Settings menu item configures the Visual Studio IDE with a layout that's optimized for the needs of data scientists. Plus précisément, cette option ouvre les fenêtres Interactive, Explorateur de variables et Espaces de travail :Specifically, this option opens the Interactive, Variable Explorer, and Workspaces windows:

Disposition de fenêtre pour scientifique des données dans Visual Studio

Pour revenir ultérieurement à d’autres paramètres de Visual Studio, utilisez d’abord la commande Outils > Importation et exportation de paramètres, sélectionnez Exporter les paramètres d’environnement sélectionnés et spécifiez un nom de fichier.To revert to other Visual Studio settings later on, first use the Tools > Import and Export Settings command, select Export selected environment settings, and specify a file name. Pour restaurer ces paramètres, utilisez la même commande et sélectionnez Importer les paramètres d’environnement sélectionnés.To restore those settings, use the same command and select Import selected environment settings. Vous pouvez aussi utiliser les mêmes commandes si vous changez la disposition pour les scientifiques des données et que vous souhaitez y revenir plus tard, au lieu d’utiliser directement la commande Paramètres de science des données.You can also use the same commands if you change the data scientist layout and want to return to it later on, rather than using the Data Science Settings command directly.

Éditeur de texte > R > Options avancéesText Editor > R > Advanced options

Ces options contrôlent le comportement de mise en forme, IntelliSense, le mode plan, la mise en retrait et la vérification de syntaxe pour R.These options control the behavior of formatting, IntelliSense, outlining, indenting, and syntax checking for R.

Boîte de dialogue Options pour les options avancées de l’éditeur de texte R

Chaque option est activée ou désactivée pour contrôler le comportement en question.Each option is set to either on or off to control the behavior in question. Pour plus d’informations sur ce qui affecte chaque option, consultez le volet d’aide au bas de la boîte de dialogue.For details on what each option affects, look at the help pane at the bottom of the dialog box. Notez que vous pouvez faire glisser le haut de ce volet d’aide pour l’agrandir.Note that you can drag the top of that help pane up to make the pane larger.

Volet d’aide développé dans la boîte de dialogue des options avancées de l’éditeur de texte R

Outils R > Options avancéesR Tools > Advanced options

La commande de menu Outils R > Options ouvre la boîte de dialogue Options relatives aux options R :The R Tools > Options menu command opens the Options dialog to the R options:

Boîte de dialogue Options pour les Outils R

Les sections suivantes décrivent les différentes options disponibles dans cette page.The following sections describe the different options available on this page.

DébogageDebugging

Ces options contrôlent la façon dont les valeurs sont gérées dans l’Explorateur de variables et dans les fenêtres du débogueur, comme Espion et Variables locales (consultez Débogage).These options control how values are handled in Variable Explorer and in debugger windows like Watch and Locals (see Debugging).

OptionOption Valeur par défautDefault value DescriptionDescription
Évaluer les liaisons activesEvaluate active bindings True Quand cette option a la valeur True, vous voyez toujours la valeur de date la plus à jour lors de l’inspection des variables et des propriétés.When True, ensures that you always see the most up-to-date value when inspecting variables and properties. Le risque est que l’évaluation des expressions peut avoir des effets secondaires, selon la façon dont elles ont été implémentées.The risk is that evaluating the expressions may cause side-effects, depending on how they were implemented.
Afficher les variables préfixées par un pointShow dot-prefixed variables False Indique si les variables précédées de . sont affichées.Specifies whether variables prefixed with . are shown.

Affichage de grilleGrid view

OptionOption Valeur par défautDefault value DescriptionDescription
Évaluation dynamiqueDynamic evaluation False Par défaut, la fonction View(<expression>) prend un instantané des données sous forme de cadre de données, ce qui peut consommer beaucoup de mémoire avec des jeux de données volumineux.By default, the View(<expression>) function takes a snapshot of data as a data frame, which can consume considerable memory with large data sets. La valeur True de cette option signifie que l’expression est évaluée lorsque la grille s’actualise pour extraire uniquement les données qui sont affichées.Setting this option to True means that the expression is evaluated when the grid refreshes to fetch only that data that is displayed. Toutefois, si l’expression change, les données changent également, ce qui peut ne pas convenir aux expressions dplyr pip.However, if the expression changes the data also changes, which may be unsuitable for dplyr pip expressions.

HelpHelp

OptionOption Valeur par défautDefault value DescriptionDescription
Navigateur web (F1)F1 Web browser Internal Contrôle comment l’aide s’affiche quand vous recherchez un terme à l’aide de Ctrl+F1.Controls how help is displayed when you are searching for a term using Ctrl+F1. Quand cette option a la valeur Internal, l’aide est affichée dans une fenêtre d’outil dans Visual Studio.When set to Internal, help is rendered within a tool window in Visual Studio. Quand elle a la valeur External, l’aide est affichée dans votre navigateur par défaut.When set to External, help appears in your default web browser.
Chaîne de recherche web (F1)F1 Web Search String R site:stackoverflow.com Contrôle comment les termes de recherche sont transmis à votre moteur de recherche quand vous appuyez sur Ctrl+F1 sur un terme dans l’éditeur.Controls how search terms are passed to your search engine when you press Ctrl+F1 on a term in the editor. Par défaut, la chaîne est R site:stackoverflow.com, ce qui ajoute R à votre terme de recherche.By default the string is R site:stackoverflow.com, which appends R to your search term. site:stackoverflow.com est une directive destinée au moteur de recherche qui lui indique de limiter la recherche aux pages du domaine stackoverflow.com.The site:stackoverflow.com is a directive to the search engine that tells it to scope the search to pages within the stackoverflow.com domain.
Navigateur de l’aide RR Help Browser Automatic Contrôle comment l’aide s’affiche quand vous effectuez une recherche dans la documentation R à l’aide de F1, ? ou ??.Controls how help is displayed when you are searching the R documentation using F1, ?, or ??. Quand cette option a la valeur Automatic, l’aide s’affiche dans la fenêtre appropriée.When set to Automatic, help renders in the appropriate window. Par exemple, l’aide HTML s’affiche dans une fenêtre d’outil Visual Studio, tandis que les fichiers PDF s’affichent dans votre programme PDF par défaut.For example, HTML help appears within a Visual Studio tool window, whereas PDFs appear in your default PDF program. Quand elle a la valeur External, l’aide s’affiche dans le navigateur web par défaut.When set to External, help is rendered in your default web browser.

HistoriqueHistory

OptionOption Valeur par défautDefault value DescriptionDescription
Toujours enregistrer l’historiqueAlways save history True Détermine si RTVS écrit votre historique des commandes dans un fichier .RHistory dans votre répertoire de travail chaque fois que le projet est fermé.Controls whether RTVS writes your command history to a .RHistory file in your working directory whenever the project is closed. L’enregistrement de l’historique se produit même si vous n’enregistrez pas votre projet avant de quitter.Saving the history happens even if you don't save your project before you exit.
Réinitialiser le filtre de rechercheReset search filter True Détermine si la fenêtre Historique peut filtrer votre historique des commandes pour afficher uniquement les commandes qui correspondent au terme du filtre dans la boîte de dialogue Historique R.Determines whether the History window can filter your command history to show only the commands that substring match against the filter term in the R History dialog. Ce paramètre détermine s’il faut réinitialiser votre filtre de recherche de l’historique chaque fois que vous exécutez une nouvelle commande ou que vous basculez vers un nouveau projet, ce qui déclenche le chargement d’un autre fichier .RHistory.This setting determines whether to reset your History search filter whenever you run a new command or switch to a new project, which triggers the load of a different .RHistory file. Le paramètre par défaut True évite d’être surpris quand vous exécutez une commande avec un filtre défini et que vous vous demandez pourquoi la commande que vous venez d’exécuter n’apparaît pas dans l’historique.The default setting of True minimizes surprise when you run a command with a filter set, and you wonder why the command you just ran didn't show up in the History.
Utiliser la sélection multiligneUse multiline selection True Spécifie si vous pouvez sélectionner une instruction sur plusieurs lignes dans l’historique avec un seul clic.Specifies whether you can select a multi-line statement in History with a single click. Autorise également la navigation avec les flèches Haut/Bas dans les fenêtres Interactive par instructions plutôt que par lignes.Also enables up/down arrow navigation in the Interactive Windows by statements rather than lines.

HTMLHTML

OptionOption Valeur par défautDefault value DescriptionDescription
Navigateur de pages HTMLHTML Pages browser External Détermine où est affiché le contenu tel qu’un tracé ggvis ou une application shiny.Determines where content such as a ggvis plot, or a shiny application is rendered. Internal affiche la sortie HTML dans une fenêtre d’outil dans Visual Studio. External affiche la sortie HTML dans votre navigateur par défaut.Internal shows HTML output within a tool window in Visual Studio; External displays HTML output in your default browser.

JournalisationLogging

OptionOption Valeur par défautDefault value DescriptionDescription
Journaliser les événementsLog events Normal Contrôle le niveau de détail de la journalisation pour les diagnostics RTV.Controls the verbosity of the logging used for RTVS diagnostics. Le paramètre par défaut Normal crée un fichier journal dans votre répertoire TEMP.The default setting of Normal creates a log file in your TEMP directory. Quand cette option a la valeur Traffic, RTVS enregistre toutes les commandes et les réponses dans votre session.When set to Traffic, RTVS logs all commands, and responses in your session. Ces fichiers journaux ne quittent jamais votre ordinateur, mais ils peuvent être utiles pour diagnostiquer des problèmes dans RTVS.These log files never leave your machine, but may be helpful for diagnosing problems in RTVS.

MarkdownMarkdown

OptionOption Valeur par défautDefault value DescriptionDescription
Navigateur d’aperçu MarkdownMarkdown preview browser External Détermine où est affichée la sortie HTML RMarkdown.Determines where RMarkdown HTML output is displayed. Internal affiche le document HTML RMarkdown dans une fenêtre d’outil dans Visual Studio. External affiche le HTML RMarkdown à l’aide de votre navigateur par défaut.Internal shows RMarkdown HTML document within a tool window in Visual Studio; External displays RMarkdown HTML using your default browser.

Moteur RR Engine

OptionOption Valeur par défautDefault value DescriptionDescription
Page de codesCode page (OS Default) Définit la page de codes (paramètres régionaux) pour R. Par défaut, les paramètres régionaux sous-jacents du système d’exploitation sont utilisés.Sets the code page (locale) for R. By default it uses the underlying locale of the operating system.
Miroir CRANCRAN Mirror (Use .Rprofile) Définit la mise en miroir CRAN par défaut pour les installations de packages.Sets the default CRAN mirror for package installations. Le paramètre par défaut Use .Rprofile respecte les paramètres de miroir CRAN dans votre fichier .RProfile.The default setting of Use .Rprofile respects the CRAN Mirror settings in your .RProfile file.

Espace de travailWorkspace

OptionOption Valeur par défautDefault value DescriptionDescription
Charger l’espace de travail à l’ouverture du projetLoad workspace when project opens No Yes active le chargement des données de session à partir du fichier .RData dans l’environnement global à l’ouverture du projet.Setting to Yes enables loading of session data from the .RData file into the global environment when the project is opened.
Demander l’enregistrement de l’espace de travail en cas de réinitialisationPrompt to save workspace on reset Yes No désactive l’invite d’enregistrement de votre espace de travail quand vous cliquez sur le bouton Réinitialiser dans la fenêtre Interactive.Setting to No disables prompting of saving your workspace when you click on the Reset button in the Interactive Window.
Enregistrer l’espace de travail à la fermeture du projetSave workspace when project closes No Yes active l’enregistrement de l’environnement global dans le fichier .RData à la fermeture du projet.Setting to Yes enables saving the global environment to the .RData file when the project is closed.
Afficher la boîte de dialogue de confirmation avant de changer d’espace de travailShow confirmation dialog before switching workspaces Yes No désactive l’invite de confirmation lors du basculement entre différents espaces de travail.Setting to No disables prompting the user for confirmation when switching between different workspaces. Voir Basculement entre espaces de travail.See switching between workspaces
Afficher l’indicateur de charge de l’ordinateurShow machine load indicator False Contrôle la visibilité de l’indicateur de la charge processeur/mémoire/réseau dans la barre d’état.Controls visibility of the CPU/Memory/Network load indicator in the status bar. Étant donné que l’indicateur génère du trafic réseau, il s’avère utile de conserver ce False dans les scénarios de limitation à distance.Because the indicator incurs network traffic, it's helpful to keep this False in remote metered scenarios. La modification de cette option vous oblige à redémarrer Visual Studio.Changing this option requires that you restart Visual Studio.