Création de documents R MarkdownCreating R Markdown documents

R Markdown est un format de document qui convertit l’analyse dans R en documents, rapports, présentations et tableaux de bord de haute qualité.R Markdown is a document format that turns analysis in R into high-quality documents, reports, presentations, and dashboards.

Les outils R pour Visual Studio (RTVS) fournissent un modèle d’élément R Markdown, la prise en charge d’éditeur (notamment IntelliSense pour le code R dans l’éditeur), des fonctionnalités de génération de fichier et un aperçu instantané.R Tools for Visual Studio (RTVS) provides a R Markdown item template, editor support (including IntelliSense for R code within the editor), file generation capabilities, and live preview.

Utilisation de R MarkdownUsing R Markdown

  1. Fermez Visual Studio.Close Visual Studio.
  2. (Une seule fois) Installez pandoc à partir de pandoc.org.(One time only) Install pandoc from pandoc.org.
  3. Redémarrez Visual Studio. L’installation de pandoc doit être détectée.Restart Visual Studio, which should pick up the pandoc installation.
  4. Installez les packages knitr et rmarkdown, ce que vous pouvez faire à partir de la Fenêtre interactive :Install the knitr and rmarkdown packages, which you can do from the interactive window:

    install.packages("knitr")
    install.packages("rmarkdown")
    
  5. Créez un fichier R Markdown à l’aide de la commande de menu Fichier > Nouveau > Fichier et en sélectionnant R > R Markdown dans la liste.Create a new R Markdown file using the File > New > File menu command and selecting R > R Markdown from the list. Dans le contexte d’un projet, cliquez avec le bouton droit sur le projet dans l’Explorateur de solutions et sélectionnez Ajouter R Markdown (ou Ajouter > Nouvel élément... et sélectionnez R Markdown dans la liste).In the context of a project, right-click the project in Solution Explorer and select Add R Markdown (or Add > New Item... and selecting R Markdown from the list).

  6. Le contenu par défaut du nouveau fichier est le suivant :The default contents of the new file are as follows:

    ---
    title: "Untitled"
    output: html_document
    ---
    
    This is an R Markdown document. Markdown is a simple formatting syntax for authoring HTML, PDF, and Microsoft Word documents. For more details on using R Markdown see <http://rmarkdown.rstudio.com>.
    
    When you click the **R Tools | Publish | Preview** button a document will be generated that includes both content as well as the output of any embedded R code chunks within the document. You can embed an R code chunk like this:
    
    ```{r}
    summary(cars)
    ```
    
    You can also embed plots, for example:
    
    ```{r, echo=FALSE}
    plot(cars)
    ```
    
    Note that the `echo = FALSE` parameter was added to the code chunk to prevent printing of the R code that generated the plot.
    

Versions d'évaluationPreviews

Visual Studio 2017 versions 15.5 et ultérieures fournissent automatiquement un aperçu instantané pour R Markdown.Visual Studio 2017 version 15.5 and later automatically provide live preview for R Markdown. Pour activer la synchronisation automatique entre l’éditeur et l’aperçu, sélectionnez Outils R > Markdown > Synchronisation automatique (Ctrl+Maj+Y).To turn on automatic sync between the editor and the preview, select R Tools > Markdown > Automatic Sync (Ctrl+Shift+Y). Si vous n’utilisez pas la synchronisation automatique, vous pouvez actualiser l’aperçu en utilisant Outils R > Markdown > Recharger l’aperçu R Markdown.If you aren't using automatic sync, you can refresh the preview using R Tools > Markdown > Reload R Markdown Preview.

Vous pouvez également afficher un aperçu du fichier au format HTML, PDF et Microsoft Word en cliquant avec le bouton droit dans l’éditeur et en sélectionnant une des commandes Aperçu.You can also preview the file in HTML, PDF, and Microsoft Word formats by right-clicking in the editor and selecting one of the Preview commands. Les mêmes commandes sont également disponibles dans le menu Outils R > Markdown.The same commands are also available on the R Tools > Markdown menu. (Dans les versions antérieures de Visual Studio, ces commandes se trouvent dans le menu Outils R > Publier.)(In earlier versions of Visual Studio these commands are found on the R Tools > Publish menu.)

Aperçu instantané R Markdown et autres commandes de menu d’aperçu