Réalité mixte - Principes fondamentaux - Cours 100 : Bien démarrer avec UnityMR Basics 100: Getting started with Unity

Important

Les tutoriels Mixed Reality Academy ont été conçus pour les appareils HoloLens (1re génération) et les casques immersifs de réalité mixte.The Mixed Reality Academy tutorials were designed with HoloLens (1st gen) and Mixed Reality Immersive Headsets in mind. Nous estimons qu’il est important de laisser ces tutoriels à la disposition des développeurs qui recherchent encore des conseils pour développer des applications sur ces appareils.As such, we feel it is important to leave these tutorials in place for developers who are still looking for guidance in developing for those devices. Notez que ces tutoriels ne sont pas mis à jour avec les derniers ensembles d’outils ou interactions utilisés pour HoloLens 2.These tutorials will not be updated with the latest toolsets or interactions being used for HoloLens 2. Ils sont fournis dans le but de fonctionner sur les appareils pris en charge.They will be maintained to continue working on the supported devices. Une nouvelle série de tutoriels a été publiée pour HoloLens 2.A new series of tutorials has been posted for HoloLens 2.

Ce didacticiel vous guide dans la création d’une application de réalité mixte de base créée avec Unity.This tutorial will walk you through creating a basic mixed reality app built with Unity.

Prise en charge des appareilsDevice support

CoursCourse HoloLensHoloLens Casques immersifsImmersive headsets
Réalité mixte - Principes fondamentaux - Cours 100 : Bien démarrer avec UnityMR Basics 100: Getting started with Unity ✔️✔️ ✔️✔️

PrérequisPrerequisites

Chapitre 1-créer un nouveau projetChapter 1 - Create a New Project

Pour générer une application avec Unity, vous devez d’abord créer un projet.To build an app with Unity, you first need to create a project. Ce projet est organisé en quelques dossiers, dont le plus important est votre dossier de ressources.This project is organized into a few folders, the most important of which is your Assets folder. Il s’agit du dossier qui contient toutes les ressources que vous importez à partir d’outils de création de contenu numérique tels que Maya, Max Cinema 4D ou Photoshop, tout le code que vous créez avec Visual Studio ou votre éditeur de code favori, et tout autre fichier de contenu créé par Unity lorsque vous composez des scènes, animations et autres types de ressources Unity dans l’éditeurThis is the folder that holds all assets you import from digital content creation tools such as Maya, Max Cinema 4D or Photoshop, all code you create with Visual Studio or your favorite code editor, and any number of content files that Unity creates as you compose scenes, animations and other Unity asset types in the editor.

Pour générer et déployer des applications UWP, Unity peut exporter le projet en tant que solution Visual Studio qui contient tous les fichiers de ressources et de code nécessaires.To build and deploy UWP apps, Unity can export the project as a Visual Studio solution that will contain all necessary asset and code files.

  1. Démarrer UnityStart Unity
  2. Sélectionnez NouveauSelect New
  3. Entrez un nom de projet (par exemple, « MixedRealityIntroduction »)Enter a project name (e.g. "MixedRealityIntroduction")
  4. Entrez un emplacement pour enregistrer votre projetEnter a location to save your project
  5. Vérifier que le bouton bascule 3D est sélectionnéEnsure the 3D toggle is selected
  6. Sélectionner créer un projetSelect Create project

Contentes, vous êtes prêt pour la prise en main de vos personnalisations de réalité mixte.Congrats, you are all setup to get started with your mixed reality customizations now.

Chapitre 2-configurer l’appareil photoChapter 2 - Setup the Camera

La caméra principale Unity gère le suivi des têtes et le rendu stéréoscopique.The Unity Main Camera handles head tracking and stereoscopic rendering. Il y a quelques modifications à apporter à la caméra principale pour l’utiliser avec la réalité mixte.There are a few changes to make to the Main Camera to use it with mixed reality.

  1. Sélectionner un fichier > nouvelle scèneSelect File > New Scene

Tout d’abord, il sera plus facile de présenter votre application si vous imaginez la position de départ de l’utilisateur comme (X: 0, Y: 0, Z: 0).First, it will be easier to lay out your app if you imagine the starting position of the user as (X: 0, Y: 0, Z: 0). Étant donné que la caméra principale effectue le suivi du mouvement de la tête de l’utilisateur, la position de départ de l’utilisateur peut être définie en définissant la position de départ de l’appareil photo principal.Since the Main Camera is tracking movement of the user's head, the starting position of the user can be set by setting the starting position of the Main Camera.

  1. Sélectionner la caméra principale dans le volet de la hiérarchieSelect Main Camera in the Hierarchy panel
  2. Dans le volet de l' inspecteur , recherchez le composant transformer et remplacez la position (x: 0, y: 1, z:-10) par (x: 0, y: 0, z: 0)In the Inspector panel, find the Transform component and change the Position from (X: 0, Y: 1, Z: -10) to (X: 0, Y: 0, Z: 0)

Deuxièmement, l’arrière-plan de la caméra par défaut a besoin d’une pensée.Second, the default Camera background needs some thought.

Pour les applications HoloLens, le monde réel doit apparaître derrière tout ce que l’appareil photo rend, et non une texture skybox.For HoloLens applications, the real world should appear behind everything the camera renders, not a Skybox texture.

  1. Avec la caméra principale toujours sélectionnée dans le panneau hiérarchie , recherchez le composant Camera dans le panneau inspecteur et remplacez la liste déroulante Clear Flags de skybox par couleur unie.With the Main Camera still selected in the Hierarchy panel, find the Camera component in the Inspector panel and change the Clear Flags dropdown from Skybox to Solid Color.
  2. Sélectionnez le sélecteur de couleur d' arrière-plan et modifiez les valeurs RVBA en (0, 0, 0, 0)Select the Background color picker and change the RGBA values to (0, 0, 0, 0)

Pour les applications de réalité mixte ciblant des casques immersifs, nous pouvons utiliser la texture skybox par défaut fournie par Unity.For mixed reality applications targeted to immersive headsets, we can use the default Skybox texture that Unity provides.

  1. Avec la caméra principale toujours sélectionnée dans le panneau hiérarchie , recherchez le composant Camera dans le panneau inspecteur et conservez la liste déroulante indicateurs clairs pour skybox.With the Main Camera still selected in the Hierarchy panel, find the Camera component in the Inspector panel and keep the Clear Flags dropdown to Skybox.

Troisièmement, examinons le plan near clip dans Unity et empêchez les objets d’être rendus trop près des yeux des utilisateurs, car un utilisateur approche un objet ou un objet s’approche d’un utilisateur.Third, let us consider the near clip plane in Unity and prevent objects from being rendered too close to the users eyes as a user approaches an object or an object approaches a user.

Pour les applications HoloLens, le plan near clip peut être défini sur les 0,85 compteurs recommandés pour hololens .For HoloLens applications, the near clip plane can be set to the HoloLens recommended 0.85 meters.

  1. Avec la caméra principale toujours sélectionnée dans le volet de hiérarchie , recherchez le composant Camera dans le panneau inspecteur , puis modifiez le champ near clip plan de la valeur par défaut 0,3 en HoloLens Recommended 0,85.With the Main Camera still selected in the Hierarchy panel, find the Camera component in the Inspector panel and change the Near Clip Plane field from the default 0.3 to the HoloLens recommended 0.85.

Pour les applications de réalité mixte ciblant des casques immersifs, nous pouvons utiliser le paramètre par défaut fourni par Unity.For mixed reality applications targeted to immersive headsets, we can use the default setting that Unity provides.

  1. Avec la caméra principale toujours sélectionnée dans le panneau hiérarchie , recherchez le composant Camera dans le panneau inspecteur , puis conservez le champ du plan near clip à la valeur par défaut 0,3.With the Main Camera still selected in the Hierarchy panel, find the Camera component in the Inspector panel and keep the Near Clip Plane field to the default 0.3.

Enfin, laissez-nous enregistrer notre progression jusqu’à présent.Finally, let us save our progress so far. Pour enregistrer les modifications de la scène, sélectionnez fichier > enregistrer la scène sous, nommez la scène main, puis sélectionnez Enregistrer.To save the scene changes, select File > Save Scene As, name the scene Main, and select Save.

Chapitre 3-configurer les paramètres du projetChapter 3 - Setup the Project Settings

Dans ce chapitre, nous allons définir des paramètres de projet Unity qui nous aident à cibler le kit de développement logiciel (SDK) Windows holographique pour le développement.In this chapter, we will set some Unity project settings that help us target the Windows Holographic SDK for development. Nous allons également définir des paramètres de qualité pour notre application.We will also set some quality settings for our application. Enfin, nous nous assurons que nos cibles de génération sont définies sur plateforme Windows universelle.Finally, we will ensure our build targets are set to Universal Windows Platform.

Paramètres de performance et de qualité UnityUnity performance and quality settings

Paramètres de qualité Unity pour HoloLensUnity quality settings for HoloLens

Paramètres de qualité Unity pour HoloLens

Étant donné que la gestion de la fréquence élevée sur HoloLens est si importante, nous souhaitons que les paramètres de qualité soient réglés pour des performances plus rapides.Since maintaining high framerate on HoloLens is so important, we want the quality settings tuned for fastest performance. Pour plus d’informations sur les performances, sur les recommandations en matière de performances pour Unity.For more detailed performance information, Performance recommendations for Unity.

  1. Sélectionnez modifier > paramètres du projet > qualitéSelect Edit > Project Settings > Quality
  2. Sélectionnez la liste déroulante sous le logo de plateforme Windows universelle et sélectionnez très faible.Select the dropdown under the Universal Windows Platform logo and select Very Low. Vous saurez que le paramètre est appliqué correctement lorsque la zone de la plateforme Windows universelle colonne et la ligne très basse est verte.You'll know the setting is applied correctly when the box in the Universal Windows Platform column and Very Low row is green.

Pour les applications de réalité mixte ciblant bloqués, vous pouvez conserver les valeurs par défaut des paramètres de qualité.For mixed reality applications targeted to occluded displays, you can leave the quality settings to its default values.

SDK Windows 10 cibleTarget Windows 10 SDK

KIT SDK Windows holographique cibleTarget Windows Holographic SDK

KIT SDK Windows holographique cible

Nous devons permettre à Unity de savoir que l’application que nous essayons d’exporter doit créer une vue immersive au lieu d’une vue 2D.We need to let Unity know that the app we are trying to export should create an immersive view instead of a 2D view. Pour ce faire, nous allons activer la prise en charge de la réalité virtuelle sur Unity ciblant le SDK Windows 10.We do this by enabling Virtual Reality support on Unity targeting the Windows 10 SDK.

  1. Accédez à modifier > paramètres du projet > Player.Go to Edit > Project Settings > Player.
  2. Dans le panneau Inspecteur pour les paramètres du lecteur, sélectionnez l’icône plateforme Windows universelle .In the Inspector Panel for Player Settings, select the Universal Windows Platform icon.
  3. Développez le groupe XR Settings.Expand the XR Settings group.
  4. Dans la section Rendering (Rendu), cochez la case Virtual Reality Supported (Réalité virtuelle prise en charge) pour ajouter une nouvelle liste Virtual Reality SDKs (SDK de réalité virtuelle).In the Rendering section, check the Virtual Reality Supported checkbox to add a new Virtual Reality SDKs list.
  5. Vérifiez que Windows Mixed Reality apparaît dans la liste.Verify that Windows Mixed Reality appears in the list. Dans le cas contraire, sélectionnez le bouton + en bas de la liste et choisissez Windows Mixed Reality.If not, select the + button at the bottom of the list and choose Windows Mixed Reality.

Notes

Si vous ne voyez pas l’icône plateforme Windows universelle , vérifiez que vous avez sélectionné plateforme Windows universelle prise en charge de la génération pendant l’installation.If you do not see the Universal Windows Platform icon, double check to make sure you selected Universal Windows Platform Build Support during installation. Si ce n’est pas le cas, vous devrez peut-être réinstaller Unity avec l’installation de Windows appropriée.If not, you may need to reinstall Unity with the correct Windows installation.

Travail étonnant d’obtenir tous les paramètres de projet appliqués.Awesome job on getting all the project settings applied. Nous allons ensuite ajouter un hologramme !Next, let us add a hologram!

Chapitre 4-créer un cubeChapter 4 - Create a cube

La création d’un cube dans votre projet Unity est identique à la création d’un autre objet dans Unity.Creating a cube in your Unity project is just like creating any other object in Unity. Le fait de placer un cube devant l’utilisateur est simple, car le système de coordonnées de Unity est mis en correspondance avec le monde réel, où un compteur dans Unity est approximativement un compteur dans le monde réel.Placing a cube in front of the user is easy because Unity's coordinate system is mapped to the real world - where one meter in Unity is approximately one meter in the real world.

  1. Dans le coin supérieur gauche du panneau de hiérarchie , sélectionnez la liste déroulante créer , puis choisissez objet 3D > cube.In the top left corner of the Hierarchy panel, select the Create dropdown and choose 3D Object > Cube.
  2. Sélectionner le cube nouvellement créé dans le volet de hiérarchieSelect the newly created Cube in the Hierarchy panel
  3. Dans l' inspecteur , recherchez le composant transformer et changez position en (X: 0, Y: 0, Z: 2).In the Inspector find the Transform component and change Position to (X: 0, Y: 0, Z: 2). Cela positionne le cube 2 mètres devant la position de départ de l’utilisateur.This positions the cube 2 meters in front of the user's starting position.
  4. Dans le composant transformer , remplacez rotation par (x: 45, Y: 45, z: 45) et remplacez adapter par (x: 0,25, y: 0,25, z: 0,25).In the Transform component, change Rotation to (X: 45, Y: 45, Z: 45) and change Scale to (X: 0.25, Y: 0.25, Z: 0.25). Le cube est mis à l’échelle sur 0,25 mètres.This scales the cube to 0.25 meters.
  5. Pour enregistrer les modifications de la scène, sélectionnez fichier > enregistrer la scène.To save the scene changes, select File > Save Scene.

Chapitre 5-vérification sur l’appareil à partir de l’éditeur UnityChapter 5 - Verify on device from Unity editor

Maintenant que nous avons créé notre cube, il est temps d’effectuer une vérification rapide de l’appareil.Now that we have created our cube, it is time to do a quick check in device. Vous pouvez le faire directement à partir de l’éditeur Unity.You can do this directly from within the Unity editor.

Configuration initialeInitial setup

  1. Sur votre PC de développement, dans Unity, ouvrez le fichier > la fenêtre Paramètres de Build.On your development PC, in Unity, open File > Build Settings window.
  2. Remplacez Platform par plateforme Windows universelle , puis cliquez sur switch Platform .Change Platform to Universal Windows Platform and click Switch Platform

Pour utiliser la communication à distance Unity pour HoloLensFor HoloLens use Unity Remoting

  1. Sur votre HoloLens, installez et exécutez le lecteur de communication à distance holographique, disponible à partir du Windows Store.On your HoloLens, install and run the Holographic Remoting Player, available from the Windows Store. Lancez l’application sur l’appareil. elle entrera en état d’attente et affichera l’adresse IP de l’appareil.Launch the application on the device, and it will enter a waiting state and show the IP address of the device. Notez l’adresse IP.Note down the IP.
  2. Ouvrez windows > XR > émulation holographique.Open Window > XR > Holographic Emulation.
  3. Remplacez le mode d’émulation aucun par distant par appareil.Change Emulation Mode from None to Remote to Device.
  4. Dans ordinateur distant, entrez l’adresse IP de votre HoloLens indiquée précédemment.In Remote Machine, enter the IP address of your HoloLens noted earlier.
  5. Cliquez sur Connecter.Click Connect.
  6. Vérifiez que l’état de la connexion devient vert connecté.Ensure the Connection Status changes to green Connected.
  7. Vous pouvez maintenant cliquer sur lire dans l’éditeur Unity.Now you can now click Play in the Unity editor.

Vous pouvez maintenant voir le cube dans l’appareil et dans l’éditeur.You will now be able to see the cube in device and in the editor. Vous pouvez suspendre, inspecter des objets et effectuer un débogage comme s’il s’agissait d’une application dans l’éditeur, car c’est essentiellement ce qui se passe, mais avec les données vidéo, audio et d’appareil transmises sur le réseau entre l’ordinateur hôte et l’appareil.You can pause, inspect objects, and debug just like you are running an app in the editor, because that's essentially what's happening, but with video, audio, and device input transmitted back and forth across the network between the host machine and the device.

Pour les autres casques pris en charge par la réalité mixteFor other mixed reality supported headsets

  1. Connectez le casque à votre PC de développement à l’aide du câble USB et du câble HDMI ou du port d’affichage.Connect the headset to your development PC using the USB cable and the HDMI or display port cable.
  2. Lancez le portail de réalité mixte et assurez-vous que vous avez effectué la première expérience d’exécution.Launch the Mixed Reality Portal and ensure you have completed the first run experience.
  3. À partir de Unity, vous pouvez maintenant appuyer sur le bouton de lecture.From Unity, you can now press the Play button.

Vous pouvez maintenant voir le rendu du cube dans votre casque de réalité mixte et dans l’éditeur.You will now be able to see the cube rendering in your mixed reality headset and in the editor.

Chapitre 6-générer et déployer sur un appareil à partir de Visual StudioChapter 6 - Build and deploy to device from Visual Studio

Nous sommes maintenant prêts à compiler notre projet dans Visual Studio et à le déployer sur notre appareil cible.We are now ready to compile our project to Visual Studio and deploy to our target device.

Exporter vers la solution Visual StudioExport to the Visual Studio solution

  1. Ouvrez le fichier > la fenêtre Paramètres de Build.Open File > Build Settings window.
  2. Cliquez sur Ajouter des scènes ouvertes pour ajouter la scène.Click Add Open Scenes to add the scene.
  3. Remplacez Platform par plateforme Windows universelle , puis cliquez sur switch Platform.Change Platform to Universal Windows Platform and click Switch Platform.
  4. Dans plateforme Windows universelle paramètres, assurez-vous que le Kit SDK est Universal 10.In Universal Windows Platform settings, ensure SDK is Universal 10.
  5. Pour appareil cible, laissez un appareil pour bloqués afficher ou basculer vers HoloLens.For Target device, leave to Any Device for occluded displays or switch to HoloLens.
  6. Le type de build UWP doit être D3D.UWP Build Type should be D3D.
  7. Le Kit de développement logiciel (SDK) UWP peut être laissé sur le dernier installé.UWP SDK could be left at Latest installed.
  8. Cliquez sur Générer.Click Build.
  9. Dans l’Explorateur de fichiers, cliquez sur nouveau dossier et nommez le dossier « app ».In the file explorer, click New Folder and name the folder "App".
  10. Après avoir sélectionné le dossier de l' application , cliquez sur le bouton Sélectionner un dossier .With the App folder selected, click the Select Folder button.
  11. Une fois la création d’Unity terminée, une fenêtre de l’Explorateur de fichiers Windows s’affiche.When Unity is done building, a Windows File Explorer window will appear.
  12. Ouvrez le dossier de l' application dans l’Explorateur de fichiers.Open the App folder in file explorer.
  13. Ouvrez la solution Visual Studio générée (MixedRealityIntroduction. sln dans cet exemple).Open the generated Visual Studio solution (MixedRealityIntroduction.sln in this example)

Compiler la solution Visual StudioCompile the Visual Studio solution

Enfin, nous allons compiler la solution Visual Studio exportée, la déployer et l’essayer sur l’appareil.Finally, we will compile the exported Visual Studio solution, deploy it, and try it out on the device.

  1. À l’aide de la barre d’outils supérieure dans Visual Studio, remplacez la cible Debug par Release et de ARM par x86.Using the top toolbar in Visual Studio, change the target from Debug to Release and from ARM to X86.

Les instructions diffèrent pour le déploiement sur un appareil et sur l’émulateur.The instructions differ for deploying to a device versus the emulator. Suivez les instructions qui correspondent à votre configuration.Follow the instructions that match your setup.

Déployer sur un appareil de réalité mixte sur Wi-FiDeploy to mixed reality device over Wi-Fi

  1. Cliquez sur la flèche en regard du bouton ordinateur local , puis remplacez la cible de déploiement par ordinateur distant.Click on the arrow next to the Local Machine button, and change the deployment target to Remote Machine.
  2. Entrez l’adresse IP de votre appareil de réalité mixte et changez le mode d’authentification en mode universel (protocole non chiffré) pour HoloLens et Windows pour les autres appareils.Enter the IP address of your mixed reality device and change Authentication Mode to Universal (Unencrypted Protocol) for HoloLens and Windows for other devices.
  3. Cliquez sur Déboguer > exécuter sans débogage.Click Debug > Start without debugging.

Pour HoloLens, s’il s’agit de la première fois que vous déployez sur votre appareil, vous devez effectuer un jumelage à l’aide de Visual Studio.For HoloLens, If this is the first time deploying to your device, you will need to pair using Visual Studio.

Déployer sur un appareil de réalité mixte sur USBDeploy to mixed reality device over USB

Assurez-vous que l’appareil est branché via le câble USB.Ensure you device is plugged in via the USB cable.

  1. Pour HoloLens, cliquez sur la flèche en regard du bouton ordinateur local , puis remplacez la cible de déploiement par appareil.For HoloLens, click on the arrow next to the Local Machine button, and change the deployment target to Device.
  2. Pour cibler des appareils bloqués connectés à votre PC, conservez le paramètre sur la machine locale.For targeting occluded devices attached to your PC, keep the setting to Local Machine. Assurez-vous que le portail de la réalité mixte est en cours d’exécution.Ensure you have the Mixed Reality Portal running.
  3. Cliquez sur Déboguer > exécuter sans débogage.Click Debug > Start without debugging.

Déployer sur l’émulateurDeploy to Emulator

  1. Cliquez sur la flèche en regard du bouton périphérique , puis dans la liste déroulante, sélectionnez émulateur HoloLens.Click on the arrow next to the Device button, and from drop down select HoloLens Emulator.
  2. Cliquez sur Déboguer > exécuter sans débogage.Click Debug > Start without debugging.

Essayer votre applicationTry out your app

Maintenant que votre application est déployée, essayez de déplacer tout autour du cube et observez qu’il reste dans le monde.Now that your app is deployed, try moving all around the cube and observe that it stays in the world in front of you.

Voir aussiSee also