שתף באמצעות


השגיאה "0xC004F038: לא היתה אפשרות להפעיל את המחשב" בהפעלת KMS

מאמר זה נכתב על-ידי אריק אשטון, מהנדס הסלמת תמיכה בכיר.

מאפייני הבעיה

אתה מנסה להפעיל את Microsoft Office 2013 או Office 2016 באמצעות מארח שירות ניהול מפתחות (KMS) באמצעות אחת מהשיטות הבאות:

  • כלי ניהול הפעלה רבת משתמשים (VAMT)
  • אשף ההפעלה של Office ממחשב לקוח
  • OSPP.vbs /act script

עם זאת, אתה מקבל את הודעת השגיאה הבאה:

0xC004F038: שירות רישוי התוכנה דיווח שלא היתה אפשרות להפעיל את המחשב. הספירה שדווחה על-ידי שירות ניהול מפתחות (KMS) אינה מספיקה. פנה למנהל המערכת שלך.

סיבה

בעיה זו מתרחשת מאחר במאגר KMS של Office מכיל פחות מחמישה מחשבי לקוח ייחודיים.

פתרון

כדי לפתור בעיה זו, הגדל את מספר מחשבי הלקוח במאגר ה- KMS של Office לחמישה מחשבי לקוח או יותר.

הערה

כדי לקבוע כמה מחשבי לקוח נמצאים כעת במאגר KMS של Office במארח ה- KMS, הפעל את הפקודה הבאה בחלון שורת פקודה עם הרשאות מלאות מ- c:\windows\system32 ולאחר מכן הקש Enter:

Cscript slmgr.vbs -dlv all >c:\temp\KMSInfo.txt

עבור אל c:\temp (או לכל מיקום מותאם אישית שבו הצבת את הפלט) ולאחר מכן פתח KMSInfo.txt. חפש את Office כדי למצוא את פרטי ההתקנה של מארח KMS של Office. בדוק את הערך ספירה נוכחית . אם ערך ספירת ה- KMS של Office קטן מ- 5, לקוחות Office לא יופעלו.

כאשר מאגר ה- KMS של Office מכיל חמישה מחשבי לקוח או יותר, נסה להפעיל את Office באמצעות אשף ההפעלה של Office, OSPP.vbsאו VAMT.

אם אתה משתמש בהכנה למערכת (Sysprep) בסביבה שלך, ייתכן ש- Office לא היה מחדש לפני יצירת התמונה. לכן, ייתכן שלמחשבים יהיה אותו מזהה מחשב לקוח (CMID) עבור Office.

אם יש לך יותר מחמישה מחשבים שמנסים להפעיל, ואתה עדיין רואה הודעת שגיאה זו, בדוק את מזהה הכניסה של מארח ה- KMS מציג האירועים בשרת ה- KMS. לדוגמה, תראה ערכים הדומים להודעה הבאה:

  • 0x0,5,Ignite1.ignite.local,930bd202-a335-4c7e-bd9d-7305361f0d37,תאריך/שעה,0,5,0,6f327760-8c5c-417c-9b61-836a98287e0c
  • 0x0,5,Ignite2.ignite.local,2f362dd3-fb39-4d18-94e6-de1d30dd27d5, תאריך/שעה,0,5,0,6f327760-8c5c-417c-9b61-836a98287e0c
  • 0x0,5,Ignite5.ignite.local,930bd202-a335-4c7e-bd9d-7305361f0d37 ,תאריך/שעה,0,5,0,6f327760-8c5c-417c-9b61-836a98287e0c

בדוגמה זו, שים לב ש- Ignite5 ו- ignite1 הם בעלי CMID זהה (930bd202-a335-4c7e-bd9d-7305361f0d37). הדבר מציין שהמערכת דילגה על הנשק מחדש של Office למרות שייתכן שתמונת מערכת ההפעלה הבסיסית נוצרה.

הערה

לפני ש- Sysprep מכין את התמונה, הקפד להפעיל אחת מהפקודות הבאות, בהתבסס על גירסת הסיביות של Office שברשותך, כדי להבטיח CMID ייחודי של Office.

  • עבור Office 32 סיביות

    C:\Program Files (x86)\Microsoft Office\Office16\ospprearm.exe

  • עבור Office 64 סיביות

    C:\Program Files\Microsoft Office\Office16\ospprearm.exe

לקבלת מידע מפורט על האופן שבו ניתן להפעיל מחדש את התקנת Office, עיין במאמרים הבאים:

באפשרותך להפעיל את קובץ ה- Script הבא של ההפעלה במחשבים אלה כדי להפעיל מחדש את Office וליצור מזהי Office ייחודיים חדשים. בקובץ Script זה, החלף את XX בערך המתאים, בהתבסס על גירסת Office שלך:

XX = 15 עבור Office 2013

XX = 16 עבור Office 2016

@echo off

:OSPP 

reg query HKLM\Software\Microsoft\Office\XX.0\Common\OSPPREARM if %errorlevel%==1 (goto RUN) else (goto END)

:RUN set ProgramFilesPath=%ProgramFiles% 

"%ProgramFilesPath%\Microsoft Office\OfficeXX\OSPPREARM.EXE"

C:\Windows\system32\cscript.exe "%ProgramFilesPath%\Microsoft Office\OfficeXX\ospp.vbs" /act set ProgramFilesPath=%ProgramFiles(x86)%

"%ProgramFilesPath%\Microsoft Office\OfficeXX\OSPPREARM.EXE"

C:\Windows\system32\cscript.exe "%ProgramFilesPath%\Microsoft Office\OfficeXX\ospp.vbs" /act REG ADD "HKLM\Software\Microsoft\Office\XX.0\Common\OSPPREARM"

:END

Exit