SQL Server servizio potrebbe non essere avviato dopo l'installazione della patch

Questo articolo consente di risolvere il problema che si verifica dopo che il programma di installazione delle patch installa una patch e tenta di riavviare il sistema.

Versione originale del prodotto: SQL Server
Numero KB originale: 961301

Sintomo

È possibile che venga visualizzato un messaggio che informa che non è stato possibile avviare un servizio SQL Server. Il SQL Server non viene riavviato dopo che il programma di installazione delle patch installa una patch e tenta di riavviare il sistema. Il messaggio di errore verrà visualizzato sullo schermo o verrà visualizzato nel log summary.txt .

Causa

Questo problema può essere causato da un servizio SQL in esecuzione, ma la password è scaduta. Quando il programma di installazione della patch tenta di riavviare il servizio SQL, il riavvio avrà esito negativo.

Risoluzione

Se viene visualizzato un messaggio che indica che non è stato possibile avviare un servizio SQL Server, per risolvere il problema, verificare quanto segue:

  • Determinare l'errore. Un messaggio verrà visualizzato nell'interfaccia utente o nel log summary.txt che si trova in %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log.

  • Verificare se il tipo di servizio di avvio è automatico o manuale.

  • Verificare che l'account e la password siano validi e non siano scaduti. Un servizio potrebbe essere stato eseguito in precedenza con un account o una password non validi.

  • Se il servizio Motore di database non verrà avviato, dopo aver verificato le credenziali e l'avvio del servizio, controllare ERRORLOG. ERRORLOG si trova in C:\Programmi\Microsoft SQL Server\<ID> istanza\MSSQL\LOG.