Le prestazioni sono scarse quando si utilizza un profilo utente predefinito personalizzato in Windows

In questo articolo viene fornita una soluzione ai problemi che si verificano quando si utilizzano i profili utente predefiniti.

Si applica a:   Windows 10 - tutte le edizioni, Windows Server 2019, Windows Server 2016
Numero KB originale:   4056823

Sintomo

Considerare lo scenario descritto di seguito:

  • È possibile creare un nuovo profilo utente predefinito e abilitarlo.
  • Un nuovo utente accede utilizzando un profilo creato dal profilo predefinito in un computer basato su Windows 10, Windows Server 2016 o Windows Server 2019.

In questo scenario, si verificano uno o più dei seguenti problemi:

  • La visualizzazione delle icone del desktop può richiedere molto tempo.

  • Le prestazioni sono scarse quando si avvia o si esplora Internet Explorer o Microsoft Edge.

  • Gli errori ESENT come i seguenti vengono registrati nel registro eventi:

    EventLogID: 454
    TaskHostW: (pid)
    WebCacheLocal: "Ripristino/ripristino del database non riuscito con errore imprevisto -1907"

    Nota

    Il messaggio del registro eventi completo può anche indicare un'associazione con un percorso di cartella utente diverso, ad esempio C: \ Amministratore \ utenti.

Causa

Questi problemi si verificano perché il profilo utente predefinito include una copia bloccata del database della cache di un altro utente.

Quando un nuovo utente accede al computer, il contenuto del profilo utente predefinito viene incorporato nel nuovo profilo. Quando la Windows shell e il desktop iniziano a caricarsi, il database non può essere completamente inizializzato per l'utilizzo. Le applicazioni che utilizzano il database hanno prestazioni negative o segnalano errori.

Risoluzione

Per risolvere il problema, eseguire la procedura seguente:

  1. Accedere a ogni computer interessato utilizzando un account con credenziali amministrative e quindi eliminare il file e la cartella nascosti seguenti, se esistenti:

    File: C: \ Users \ Default \ AppData Local Microsoft Windows \ \ \ \ WebCacheLock.dat
    Cartella: C: \ Utenti \ \ AppData predefinito \ Microsoft \ Windows \ \ WebCache

  2. Per ogni account utente nel computer, assicurarsi che l'utente sia disconnesso completamente e che il profilo sia stato scaricato completamente, quindi eliminare il file nascosto e la cartella seguenti, se esistenti:

    File: C: \ Users \ <affectedUserFolder> \ AppData \ Local Microsoft Windows \ \ \ WebCacheLock.dat
    Cartella: C: \ Utenti \ <affectedUserFolder> \ AppData \ Locale Microsoft Windows \ \ \ WebCache

Nota

<affectedUserFolder> è un segnaposto per il nome della cartella del profilo utente. Ad esempio, per l'account utente Administrator, la cartella si trova in C: \ Users \ Administrator. È necessario rimuovere i file e le cartelle precedenti per ogni account utente interessato nel computer.

Come visualizzare i file nascosti

Per visualizzare i file nascosti, attenersi alla seguente procedura:

  1. In Windows Explorer seleziona File e quindi opzioni.
  2. Nella scheda Visualizza selezionare l'opzione Mostra file, cartelle e unità nascosti.
  3. Deselezionare l'opzione Nascondi file del sistema operativo protetti (scelta consigliata) e quindi fare clic su OK.

Nota

È consigliabile selezionare di nuovo le due opzioni dopo aver risolto il problema.

Altre informazioni

Poiché il database della cache è progettato per essere generato per utente al momento dell'accesso iniziale a un singolo computer, Microsoft non consiglia o supporta l'inclusione del database della cache nel profilo predefinito o in qualsiasi altro profilo utente destinato a essere utilizzato come modello.