Non è possibile trovare dati nei log attività di Azure Active Directory scaricati

Sintomi

I log attività (controllo o accessi) sono stati scaricati ma non vengono visualizzati tutti i record per l'orario scelto. Perché?

Creazione di report

Causa

Quando si scaricano i log attività nel portale di Azure, viene applicata una limitazione a 120.000 record, ordinati a partire dal più recente.

Risoluzione

È possibile sfruttare le API di Creazione rapporti di Azure AD per recuperare fino a un milione di record per un momento specifico. L'approccio consigliato consiste nell'eseguire uno script in base a una pianificazione per chiamare le API di Creazione rapporti per recuperare i record in modo incrementale in un periodo di tempo specifico, ad esempio ogni giorno oppure ogni settimana.

Passaggi successivi

Vedere Domande frequenti sulla creazione di report in Azure Active Directory.