Lezione 1: Creare un progetto di modello tabulareLesson 1: Create a tabular model project

SI APPLICA A:SìAzure Analysis ServicesSìSQL Server Analysis Services (a partire dalla versione 2017)APPLIES TO:yesAzure Analysis ServicesyesSQL Server Analysis Services (starting with 2017)

In questa lezione si usa SQL Server Data Tools (SSDT) per creare un nuovo progetto di modello tabulare al livello di compatibilità 1400.In this lesson, you use SQL Server Data Tools (SSDT) to create a new tabular model project at the 1400 compatibility level. Dopo aver creato il nuovo progetto, è possibile iniziare ad aggiungere i dati e a lavorare al modello.Once your new project is created, you can begin adding data and authoring your model. Questa lezione offre anche una breve introduzione all'ambiente per la creazione dei modelli tabulari in SSDT.This lesson also gives you a brief introduction to the tabular model authoring environment in SSDT.

Tempo previsto per il completamento della lezione: 10 minutiEstimated time to complete this lesson: 10 minutes

PrerequisitiPrerequisites

Questo argomento è la prima lezione dell'esercitazione per la creazione di un modello tabulare.This topic is the first lesson in a tabular model authoring tutorial. Per completare questa lezione, esistono alcuni prerequisiti che è necessario soddisfare.To complete this lesson, there are several prerequisites you need to have in-place. Per altre informazioni, vedere Azure Analysis Services: esercitazione su Adventure Works.To learn more, see Azure Analysis Services - Adventure Works tutorial.

Creare un nuovo progetto di modello tabulareCreate a new tabular model project

Per creare un nuovo progetto di modello tabulareTo create a new tabular model project

  1. In SSDT scegliere Nuovo > Progetto dal menu File.In SSDT, on the File menu, click New > Project.

  2. Nella finestra di dialogo Nuovo progetto espandere Installati > Business Intelligence > Analysis Services e quindi fare clic su Progetto tabulare di Analysis Services.In the New Project dialog box, expand Installed > Business Intelligence > Analysis Services, and then click Analysis Services Tabular Project.

  3. Nella casella Nome digitare AW Internet Sales e quindi specificare una posizione per i file di progetto.In Name, type AW Internet Sales, and then specify a location for the project files.

    Per impostazione predefinita, in Nome soluzione è indicato lo stesso nome del progetto, ma è possibile digitare un nome diverso per la soluzione.By default, Solution Name is the same as the project name; however, you can type a different solution name.

  4. Fare clic su OK.Click OK.

  5. Nella finestra di dialogo Progettazione modelli tabulari selezionare Area di lavoro integrata.In the Tabular model designer dialog box, select Integrated workspace.

    L'area di lavoro ospita un database del modello tabulare con lo stesso nome del progetto durante la creazione del modello.The workspace hosts a tabular model database with the same name as the project during model authoring. Area di lavoro integrata significa che SSDT usa un'istanza predefinita, eliminando la necessità di installare un'istanza del server Analysis Services separata solo per la creazione del modello.Integrated workspace means SSDT uses a built-in instance, eliminating the need to install a separate Analysis Services server instance just for model authoring.

  6. In Livello di compatibilità selezionare SQL Server 2017 / Azure Analysis Services (1400).In Compatibility level, select SQL Server 2017 / Azure Analysis Services (1400).

    aas-lesson1-tmd

    Se la casella di riepilogo Livello di compatibilità non include SQL Server 2017 / Azure Analysis Services (1400), ciò indica che non è disponibile la versione più recente di SQL Server Data Tools.If you don’t see SQL Server 2017 / Azure Analysis Services (1400) in the Compatibility level listbox, you’re not using the latest version of SQL Server Data Tools. Per ottenere la versione più recente, vedere Download SQL Server Data Tools (SSDT) (Scaricare SQL Server Data Tools (SSDT)).To get the latest version, see Install SQL Server Data tools.

Informazioni sull'ambiente di creazione di modelli tabulari di SSDTUnderstanding the SSDT tabular model authoring environment

Dopo aver creato un nuovo progetto di modello tabulare è possibile iniziare a esplorare l'ambiente di SSDT per la creazione di modelli tabulari.Now that you’ve created a new tabular model project, let’s take a moment to explore the tabular model authoring environment in SSDT.

Il progetto creato viene aperto in SSDT.After your project is created, it opens in SSDT. Sul lato destro in Esplora modelli tabulari è disponibile una visualizzazione struttura ad albero degli oggetti nel modello.On the right side, in Tabular Model Explorer, you see a tree view of the objects in your model. Le cartelle sono vuote perché non sono stati ancora importati i dati.Since you haven't yet imported data, the folders are empty. È possibile fare clic con il pulsante destro del mouse su una cartella di oggetti per eseguire varie azioni, in modo simile alla barra dei menu.You can right-click an object folder to perform actions, similar to the menu bar. Durante l'esecuzione di questa esercitazione si usa Esplora modelli tabulari per spostarsi tra i diversi oggetti nel progetto del modello.As you step through this tutorial, you use the Tabular Model Explorer to navigate different objects in your model project.

aas-lesson1-tme

Fare clic sulla scheda Esplora soluzione. In questa scheda è possibile visualizzare il file Model.bim.Click the Solution Explorer tab. Here, you see your Model.bim file. Se la finestra di progettazione a sinistra non è visibile (la finestra vuota con la scheda Model.bim), in Esplora soluzioni fare doppio clic sul file Model.bim nel progetto AW Internet Sales.If you don’t see the designer window to the left (the empty window with the Model.bim tab), in Solution Explorer, under AW Internet Sales Project, double-click the Model.bim file. Il file Model.bim contiene i metadati per il progetto del modello.The Model.bim file contains the metadata for your model project.

aas-lesson1-se

Fare clic su Model.bim.Click Model.bim. Nella finestra Proprietà sono visualizzate le proprietà del modello, la più importante delle quali è la proprietà Modalità DirectQuery.In the Properties window, you see the model properties, most important of which is the DirectQuery Mode property. Questa proprietà specifica se il modello viene distribuito in modalità In-Memory (Disattivata) o in modalità DirectQuery (Attivata).This property specifies if the model is deployed in In-Memory mode (Off) or DirectQuery mode (On). Per questa esercitazione, il modello viene creato e distribuito in modalità In-Memory.For this tutorial, you author and deploy your model in In-Memory mode.

aas-lesson1-properties

Quando si crea un progetto di modello, determinate proprietà del modello vengono impostate automaticamente in base alle impostazioni di Modellazione dati che possono essere specificate nella finestra di dialogo Opzioni accessibile dal menu Strumenti.When you create a model project, certain model properties are set automatically according to the Data Modeling settings that can be specified in the Tools menu > Options dialog box. Le proprietà Backup dei dati, Memorizzazione area di lavoro e Server dell'area di lavoro specificano come e dove viene eseguito il backup, viene mantenuto in memoria e viene creato il database dell'area di lavoro, ovvero il database per la creazione del modello.Data Backup, Workspace Retention, and Workspace Server properties specify how and where the workspace database (your model authoring database) is backed up, retained in-memory, and built. È possibile modificare queste impostazioni in un secondo momento, se necessario, ma per ora, lasciarle come sono.You can change these settings later if necessary, but for now, leave these properties as they are.

In Esplora soluzioni fare clic con il pulsante destro del mouse su AW Internet Sales (progetto) e quindi scegliere Proprietà.In Solution Explorer, right-click AW Internet Sales (project), and then click Properties. Verrà visualizzata la finestra di dialogo Pagine delle proprietà di AW Internet Sales.The AW Internet Sales Property Pages dialog box appears. Alcune di queste proprietà verranno impostate in un secondo momento, durante la distribuzione del modello.You set some of these properties later when you deploy your model.

Con l'installazione di SSDT vengono aggiunte varie voci di menu nuove all'ambiente di Visual Studio.When you installed SSDT, several new menu items were added to the Visual Studio environment. Fare clic sul menu Modello.Click the Model menu. Da questo menu è possibile importare dati, aggiornare i dati dell'area di lavoro, esplorare il modello in Excel, creare prospettive e ruoli, selezionare la vista modelli e impostare le opzioni di calcolo.From here, you can import data, refresh workspace data, browse your model in Excel, create perspectives and roles, select the model view, and set calculation options. Fare clic sul menu Tabella.Click the Table menu. Da questo menu è possibile creare e gestire relazioni, specificare le impostazioni della tabella data, creare partizioni e modificare le proprietà della tabella.From here, you can create and manage relationships, specify date table settings, create partitions, and edit table properties. Dal menu Colonna è possibile aggiungere ed eliminare colonne in una tabella, bloccare le colonne e specificare l'ordinamento.If you click the Column menu, you can add and delete columns in a table, freeze columns, and specify sort order. SSDT aggiunge anche alcuni pulsanti alla barra.SSDT also adds some buttons to the bar. Il più utile è quello della funzionalità Somma automatica che consente di creare una misura di aggregazione standard per una colonna selezionata.Most useful is the AutoSum feature to create a standard aggregation measure for a selected column. Con gli altri pulsanti della barra degli strumenti è possibile accedere rapidamente ai comandi e alle funzioni usati di frequente.Other toolbar buttons provide quick access to frequently used features and commands.

Esplorare alcune delle finestre di dialogo e individuare le posizioni delle varie funzionalità specifiche per la creazione di modelli tabulari.Explore some of the dialogs and locations for various features specific to authoring tabular models. Anche se alcune voci di menu o opzioni non sono ancora attive, è così possibile acquisire familiarità con l'ambiente per la creazione di modelli tabulari.While some items are not yet active, you can get a good idea of the tabular model authoring environment.

Passaggi successiviWhat's next?

Lezione 2: Ottenere i dati.Lesson 2: Get data.