Risolvi i problemi di distribuzione con il riavvio o il ridimensionamento di una macchina virtuale Windows esistente in Azure

Quando si tenta di avviare una macchina virtuale di Azure (VM) arrestata o di ridimensionare una macchina virtuale di Azure esistente, l'errore comune riscontrato è un errore di allocazione. Questo errore si verifica quando il cluster o l'area non dispone di risorse disponibili o non è in grado di supportare la dimensione della macchina virtuale richiesta.

Se il problema di Azure non è stato risolto in questo articolo, visitare i forum di Azure su MSDN e Stack Overflow. È possibile pubblicare il problema in questi forum o su @AzureSupport su Twitter. È inoltre possibile inviare una richiesta di supporto di Azure. Per inviare una richiesta di supporto, nella pagina Supporto di Azure selezionare Ottieni supporto.

Raccogli i registri delle attività

Per avviare la risoluzione dei problemi, raccogli i registri delle attività per identificare l'errore associato al problema. I seguenti collegamenti contengono informazioni dettagliate sul processo:

Visualizzare le operazioni di distribuzione

Visualizzare i log delle attività per gestire le risorse di Azure

Problema: errore durante l'avvio di una macchina virtuale arrestata

Si tenta di avviare una macchina virtuale arrestata ma si ottiene un errore di allocazione.

Causa

La richiesta di avviare la macchina virtuale arrestata deve essere tentata nel cluster originale che ospita il servizio cloud. Tuttavia, il cluster non dispone di spazio libero disponibile per soddisfare la richiesta.

Risoluzione

  • Arrestare tutte le macchine virtuali nel set di disponibilità e quindi riavviare ogni macchina virtuale.

    1. Fai clic su Gruppi di risorse>il tuo gruppo di risorse>Risorse>il tuo set di disponibilità>Macchine virtuali>la tua macchina virtuale>Arresta.
    2. Dopo l'arresto di tutte le macchine virtuali, selezionare ognuna delle macchine virtuali arrestate e fare clic su Avvia.
  • Riprovare la richiesta di riavvio in un secondo momento.

Problema: errore durante il ridimensionamento di una macchina virtuale esistente

Si tenta di ridimensionare una macchina virtuale esistente ma si ottiene un errore di allocazione.

Causa

La richiesta di ridimensionamento della VM deve essere tentata nel cluster originale che ospita il servizio cloud. Tuttavia, il cluster non supporta la dimensione della macchina virtuale richiesta.

Risoluzione

  • Riprovare la richiesta utilizzando una dimensione della macchina virtuale più piccola.

  • Se non è possibile modificare le dimensioni della macchina virtuale richiesta:

    1. Arrestare tutte le macchine virtuali nel set di disponibilità.

      • Fai clic su Gruppi di risorse>il tuo gruppo di risorse>Risorse>il tuo set di disponibilità>Macchine virtuali>la tua macchina virtuale>Arresta.
    2. Dopo l'arresto di tutte le VM, ridimensionare la VM desiderata a una dimensione maggiore.

    3. Selezionare la macchina virtuale ridimensionata e fare clic su Avvia, quindi avvia ogni macchina virtuale arrestata.

Errore durante l'arresto, l'avvio, il riavvio o la ridistribuzione di una macchina virtuale esistente

Quando si tenta di arrestare, avviare, riavviare o ridistribuire una macchina virtuale esistente, il processo ha esito negativo e viene visualizzato un errore imprevisto durante l'elaborazione del profilo di rete della macchina virtuale. Messaggio di errore Riprovare in un secondo momento. Quando si verifica questo errore, la macchina virtuale viene messa in stato di errore.

Causa

Questo problema si verifica se si verifica un problema nell'allocazione o nell'aggiornamento delle risorse di rete.

Risoluzione

Prova a riapplicare lo stato della macchina virtuale. Questa operazione esegue nuovamente il provisioning della macchina virtuale e aiuta a risolvere l'errore di stato della macchina virtuale che si verifica se il relativo provisioning non è riuscito durante l'esecuzione di un'azione precedente.

  1. Passare alla macchina virtuale bloccata nello stato di errore.
  2. Nella Guida, selezionare Ridistribuisci + riapplica.
  3. Seleziona l'opzione Riapplica.

Passaggi successivi

Se si verificano problemi durante la creazione di una nuova macchina virtuale Windows in Azure, vedere Risolvere i problemi di distribuzione con la creazione di una nuova macchina virtuale Windows in Azure.

Contattaci per ricevere assistenza

In caso di domande o bisogno di assistenza, creare una richiesta di supporto tecnico oppure formula una domanda nel Supporto della community di Azure. È possibile anche inviare un feedback sul prodotto al feedback della community di Azure.