Risolvere gli errori nei criteri delle etichette di conservazione e conservazione di Microsoft 365

Se si verifica un errore correlato ai criteri di conservazione o etichetta di conservazione di Microsoft 365, selezionare la descrizione dell'errore applicabile nell'elenco seguente:

Se nessuna delle risoluzioni si applica al problema, contattare supporto tecnico Microsoft.

Per informazioni su come identificare gli errori dei criteri di conservazione, vedere Identificare gli errori nei criteri delle etichette di conservazione e conservazione di Microsoft 365.

Importante

Microsoft Purview non supporta i criteri che contengono errori. È innanzitutto necessario risolvere tutti gli errori dei criteri. In caso contrario, i criteri delle etichette di conservazione e conservazione potrebbero non funzionare come previsto.

Errore: Impostazioni non trovate

Sintomi

Quando si controlla il riquadro dei dettagli per un criterio di conservazione nel Portale di conformità di Microsoft Purview, viene visualizzato il messaggio di errore "Impostazioni non trovate".

Causa

I criteri di conservazione non hanno regole di conservazione.

Risoluzione

Per risolvere questo problema, usare uno dei metodi seguenti.

Metodo 1: usare il Portale di conformità di Microsoft Purview

  1. Nella Portale di conformità di Microsoft Purview cercare i criteri nelle schede seguenti:

    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di conservazione
    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di etichetta
    • Gestione> recordCriteri di etichetta
  2. Selezionare il criterio e quindi selezionare Modifica.

  3. In Impostazioni di conservazione aggiungere regole ai criteri di conservazione.

Metodo 2: Usare PowerShell

  1. Connettersi a PowerShell per Sicurezza e conformità.

  2. Usare il cmdlet applicabile per il carico di lavoro per aggiungere regole ai criteri di conservazione.

    Usare il cmdlet New-RetentionComplianceRule per i criteri destinati a:

    • Microsoft Exchange Online messaggio di posta elettronica
    • Siti di Microsoft SharePoint
    • Account di Microsoft OneDrive
    • Gruppi di Microsoft 365
    • Conversazioni di Microsoft Skype for Business
    • Cartelle pubbliche di Exchange Online
    • Messaggi di chat di Microsoft Teams
    • Messaggi del canale di Teams

    Ad esempio, per aggiungere una regola che specifica un periodo di conservazione illimitato, eseguire il comando seguente:

    New-RetentionComplianceRule -Name "<new rule name>" -Policy "<existing policy name>" -RetentionDuration Unlimited
    

    Usare il cmdlet New-AppRetentionComplianceRule per i criteri destinati a:

    • Messaggi del canale privato di Teams
    • Microsoft Viva Engage messaggi utente
    • Viva Engage messaggi della community

    Ad esempio, per aggiungere una regola che specifica un periodo di conservazione illimitato, eseguire il comando seguente:

    New-AppRetentionComplianceRule -Name "<new rule name>" -Policy "<existing policy name>" -RetentionDuration Unlimited
    

Inizio pagina

Errore: si è verificato un errore

Sintomi

Quando si controlla il riquadro dei dettagli per un criterio nel Portale di conformità di Microsoft Purview, viene visualizzato il messaggio di errore "Qualcosa è andato storto".

Se si esegue il comando seguente, viene visualizzato PolicyNotifyError nel valore restituito dalla DistributionResults proprietà :

Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults

Causa

Si è verificato un errore non specificato nella pipeline di notifica del processo di sincronizzazione e distribuzione dei criteri.

Risoluzione

Per risolvere questo problema, usare uno dei metodi seguenti. Se si usa il metodo 1, verificare la presenza di opzioni di risoluzione aggiuntive nel riquadro dei dettagli dei criteri.

Metodo 1: usare il Portale di conformità di Microsoft Purview

  1. Nella Portale di conformità di Microsoft Purview cercare i criteri nelle schede seguenti:

    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di conservazione
    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di etichetta
    • Gestione> recordCriteri di etichetta
  2. Selezionare il criterio per aprire il riquadro dei dettagli dei criteri. Assicurarsi di selezionare il nome del criterio e non la casella di controllo corrispondente. In caso contrario, il riquadro dei dettagli non verrà aperto.

  3. Nel riquadro dei dettagli dei criteri selezionare Riprova. Il criterio entra in uno stato in sospeso fino al termine della sincronizzazione e della distribuzione dei criteri.

Metodo 2: Usare PowerShell

  1. Connettersi a PowerShell per Sicurezza e conformità.

  2. Sincronizzazione e distribuzione dei criteri di ripetizione dei tentativi. Usare il cmdlet Set-RetentionCompliancePolicy insieme all'opzione RetryDistribution per ridistribuire i criteri:

    Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
    

Inizio pagina

Errore: il percorso è ambiguo

Sintomi

Quando si controlla il riquadro dei dettagli per un criterio nel Portale di conformità di Microsoft Purview, viene visualizzato il messaggio di errore "La posizione è ambigua".

Se si esegue il comando seguente, viene visualizzato MultipleInactiveRecipientsError nel valore restituito dalla DistributionResults proprietà :

Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults

Causa

Il sistema ha restituito più di un risultato per la posizione specificata. Affinché il sistema applichi un criterio, ogni posizione applicabile deve avere una corrispondenza.

Risoluzione

Per risolvere questo problema, usare uno dei metodi seguenti. Se si usa il metodo 1, verificare la presenza di opzioni di risoluzione aggiuntive nel riquadro dei dettagli dei criteri che si apre quando si seleziona il nome del criterio.

Metodo 1: usare il Portale di conformità di Microsoft Purview

  1. Nella Portale di conformità di Microsoft Purview cercare i criteri nelle schede seguenti:

    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di conservazione
    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di etichetta
    • Gestione> recordCriteri di etichetta
  2. Selezionare il criterio e quindi selezionare Modifica.

  3. Rimuovere i percorsi duplicati dai criteri.

Metodo 2: Usare PowerShell

  1. Connettersi a PowerShell per Sicurezza e conformità.

  2. Rimuovere i percorsi duplicati dai criteri usando il cmdlet Set-RetentionCompliancePolicy . Ad esempio, per rimuovere un percorso di Exchange, usare l'opzione RemoveExchangeLocation .

  3. Sincronizzazione e distribuzione dei criteri di ripetizione dei tentativi. Usare il cmdlet Set-RetentionCompliancePolicy insieme all'opzione RetryDistribution per ridistribuire i criteri:

    Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
    

Inizio pagina

Errore: la posizione non è disponibile nell'archiviazione

Sintomi

Quando si tenta di creare o aggiornare un criterio nel Portale di conformità di Microsoft Purview, l'operazione ha esito negativo. Nel riquadro dei dettagli per i criteri viene visualizzato il messaggio di errore "La posizione non è disponibile".

Se si esegue il comando seguente, viene visualizzato SiteOutOfQuota nel valore restituito dalla DistributionResults proprietà :

Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults

Causa

La posizione non dispone di spazio di archiviazione sufficiente per consentire al sistema di applicare i criteri o l'aggiornamento dei criteri.

Risoluzione

Per risolvere questo problema, usare uno dei metodi seguenti. Se si usa il metodo 1, verificare la presenza di opzioni di risoluzione aggiuntive nel riquadro dei dettagli dei criteri.

Metodo 1: usare il Portale di conformità di Microsoft Purview

  1. Aumentare la quota di archiviazione per la posizione specificata. Contattare l'amministratore del sito o l'amministratore globale di SharePoint per gestire la quota per la posizione. È anche possibile eliminare gli elementi non necessari per aumentare l'archiviazione disponibile.

  2. Nella Portale di conformità di Microsoft Purview cercare i criteri nelle schede seguenti:

    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di conservazione
    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di etichetta
    • Gestione> recordCriteri di etichetta
  3. Selezionare il criterio per aprire il riquadro dei dettagli dei criteri. Assicurarsi di selezionare il nome del criterio e non la casella di controllo corrispondente. In caso contrario, il riquadro dei dettagli non verrà aperto.

  4. Nel riquadro dei dettagli dei criteri selezionare Riprova. Il criterio entra in uno stato in sospeso fino al termine della sincronizzazione e della distribuzione dei criteri.

Metodo 2: Usare PowerShell

  1. Aumentare la quota di archiviazione. Contattare l'amministratore del sito o l'amministratore globale di SharePoint per gestire la quota per la posizione. È anche possibile eliminare gli elementi non necessari per aumentare l'archiviazione disponibile.

  2. Dopo aver aumentato la quota di archiviazione, connettersi a PowerShell sicurezza & conformità.

  3. Sincronizzazione e distribuzione dei criteri di ripetizione dei tentativi. Per ridistribuire i criteri, usare il cmdlet Set-RetentionCompliancePolicy insieme all'opzione RetryDistribution :

    Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
    

Inizio pagina

Errore: il sito è bloccato

Sintomi

Quando si controlla il riquadro dei dettagli per un criterio nel Portale di conformità di Microsoft Purview, viene visualizzato il messaggio di errore "Il sito è bloccato".

Se si esegue il comando seguente, viene visualizzato SiteInReadOnlyOrNotAccessible nel valore restituito dalla DistributionResults proprietà :

Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults

Causa

Un amministratore ha bloccato il sito o il sistema ha bloccato temporaneamente il sito durante un processo automatizzato. Durante un processo automatizzato, gli aggiornamenti non sono consentiti.

Risoluzione

Per risolvere questo problema, usare uno dei metodi seguenti. Se si usa il metodo 1, verificare la presenza di opzioni di risoluzione aggiuntive nel riquadro dei dettagli dei criteri.

Metodo 1: usare il Portale di conformità di Microsoft Purview

  1. Contattare l'amministratore del sito o l'amministratore globale di SharePoint per sbloccare il sito e quindi ridistribuire questo criterio.

  2. Nella Portale di conformità di Microsoft Purview cercare i criteri nelle schede seguenti:

    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di conservazione
    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di etichetta
    • Gestione> recordCriteri di etichetta
  3. Selezionare il criterio per aprire il riquadro dei dettagli dei criteri. Assicurarsi di selezionare il nome del criterio e non la casella di controllo corrispondente. In caso contrario, il riquadro dei dettagli non verrà aperto.

  4. Nel riquadro dei dettagli dei criteri selezionare Riprova. Il criterio entra in uno stato in sospeso fino al termine della sincronizzazione e della distribuzione dei criteri.

Metodo 2: Usare PowerShell

  1. Per sbloccare il sito, contattare l'amministratore del sito o l'amministratore globale di SharePoint e quindi ridistribuire questo criterio

  2. Connettersi a PowerShell per Sicurezza e conformità.

  3. Quando il sito è sbloccato, ripetere la sincronizzazione e la distribuzione dei criteri. Usare il cmdlet Set-RetentionCompliancePolicy insieme all'opzione RetryDistribution per ridistribuire i criteri:

    Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
    

Inizio pagina

Errore: i criteri vengono ancora elaborati

Sintomi

Quando si controlla il riquadro dei dettagli per un criterio nel Portale di conformità di Microsoft Purview, viene visualizzato il messaggio di errore "Stiamo ancora elaborando i criteri".

Se si esegue il comando seguente, viene visualizzato PolicySyncTimeout nel valore restituito dalla DistributionResults proprietà :

Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults

Causa

La sincronizzazione dei criteri non è stata completata entro l'intervallo di tempo previsto.

Risoluzione

Per risolvere questo problema, usare uno dei metodi seguenti. Se si usa il metodo 1, verificare la presenza di opzioni di risoluzione aggiuntive nel riquadro dei dettagli dei criteri.

Metodo 1: usare il Portale di conformità di Microsoft Purview

  1. Nella Portale di conformità di Microsoft Purview cercare i criteri nelle schede seguenti:

    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di conservazione
    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di etichetta
    • Gestione> recordCriteri di etichetta
  2. Selezionare il criterio per aprire il riquadro dei dettagli dei criteri. Assicurarsi di selezionare il nome del criterio e non la casella di controllo corrispondente. In caso contrario, il riquadro dei dettagli non verrà aperto.

  3. Nel riquadro dei dettagli dei criteri selezionare Riprova. Il criterio entra in uno stato in sospeso fino al termine della sincronizzazione e della distribuzione dei criteri.

Metodo 2: Usare PowerShell

  1. Connettersi a PowerShell per Sicurezza e conformità.

  2. Sincronizzazione e distribuzione dei criteri di ripetizione dei tentativi. Usare il cmdlet Set-RetentionCompliancePolicy insieme all'opzione RetryDistribution per ridistribuire i criteri:

    Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
    

Inizio pagina

Errore: non è possibile elaborare i criteri

Sintomi

Quando si controlla il riquadro dei dettagli per un criterio nel Portale di conformità di Microsoft Purview, viene visualizzato il messaggio di errore "Non è possibile elaborare i criteri".

Se si esegue il comando seguente, viene visualizzato ActiveDirectorySyncError nel valore restituito dalla DistributionResults proprietà :

Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults

Causa

I criteri non sono stati sincronizzati con Microsoft Entra ID.

Risoluzione

Per risolvere questo problema, usare uno dei metodi seguenti. Se si usa il metodo 1, verificare la presenza di opzioni di risoluzione aggiuntive nel riquadro dei dettagli dei criteri.

Metodo 1: usare il Portale di conformità di Microsoft Purview

  1. Nella Portale di conformità di Microsoft Purview cercare i criteri nelle schede seguenti:

    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di conservazione
    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di etichetta
    • Gestione> recordCriteri di etichetta
  2. Selezionare il criterio per aprire il riquadro dei dettagli dei criteri. Assicurarsi di selezionare il nome del criterio e non la casella di controllo corrispondente. In caso contrario, il riquadro dei dettagli non verrà aperto.

  3. Nel riquadro dei dettagli dei criteri selezionare Riprova. Il criterio entra in uno stato in sospeso fino al termine della sincronizzazione e della distribuzione dei criteri.

Metodo 2: Usare PowerShell

  1. Connettersi a PowerShell per Sicurezza e conformità.

  2. Sincronizzazione e distribuzione dei criteri di ripetizione dei tentativi. Usare il cmdlet Set-RetentionCompliancePolicy insieme all'opzione RetryDistribution per ridistribuire i criteri:

    Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
    

Inizio pagina

Errore: non è stato possibile trovare questa posizione

Sintomi

Quando si controlla il riquadro dei dettagli per un criterio nel Portale di conformità di Microsoft Purview, viene visualizzato il messaggio di errore "Non è stato possibile trovare questa posizione".

Se si esegue il comando seguente, viene visualizzato FailedToOpenContainer nel valore restituito dalla DistributionResults proprietà :

Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults

Causa

I criteri non possono essere sincronizzati con una posizione perché la posizione non esiste. La posizione potrebbe essere presente in precedenza.

Nota

Se si verifica questo errore, il sistema richiede di rimuovere i percorsi problematici come parte dell'aggiornamento successivo ai criteri.

Risoluzione

Per risolvere questo problema, usare uno dei metodi seguenti. Se si usa il metodo 1, verificare la presenza di opzioni di risoluzione aggiuntive nel riquadro dei dettagli dei criteri.

Metodo 1: usare il Portale di conformità di Microsoft Purview

  1. Nella Portale di conformità di Microsoft Purview cercare i criteri nelle schede seguenti:

    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di conservazione
    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di etichetta
    • Gestione> recordCriteri di etichetta
  2. Selezionare il criterio per aprire il riquadro dei dettagli dei criteri. Assicurarsi di selezionare il nome del criterio e non la casella di controllo corrispondente. In caso contrario, il riquadro dei dettagli non verrà aperto.

  3. Rimuovere i percorsi problematici dai criteri.

Metodo 2: Usare PowerShell

  1. Connettersi a PowerShell per Sicurezza e conformità.

  2. Rimuovere i percorsi problematici dai criteri usando il cmdlet Set-RetentionCompliancePolicy . Ad esempio, per rimuovere un percorso di Exchange, usare l'opzione RemoveExchangeLocation .

  3. Sincronizzazione e distribuzione dei criteri di ripetizione dei tentativi. Usare il cmdlet Set-RetentionCompliancePolicy insieme all'opzione RetryDistribution per ridistribuire i criteri:

    Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
    

Inizio pagina

Errore: si è verificato un problema

Sintomi

Quando si controlla il riquadro dei dettagli per un criterio nel Portale di conformità di Microsoft Purview, viene visualizzato il messaggio di errore "Si è verificato un problema".

Se si esegue il comando seguente, viene visualizzato InternalError nel valore restituito dalla DistributionResults proprietà :

Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults

Causa

Si è verificato un errore non specificato nel processo di sincronizzazione e distribuzione dei criteri.

Risoluzione

Per risolvere questo problema, usare uno dei metodi seguenti. Se si usa il metodo 1, verificare la presenza di opzioni di risoluzione aggiuntive nel riquadro dei dettagli dei criteri.

Metodo 1: usare il Portale di conformità di Microsoft Purview

  1. Nella Portale di conformità di Microsoft Purview cercare i criteri nelle schede seguenti:

    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di conservazione
    • Gestione >del ciclo di vita dei datiMicrosoft 365>Criteri di etichetta
    • Gestione> recordCriteri di etichetta
  2. Selezionare il criterio per aprire il riquadro dei dettagli dei criteri. Assicurarsi di selezionare il nome del criterio e non la casella di controllo corrispondente. In caso contrario, il riquadro dei dettagli non verrà aperto.

  3. Nel riquadro dei dettagli dei criteri selezionare Riprova. Il criterio entra in uno stato in sospeso fino al termine della sincronizzazione e della distribuzione dei criteri.

Metodo 2: Usare PowerShell

  1. Connettersi a PowerShell per Sicurezza e conformità.

  2. Sincronizzazione e distribuzione dei criteri di ripetizione dei tentativi. Usare il cmdlet Set-RetentionCompliancePolicy insieme all'opzione RetryDistribution per ridistribuire i criteri:

    Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
    

Inizio pagina

Errore: non è possibile applicare un blocco qui

Sintomi

Quando si tenta di aggiungere un percorso a un criterio nel Portale di conformità di Microsoft Purview, l'operazione ha esito negativo e viene visualizzato il messaggio di errore "Non è possibile applicare un blocco qui".

Se si tenta di aggiungere un percorso a un criterio usando PowerShell, viene visualizzato il RecipientTypeNotAllowed messaggio di errore.

Causa

Si è tentato di aggiungere un percorso della cassetta postale a un criterio, ma il criterio non supporta il tipo di cassetta postale. Questo errore si verifica solo quando un percorso viene aggiunto a un criterio.

Risoluzione

Per risolvere questo problema, usare uno dei metodi seguenti.

Metodo 1: usare il Portale di conformità di Microsoft Purview

  1. Indietro al passaggio in cui sono stati specificati i percorsi dei criteri e quindi rimuovere i percorsi problematici dai criteri.

  2. Riprovare l'aggiornamento.

Metodo 2: Usare PowerShell

  1. Nello script o nel comando usato per aggiungere posizioni rimuovere i percorsi problematici. I cmdlet di PowerShell applicabili sono:

  2. Riprovare l'aggiornamento.

Inizio pagina

Errore: i criteri sono bloccati in PendingDeletion

Sintomi

Quando si tenta di eliminare un criterio, l'operazione ha esito negativo.

Causa

Si è verificato un errore non specificato quando si è tentato di eliminare i criteri.

Risoluzione

  1. Connettersi a PowerShell per Sicurezza e conformità.

  2. Rimuovere i criteri. Usare il cmdlet Remove-RetentionCompliancePolicy insieme all'opzione ForceDeletion :

    Remove-RetentionCompliancePolicy -Identity "<policy name>" -ForceDeletion
    

Inizio pagina

Ulteriori informazioni

Per informazioni su come risolvere i problemi di eDiscovery, vedere Risolvere i problemi comuni di eDiscovery.