Problemi relativi alle cassette postali di archiviazione per una cassetta postale di cui è stata eseguita la migrazione o da Office 365

Nota

Office 365 ProPlus viene rinominato in Microsoft 365 Apps for enterprise. Per ulteriori informazioni su questa modifica, leggere questo post di blog.

Numero KB originale:   2757430

Problema

Quando si esegue la migrazione di una cassetta postale da o verso Microsoft Office 365 e si utilizza una cassetta postale di archiviazione, si verifica un problema in cui il servizio di replica delle cassette postali di Microsoft Exchange (MRS) in Microsoft Exchange Online timbra il valore del dominio di destinazione della proprietà ArchiveDomain della cassetta postale al termine della migrazione.

Nota

Non è necessario che il problema si verifichi su un account che non dispone di una cassetta postale di archiviazione.

Sono disponibili cinque scenari correlati alle cassette postali di archiviazione. Ogni scenario richiede una risoluzione diversa.

  • Scenario 1-onboarding: si spostano le cassette postali di Microsoft Exchange Server locali in Exchange Online.
  • Scenario 2-onboarding: la cassetta postale di archiviazione esiste in Exchange Online e si sposta la cassetta postale principale dall'ambiente Exchange Server locale a Exchange Online.
  • Scenario 3-Offboarding: si abilita una cassetta postale di archiviazione e quindi si esegue la migrazione delle cassette postali primarie e di archiviazione da Exchange Online all'ambiente Exchange Server locale. Uno scenario analogo si verifica quando la cassetta postale principale è già in locale e si decide di trasferisce la cassetta postale di archiviazione da Exchange Online all'ambiente Exchange Server locale.
  • Scenario 4-Offboarding: nella cassetta postale principale non è abilitata una cassetta postale di archiviazione e la cassetta postale principale viene spostata da Exchange Online all'ambiente Exchange Server locale.
  • Scenario 5-Offboarding: la cassetta postale principale esiste nell'ambiente Exchange Server locale e la cassetta postale di archiviazione è disponibile in Exchange Online. Questo scenario può verificarsi quando si esegue una delle operazioni seguenti:
    • Si trasferisce la cassetta postale principale. Tuttavia, è possibile lasciare la cassetta postale di archiviazione in Exchange Online.
    • Sia le cassette postali primarie che quelle di archiviazione sono situate nell'ambiente Exchange Server locale. Tuttavia, si è a bordo solo della cassetta postale di archiviazione.

    Nota

    L'unico scenario di suddivisione di archiviazione supportato è una cassetta postale principale locale e una cassetta postale di archiviazione in Exchange Online.

Causa

Questo problema si verifica se si esegue la migrazione di una cassetta postale tra un ambiente Exchange Server locale ed Exchange Online.

Se si utilizza il seguente cmdlet di Windows PowerShell per visualizzare le proprietà dell'archivio, si noterà che lo stato dell'archivio è attivo. Tuttavia, molte delle informazioni sull'archivio sono mancanti.

Get-Mailbox alias |fl Name, Archive*

Nota

Per eseguire il cmdlet, è possibile utilizzare Exchange Management Shell locale o Exchange Online PowerShell. Per ulteriori informazioni su come utilizzare PowerShell di Exchange Online, passare a connettere Windows PowerShell al servizio.

Quando si esegue il cmdlet, il risultato è analogo al seguente:

Name : jsmith
ArchiveDatabase :
ArchiveGuid : 00000000-0000-0000-0000-000000000000
ArchiveName : {}
ArchiveQuota : 100 GB (107,374,182,400 bytes)
ArchiveWarningQuota : 90 GB (96,636,764,160 bytes)
ArchiveDomain : contoso.mail.onmicrosoft.com
ArchiveStatus : Active

Soluzione

Per risolvere il problema, utilizzare uno dei metodi seguenti, in base alle esigenze dello scenario.

Scenario 1

Il problema nello scenario 1 è stato risolto come indicato di seguito: tutte le migrazioni onboarding di Exchange Online sono indirizzate e la proprietà ArchiveDomain non è più impostata finché la cassetta postale di archiviazione non è abilitata dall'amministratore del tenant.

Prima di risolvere il problema, gli utenti hanno segnalato la presenza di una cassetta postale di archiviazione in Outlook e le richieste di autenticazione ricevute. Tuttavia, gli utenti non possono visualizzare la stessa cassetta postale di archiviazione in Outlook Web App. Microsoft si riferisce all'archivio come ' archivio di fantasmi ' perché non è una cassetta postale di archiviazione vera che può essere letta dagli utenti.

Scenario 2

Il problema nello scenario 2 è stato risolto come indicato di seguito: il componente MRS che è responsabile dello spostamento delle cassette postali ora correttamente determina la presenza di una cassetta postale di archiviazione di Exchange Online. Pertanto, gli utenti possono accedere correttamente alle cassette postali di archiviazione in Outlook o Outlook Web App senza errori. Non è necessaria alcuna azione.

Scenario 3

Il problema in entrambe le varianti dello scenario 3 viene risolto nel modo seguente: MRS in Exchange Online imposta il valore della proprietà ArchiveDomain sul dominio locale. Pertanto, gli utenti possono accedere correttamente alle cassette postali di archiviazione in Outlook o Outlook Web App senza errori. Non è necessaria alcuna azione.

Scenario 4

Il problema nello scenario 4 è stato risolto nel modo seguente: in questo scenario, la signora in Exchange Online imposta il valore della proprietà ArchiveDomain sul dominio locale. Di conseguenza, gli utenti visualizzano la presenza di una cassetta postale di archiviazione in Outlook, anche se la cassetta postale di archiviazione non è abilitata. Questo archivio assomiglia all'' archivio di fantasmi ' menzionato nella sezione ' risoluzione ' dello scenario 1. Tuttavia, l'archivio richiede che l'amministratore di Exchange dell'ambiente Exchange Server locale esegua lo script fornito nella sezione "risoluzione dello scenario 5". Microsoft ha distribuito un aggiornamento per risolvere questo scenario. Pertanto, il futuro di Offboarding non verrà influenzato.

Per determinare se si è coinvolti quando si esegue una migrazione di Offboarding da Exchange Online, eseguire lo script fornito nella sezione ' risoluzione dello scenario 5' in modalità di analisi.

Scenario 5

In questo scenario, il valore della proprietà ArchiveDomain è impostato sul dominio locale. Pertanto, Outlook non è in grado di individuare e aprire la cassetta postale di archiviazione.

Per risolvere gli scenari 4 e 5, Microsoft fornisce lo script seguente che consente di modificare automaticamente gli attributi necessari se si spostano le cassette postali da Exchange Online all'ambiente Exchange Server locale. Per eseguire lo script, eseguire la procedura seguente:

  1. Avviare il blocco note.
  2. Copiare e incollare lo script seguente nel blocco note:
#-------------------------------------------------------------------------------
#
# Copyright (c) Microsoft Corporation. All rights reserved.
#
# PLEASE NOTE:
# Microsoft Corporation (or based on where you live, one of its affiliates)
# licenses this supplement to you. You may use it with each validly licensed
# copy of Microsoft Online Services Migration Tools software (the "software").
# You may not use the supplement if you do not have a license for the software.
# The license terms for the software apply to your use of this supplement.
# Microsoft may provide support services for the supplement as described at
# http://www.support.microsoft.com/common/international.aspx.
#
#-------------------------------------------------------------------------------
#
# PowerShell Source Code
#
aram([Parameter(Mandatory = $false)]
[string]$TenantCloudDomain,
[Parameter(Mandatory = $false)]
[string]$Domain,
[Parameter(Mandatory = $false)]
[Switch]$Fix,
[Parameter(Mandatory = $false)]
[Switch]$FindAllUsersInForest
)
function GetNameFromDN([string]$dn)
{
if ($dn.Length -eq 0) { return $null; }
return ($dn -split ",")[0].Replace("CN=", "")
}
Import-Module ActiveDirectory
If ($TenantCloudDomain.Length -eq 0) {
$ldapQuery = "(&(objectClass=user)(msExchArchiveAddress=*))"
} else {
$ldapQuery = "(&(objectClass=user)(msExchArchiveAddress=*)(!(&(msExchArchiveGuid=*)(!(msExchArchiveDatabaseLink=*))(msExchArchiveAddress=$TenantCloudDomain))))"
}
if ($Domain.Length -eq 0) {
# default domain to computer's domai
$computer = Get-WmiObject -Class Win32_ComputerSystem
$Domain = $computer.Domai
}
if ($FindAllUsersInForest -and $Fix) {
throw "You cannot specify -FindAllUsersInForest when running in -Fix mode, only one domain can be cleaned up at a time."
}
Write-Host "Looking for objects to clean up in ${Domain}: ${ldapQuery}"
$propertiesToLoad = @("msExchMailboxGuid","homeMDB","msExchArchiveGuid","msExchArchiveDatabaseLink","msExchArchiveAddress")
$tsStart = [DateTime](Get-Date)
if ($FindAllUsersInForest) {
$m = Get-ADObject -Server "${Domain}:3268" -SearchBase "" -LDAPFilter $ldapQuery -ResultSetSize $null -Properties $propertiesToLoad
} else {
$m = Get-ADObject -Server $Domain -LDAPFilter $ldapQuery -ResultSetSize $null -Properties $propertiesToLoad
}
$elapsed = [DateTime](Get-Date) - $tsStart
if ($m -eq $null) {
Write-Host "No objects need to be cleaned up."
retur
}
$cleanedCount = 0
$failedCount = 0
$filename = $("~\ArchiveDomainCleanup_{0:yyyymmdd_HHmmss}.csv" -f (Get-Date))
# Run cleanup and output data to CSV file
Write-Host "Writing output to $filename..."
try {
$m | %{
$success = $true
if ($Fix) {
$prevError = $error[0]
Set-ADObject -Identity $_ -Server $Domain -Clear "msExchArchiveAddress"
if ($error[0] -ne $prevError) {
$success = $false
Write-Host "x" -NoNewLine
} else {
Write-Host "." -NoNewLine
}
}
if ($success) {
$cleanedCount++
# object was cleaned up successfully, let's append it to output CSV.
$mm = $_ | Select ObjectGuid,DistinguishedName
# Morph guid values from binary blob to proper guid
$mbxGuid = [Guid]$_.msExchMailboxGuid
if ($_.msExchArchiveGuid -ne $null) {
$archiveGuid = [Guid]$_.msExchArchiveGuid
} else {
$archiveGuid = $null
}
Add-Member -InputObject $mm -MemberType NoteProperty -Name CleanedArchiveDomain -Value $($_.msExchArchiveAddress)
Add-Member -InputObject $mm -MemberType NoteProperty -Name ExchangeGuid -Value $mbxGuid
Add-Member -InputObject $mm -MemberType NoteProperty -Name Database -Value $(GetNameFromDN $_.homeMDB)
Add-Member -InputObject $mm -MemberType NoteProperty -Name ArchiveGuid -Value $archiveGuid
Add-Member -InputObject $mm -MemberType NoteProperty -Name ArchiveDatabase -Value $(GetNameFromDN $_.msExchArchiveDatabaseLink)
$mm
} else {
$failedCount++
}
} | Export-CSV $filename -NoTypeInformatio
}
finally {
if ($Fix) {
Write-Host ""
Write-Host "Cleaned up $cleanedCount recipients."
if ($failedCount -gt 0) {
Write-Warning "Failed to update $failedCount recipients."
}
} else {
Write-Host "Discovered $cleanedCount recipients."
}
}
  1. Scegliere Salvadal menu file .
  2. Nella casella Salva con nome fare clic su tutti i file (.).
  3. Nella casella Nome File typeCleanup-ArchiveDomain.ps1 e quindi fare clic su Salva.
  4. Individuare la directory in cui è stato salvato il file Cleanup-ArchiveDomain.ps1, quindi eseguire lo script insieme ai parametri seguenti:
Cleanup-ArchiveDomain.ps1 [-TenantCloudDomain serviceDomain] [-Domain domain] [-Fix] [-FindAllUsersInForest]

Nota

  • Il parametro TenantCloudDomain deve essere specificato solo se il tenant utilizza la funzionalità di archiviazione cloud. Il valore del parametro deve essere il nome di dominio DNS utilizzato dal tenant per accedere agli archivi cloud, ad esempio Contoso. com.
  • Il parametro Domain viene utilizzato per eseguire la funzionalità di pulizia in un dominio che non è il dominio del computer corrente.
  • L'opzione fix attiva la funzionalità di pulizia effettiva. La funzione predefinita dell'opzione (nota anche come "modalità di analisi") è solo per individuare gli utenti e quindi visualizzarli in un file CSV.
  • L'opzione TheFindAllUsersInForest consente di cercare un catalogo globale e di individuare tutti gli utenti interessati nella foresta locale (tra tutti i domini). Tuttavia, questa opzione non può essere combinata con l'opzione Correggi. È possibile risolvere gli utenti solo in un dominio alla volta.

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