Outlook problemi di prestazioni quando sono presenti troppi elementi o cartelle in un file ost o pst in modalità cache

Numero KB originale:   2768656

Sintomi

Se si dispone di molti elementi in una singola cartella, è possibile che si verifichino sintomi come i seguenti in Microsoft Outlook:

  • Quando si utilizza la modalità Exchange cache o un file di dati Outlook (pst), si notano problemi di prestazioni quando si eseguono determinate azioni.
  • Si verifica una riduzione delle prestazioni in Outlook se le cartelle Posta in arrivo, Calendario, Attività, Posta inviata e Posta eliminata contengono molti elementi.
  • Le prestazioni del calendario non sono coerenti. Ad esempio, gli aggiornamenti delle riunioni potrebbero non essere riflessi nel Calendario principale, condiviso o delegato.

Se si dispone di molte cartelle di posta, potrebbero verificarsi problemi di prestazioni come i seguenti:

  • Le cartelle non vengono visualizzate correttamente o la visualizzazione delle cartelle potrebbe richiedere molto tempo, soprattutto in modalità cache.
  • Se il profilo di Outlook dispone di cassette postali condivise e la memorizzazione nella cache è abilitata ( è selezionata l'opzione Scarica cartelle condivise), si verificano problemi di sincronizzazione delle cartelle, problemi di prestazioni e altri problemi se il numero di cartelle condivise per cassetta postale supera 500, come descritto in Problemi di sincronizzazione e prestazioni quando si lavora con cartelle in una cassetta postale secondaria in Outlook. Inoltre, gli errori vengono registrati nella cartella Problemi di sincronizzazione e gli eventi "9646" vengono registrati nel registro applicazioni.
  • In casi estremi, se sono presenti più di 10.000 cartelle, Outlook l'apertura è molto lenta. Questo comportamento si verifica perché l'enumerazione delle cartelle richiede molto tempo.

Causa

Questo problema può verificarsi se si dispone di cartelle che superano il limite per il numero di elementi per cartella o se il numero totale di cartelle è troppo elevato. I limiti per Outlook 2019, Outlook 2016, Outlook 2013 e Outlook 2010 sono i seguenti:

  • 100.000 elementi per cartella
  • 5.000 elementi per cartella Calendario

Risoluzione

Importante

Seguire attentamente i passaggi in questa sezione. L'errata modifica del Registro di sistema può causare seri problemi. Prima di apportare le modifiche, eseguire il backup del Registro di sistema per il ripristino nel caso si verifichino dei problemi.

Se si dispone di cartelle che superano il limite per il numero di elementi in un file di dati di Outlook (pst) o in un file di dati Outlook offline ( ), spostare gli elementi dalle cartelle più grandi a cartelle separate o più piccole nella stessa cassetta postale o file di .ost dati. Facoltativamente, se si dispone di un archivio online di Microsoft Exchange, è possibile spostare gli elementi in tale archivio.

Se è stato superato il limite consigliato di 5.000 elementi totali del Calendario, utilizzare uno dei metodi seguenti per ridurre il numero di elementi disponibili.

Metodo 1

Se è stata abilitata la cassetta postale di archiviazione online, archiviare gli elementi nella cassetta postale di archiviazione online.

Metodo 2

Applicare un criterio di conservazione nella cartella Calendario per eliminare gli elementi da questa cartella. Ad esempio: qualsiasi elemento che non viene modificato entro un anno viene spostato nella cartella Posta eliminata.

Metodo 3

In Finestra di Impostazioni modificare il numero di mesi di dati sincronizzati per i calendari condivisi principali. A tale scopo, aggiungere le seguenti chiavi del Registro di sistema.

Nota

Questo metodo si applica alla versione 1810 o successiva di Microsoft 365 Apps for enterprise (A scelta rapida).

Descrizione Impostazione per abilitare la finestra Sincronizzazione calendario
Percorso del Registro di sistema HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Nome CalendarSyncWindowSetting
Tipo REG_DWORD
Valore Valore = 0 Inattivo
Valore = 1 cartella Calendario principale
Valore = 2 Tutte le cartelle calendario
Il valore predefinito è 0 se non è impostato
Descrizione Impostazione per controllare il numero di mesi nella finestra Sincronizzazione calendario
Percorso del Registro di sistema HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Nome CalendarSyncWindowSettingMonths
Tipo REG_DWORD
Valore Value = Choose decimal value to select how many months in the Calendar sync window such as 1, 3, 6, or 12
Il valore predefinito è 6 se non è impostato
Descrizione Impostazione per controllare se mantenere tutti gli elementi ricorrenti invece di filtrarli
Percorso del Registro di sistema HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Nome CalendarSyncWindowAllRecurring
Tipo REG_DWORD
Valore 0

Queste chiavi del Registro di sistema aggiornano la restrizione di sincronizzazione in modo che il client in modalità cache scarica meno elementi del Calendario, anche per un calendario con più anni di cronologia nel server. Queste chiavi non eliminano il contenuto del calendario precedente già scaricato. Tuttavia, questo metodo può essere efficace se vuoi cancellare gli elementi offline e risincronizzare il calendario (invece di eliminare in blocco gli elementi meno vecchi). Se il calendario è già presente nel profilo, è necessario cancellare gli elementi offline dopo aver impostato le chiavi del Registro di sistema e aver riavviato Outlook.

Per cancellare gli elementi del Calendario offline, attenersi alla seguente procedura:

  1. Aprire il riquadro Calendario in Outlook, quindi fare clic con il pulsante destro del mouse sulla cartella Calendario.
  2. Selezionare Proprietà.
  3. Nella scheda Generale selezionare Cancella elementi offline.
  4. Selezionare OK.

Inoltre, è possibile utilizzare il Assistente supporto e ripristino (Assistente supporto e ripristino) per Office 365 diagnosticare i problemi che influiscono Outlook. Lo strumento funziona per entrambi i programmi.

Per scaricare e installare lo strumento, visitare il seguente sito Web Microsoft:

Scaricare Microsoft Assistente supporto e ripristino per Office 365

Nello strumento, eseguire la Outlook diagnostica nella sezione Diagnostica avanzata per determinare la causa del problema di prestazioni.

Ulteriori informazioni

Per visualizzare il numero di elementi del calendario, utilizzare la finestra di dialogo Proprietà calendario per controllare il numero di elementi presenti in una cartella Calendario in Outlook modalità cache.

A tal fine, attenersi alla seguente procedura:

  1. Aprire il riquadro Calendario in Outlook, quindi fare clic con il pulsante destro del mouse sulla cartella Calendario.
  2. Selezionare Proprietà.
  3. Nella scheda Generale selezionare Mostra numero totale di elementi.
  4. Scegli la scheda Sincronizzazione.
  5. Visualizzare il conteggio in Visualizza statistiche per questa cartella.

Outlook un file solo se l'account Exchange di posta elettronica è configurato per .ost l'utilizzo della modalità cache Exchange cache. Quando Outlook è configurato per connettersi alla cassetta Exchange in modalità online, non .ost viene utilizzato un file. Se il client Outlook è connesso a Exchange in modalità online e non si dispone di cartelle con numero elevato di elementi in un file PST, è possibile che si verifichi un problema di prestazioni nel server.

Per ulteriori informazioni sui problemi Outlook prestazioni, vedere È possibile che si verifichino pause dell'applicazione se si dispone di un file di dati Outlook di grandi dimensioni.