Salvataggio di eventi Showplan XML in modo indipendente (SQL Server Profiler)Save Showplan XML Events Separately (SQL Server Profiler)

In questo argomento viene illustrato come salvare eventi Showplan XML acquisiti in tracce in file SQLPlan distinti utilizzando SQL Server ProfilerSQL Server Profiler.This topic describes how to save Showplan XML events that are captured in traces into separate .SQLPlan files by using SQL Server ProfilerSQL Server Profiler. È possibile aprire i file degli eventi Showplan XML in SQL Server Management StudioSQL Server Management Studioper visualizzare il piano di esecuzione grafico per ogni evento.You can open the Showplan XML event files in SQL Server Management StudioSQL Server Management Studio, which enables you to view the graphical execution plan for each event.

Per salvare gli eventi Showplan XML in modo indipendenteTo save Showplan XML events separately

  1. Scegliere Nuova traccia dal menu Filee quindi connettersi a un'istanza di SQL Server.On the File menu, click New Trace, and then connect to an instance of SQL Server.

    Verrà visualizzata la finestra di dialogo Proprietà traccia.The Trace Propertiesdialog box appears.

    Nota

    Se l'opzione Avvia traccia non appena viene stabilita una connessioneè selezionata, la finestra di dialogo Proprietà traccianon viene visualizzata e viene invece avviata la traccia.If Start tracing immediately after making connectionis selected, the Trace Propertiesdialog box fails to appear and the trace begins instead. Per disabilitare questa impostazione, scegliere Opzionidal menu Strumentie deselezionare la casella di controllo Avvia traccia non appena viene stabilita una connessione .To turn off this setting, on the Toolsmenu, click Options, and clear the Start tracing immediately after making connection check box.

  2. Nella finestra di dialogo Proprietà traccia digitare un nome per la traccia nella casella Nome traccia .In the Trace Properties dialog box, type a name for the trace in the Trace name box.

  3. Nell'elenco Modello selezionare un modello di traccia sul quale basare la traccia oppure selezionare Vuoto per non utilizzare alcun modello.In the Use the template list, select a trace template on which to base the trace, or select Blank if you do not want to use a template.

  4. Eseguire una delle operazioni seguenti:Do one of the following:

    • Selezionare la casella di controlloSalva nel file per acquisire la traccia in un file.Select theSave to file check box to capture the trace to a file. Specificare un valore per l'opzione Dimensioni massime del file.Specify a value for Set maximum file size. Se lo si desidera, selezionare le caselle di controllo Consenti rollover dei file e Dati di traccia elaborati dal server .Optionally, select the Enable file rollover and Server processes trace data check boxes.

    • Selezionare la casella di controlloSalva nella tabella per acquisire la traccia in una tabella di database.Select theSave to table check box to capture the trace to a database table. Facoltativamente selezionare la casella di controllo Numero massimo di righee specificare un valore.Optionally click Set maximum rows, and specify a value.

  5. Facoltativamente, selezionare la casella di controllo Data e ora di arresto della traccia e specificare una data e un'ora di arresto della traccia.Optionally, select the Enable trace stop time check box, and specify a stop date and time.

  6. Fare clic sulla scheda Selezione eventi.Click the Events Selectiontab.

  7. Nella finestra di dialogo Eventiespandere la categoria di eventi Prestazionie quindi selezionare la casella di controllo Showplan XML.In the Eventsdata column, expand the Performanceevent category, and then select the Showplan XMLcheck box. Se la categoria di eventi Performance non è visualizzata, selezionare la casella di controllo Mostra tutti gli eventi .If the Performance event category is not available, check Show all events to display it.

    Verrà visualizzata la finestra di dialogo Impostazioni estrazione eventviene aggiunta alla finestra di dialogo Proprietà traccia.The Events Extraction Settingstab is added to the Trace Propertiesdialog box.

  8. Scegliere Impostazioni estrazione eventselezionare la casella di controllo Salva eventi Showplan XML separatamente.On the Events Extraction Settingstab, click Save XML Showplan events separately.

  9. Nella finestra di dialogo Salva con nome immettere il nome del file in cui archiviare gli eventi Showplan XML .In the Save As dialog box, enter the name of the file in which to store the Showplan XML events.

  10. Fare clic su Tutti i batch Showplan XML in un singolo file per salvare tutti gli eventi Showplan XML in un unico file XML oppure su Crea un file distinto per ogni singolo batch Showplan XMLper creare un nuovo file XML per ogni evento Showplan XML .Click All XML Showplan batches in a single file to save all Showplan XML events in a single XML file, or click Each XML Showplan batch in a distinct fileto create a new XML file for each Showplan XML event.

  11. Per visualizzare i file degli eventi Showplan XML in SQL Server Management Studio, scegliere Apri dal menu Filee quindi fare clic su File.To view the Showplan XML event file in SQL Server Management Studio, on the File menu, point to Open, and click File. Passare alla directory in cui sono stati salvati i file o il file degli eventi Showplan XML per selezionarne uno e aprirlo.Navigate to the directory where you saved the Showplan XML event file or files to select one and open it. I file degli eventiShowplan XML hanno estensione SqlPlan.Showplan XML event files have a .SQLPlan file extension.

Vedere ancheSee Also

Analizzare query con risultati SHOWPLAN in SQL Server ProfilerAnalyze Queries with SHOWPLAN Results in SQL Server Profiler