Salvataggio della classe di eventi Showplan XML Statistics Profile Events in file distinti (SQL Server Profiler)Save Showplan XML Statistics Profile Events Separately (SQL Server Profiler)

Questo argomento descrive la procedura da seguire per salvare gli eventi Showplan XML Statistics Profile acquisiti in tracce in file SQLPlan distinti tramite SQL Server ProfilerSQL Server Profiler.This topic describes how to save Showplan XML Statistics Profile events that are captured in traces into separate .SQLPlan files by using SQL Server ProfilerSQL Server Profiler. È possibile aprire i file di eventi Showplan XML Statistics Profile in SQL Server Management StudioSQL Server Management Studioper visualizzare graficamente il piano di esecuzione di ogni evento.You can open the Showplan XML Statistics Profile event files in SQL Server Management StudioSQL Server Management Studio, which enables you to view the graphical execution plan for each event.

Per salvare eventi Showplan XML Statistics Profile in file distintiTo save Showplan XML statistics events separately

  1. Scegliere Nuova traccia dal menu Filee quindi connettersi a un'istanza di SQL ServerSQL Server.On the File menu, click New Trace, and then connect to an instance of SQL ServerSQL Server.

    Verrà visualizzata la finestra di dialogo Proprietà traccia .The Trace Properties dialog box appears.

    Nota

    Se l'opzione Avvia traccia non appena viene stabilita una connessioneè selezionata, la finestra di dialogo Proprietà traccianon viene visualizzata e viene invece avviata la traccia.If Start tracing immediately after making connectionis selected, the Trace Propertiesdialog box does not appear and the trace begins instead. Per disabilitare questa impostazione, scegliere Opzionidal menu Strumentie deselezionare la casella di controllo Avvia traccia non appena viene stabilita una connessione .To turn off this setting, on the Toolsmenu, click Options, and clear the Start tracing immediately after making connection check box.

  2. Nella finestra di dialogo Proprietà traccia digitare un nome per la traccia nella casella Nome traccia .In the Trace Properties dialog box, type a name for the trace in the Trace name box.

  3. Nell'elenco Modello selezionare un modello di traccia su cui basare la traccia oppure selezionare Vuoto se non si desidera utilizzare alcun modello.In the Use the template list, select a trace template to base the trace on, or select Blank if you do not want to use a template.

  4. Eseguire una delle operazioni seguenti:Do one of the following:

    • Fare clic suSalva nel fileper acquisire la traccia in un file.ClickSave to fileto capture the trace to a file. Specificare un valore per l'opzione Dimensioni massime del file.Specify a value for Set maximum file size.

      Facoltativamente selezionare le caselle di controllo Consenti rollover dei file e Dati di traccia elaborati dal server.Optionally select Enable file rollover and Server processes trace data.

    • Fare clic suSalva nella tabella per acquisire la traccia in una tabella del database.ClickSave to table to capture the trace to a database table.

      Facoltativamente selezionare la casella di controllo Numero massimo di righee specificare un valore.Optionally click Set maximum rows, and specify a value.

  5. Facoltativamente selezionare la casella di controllo Data e ora di arresto della traccia e specificare la data e l'ora di arresto desiderate.Optionally select the Enable trace stop time check box, and specify a stop date and time.

  6. Fare clic sulla scheda Selezione eventi.Click the Events Selectiontab.

  7. Nella colonna di dati Eventsespandere la categoria di eventi Performancee quindi selezionare la casella di controllo Showplan XML Statistics Profile.In the Eventsdata column, expand the Performanceevent category, and then select the Showplan XML Statistics Profilecheck box. Se la categoria di eventi Performance non è visualizzata, selezionare la casella di controllo Mostra tutti gli eventi .If the Performance event category is not available, check Show all events to display it.

    La scheda Impostazioni estrazione eventiviene aggiunta alla finestra di dialogo Proprietà traccia.The Events Extraction Settingstab is added to the Trace Propertiesdialog.

  8. Scegliere Impostazioni estrazione eventselezionare la casella di controllo Salva eventi Showplan XML separatamente.On the Events Extraction Settingstab, click Save XML Showplan events separately.

  9. Nella finestra di dialogo Salva con nome immettere un nome per il file in cui archiviare gli eventi Showplan XML Statistics Profile .In the Save As dialog box, enter the file name to store the Showplan XML Statistics Profile events.

  10. Fare clic su Tutti i batch in un singolo file per salvare tutti gli eventi Showplan XML Statistics Profile in un unico file XML oppure fare clic su Crea un file distinto per ogni singolo batch Showplan XMLper creare un nuovo file XML per ogni evento Showplan XML Statistics Profile .Click All batches in a single file to save all Showplan XML Statistics Profile events in a single XML file, or click Each XML Showplan batch in a distinct fileto create a new XML file for each Showplan XML Statistics Profile event.

  11. Per visualizzare il file di eventi Showplan XML Statistics Profile in SQL Server Management Studio, scegliere Apri dal menu Filee quindi fare clic su File.To view the Showplan XML Statistics Profile event file in SQL Server Management Studio, on the File menu, point to Open, and click File. Spostarsi sulla directory in cui è stato salvato il file o i file di eventi Showplan XML Statistics Profile , selezionare il file desiderato e quindi aprirlo.Navigate to the directory where you saved the Showplan XML Statistics Profile event file or files to select one and open it. I file di eventiShowplan XML Statistics Profile sono contraddistinti dall'estensione SQLPlan.Showplan XML Statistics Profile event files have a .SQLPlan file extension.

Vedere ancheSee Also

Analizzare query con risultati SHOWPLAN in SQL Server ProfilerAnalyze Queries with SHOWPLAN Results in SQL Server Profiler