Associazione di estensioni di file a un editor di codiceAssociate File Extensions to a Code Editor

L'associazione di estensioni di file a un editor di codice specifico consente di aprire un file con l'editor di codice SQL Server Management StudioSQL Server Management Studio appropriato quando si fa doppio clic su un file in Esplora risorse.Associating file extensions to a specific code editor allows you to open a file with the appropriate SQL Server Management StudioSQL Server Management Studio code editor when you double-click a file in Windows Explorer. L'associazione delle estensioni utilizzate solitamente da Management StudioManagement Studio, ad esempio sql e mdx, viene eseguita durante l'installazione.The extensions commonly used by Management StudioManagement Studio, such as .sql and .mdx, are associated during installation. È inoltre necessario associare le nuove estensioni di file a Management StudioManagement Studio nel file system.New file extensions must also be associated to Management StudioManagement Studio in the file system. Questa caratteristica consente di aprire file creati con altri editor oppure di aprire file rinominati, ad esempio copie di backup di file con estensione sql rinominati con estensione bak.You can use this feature to open files created with other editors, or to open files you have renamed, such as backups of .sql files that were renamed .bak.

Il processo è suddiviso in due passaggi.There are two steps in the process. È innanzitutto necessario associare l'estensione a Management StudioManagement Studioe quindi associare l'estensione a un editor di codice specifico.First associate the extension with Management StudioManagement Studio, and then associate the extension with a specific code editor.

Per associare una nuova estensione di file a SQL Server Management StudioTo associate a new file extension with SQL Server Management Studio

  1. Fare clic sul pulsante Start , scegliere Tutti i programmi, Accessorie quindi Esplora risorse.On the Start menu, point to All Programs, point to Accessories, and then click Windows Explorer.

  2. In Esplora risorse scegliere Opzioni cartella dal menu Strumenti.In Windows Explorer, on the Tools menu, click Folder Options.

  3. Nella finestra di dialogo Opzioni cartella fare clic su Nuovo nella scheda Tipi di file.In the Folder Options dialog box, on the File Types tab, click New.

  4. Nella finestra di dialogo Creazione nuova estensione immettere nella casella Estensione file la nuova estensione di file da associare e quindi fare clic su OK.In the Create New Extension dialog box, in the File Extension box, type the new file extension that you want to associate, and then click OK. Non inserire un punto davanti all'estensione.Do not start the extension with a period.

  5. Selezionare la nuova estensione nella casella Tipi di file registrati , quindi fare clic su Cambia.In the Registered file types box, click on your new extension, and then click Change.

  6. Nella finestra di dialogo Apri con fare clic su SSMS - SQL Server Management Studioe quindi su OK.In the Open With dialog box, click SSMS – SQL Server Management Studio, and then click OK.

  7. Fare clic su Chiudi per chiudere la finestra di dialogo Opzioni cartella , quindi chiudere Esplora risorse.Click Close to close the Folder Options dialog box, and then close Windows Explorer.

Per associare una nuova estensione di file a un editor di codice in SQL Server Management StudioTo associate a new file extension with a code editor in SQL Server Management Studio

  1. In SQL Server Management StudioSQL Server Management Studioscegliere Opzioni dal menu Strumenti.In SQL Server Management StudioSQL Server Management Studio, from the Tools menu, click Options.

  2. Nella finestra di dialogo Opzioni fare clic su Editor di testoe quindi su Estensione file.In the Options dialog box, click Text Editor, and then click File Extension.

  3. Immettere la nuova estensione di file nella casella Estensione .In the Extension box, type your new file extension.

  4. Nella casella Editor selezionare l'editor di codice da usare per aprire questo tipo di file, fare clic su Aggiungie quindi su OK.In the Editor box, click the code editor that you wish to use to open this file type, click Add, and then click OK.

Vedere ancheSee Also

Utilità SsmsSsms Utility