Gestione della formattazione del codiceManage Code Formatting

L'editor consente di formattare il codice con rientri, testo nascosto, URL e così via.With the Editor you can format your code with indenting, hidden text, URLs, and so forth. È inoltre possibile formattare il codice automaticamente durante la digitazione tramite la funzionalità intelligente per la gestione dei rientri.You can also auto-format your code as you type by using Smart Indenting.

Stili rientriIndenting

È possibile scegliere tra tre diversi stili di rientro del testo.You can choose three different styles of text indenting. È inoltre possibile specificare il numero di spazi di ogni singolo rientro o tabulazione e se per il rientro l'editor deve utilizzare tabulazioni o spazi.You can also specify how many spaces compose a single indentation or tab, and whether the Editor uses tabs or space characters when indenting.

Per scegliere uno stile di rientroTo choose an indenting style

  1. Scegliere Opzioni dal menu Strumenti.On the Tools menu, click Options.

  2. Fare clic su Editor di testo.Click Text Editor.

  3. Selezionare la cartella Tutti i linguaggi per impostare i rientri per tutti i linguaggi.Click the folder, and select All Languages to set indenting for all languages.

  4. Fare clic su Tabulazioni.Click Tabs.

  5. Selezionare una delle opzioni seguenti:Click one of the following options:

    • None.None. Il cursore si porta all'inizio della riga successiva.The cursor goes to the beginning of the next line.

    • Blocco.Block. Il cursore allinea la riga successiva con quella precedente.The cursor aligns the next line with the previous line.

    • Intelligenti (impostazione predefinita).Smart (Default). Il servizio di linguaggio determina lo stile di rientro appropriato da utilizzare.The language service determines the appropriate indenting style to use.

    Nota

    Non tutte le opzioni di rientro sono disponibili per tutti i linguaggi.Some languages do not offer all three indenting options.

Per modificare le impostazioni di tabulazione dei rientriTo change indent tab settings

  1. Scegliere Opzioni dal menu Strumenti.On the Tools menu, click Options.

  2. Fare clic su Editor di testo.Click Text Editor.

  3. Selezionare la cartella Tutti i linguaggi per impostare i rientri per tutti i linguaggi.Select the folder for All Languages to set indenting for all languages.

  4. Fare clic su Tabulazioni.Click Tabs.

  5. Per specificare i caratteri per tabulazioni e rientri, fare clic su Mantieni tabulazioni.To specify tab characters for tab and indent operations, click Keep tabs. Per specificare spazi, selezionare Inserisci spazi.To specify space characters, select Insert spaces.

    Se si seleziona Inserisci spazi, immettere il numero di spazi per ogni tabulazione o rientro rispettivamente in Dimensione tabulazione o Dimensione rientro.If you select Insert Spaces, enter the number of space characters each tab or indent represents under Tab Size or Indent Size, respectively.

Per rientrare il codiceTo indent code

  1. Selezionare il testo che si desidera rientrare.Select the text you want to indent.

  2. Premere TAB o fare clic sul pulsante Rientra sulla barra degli strumenti Standard.Press TAB, or click the Indent button on the Standard toolbar.

Per ridurre il rientro del codiceTo unindent code

  1. Selezionare il testo a cui applicare la riduzione del rientro.Select the text you want to unindent.

  2. Premere MAIUSC+TAB, oppure fare clic sul pulsante Riduci rientro sulla barra degli strumenti Standard.Press SHIFT+TAB, or click the Unindent button on the Standard toolbar.

Per rientrare automaticamente tutto il codiceTo automatically indent all of your code

  1. Scegliere Opzioni dal menu Strumenti.On the Tools menu, click Options.

  2. Fare clic su Editor di testo.Click Text Editor.

  3. Fare clic su Tutti i linguaggi.Click All Languages.

  4. Fare clic su Tabulazioni.Click Tabs.

  5. Scegliere Intelligenti.Click Smart.

Nota

L'opzione Intelligenti non è disponibile per tutti i linguaggi.The Smart option is not available for some languages.

Per convertire gli spazi vuoti in tabulazioniTo convert white space to tabs

  1. Selezionare il testo in cui si desidera convertire lo spazio vuoto in tabulazioni.Select the text whose white space you want to convert to tabs.

  2. Scegliere Avanzate dal menu Modificae quindi fare clic su Inserisci tabulazione.On the Edit menu, point to Advanced, and click Tabify Selection.

Per convertire le tabulazioni in spaziTo convert tabs to spaces

  1. Selezionare il testo in cui si desidera convertire le tabulazioni in spazi.Select the text whose tabs you want to convert to spaces.

  2. Scegliere Avanzate dal menu Modificae quindi fare clic su Rimuovi tabulazione.On the Edit menu, point to Advanced, and click Untabify Selection.

    Il comportamento di questi comandi dipende dalle impostazioni di tabulazione nella finestra di dialogo Opzioni .The behavior of these commands depends on the tab settings in the Options dialog box. Se, ad esempio, l'impostazione di tabulazione è 4, Inserisci tabulazione comporta la creazione di una tabulazione ogni 4 spazi contigui, mentre Rimuovi tabulazione comporta la creazione di 4 spazi per ogni tabulazione.For example, if the tab setting is 4, Tabify Selection creates a tab for every 4 contiguous spaces, and Untabify Selection creates 4 spaces for every tab.

Conversione del testo in lettere maiuscole e minuscoleConverting Text to Upper and Lower Case

Sono previsti dei comandi per convertire un testo in tutte lettere maiuscole o minuscole.You can use commands to convert text to all uppercase or lower case.

Per convertire un testo in lettere maiuscole o minuscoleTo switch text to upper or lower case

  1. Selezionare il testo che si desidera convertire.Select the text you want to convert.

  2. Per convertirlo in lettere maiuscole, premere CTRL+MAIUSC+U, oppure scegliere Maiuscole dal sottomenu Avanzate del menu Modifica .To convert text to uppercase, press CTRL+SHIFT+U, or click Make Uppercase on the Advanced submenu of the Edit menu.

  3. Per convertirlo in lettere minuscole, premere CTRL+MAIUSC+L, oppure scegliere Minuscole dal sottomenu Avanzate del menu Modifica .To convert text to lowercase, press CTRL+SHIFT+L, or click Make Lowercase on the Advanced submenu of the Edit menu.

Nota

Per un elenco completo dei tasti di scelta rapida, vedere Tasti di scelta rapida di SQL Server Management Studio.For a complete list of keyboard shortcut keys, see SQL Server Management Studio Keyboard Shortcuts.

Visualizzazione e collegamenti agli URLDisplaying and Linking to URLs

All'interno del codice è possibile creare e visualizzare URL selezionabili.You can create and display clickable URLs in your code. Per impostazione predefinita:By default, the URLs:

  • Gli URL sono sottolineati.Are underlined.

  • Il puntatore del mouse si trasforma in una mano quando viene spostato su di essi.Change the mouse pointer to a hand when you move over them.

  • Se l'URL è valido, viene aperto quando si fa clic su di esso.Open the URL when clicked, if the URL is valid.

Per visualizzare un URL selezionabileTo display a clickable URL

  1. Scegliere Opzioni dal menu Strumenti.On the Tools menu, click Options.

  2. Fare clic su Editor di testo.Click Text Editor.

  3. Per modificare l'opzione per un solo linguaggio, fare clic sulla cartella corrispondente e quindi scegliere Generale.To change the option for only one language, click that language folder and then click General. Per modificarla per tutti i linguaggi, fare clic su Tutti i linguaggi e quindi scegliere Generale.To change the option for all languages, click All Languages and then click General.

  4. Selezionare Consenti navigazione URL con clic singolo.Select Enable single-click URL navigation.