Ricerca interattiva all'interno di documentiSearch Documents Interactively

La finestra di dialogo Trova e sostituisci consente di eseguire una ricerca in uno o più file o finestre aperti e passare da un risultato della ricerca all'altro.Using the Find and Replace dialog box, you can search one or more open files or windows and move through the search matches one by one. Questa tecnica consente di esaminare ogni singola corrispondenza della ricerca contestualmente, ossia nel testo che la precede e la segue.This technique allows you to review each individual search match in the context of the text around the match. È inoltre possibile eseguire operazioni di ricerca bulk ed esaminare i risultati corrispondenti in formato report usando la finestra di dialogo Trova e sostituisci .You also have the option of performing bulk find operations and reviewing search matches in report format using the Find and Replace dialog box.

Per eseguire la ricerca in tutti i documenti apertiTo search all open documents

  1. Aprire gli elementi nei quali si desidera eseguire la ricerca.Open the items you wish to search.

  2. Scegliere Trova e sostituisci dal menu Modifica e quindi fare clic su Ricerca veloce.On the Edit menu, point to Find and Replace, and then click QuickFind.

  3. Nella casella di testo Trova e sostituisci immettere il testo che si desidera cercare.In the Find and Replace text box, enter the text to search for.

  4. Nell'elenco Cerca in selezionare Tutti i documenti aperti.In the Look in list, select All Open Documents.

    Nota

    Quando si seleziona Tutti i documenti aperti , è possibile che la ricerca non venga eseguita in alcuni file aperti.Certain open files might not be searched when All Open Documents is selected. Nella ricerca vengono inclusi solo i file attualmente aperti in una visualizzazione di testo, ad esempio in visualizzazione Codice.Only files currently open in a textual view, such as Code view, are included in searches. I file in visualizzazione di progettazione non vengono inclusi nella ricerca.Files in Designer view are not included in searches.

  5. Per migliorare la precisione della ricerca, selezionare opzioni di ricerca aggiuntive.Select additional search options to increase the accuracy of the search.

  6. Fare clic su Trova successivo per avviare la ricerca e continuare a fare clic su Trova successivo fino al termine della ricerca nell'ultimo file.Click Find Next to start the search, and continue clicking Find Next until the last file has been searched.

    Quando la ricerca raggiunge l'inizio o la fine del documento, nella barra di stato viene visualizzato un messaggio.When the search passes the beginning or end of the document, a message is displayed in the status bar. Quando viene raggiunto il punto iniziale della ricerca, viene visualizzata una finestra di messaggio.A message box appears when the search reaches the starting point of the search.

Per eseguire una sostituzione in tutti i file attivi in modo interattivoTo replace in all active files interactively

  1. Scegliere Trova e sostituisci dal menu Modificae quindi fare clic su Sostituzione veloce.On the Edit menu, point to Find and Replace, and then click QuickReplace.

  2. Nella casella di testo Trova immettere il testo da cercare.In the Find what box, enter the text to search for.

  3. Nella casella di testo Sostituisci con immettere il testo con cui sostituire il testo trovato.In the Replace with box, enter the text to replace the search text.

  4. Nell'elenco Cerca in selezionare Tutti i documenti aperti.In the Look in list, select All Open Documents.

  5. Fare clic su Sostituiscie continuare a fare clic su Sostituisci fino all'ultima sostituzione nell'ultimo file.Click Replace, and continue clicking Replace until the last match in the last file has been replaced. Fare clic su Trova successivo per ignorare una corrispondenza che non si desidera sostituire.Click Find Next to skip a match you do not want to replace.

    oppure-or-

    Scegliere Sostituisci tutto per sostituire tutte le corrispondenze.Choose Replace All to replace all matches. Verrà visualizzata una finestra di messaggio con il numero totale di sostituzioni.A message box appears, listing the total number of replacements.

    Il comando Sostituisci tutto esegue la sostituzione di tutte le corrispondenze, comprese quelle che sono state ignorate usando il pulsante Trova successivo .The Replace All command replaces all search matches, including those you have skipped with the Find Next button. Per annullare il comando Sostituisci tutto, scegliere Annulla dal menu Modifica prima di chiudere un file.To cancel Replace All, click Undo from the Edit menu before closing any of the files.

Vedere ancheSee Also

Ricerca incrementale in un documento attivo Search an Active Document Incrementally
Ricerca e sostituzione Search and Replace
Ricerca nei documenti utilizzando gli elenchi dei risultati Search Documents Using Results Lists
Testo di ricerca con caratteri jolly Search Text with Wildcards
Testo di ricerca con espressioni regolari Search Text with Regular Expressions