Lezione 1: Creazione di un progetto server report (Reporting Services)Lesson 1: Creating a Report Server Project (Reporting Services)

Per contenuti relativi a versioni precedenti di SQL Server Reporting Services, vedere Lezione 1: Creazione di un progetto server report (Reporting Services).For content related to previous versions of SQL Server, see Lesson 1: Creating a Report Server Project (Reporting Services).

In questa lezione si creerà un progetto server report e un file di definizione del report (con estensione rdl) in SQL Server Data ToolsSQL Server Data Tools all'interno di Visual Studio.In this lesson, you'll create a report server project and a report definition (.rdl) file in SQL Server Data ToolsSQL Server Data Tools within Visual Studio.

Per creare un report con SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), è innanzitutto necessario creare un progetto server di report in cui è possibile salvare il file della definizione del report (con estensione rdl) e altri file di risorse necessari per il report.To create a report with SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), first you need a report server project where you can save your report definition (.rdl) file and other resource files you need for your report.

Nelle lezioni successive verranno definiti un'origine dati per il report, un set di dati e il layout del report.In the following lessons, you define a data source for your report, define a dataset, and define the report layout. Quando si esegue il report, i dati vengono recuperati e combinati con il layout, quindi visualizzati sullo schermo,When you run the report, the data is retrieved and combined with the layout, and then rendered on your screen. da dove sarà possibile esportarli, stamparli o salvarli.From there you can export it, print it, or save it.

Per creare un progetto server di reportTo create a report server project

  1. Aprire SQL Server Data ToolsSQL Server Data Tools.Open SQL Server Data ToolsSQL Server Data Tools.

  2. Nel menu File > Nuovo > Progetto.On the File menu > New > Project.

    ssrs-ssdt-file-01-new-project

  3. In Installato > Modelli > Business Intelligencefare clic su Reporting Services.Under Installed > Templates > Business Intelligence, click Reporting Services.

    ssrs-ssdt-01-new-rs-project

  4. Fare clic su Progetto server di report ssrs_ssdt_report_server_project.Click Report Server Project ssrs_ssdt_report_server_project.

    Note: se non vengono visualizzate le opzioni Business Intelligence o Progetto server di report, è necessario aggiornare SSDT con i modelli di Business Intelligence.Note: If you don't see the Business Intelligence or Report Server Project options, you need to update SSDT with the Business Intelligence templates. Vedere Scaricare SQL Server Data Tools (SSDT)See Download SQL Server Data Tools (SSDT)

  5. In Nomedigitare Esercitazione.In Name, type Tutorial.

    Per impostazione predefinita, viene creato nella cartella Visual Studio 2015\Projects in una nuova directory.By default, it's created in your Visual Studio 2015\Projects folder in a new directory.

    ssrs-ssdt-01-solution-location

  6. Fare clic su OK per creare il progetto.Click OK to create the project.

    Il progetto Esercitazione viene visualizzato sul lato destro del riquadro Esplora soluzioni.The Tutorial project is displayed in the Solution Explorer pane on the right.

Per creare un nuovo file di definizione del reportTo create a new report definition file

  1. Nel riquadro Esplora soluzioni fare clic con il pulsante destro del mouse su Report > Aggiungi > Nuovo elemento.In the Solution Explorer pane, right-click the Reports > Add > New Item.

    Suggerimento: se non viene visualizzato il riquadro Esplora soluzioni , scegliere Esplora soluzioni dal menu Visualizza.Tip: If you don't see the Solution Explorer pane, on the View menu, click Solution Explorer.

    ssrs_ssdt_add_report

  2. Nella finestra Aggiungi nuovo elemento fare clic su Report ssrs_ssdt_report.In the Add New Item window, click Report ssrs_ssdt_report.

  3. Digitare Sales Orders.rdlin Nome , quindi fare clic su Aggiungi.In Name, type Sales Orders.rdl and then click Add.

    Verranno visualizzati Progettazione report e il nuovo file con estensione rdl nella visualizzazione Progettazione.Report Designer opens and displays the new .rdl file in Design view.

    ssrs-ssdt-01-new-report-designer

    Progettazione report è il componente di Reporting ServicesReporting Services eseguito in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)Report Designer is a Reporting ServicesReporting Services component that runs in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT). e ha due viste: Progettazione e Anteprima.It has two views: Design and Preview. Fare clic sulla scheda corrispondente per cambiare la vista.Click each tab to change views.

    I dati vengono definiti nel riquadro Dati report .You define your data in the Report Data pane. Il layout dei report viene definito nella vista Progettazione .You define your report layout in Design view. Dopo aver eseguito il report, è possibile vederne l'aspetto nella vista Anteprima .You can run the report and see what it looks like in Preview view.

Lezione successivaNext lesson

In questo modo è stato creato un progetto di report denominato Esercitazione, cui è stato aggiunto un file di definizione del report (con estensione rdl).You have successfully created a report project called "Tutorial" and added a report definition (.rdl) file to the report project. Il passaggio successivo consiste nello specificare un'origine dei dati per il report.Next, you will specify a data source to use for the report. Vedere Lezione 2: Specifica delle informazioni di connessione (Reporting Services).See Lesson 2: Specifying Connection Information (Reporting Services).

Vedere ancheSee Also

Creare un report tabella semplice (esercitazione su SSRS)Create a Basic Table Report (SSRS Tutorial)