Reporting Services in SQL Server Data Tools (SSDT)Reporting Services in SQL Server Data Tools (SSDT)

SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) è un ambiente MicrosoftMicrosoft Visual StudioVisual Studio per la creazione di soluzioni di Business Intelligence. is a MicrosoftMicrosoft Visual StudioVisual Studio environment for creating business intelligence solutions. SSDT vanta l'ambiente di creazione Progettazione report in cui è possibile aprire, modificare, visualizzare in anteprima, salvare e distribuire definizioni impaginate di Reporting ServicesReporting Services , origini dati condivise, set di dati condivisi e parti di report.SSDT features the Report Designer authoring environment, where you can open, modify, preview, save, and deploy Reporting ServicesReporting Services paginated report definitions, shared data sources, shared datasets, and report parts. SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) non è incluso in SQL Server. is not included with SQL Server. Scaricare SQL Server Data Tools.Download SQL Server Data Tools.

Questo argomento descrive le soluzioni, i progetti, i modelli di progetto e le configurazioni di SQL Server Data ToolsSQL Server Data Tools usati per Reporting ServicesReporting Services, nonché le visualizzazioni, le barre degli strumenti e i collegamenti che è possibile usare in Progettazione report.This topic describes SQL Server Data ToolsSQL Server Data Tools solutions, projects, project templates, and configurations used for Reporting ServicesReporting Services, and the views, menus, toolbars, and shortcuts that you can use in Report Designer.

Per un'introduzione alla progettazione di report, vedere Progettare report con Progettazione report (SSRS).To get started designing reports, see Design Reports with Report Designer (SSRS).

Soluzioni e progettiSolutions and Projects

Un progetto report costituisce il contenitore per le definizioni e le risorse del report.A report project acts as a container for report definitions and resources. Tutti i file inclusi nel progetto report vengono pubblicati nel server di report al momento della distribuzione del progetto.Every file in the report project is published to the report server when the project is deployed. Quando si crea un progetto per la prima volta, viene creata anche una soluzione come contenitore per il progetto.When you create a project for the first time, a solution is also created as a container for the project. A una singola soluzione è possibile aggiungere più progetti.You can add multiple projects to a single solution.

ConfigurazioniConfigurations

Per creare più set di proprietà di progetto per distribuzioni diversificate, ad esempio server di report aziendali di test e produzione, utilizzare Gestione configurazione.To create multiple sets of project properties for deployment variations such as enterprise test and production report servers, use the Configuration Manager. Per altre informazioni, vedere Distribuzione e supporto della versione in SQL Server Data Tools (SSRS).For more information, see Deployment and Version Support in SQL Server Data Tools (SSRS).

Progetti server di reportReport Server Projects

Dopo l'installazione di Reporting ServicesReporting Services, in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)sono disponibili i modelli di progetto seguenti:When you install Reporting ServicesReporting Services, the following project templates are made available in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT):

  • Progetto server di report.Report Server Project. Quando si seleziona un progetto server di report, verrà aperto Progettazione report.When you select a Report Server Project, Report Designer opens. Un progetto server di report è un modello di progetti Business Intelligence installato da Visual StudioVisual Studio e disponibile nella finestra di dialogo Nuovo progetto .A Report Server Project is a Business Intelligence Projects template installed by Visual StudioVisual Studio that is available from the New Project dialog box. Per altre informazioni, vedere Aggiungere un report nuovo o esistente a un progetto report (SSRS). Le proprietà dei progetti server di report sono applicabili a tutti i report e a tutte le origini dati condivise di un progetto di SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).For more information, see Add a New or Existing Report to a Report Project (SSRS).Report Server project properties apply to all reports and all shared data sources in a SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) project. Queste proprietà includono l'URL del server di report e i nomi di cartella per i report e le origini dati condivise.These properties include the URL for the report server and the folder names for reports and shared data sources. Usare la finestra di dialogo delle pagine delle proprietà del progetto per visualizzare i valori correnti delle proprietà.Use the Project Property Pages dialog box to view the current property values. Per aprire questa finestra di dialogo, scegliere Proprietà dal menu Progetto.To open this dialog box, on the Project menu, click Properties.

  • Creazione guidata progetto server di report.Report Server Project Wizard. Quando si seleziona un progetto Creazione guidata server di report, verrà creato automaticamente un progetto server di report e verrà aperta la Creazione guidata report.When you select a Report Server Wizard Project, a report server project is automatically created, and the Report Wizard opens. Nella procedura guidata è possibile creare un report seguendo le istruzioni riportate in ogni pagina per creare una stringa di connessione a un'origine dati, impostare le credenziali dell'origine dati, progettare una query, aggiungere un'area dati Tabella o Matrice, specificare i dati del report e i gruppi, selezionare uno stile di carattere e colore, pubblicare il report in un server di report e visualizzare l'anteprima del report in locale.In the wizard, you can create a report by following instructions on each page to create a connection string to a data source, set data source credentials, design a query, add a table or matrix data region, specify report data and groups, pick a font and color style, publish the report to a report server, and preview the report locally. Dopo aver creato un report con la procedura guidata, è possibile modificarne i dati e la finestra di progettazione tramite Progettazione report nel progetto server di report.After you create a report with the wizard, you can change the report data and the report designer by using Report Designer in the Report Server project.

    Nuovi modelli di progetto in SSDTNew Project templates in SSDT

Finestre e riquadri Progettazione reportReport Designer Windows and Panes

Progettazione report supporta due visualizzazioni: Progettazione per definire i dati e il layout del report e Anteprima per mostrare una visualizzazione del report di cui è stato eseguito il rendering.Report Designer supports two views: Design to define the report data and report layout, and Preview to display a rendered view of the the report. In ogni visualizzazione è possibile aprire più finestre per progettare o visualizzare un report visualizzabile.In each view, you can display multiple windows to help you design or view a rendered report.

Riquadro Dati reportReport Data Pane

Nel riquadro dei dati del report vengono visualizzati campi predefiniti, origini dati, set di dati, raccolte di campi, parametri di report e immagini.The Report Data pane displays built-in fields, data sources, datasets, field collections, report parameters, and images.

Utilizzare il riquadro dei dati del report per visualizzare quanto segue:Use the Report Data pane to view:

  • Campi predefiniti Informazioni predefinite sul report, ad esempio il nome o l'ora in cui è stato elaborato.Built-in Fields Predefined report information such as the report name or the time the report was processed.

  • Origini dati Un'origine dati rappresenta un nome e una connessione a un'origine dati.Data sources A data source represents a name and connection to a source of data.

  • Set di dati Ogni set di dati include una query che consente di specificare i dati da recuperare dall'origine dati.Datasets Each dataset includes a query that specifies which data to retrieve from the data source. Espandere il set di dati per visualizzare la raccolta di campi specificati dalla query del set di dati.Expand the dataset to view the collection of fields specified by the dataset query.

    In alcune finestre Progettazione query per i set di dati multidimensionali, è possibile specificare i filtri nel riquadro Filtri e indicare se creare i parametri del report.In some query designers for multidimensional datasets, you can specify filters in the Filters pane and indicate whether to create report parameters. Se si specifica l'opzione relativa ai parametri del report, viene automaticamente creato un set di dati speciale per popolare l'elenco dei valori validi del parametro.If you specify the report parameter option, a special dataset is automatically created to populate the parameter’s valid values list. Per impostazione predefinita, questo set di dati non viene visualizzato nel riquadro dei dati del report.By default, the dataset does not appear in the Report Data Pane. Per altre informazioni, vedere Visualizzazione di set di dati nascosti per i valori dei parametri di dati multidimensionali (Generatore report e SSRS).For more information, see Show Hidden Datasets for Parameter Values for Multidimensional Data (Report Builder and SSRS).

  • Parametri report L'elenco dei parametri del report.Report parameters The list of report parameters. Se una query del set di dati include parametri di query, è possibile creare i parametri manualmente o automaticamente.Parameters can be created manually or automatically when a dataset query includes query parameters.

  • Immagini L'elenco delle immagini disponibili da includere come elemento del report Immagine in un report.Images The list of images that are available to include as an Image report item in a report.

    Le origini dati e i set di dati nel riquadro dei dati del report rappresentano gli elementi inclusi nella definizione del report.Data sources and datasets in the Report Data pane represent the elements in the report definition. Il riquadro dei dati del report è una funzionalità supportata da più ambienti di creazione di report.The Report Data pane is a feature supported by multiple report authoring environments. In Generatore report, è l'unico riquadro disponibile per la gestione delle origini dati e dei set di dati.In Report Builder, it is the only pane available for managing data sources and datasets. In Progettazione report il riquadro dei dati del report funziona con Esplora soluzioni in cui le origini dati condivise e i set di dati condivisi vengono elencati come file.In Report Designer, the Report Data pane works with Solution Explorer, which lists shared data sources and shared datasets as files. Le origini dati condivise e i set di dati condivisi nel riquadro dei dati del report devono puntare alle origini dati condivise e ai set di dati condivisi corrispondenti di Esplora soluzioni.Shared data sources and shared datasets in the Report Data pane must point to their corresponding Shared Data Sources and Shared Datasets in Solution Explorer. Gli elementi del riquadro dei dati del report contengono un riferimento ai file di dati di Esplora soluzioni.The Report Data pane elements then contain a reference to the data files in Solution Explorer. Le proprietà del progetto determinano se le origini dati condivise e i set di dati condivisi vengono distribuiti nel server di report o nel sito di SharePoint.The project properties determine whether the shared data sources and shared datasets are deployed to the report server or SharePoint site. Per altre informazioni, vedere Conversione di origini dati (Generatore report e SSRS).For more information, see Convert Data Sources (Report Builder and SSRS).

Nota

Se non è possibile visualizzare il riquadro dei dati del report, fare clic nell'area di progettazione e scegliere Dati report dal menu Visualizza.If you do not see the Report Data pane, click in the Design area and then on the View menu, click Report Data. Se il riquadro dei dati del report è mobile, è possibile ancorarlo.If the Report Data pane is floating, you can anchor it. Per altre informazioni, vedere Ancorare il riquadro dei dati del report in Progettazione report (SSRS).For more information, see Dock the Report Data Pane in Report Designer (SSRS).

Riquadro di raggruppamentoGrouping Pane

Utilizzare il riquadro di raggruppamento per definire i gruppi per un'area dati Tablix.Use the Grouping pane to define groups for a tablix data region. È possibile definire gruppi di righe e gruppi di dettagli per le tabelle, nonché gruppi di righe e colonne per le matrici.You can define row groups and detail groups for tables and row and column groups for matrices. Non è possibile utilizzare il riquadro di raggruppamento per definire gruppi per grafici o altre aree dati.You cannot use the Grouping pane to define groups for Charts or other data regions. Per altre informazioni, vedere Informazioni sui gruppi (Generatore report e SSRS).For more information, see Understanding Groups (Report Builder and SSRS).

Il riquadro di raggruppamento presenta due modalità:The Grouping pane has two modes:

  • Valore predefinito.Default. Usare la modalità Predefinita per visualizzare tutti i gruppi di righe e di colonne in un formato gerarchico che consente di visualizzare la relazione esistente tra gruppi padre, gruppi figlio, gruppi adiacenti e gruppi di dettagli.Use the Default mode to display all row and column groups in a hierarchical format that shows the relationship of parent groups, child groups, adjacent groups, and detail groups. Un gruppo figlio viene visualizzato al di sotto e al livello di rientro successivo rispetto al relativo gruppo padre.A child group appears under and at the next indent level compared to its parent group. Un gruppo adiacente viene visualizzato allo stesso livello di rientro dei gruppi di pari livello.An adjacent group appears at the same indent level as its peer or sibling groups.

    Utilizzare la modalità predefinita per aggiungere, modificare o eliminare gruppi.Use default mode to add, edit, or delete groups. Per i gruppi basati su un singolo campo del set di dati, trascinare il campo nel riquadro Gruppi di righe o Gruppi di colonne.For groups based a single dataset field, drag the field to the Row Groups or Column Groups pane. È possibile inserire il gruppo sopra o sotto un gruppo esistente.You can insert the group above or below an existing group. Per aggiungere un gruppo adiacente, fare clic con il pulsante destro del mouse sul gruppo di pari livello, quindi utilizzare il menu di scelta rapida.To add an adjacent group, right-click the sibling group, and use the shortcut menu. Per visualizzare le celle della Tablix appartenenti a un gruppo, selezionare il gruppo nel riquadro di raggruppamento.To display which tablix cells belong to a group, select the group in the Grouping pane.

  • AvanzataAdvanced. Usare la modalità Avanzata per visualizzare membri di gruppi di righe e di colonne statici e dinamici dell'area dati Tablix selezionata.Use the Advanced mode to display static and dynamic row and column group members of the selected tablix data region. È necessario utilizzare i membri dei gruppi per impostare le proprietà che consentono di controllare la visibilità delle righe e delle colonne associate a un gruppo o a un membro di un gruppo oppure le regole utilizzate dai renderer per tentare di tenere insieme i gruppi in una pagina.You must use group members to set properties that control the visibility of the rows and columns associated with a group or group member, or the rules that renderers use to try to keep groups together on a page. I membri dei gruppi vengono visualizzati nell'area di progettazione come celle nelle aree dei gruppi di righe e di colonne.Group members appear on the design surface as cells in the row group and column group areas.

Nota

Per passare dalla modalità Predefinita alla modalità Avanzata (e viceversa), fare clic con il pulsante destro del mouse sulla freccia GIÙ a destra dell'icona Gruppi di colonne .To toggle between Default and Advanced modes, right-click the down arrow to the right of the Column Groups icon.

Per altre informazioni, vedere Riquadro di raggruppamento.For more information, see Grouping Pane.

Casella degli strumentiToolbox

La casella degli strumenti contiene elementi del report che è possibile trascinare nell'area di progettazione.The Toolbox contains report items that you can drag to the design surface. Le aree dati sono elementi del report che è possibile utilizzare per organizzare i dati nel report.Data regions are report items that you use to organize data on the report. Tabelle, matrici, elenchi, grafici, misuratori, barre dei dati, grafici sparkline e indicatori sono aree dati.Table, Matrix, List, Chart, Gauge, Data Bar, Sparkline, and Indicator are data regions. Altri elementi del report sono Mappa, Casella di testo, Rettangolo, Riga, Immagine e Sottoreport.Other report items include Map, Text Box, Rectangle, Line, Image, and Subreport. In questo elenco possono anche essere inclusi elementi del report personalizzati, se sono stati installati e registrati dall'amministratore del sistema.Custom report items might also appear on this list if they have been installed and registered by your system administrator.

Riquadro delle proprietàProperties Pane

Il riquadro Proprietà è una finestra standard di Visual StudioVisual Studio in cui vengono visualizzati i nomi e i valori delle proprietà relative all'elemento del report attualmente selezionato nell'area di progettazione.The Properties pane is a standard Visual StudioVisual Studio window that shows property names and values for the currently selected report item on the design surface. Nella maggior parte dei casi i nomi delle proprietà corrispondono agli elementi e agli attributi contenuti nel file RDL (Report Definition Language).In most cases, property names correspond to elements and attributes in the Report Definition Language (RDL) file. Le proprietà utilizzate più di frequente possono essere impostate utilizzando la finestra di dialogo Proprietà relativa all'elemento selezionato.The most commonly used properties can be set by using the Properties dialog box for the selected item. Per aprire la finestra di dialogo corrispondente, fare clic sul pulsante Pagine delle proprietà sulla barra degli strumenti del riquadro Proprietà.To open the corresponding dialog box, click the Property Pages button on the Properties pane toolbar. Gli utenti esperti possono impostare i valori delle proprietà direttamente nel riquadro Proprietà.Advanced users can set property values directly in the Properties pane.

Utilizzare il riquadro Proprietà per:Use the Properties pane to:

  • Impostare le proprietà per l'elemento attualmente selezionato nell'area di progettazione.Set properties for the currently selected item on the design surface. Per alcune proprietà è disponibile un elenco a discesa di valori.Some properties provide a drop-down list of values. È inoltre possibile digitare il valore direttamente nella cella.You can also type the value directly in the cell. Alcune proprietà contengono una raccolta di valori, indicata dal valore (Raccolta).Some properties contain a collection of values, indicated by the value (Collection). La maggior parte delle proprietà può accettare un'espressione. Le espressioni complesse sono indicate dal valore <Espressione>.Most properties can accept an expression; complex expressions are indicated by the value <Expression>. Fare clic su <Espressione> per aprire la finestra di dialogo Espressione.Click <Expression> to open the Expression dialog box. Per altre informazioni, vedere Finestra di dialogo Espressione.For more information, see Expression Dialog Box.

  • Utilizzare i pulsanti della barra degli strumenti del riquadro Proprietà per modificare la modalità di visualizzazione della griglia passando dalla visualizzazione per categorie alla visualizzazione in ordine alfabetico.Use the Properties pane toolbar buttons to change the grid from category view to alphabetical view. In visualizzazione categorie può essere necessario espandere una categoria per visualizzare tutte le proprietà sottostanti.In category view, you may need to expand a category to see all the properties under it. Per aprire la finestra di dialogo Proprietà di un elemento, fare clic sul pulsante delle pagine delle proprietà sulla barra degli strumenti oppure fare clic con il pulsante destro del mouse sull'elemento e scegliere Proprietà.To open an item's Properties dialog box, click the Property Pages button on the toolbar or by right-click the item and click Properties.

  • Impostare le proprietà per il membro del gruppo attualmente selezionato nel riquadro di raggruppamento.Set properties for the currently selected group member in the Grouping pane. Le proprietà dei membri del gruppo consentono di controllare in che modo le righe dell'intestazione e del piè di pagina di un gruppo statico si ripetono per ogni istanza di un gruppo.Group member properties help control how static group header and footer rows repeat for each group instance. Per altre informazioni, vedere Visualizzare intestazioni e piè di pagina con un gruppo (Generatore report e SSRS).For more information, see Display Headers and Footers with a Group (Report Builder and SSRS).

    Per visualizzare il riquadro Proprietà, scegliere Finestra Proprietà dal menu Visualizza.To display the Properties pane, from the View menu, click Properties Window. È possibile annullare l'ancoraggio a questo riquadro e spostarlo in un'altra area della finestra di SQL Server Data ToolsSQL Server Data Toolsoppure aprirlo come visualizzazione a schede nell'area di progettazione.You can undock this pane and move it to another area of the SQL Server Data ToolsSQL Server Data Toolswindow, or display it as a tabbed view on the design surface.

Esplora soluzioniSolution Explorer

Esplora soluzioni è un componente standard di Visual StudioVisual Studio in cui vengono visualizzati tutti gli elementi del progetto.Solution Explorer is a standard Visual StudioVisual Studio component that displays all the items in your project. Per un progetto server di report, questo componente include cartelle per organizzare origini dati condivise, set di dati condivisi, report e risorse.For a Report Server project, this includes folders to organize shared data sources, shared datasets, reports and resources. Gli elementi della cartella vengono automaticamente disposti in ordine alfabetico quando si apre il file di soluzione.Folder items are automatically alphabetized when you open the solution file. Per visualizzare le proprietà dell'elemento nel riquadro Proprietà, selezionare questo elemento.To view item properties in the Properties pane, select the item.

OutputOutput

Nella finestra di output vengono visualizzati gli errori di elaborazione che si verificano durante la visualizzazione dell'anteprima di un report e gli errori di pubblicazione che si verificano quando si distribuisce un report o un'origine dati condivisa.The Output window displays processing errors when you preview a report, and publishing errors when you deploy a report or a shared data source.

Utilizzare la finestre di output e la finestra Struttura documento per eseguire il debug degli errori contenuti nelle espressioni.Use the Output and the Document Outline windows to help debug errors in expressions.

Struttura documento.Document Outline

Nella finestra Struttura documento viene visualizzato un elenco gerarchico di tutti gli elementi del report inclusi nella definizione del report.The Document Outline window displays a hierarchical list of all report items in the report definition. Per aprire il riquadro Struttura documento, scegliere Altre finestre dal menu Visualizza e quindi fare clic sulla finestra del documento.To open the Document Outline pane, from the View menu, point to Other Windows and click Document Window.

Utilizzare il riquadro Struttura documento per identificare le caselle di testo e altri elementi del report in base al nome.Use the Document Outline pane to help identify text boxes and other report items by name. Quando si seleziona un elemento in Struttura documento, questo elemento viene anche selezionato nell'area di progettazione.When you select an item in the Document Outline, the item is also selected on the Design Surface.

Elenco attivitàTask List

Nella finestra Elenco attività vengono visualizzati gli errori di compilazione relativi alle funzionalità non supportate quando si importa un report da un'altra applicazione, ad esempio MicrosoftMicrosoft Access.The Task List window displays build errors for unsupported features when you import a report from another application, such as MicrosoftMicrosoft Access.

Visualizzazione Progettazione di Progettazione reportReport Designer Design View

Per impostazione predefinita, quando si crea un progetto server di report, Progettazione report viene aperto in visualizzazione Progettazione e consente di visualizzare l'area di progettazione.By default, when you create a Report Server project, Report Designer opens in Design view and displays the design surface. Per impostazione predefinita, nell'area di progettazione vengono visualizzati il corpo e lo sfondo del report.By default, the design surface displays the report body and the report background.

Il menu di scelta rapida sullo sfondo include le opzioni per l'aggiunta di un'intestazione e un piè di pagina, mentre dal menu Visualizza è possibile visualizzare un righello e il riquadro di raggruppamento.The shortcut menu on the background provides options to add a page header and page footer, and from the View menu, display a ruler and the Grouping pane.

Utilizzare il controllo Zoom per aumentare o ridurre l'ingrandimento del report.Use the zoom control to increase or decrease the magnification of the report.

Per progettare un report, trascinare gli elementi del report dalla casella degli strumenti all'area di progettazione, configurare quindi le proprietà di questi elementi e modificarne la disposizione nel report.To design a report, drag report items from the Toolbox to the design surface, and then configure their properties and alter their arrangement on the report.

Anteprima di Progettazione reportReport Designer Preview

Utilizzare Anteprima per eseguire il report e aprire il report visualizzabile nel visualizzatore di report.Use Preview to run the report and view the rendered report in the report viewer. Con l'anteprima i dati del report vengono memorizzati nella cache in locale.Preview caches report data locally. È anche possibile impostare le proprietà di configurazione in modo da eseguire il report in modalità debug, tramite un browser.You can also set configuration properties to run the report in debug view, using a browser.

Quando si visualizza l'anteprima di un report, Progettazione report si connette alle origini dati del report, esegue le query del set di dati, memorizza i dati nella cache del computer locale, elabora il report per combinare dati e layout ed esegue il rendering del report.When you preview a report, Report Designer connects to the report data sources, runs dataset queries, caches the data on the local computer, processes the report to combine data and layout, and renders the report. È possibile visualizzare il report nella scheda Anteprima oppure configurare le proprietà del progetto per visualizzarlo in modalità debug e aprirlo direttamente in un browser.You can view the report in on the Preview tab or you can set up project properties to view the report in debug mode and view it directly in a browser.

  • Visualizzazione dell'anteprima dei report con parametri.Previewing Parameterized Reports. Quando si visualizza l'anteprima di un report, quest'ultimo viene automaticamente elaborato se tutti i relativi parametri includono valori predefiniti validi.When you preview a report, the report is processed automatically if all report parameters have valid default values. Se uno o più parametri del report non includono un valore predefinito valido, è necessario scegliere un valore per ogni parametro non assegnato e quindi fare clic su Visualizza reportsulla barra degli strumenti del report.If one or more report parameters do not have a valid default value, you must choose a value for each unassigned parameter, and then, on the report toolbar, click View Report.

  • Informazioni sulla cache di dati locale Quando si visualizza l'anteprima di un report, il componente Elaborazione report esegue tutte le query per i set di dati del report usando i valori predefiniti correnti dei parametri, quindi salva i risultati come file della cache di dati locale (con estensione rdl).Understanding the Local Data Cache When you preview a report, the report processor runs all the queries for datasets in the report using the current parameter defaults, and saves the results as a local data cache (.rdl.data) file. È possibile continuare a progettare il report senza incorrere nell'overhead associato a un nuovo recupero dei dati, se non vengono apportate modifiche alle query del set di dati o ai parametri del report.You can continue to design your report without incurring the overhead of retrieving this data again if you make no changes to either the report dataset queries or the report parameters.

  • Visualizzazione dell'anteprima del report tramite Gestione configurazione e Debug.Previewing the Report using Configuration Manager and Debug. In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)le proprietà del progetto consentono di definire come distribuire i report ed eseguirne il debug.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), project properties define how you want to deploy and debug your reports. Queste proprietà si applicano a tutti i report e a tutte le origini dati condivise del progetto.These properties apply to all reports and shared data sources in the project. Per impostare le proprietà del progetto, scegliere Proprietà dal menu Progetto.To set the project properties, from the Project menu, click Properties. Utilizzare queste impostazioni per testare i report e pubblicarli nel server di report.Use these settings to test your reports and publish them to the report server.

  • Monitoraggio del riquadro di output per individuare i messaggi di errore.Monitoring the Output Pane for Error Messages. Quando si visualizza l'anteprima di un report e viene rilevato un problema, il componente Elaborazione report scrive i messaggi di errore nel riquadro di output.When you preview a report and the report processor detects a problem, it writes error messages to the Output pane.

Menu di Progettazione reportReport Designer Menus

Quando in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)è attivo un progetto di Progettazione report, alla barra degli strumenti principale vengono aggiunte le barre degli strumenti seguenti.When a Report Designer project is active in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), the following toolbars are added to the main toolbar. I menu di Progettazione report sono visibili solo in visualizzazione Progettazione.The Report Designer menus are visible only when in Design view.

Menu FormatoFormat Menu

Quando si seleziona un elemento nell'area di progettazione, il menu Formato contiene le opzioni seguenti:When you select an item on the design surface, the Format menu contains the following options:

  • Colore primo piano Selezionare un colore per il testo.Foreground Color Select a text color. Il colore predefinito è il nero.Black is the default text color.

  • Colore di sfondo Selezionare un colore di sfondo per le caselle di testo e le aree dati.Background Color Select a background color for your text boxes and data regions.

  • Carattere Specificare se lo stile del testo è grassetto, corsivo o sottolineato.Font Specify whether the text is bold, italic, or underlined.

  • Giustifica Specificare se il testo è allineato a destra, centrato o allineato a sinistra.Justify Specify whether the text is right-aligned, centered, or left-aligned.

  • Allinea Specificare il modo in cui gli oggetti selezionati sono allineati tra loro nel report.Align Specify how the selected objects are aligned in relation to one another within the report.

  • Rendi uguali Consente di regolare le dimensioni degli oggetti selezionati nel report.Make Same Size Adjust the size of the selected objects within the report.

  • Spaziatura orizzontale Consente di regolare la spaziatura orizzontale tra gli oggetti selezionati nel report.Horizontal Spacing Adjust the horizontal spacing between the selected objects within the report.

  • Spaziatura verticale Consente di regolare la spaziatura verticale tra gli oggetti selezionati nel report.Vertical Spacing Adjust the vertical spacing between the selected objects within the report.

  • Centra nel form Consente di allineare al centro orizzontalmente e verticalmente l'oggetto selezionato rispetto alla finestra di Progettazione report.Center in Form Center the selected object vertically and horizontally in relation to the Report Designer window.

  • Ordina Consente di spostare sullo sfondo o in primo piano gli oggetti selezionati.Order Move selected objects into the background or foreground.

Menu ReportReport Menu

Quando l'area di progettazione report ha lo stato attivo, il menu Report contiene le opzioni seguenti:When the report design surface has focus, the Report menu contains the following options:

  • Proprietà report Selezionare questa opzione per aprire la finestra di dialogo Proprietà report ,Report Properties Select to open the Report Properties dialog box. in cui è possibile assegnare proprietà generali del report come il nome dell'autore e la spaziatura della griglia, nonché proprietà per il layout come il numero di colonne e le dimensioni pagina.In this dialog box, you can assign general report properties, such as author name and grid spacing, and specify properties for the report layout, such as the number of columns and page size. È inoltre possibile includere codice personalizzato, riferimenti ad assembly e classi e i nomi di elementi di output dei dati, trasformazioni dati e schemi dati.You can also include custom code, references to assemblies and classes, and the names of data output elements, data transforms, and data schemas.

  • Visualizzazione Consente di passare tra le due schede di Progettazione report: Progettazione e Anteprima.View Switch between the two Report Designer tabs: Design and Preview.

  • Intestazione pagina Consente di aggiungere o eliminare un'intestazione di pagina nel report.Page Header Add or delete a page header to the report. L'eliminazione di un'intestazione di pagina implica la rimozione di tutti gli elementi al suo interno.When you delete a page header, all items in the page header are deleted.

  • Piè di pagina Consente di aggiungere o eliminare un piè di pagina nel report.Page Footer Add or delete a page footer to the report. L'eliminazione di un piè di pagina implica la rimozione di tutti gli elementi al suo interno.When you delete a page footer, all items in the page footer are deleted.

  • Riquadro di raggruppamento Consente di visualizzare o nascondere il riquadro Raggruppamento.Grouping Pane Show or hide the Grouping pane.

Menu VisualizzaView Menu

Usare il menu Visualizza per visualizzare finestre e barre degli strumenti di Progettazione report.Use the View menu to display Report Designer windows and toolbars

  • Elenco errori Usare questa opzione per visualizzare gli errori rilevati durante la pubblicazione o l'anteprima di un report.Error List Use this option to display errors detected when publishing or previewing a report.

  • Output Usare questa opzione per visualizzare gli errori rilevati durante la pubblicazione o l'elaborazione di un report oppure per ulteriori informazioni sugli errori delle espressioni quando in un report viene visualizzato il messaggio "#Errore".Output Use this option to display errors detected when publishing or processing a report, or for more information about expression errors when a report displays the text "#Error".

  • Finestra Proprietà Usare questa opzione per visualizzare i valori delle proprietà dell'elemento del report selezionato nell'area di progettazione.Properties Window Use this option to display the property values for the currently selected report item on the design surface. Per visualizzare le proprietà relative agli elementi nidificati del report, è necessario fare clic più volte su un elemento per scorrere la gerarchia di questo elemento e dei relativi membri nidificati.To see properties for nested report items, you must click a report item multiple times to cycle through the hierarchy for a report item and its nested members. Controllare il nome dell'elemento visualizzato nella parte superiore del riquadro Proprietà per verificare a quale elemento del report appartengono le proprietà visualizzate.Check the name of the item that appears at the top of the Properties pane to see which report item's properties are displayed.

  • Casella degli strumenti Usare questa opzione per visualizzare la casella degli strumenti.Toolbox Use this option to display the Toolbox.

  • Altre finestre Usare questa opzione per visualizzare il riquadro seguente:Other Windows Use this option to display the following pane:

    • Struttura documento Usare questa opzione per aprire una vista gerarchica degli elementi del report e le relative raccolte di caselle di testo in un report.Document Outline Use this option to display a hierarchical view of report items and their collections of text boxes in a report.
  • Barre degli strumenti Usare questa opzione per visualizzare le barre degli strumenti che supportano le funzionalità di Progettazione report, tra cui Bordi report e Formattazione report.Toolbars Use this option to display toolbars that support Report Designer features, including Report Borders and Report Formatting. Per altre informazioni, vedere Barre degli strumenti di Progettazione report.For more information, see Report Designer Toolbars.

  • Dati report Usare questa opzione per visualizzare il riquadro dei dati del report, in cui è possibile aggiungere parametri, origini dati, set di dati e immagini del report.Report Data Use this option to display the Report Data pane, where you can add report parameters, data sources, datasets, images.

Menu ProgettoProject Menu

Usare il menu Progetto per gestire origini dati condivise e report in un progetto.Use the Project menu to manage shared data sources and reports in a project. Quando si aggiungono o rimuovono elementi dal progetto, la vista gerarchica degli elementi del progetto in Esplora soluzioni viene automaticamente aggiornata.When you add or remove items from the project, the hierarchical display of project items in Solution Explorer is automatically updated.

  • Aggiungi nuovo elemento Consente di aggiungere una nuova origine dati condivisa o un nuovo report al progetto.Add New Item Add a new shared data source or new report to the project.

  • Aggiungi elemento esistente Consente di aggiungere un'origine dati condivisa o un report esistente al progetto.Add Existing Item Add an existing shared data source or an existing report to the project.

  • Importa report Consente di importare report da un'altra applicazione, ad esempio Microsoft Access.Import Reports Import reports from another application, for example, Microsoft Access.

  • Escludi dal progetto Consente di escludere elementi dal progetto.Exclude from Project Exclude items from the project. Con questa opzione l'elemento non viene eliminato dal file system.This option does not delete the item from your file system.

  • Mostra tutti i file Consente di visualizzare tutti i file di un progetto.Show All Files Show all files in a project.

  • Aggiorna elementi della casella degli strumenti del progetto Consente di aggiornare la cache della casella degli strumenti quando si installano nuovi elementi del report personalizzati nel progetto.Refresh Project Toolbox Items Refresh the toolbox cache when you install new custom report items in your project.

  • Proprietà Consente di aprire la finestra di dialogo Pagine delle proprietà per il progetto.Properties Open the Property Pages dialog box for this project. Per altre informazioni, vedere Finestra di dialogo Pagine delle proprietà del progetto.For more information, see Project Property Pages Dialog Box.

Barre degli strumenti di Progettazione reportReport Designer Toolbars

In Progettazione report sono disponibili le seguenti barre degli strumenti speciali da utilizzare per la progettazione di report:Report Designer provides the following specialized toolbars to use when designing reports:

  • Report Consente di aggiungere un'intestazione o un piè di pagina, impostare le proprietà del report, attivare e disattivare il righello o il riquadro Raggruppamento oppure usare lo zoom per cambiare la visualizzazione del report.Report Add a page header or page footer, set report properties, toggle the ruler or Grouping pane, or use zoom to change your view of the report.

  • Bordi report Consente di impostare il colore, lo stile e lo spessore per tutte le linee e i bordi selezionati di tutti gli elementi del report selezionati.Report Borders Set the color, style, and width for all selected lines and the borders of all selected report items.

  • Formattazione report Consente di impostare il formato degli elementi del report selezionati.Report Formatting Set the format of selected report items. Per le caselle di testo, è possibile modificare i tipi di formattazione seguenti tramite la barra degli strumenti: proprietà del carattere e colore del testo, colore di sfondo e giustificazione del testo.For text boxes, the following types of formatting can be changed using the toolbar: font properties and text color, background color, and text justification.

  • Layout Consente di impostare l'ordine con cui vengono disegnati gli elementi del report e l'unione di celle in un'area dati.Layout Set the drawing order of report items and merging cells within a data region.

  • Standard Consente di aprire o salvare progetti, visualizzare finestre e selezionare la configurazione di debug.Standard Open or save projects, display windows, and select the Debug configuration.

    Usare il menu Visualizza per controllare se visualizzare o meno queste barre degli strumenti.Use the View menu to control whether to display these toolbars. È possibile che altre barre degli strumenti di Visual StudioVisual Studio siano disabilitate se le relative funzionalità non sono applicabili alle funzionalità di Progettazione report.Other Visual StudioVisual Studio toolbars may be disabled if their functionality does not apply to Report Designer features.

Controllo del codice sorgenteSource Control

SQL Server Data ToolsSQL Server Data Tools può essere integrato con i plug-in di origine. Usare le pagine Progetti e soluzioni della finestra di dialogo Opzioni per specificare il plug-in e configurare le proprietà. can integrate with source plug-ins. Use the Projects and Solutions pages in the Options dialog box to specify the plug-in and configure properties.

Modelli di report personalizzatiCustom Report Templates

Per utilizzare report personalizzati come modelli per nuovi report, è sufficiente copiarli nella cartella ReportProject nel computer in cui è installato SQL Server Data ToolsSQL Server Data Tools .To use custom reports as templates for new reports, you simply copy them to the ReportProject folder on the computer on which SQL Server Data ToolsSQL Server Data Tools is installed. Per impostazione predefinita, questa cartella si trova nel percorso seguente: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject.By default, this folder is in the following location: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject. Quando si aggiunge un nuovo elemento al progetto report, il report personalizzato viene visualizzato nel riquadro dei Modelli.When you add a new item to the report project, your custom report appears in the Templates pane.

È inoltre possibile aggiungere stili personalizzati alla procedura guidata del report.You can also add custom styles to the report wizard.

Supporto della riga di comando per SQL Server Data ToolsCommand Line Support for SQL Server Data Tools

SQL Server Data ToolsSQL Server Data Tools è basato su MicrosoftMicrosoft Visual StudioVisual Studio e sull'applicazione devenv.exe sottostante. is based on MicrosoftMicrosoft Visual StudioVisual Studio and the underlying devenv.exe application. Prima di poter utilizzare queste opzioni, è necessario impostare i valori validi dei seguenti due elementi:Before you can use these options, you must set valid values for following two items:

  • Proprietà del progetto per OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder e TargetServerURL.Project properties for OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder, and TargetServerURL.

  • Almeno un set di proprietà di configurazione, ad esempio Debug o Release.At least one set of configuration properties, for example, Debug or Release.

    Per altre informazioni, vedere Pubblicazione di origini dati e report.For more information, see Publishing Data Sources and Reports.

    Per un progetto server di report, è possibile specificare le opzioni seguenti dalla riga di comando:For a report server project, you can specify the following options from the command line:

  • /deploy Distribuisce i report tramite le proprietà del progetto specificate in un file di configurazione./deploy Deploy reports by using the project properties specified in a configuration file. Ad esempio, nel comando seguente vengono distribuiti i report specificati dal file di soluzione Reports.sln tramite le impostazioni di configurazione Release specificate nelle proprietà del progetto:For example, the following command deploys the reports specified by the solution file Reports.sln by using the Release configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /deploy "Release"  
    
  • /build Compila il file di soluzione, ma non lo distribuisce./build Build the solution file, but do not deploy it. Ad esempio, nel comando seguente vengono compilati i report specificati dal file di soluzione Reports.sln tramite le impostazioni di configurazione Debug specificate nelle proprietà del progetto:For example, the following command builds the reports specified by the solution file Reports.sln by using the Debug configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug"  
    
  • /out Reindirizza l'output generato dalla compilazione di una soluzione nel file specificato./out Redirect the output generated by building a solution to the specified file. Ad esempio, il comando seguente consente di reindirizzare l'output dalla compilazione dell'esempio precedente in un file denominato mybuildlog.txt.For example, the following command redirects the output from the build in the previous example to a file named mybuildlog.txt.

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug" /out mybuildlog.txt  
    

Tasti di scelta rapida di Reporting ServicesKeyboard Shortcuts in Reporting Services

Utilizzare i tasti di scelta rapida per:Use keyboard shortcuts to:

  • Controllare le finestre e le modalità di SQL Server Data ToolsSQL Server Data Tools:Control windows and modes in SQL Server Data ToolsSQL Server Data Tools:

    DescriptionDescription Combinazione di tastiKey Combination
    Consente di compilare il progetto selezionatoBuild the selected project CTRL+SHIFT+BCTRL+SHIFT+B
    Consente di visualizzare la finestra ProprietàDisplay Properties window F4F4
    Consente di visualizzare la finestra dei datiDisplay Data window CTRL+ALT+DCTRL+Alt+D
    Consente di iniziare il debugStart debugging F5F5
    Consente di spostarsi da una finestra aperta a quella successivaMove from one open window to the next F6F6
  • Consente di controllare gli elementi nell'area di progettazione del reportControl items on the report design surface:

    DescriptionDescription Combinazione di tastiKey Combination
    Consente di spostare lo stato attivo da un elemento del report all'elemento successivoMove focus from one report item to the next report item TABTAB
    Consente di spostare l'elemento del report selezionatoMove selected report item Tasti di direzioneArrow keys
    Consentono di spostare l'elemento del report selezionatoNudge selected report item CTRL+Tasti di direzioneCTRL+Arrow keys
    Consente di aumentare o ridurre le dimensioni dell'elemento del report selezionatoIncrease or decrease the size of the selected report item CTRL+MAIUSC+Tasti di direzioneCTRL+SHIFT+Arrow keys
    In una casella di testo, consente di spostare il cursore all'inizio del testo visualizzatoIn a text box, move cursor to the beginning of the display text that is visible CTRL+HOMECTRL+HOME
    In una casella di testo, consente di spostare il cursore alla fine del testo visualizzatoIn a text box, move cursor to the end of the display text that is visible CTRL+FINECTRL+END
    In una casella di testo, seleziona il testo dalla posizione corrente del cursore all'inizio del testo visualizzatoIn a text box, select text from the current cursor position to the beginning of the display text that is visible MAIUSC+HOMESHIFT+HOME
    In una casella di testo, seleziona il testo dalla posizione corrente del cursore alla fine del testo visualizzatoIn a text box, select text from the current cursor position to the end of the display text that is visible MAIUSC+FINESHIFT+END
    In una casella di testo, seleziona il testo dalla posizione corrente del cursore all'inizio dell'espressioneIn a text box, select text from the current cursor position to the beginning of the expression CTRL+MAIUSC+HOMECTRL+SHIFT+HOME
    In una casella di testo, seleziona il testo dalla posizione corrente del cursore alla fine dell'espressioneIn a text box, select text from the current cursor position to the end of the expression CTRL+MAIUSC+FINECTRL+SHIFT+END
    Consente di aprire il menu di scelta rapida dell'elemento del report selezionatoOpen the shortcut menu for the selected report item MAIUSC+F10+tasto della proprietà nelle tastiere più recentiSHIFT+F10+Property Key on newer keyboards

Passaggi successiviNext steps

Scaricare SQL Server Data Tools Esplora soluzioni Download SQL Server Data Tools Solution Explorer
Report di Reporting Services Reporting Services Reports
Report Definition Language Report Definition Language
Deployment and Version Support in SQL Server Data ToolsDeployment and Version Support in SQL Server Data Tools

Altre domande?More questions? Visitare il forum su Reporting ServicesTry asking the Reporting Services forum