Creazione e gestione di progetti (AccessToSQL)Creating and Managing Projects (AccessToSQL)

Eseguire la migrazione di database di Access in SQL ServerSQL Server o SQL Azure, è necessario creare innanzitutto un progetto SSMA.To migrate Access databases to SQL ServerSQL Server or SQL Azure, you must first create an SSMA project. Il progetto è un file che contiene metadati sui database di Access che si desidera eseguire la migrazione a SQL ServerSQL Server o SQL Azure, i metadati relativi all'istanza di destinazione SQL ServerSQL Server o SQL Azure in cui verranno inseriti gli oggetti migrati e dati, SQL ServerSQL Server informazioni di connessione e le impostazioni del progetto.The project is a file that contains metadata about the Access databases that you want to migrate to SQL ServerSQL Server or SQL Azure, metadata about the target instance of SQL ServerSQL Server or SQL Azure that will receive the migrated objects and data, SQL ServerSQL Server connection information, and project settings.

Esame impostazioni predefinite del progettoReviewing Default Project Settings

SSMA contiene diverse opzioni per la conversione e la sincronizzazione degli oggetti di database e per la conversione dei dati.SSMA contains several options for converting and synchronizing database objects and for converting data. L'impostazione predefinita per queste opzioni è appropriata per molti utenti.The default setting for these options is appropriate for many users. Tuttavia, prima di creare un nuovo progetto SSMA, si deve esaminare le opzioni e, se si desidera, modificare le impostazioni predefinite che verranno usate per tutti i nuovi progetti.However, before you create a new SSMA project, you should review the options and, if you want to, change the default settings that will be used for all your new projects.

Per controllare le impostazioni di progetto predefinitoTo review default project settings

  1. Nel degli strumenti dal menu impostazioni di progetto predefinite.On the Tools menu, select Default Project Settings.

  2. Selezionare il tipo di progetto in versione di destinazione della migrazione elenco a discesa per quali impostazioni devono essere visualizzati o modificati e quindi fare clic su generali scheda.Select the project type in Migration Target Version drop down for which settings are to be viewed/ changed and then click General tab.

  3. Nel riquadro sinistro, fare clic su conversione.In the left pane, click Conversion.

  4. Nel riquadro di destra, esaminare le opzioni.In the right pane, review the options. Per altre informazioni su queste opzioni, vedere impostazioni progetto (conversione).For more information about these options, see Project Settings (Conversion).

  5. Modificare le opzioni in base alle esigenze.Change options as necessary.

  6. Ripetere i passaggi precedenti per il migrazione, GUI, e Mapping di tipo pagine.Repeat the previous steps for the Migration, GUI, and Type Mapping pages.

Nota le impostazioni di SQL Azure saranno disponibili solo quando si seleziona la migrazione a SQL Azure durante la creazione di un progetto.Note SQL Azure settings will be available only when you select Migration to SQL Azure while creating a project.

Creazione di nuovi progettiCreating New Projects

SSMA viene avviato senza il caricamento di un progetto predefinito.SSMA starts without loading a default project. Per eseguire la migrazione dei dati dal database di Access in SQL ServerSQL Server o SQL Azure, è necessario creare un progetto.To migrate data from Access databases to SQL ServerSQL Server or SQL Azure, you must create a project.

Per creare un nuovo progettoTo create a new project

  1. Scegliere Nuovo progetto dal menu File.On the File menu, select New Project.

    Verrà visualizzata la finestra di dialogo Nuovo progetto .The New Project dialog box appears.

  2. Nel nome immettere un nome per il progetto.In the Name box, enter a name for your project.

  3. Nel posizione casella, immettere o selezionare una cartella per il progettoIn the Location box, enter or select a folder for the project

  4. Nell'elenco per la migrazione verso il basso, selezionare uno di SQL Server 2005 / SQL Server 2008 o SQL Server 2012 o SQL Server 2014 / SQL Server 2016 / Azure SQL DB, quindi fare clic su OK.In the Migration To drop down, select one of SQL Server 2005/ SQL Server 2008/ SQL Server 2012/ SQL Server 2014/ SQL Server 2016/ Azure SQL DB, and then click OK.

SSMA consente di creare il file di progetto.SSMA creates the project file. È ora possibile eseguire il passaggio successivo della aggiunta di uno o più database di Access.You can now perform the next step of adding one or more Access databases.

Personalizzazione delle impostazioni di progettoCustomizing Project Settings

Oltre a definire impostazioni di progetto predefinite, che si applicano a tutti i nuovi progetti SSMA, è anche possibile personalizzare le impostazioni per ogni progetto.In addition to defining default project settings, which apply to all new SSMA projects, you can also customize the settings for each project. Per altre informazioni, vedere impostazione di conversione e le opzioni di migrazione.For more information, see Setting Conversion and Migration Options.

Quando si personalizzano i mapping tra i database di origine e di destinazione, è possibile definire i mapping per il progetto, database o a livello di oggetto.When you customize data type mappings between source and target databases, you can define mappings at the project, database, or object level. Per altre informazioni sul mapping dei tipi, vedere tipi di dati di destinazione e origine del Mapping.For more information about type mapping, see Mapping Source and Target Data Types.

Il salvataggio dei progettiSaving Projects

Quando si salva un progetto, SSMA rende persistenti le impostazioni del progetto e, facoltativamente, i metadati del database, al file di progetto.When you save a project, SSMA persists the project settings, and optionally the database metadata, to the project file.

Per salvare un progettoTo save a project

  • Nel File dal menu Salva progetto.On the File menu, select Save Project.

    Se i database all'interno del progetto sono stati modificati o non sono stati convertiti, SSMA richiederà di salvare i metadati nel progetto.If databases within the project have changed or have not been converted, SSMA will prompt you to save metadata into the project. Salvataggio dei metadati consente di lavorare offline.Saving metadata lets you work offline. Consente inoltre di inviare un file di progetto completo ad altre persone, tra cui il personale di supporto tecnico.It also lets you send a complete project file to other people, including technical support personnel. Se viene chiesto di salvare i metadati, eseguire le operazioni seguenti:If you are prompted to save metadata, do the following:

    1. Per ogni database che viene visualizzato lo stato i metadati mancanti, selezionare la casella di controllo accanto al nome del database.For each database that shows a status of Metadata missing, select the check box next to the database name.

      Salvataggio di metadati potrebbe richiedere alcuni minuti.Saving metadata might take several minutes. Se non si desidera salvare i metadati a questo punto, non selezionare le caselle di controllo.If you do not want to save metadata at this point, do not select any check boxes.

    2. Fare clic su Salva.Click Save.

      Analizza gli schemi di accesso e salvare i metadati del file di progetto SSMA.SSMA will parse the Access schemas and save the metadata to the project file.

Apertura di progettiOpening Projects

Quando si apre un progetto, questo viene disconnesso dal SQL ServerSQL Server o SQL Azure.When you open a project, it is disconnected from SQL ServerSQL Server or SQL Azure. Ciò consente di lavorare offline.This lets you work offline. Per aggiornare gli oggetti di database carica i metadati in SQL ServerSQL Server o SQL Azure.To update metadata load database objects into SQL ServerSQL Server or SQL Azure. Per eseguire la migrazione dei dati, è necessario riconnettersi alla SQL ServerSQL Server o SQL Azure.To migrate data, you must reconnect to SQL ServerSQL Server or SQL Azure.

Per aprire un progettoTo open a project

  1. Usare una delle procedure riportate di seguito:Use one of the following procedures:

    • Nel File dal menu progetti recentie quindi selezionare il progetto da aprire.On the File menu, point to Recent Projects, and then select the project you want to open.

    • Nel File dal menu aprire il progetto, individuare il file di progetto .a2ssproj, selezionare il file e quindi fare clic su Open.On the File menu, select Open Project, locate the .a2ssproj project file, select the file, and then click Open.

  2. Per riconnettersi SQL ServerSQL Servervia il File dal menu Riconnetti a SQL Server.To reconnect to SQL ServerSQL Server, on the File menu, select Reconnect to SQL Server.

  3. Per riconnettersi a SQL Azure, nelle File dal menu ristabilire la connessione a SQL Azure.To reconnect to SQL Azure, on the File menu, select Reconnect to SQL Azure.

Passaggio successivoNext Step

Il passaggio successivo del processo di migrazione consiste aggiungere uno o più database di Access.The next step in the migration process is to add one or more Access databases.

Vedere ancheSee Also

Migrazione dei database di Access a SQL ServerMigrating Access Databases to SQL Server
Aggiunta e rimozione di file di Database di AccessAdding and Removing Access Database Files