Nuove funzionalità di interfaccia utente grafica di SSMA per DB2 (DB2ToSQL)New GUI features in SSMA for DB2 (DB2ToSQL)

In questo capitolo descrive nuove funzionalità dell'interfaccia utente di SSMA.This chapter describes new features of SSMA User Interface.

LayoutLayouts

Questa funzionalità consente di scegliere una delle due finestre predefiniti disposizione o creare un layout.This feature allows you to choose one of two predefined windows lay-out or create you own layout. Per accedere a sottomenu layout, scegliere dal menu Visualizza dal layout.To access layout submenu, on the View menu point to Layouts. Non esiste è possibile scegliere uno dei layout esistente, aggiungere di nuovo layout o gestire layout.There you can choose one of the existing layouts, add new layout or manage layouts.

Aggiungere il Layout correnteAdd Current Layout

Per salvare i layout di windows corrente, dal menu Visualizza di layout, quindi aggiungere Layout corrente.To save current windows layout, on the View menu point to Layouts, then click Add Current Layout.

Scegliere il layout predefinitoChoose predefined layout

Per scegliere uno dei layout predefinito, dal menu Visualizza di layout, quindi Layout predefinito o senza le finestre di esplorazione.To choose one of the predefined layouts, on the View menu point to Layouts, then click Default Layout or Without Explorers. È inoltre possibile utilizzare i tasti di scelta rapida Ctrl + Alt + 1 o Ctrl + Alt + 2 per layout predefiniti.You can also use shortcuts Ctrl+Alt+1 or Ctrl+Alt+2 for predefined layouts.

Scegliere il layout definite dall'utenteChoose user-defined layout

Per scegliere layout definite dall'utente, scegliere Layout dal menu Visualizza, quindi fare clic su uno dei layout definite dall'utente.To choose user-defined layout, on the View menu point to Layouts, then click one of the user-defined layout. È anche possibile utilizzare i collegamenti definiti per il layout.You can also use shortcuts defined for the layouts.

Gestire layoutManage layouts

Per aprire una finestra di dialogo Gestisci layout, scegliere Layout dal menu Visualizza e fare clic su Gestisci layout.To open Manage Layouts dialog, on the View menu point to Layouts and click Manage Layouts. Nella finestra di dialogo Gestisci layout si troverà un elenco dei layout esistente sul lato sinistro della finestra di dialogo.In the Manage Layouts dialog you will find a list of the existing layouts on the left side of the dialog. Non esiste è possibile selezionare il layout per modificare le impostazioni.There you can select the layout to change its settings. È inoltre possibile modificare l'ordine di layout nell'elenco o eliminare il layout utilizzando i pulsanti nella parte superiore nell'elenco.Also you can change layouts order in the list or delete the layout using buttons on the top of the list. Sul lato destro della finestra di dialogo è possibile modificare le impostazioni di layout seguenti:On the right side of the dialog you can change the following layout settings:

  • Nome di layoutLayout name

  • Sincronizzazione delle finestre di esplorazione dei metadatiSynchronization of metadata explorers

  • Visibilità e la larghezza delle finestre di esplorazione dei metadati origine e di destinazioneVisibility and width of the source and target metadata explorers

  • Visibilità di finestre di origine o destinazione e le relative dimensioniVisibility of the source or target windows and their sizes

  • Visibilità e l'altezza di finestre supplementariVisibility and height of auxiliary windows

SegnalibriBookmarks

Questa funzionalità consente di impostare uno o più segnalibri nell'origine o codice di destinazione, rapido trovato un segnalibro utilizzando i tasti di scelta rapida, gestire i segnalibri con una finestra di dialogo descrittivo.This feature allows you to set one or more bookmarks in the source or target code, quick found a bookmark by using shortcuts, manage the bookmarks with a friendly dialog.

Attiva/Disattiva segnalibroToggle Bookmark

È possibile Imposta/Rimuovi un segnalibro nei modi seguenti:You can set/remove a bookmark in the following ways:

  • Utilizzare il pulsante Attiva/Disattiva segnalibro sopra finestra SQL di origine o di destinazioneUse button Toggle Bookmark on top of source or target SQL window

  • Scegliere l'area grigia a sinistra della finestra di SQLClick on the grey area on the left of the SQL window

  • Utilizzare Ctrl + Maiusc +<0..9> per impostare un segnalibro numeratoUse Ctrl+Shift+<0..9> to set numbered bookmark

Spostamento di segnalibroBookmark navigation

È possibile scorrere attraverso i segnalibri nei modi seguenti:You can walk thru the bookmarks in the following ways:

  • Utilizzare i pulsanti segnalibro successivo segnalibro precedente nella parte superiore della finestra SQLUse buttons Next Bookmark, Previous Bookmark on the top of the SQL window

  • Utilizzare Ctrl +<0..9> per trovare il segnalibro numeratoUse Ctrl+<0..9> to find numbered bookmark

  • Utilizzare i pulsanti Vai a visualizzazione origine o nella finestra di dialogo Gestisci segnalibriUse buttons Go To or View Source in Manage Bookmarks dialog

Rimozione di segnalibroRemoving Bookmark

È possibile rimuovere un segnalibro nei modi seguenti:You can remove a bookmark in the following ways:

  • Pulsante Cancella nella parte superiore della finestra SQL per rimuovere tutti i segnalibri nel documento correnteUse button Clear on the top of the SQL window to remove all bookmarks in the current document

  • Utilizzare i pulsanti Rimuovi o Rimuovi tutto nella finestra di dialogo Gestisci segnalibriUse buttons Remove or Remove All in Manage Bookmarks dialog

Gestione di segnalibriManage bookmarks

Per aprire una finestra di dialogo Gestisci segnalibri, fare clic su Gestisci segnalibri dal menu Modifica.To open Manage Bookmarks dialog, on the Edit menu click Manage Bookmarks. Nella finestra di dialogo verrà visualizzato un elenco di segnalibri.In the dialog you will see a list of existing bookmarks. È possibile utilizzare i pulsanti sul lato destro della finestra di dialogo per gestire i segnalibri.You can use the buttons on the right side of the dialog to manage the bookmarks.

Cronologia dell'oggettoObject History

Quando si passa gli oggetti, cronologia dell'interfaccia utente grafica di oggetto consente i vantaggi seguenti:GUI Object History lets you the following advantages when you navigate objects:

  • È possibile utilizzare i pulsanti Indietro e Avanti per spostarsi tra gli oggetti che sono già selezionatiYou can use Go Back and Go Forward buttons to navigate the objects you have already visited

  • Quando esegue il backup per l'oggetto, eseguire la stessa scheda che haiWhen you back to the object, you back to the same tab that you have left

  • Quando si torna all'oggetto e la scheda è SQL, eseguire la stessa posizione del cursore che haiWhen you back to the object and the tab is SQL, you back to the same cursor position that you have left

Funzionalità di ricerca avanzateAdvanced search capabilities

Funzionalità di ricerca avanzate forniscono le funzionalità di ricerca potenti e flessibili e consentono di trovare una dichiarazione dell'oggetto, ottenere informazioni sull'oggetto, eseguire una ricerca rapida, eseguire la ricerca in categorie in base a modelli e così via avanzata di oggetti.Advanced search capabilities provide the powerful and flexible searching features and let you to find object declaration, get object information, perform quick search, perform advanced object searching in categories using patterns etc.

Ottenere informazioni rapideGet quick information

È possibile ottenere informazioni rapide per l'oggetto in corrispondenza della posizione del cursore nei modi seguenti:You can get quick information on the object at the cursor position in the following ways:

  • Fare clic sul pulsante informazioni rapide nella parte superiore di finestra SQLClick button Quick Info on the top of SQL window

  • Seleziona informazioni rapide del menu a comparsa del pulsante destro del mouseSelect Quick Info in the right-click pop-up menu

  • Premere Ctrl + Maiusc + barra spaziatricePress Ctrl+Shift+Space

Trovare dichiarazioneFind declaration

È possibile passare alla dichiarazione dell'oggetto nella posizione del cursore nei modi seguenti:You can go to the declaration of the object at cursor position in the following ways:

  • Fare clic sul pulsante Vai a dichiarazione sopra la finestra SQLClick button Go To Declaration on top of the SQL window

  • Selezionare Vai a dichiarazione nel menu a comparsa pulsante destro del mouseSelect Go To Declaration in the right-click pop-up menu

  • Premere F12Press F12

È possibile eseguire la ricerca rapida utilizzando le funzionalità seguenti:You can perform quick text search using the following features:

  • È possibile avviare la ricerca tramite la scelta rapida Ctrl + FYou can start searching by using Ctrl+F shortcut

  • È possibile ripetere l'ultima ricerca in avanti utilizzando F3You can repeat last search forward by using F3

  • È possibile ripetere l'ultima ricerca all'indietro con MAIUSC + F3You can repeat last search backward by using Shift+F3

  • È possibile trovare l'occorrenza successiva della parola nella posizione del cursore utilizzando Ctrl + F3You can find next occurrence of the word at the cursor position by using Ctrl+F3

  • È possibile trovare l'occorrenza precedente della parola nella posizione del cursore utilizzando Ctrl + MAIUSC + F3You can find previous occurrence of the word at the cursor position by using Ctrl+Shift+F3

  • È anche possibile eseguire tutte queste azioni con voci di menu.You can also perform all these actions with menu items.

Per aprire ricerca avanzata della finestra di dialogo Trova il punto dal menu Modifica, quindi fare clic su ricerca avanzata.To open Advanced Search dialog, on the Edit menu point Find, then click Advanced Search. Nella finestra di dialogo sarà in grado di trovare qualsiasi oggetto con modello.In the dialog you will be able to find any object using pattern. Nella parte superiore la finestra di dialogo è possibile scegliere le categorie di area e dell'oggetto di ricerca.On the top of the dialog you can choose search area and object categories.