Uso dei progetti SSMA (MySQLToSQL)Working with SSMA Projects (MySQLToSQL)

Per eseguire la migrazione di database MySQL a SQL Server o SQL Azure, è innanzitutto necessario creare un progetto SSMA.To migrate MySQL databases to SQL Server or SQL Azure, you must first create an SSMA project. Il progetto è un file che contiene le informazioni seguenti:The project is a file that contains the following information:

  • Metadati sui database MySQL che si desidera eseguire la migrazione a SQL Server o SQL Azure.Metadata about the MySQL databases that you want to migrate to SQL Server or SQL Azure.

  • Metadati relativi a questa istanza di destinazione di SQL Server o SQL Azure in cui verranno inseriti gli oggetti migrati e dati.Metadata about the target instance of SQL Server or SQL Azure that will receive the migrated objects and data.

  • Informazioni di connessione SQL Server o SQL Azure.SQL Server or SQL Azure connection information.

  • Impostazioni del progetto.Project settings.

Quando si apre un progetto, questo viene disconnesso da MySQL e SQL Server o SQL Azure.When you open a project, it is disconnected from MySQL and SQL Server or SQL Azure. Che consente di lavorare offline.That lets you work offline. Per altre informazioni su come connettersi a SQL Server, vedere connessione a SQL Server (MySQLToSQL)For more information about reconnecting to SQL Server, see Connecting to SQL Server (MySQLToSQL)

Esame impostazioni predefinite del progettoReviewing Default Project Settings

SSMA contiene diverse impostazioni per la conversione e il caricamento di database, la migrazione dei dati e sincronizzazione SSMA con MySQL e SQL Server o SQL Azure.SSMA contains several settings for converting and loading database, migrating data, and synchronizing SSMA with MySQL and SQL Server or SQL Azure. Le impostazioni predefinite sono appropriate per molti utenti.The default settings are appropriate for many users. Tuttavia, prima di creare un nuovo progetto SSMA, è consigliabile verificare le impostazioni.However, before you create a new SSMA project, you should review the settings. Se necessario, è possibile modificare le impostazioni predefinite che verranno usate per tutti i nuovi progetti.If required, you can change the default settings that will be used for all your new projects.

Per controllare le impostazioni di progetto predefinitoTo review default project settings
  1. Selezionare impostazioni di progetto predefinite dalle strumenti menu.Select Default Project Settings from the Tools menu.

  2. Selezionare il tipo di progetto in versione di destinazione della migrazione elenco a discesa per quali impostazioni devono essere visualizzati o modificati e quindi fare clic su generali scheda.Select the project type in Migration Target Version drop down for which settings are to be viewed/ changed and then click General tab.

  3. Nel riquadro sinistro, fare clic su conversione.In the left pane, click Conversion.

  4. Nel riquadro di destra, esaminare e modificare le impostazioni in base alle esigenze.In the right pane, review and change the settings as necessary. Per altre informazioni su queste impostazioni, vedere impostazioni del progetto (conversione) (MySQLToSQL) .For more information about these settings, see Project Settings (Conversion) (MySQLToSQL) .

  5. Ripetere i passaggi da 1 a 3 per le pagine di migrazione, la sincronizzazione, SQL Azure, interfaccia utente grafica e del mapping dei tipi.Repeat steps 1-3 for the Migration, Synchronization, SQL Azure, GUI, and Type Mapping pages.

Nota

Le impostazioni di SQL Azure verranno visualizzate solo quando si seleziona migrazione a SQL Azure durante la creazione di un progetto.The SQL Azure settings will be displayed only when you select Migration to SQL Azure while creating a project.

Creazione di nuovi progettiCreating New Projects

Per eseguire la migrazione dei dati dal database MySQL a SQL Server o SQL Azure, è necessario creare un progetto.To migrate data from MySQL databases to SQL Server or SQL Azure, you must create a project.

Per creare un nuovo progettoTo create a new project
  1. Selezionare nuovo progetto dalle File menu.Select New Project from the File menu. Verrà visualizzata la finestra di dialogo Nuovo progetto .The New Project dialog box appears. Scegliere Nuovo progetto dal menu File.On the File menu, select New Project. Verrà visualizzata la finestra di dialogo Nuovo progetto .The New Project dialog box appears.

  2. Nel nome immettere un nome per il progetto.In the Name box, enter a name for your project.

  3. Nel posizione casella, immettere o selezionare una cartella per il progetto.In the Location box, enter or select a folder for the project.

  4. Nel migrazione a elenco a discesa, selezionare la versione del server di destinazione SQL ServerSQL Server usato per la migrazione.In the Migration To drop down, select the version of target SQL ServerSQL Server used for migration. Le opzioni disponibili sono:The options available are:

    • SQL ServerSQL Server 2005 2005

    • SQL ServerSQL Server 2008 2008

    • SQL ServerSQL Server 2012 2012

    • SQL ServerSQL Server 2014 2014

    • Azure SQL databaseAzure SQL DB

E quindi fare clic su OKAnd then Click OK

SSMA consente di creare il file di progetto.SSMA creates the project file.

Personalizzazione delle impostazioni di progettoCustomizing Project Settings

Oltre a definire il valore predefinito delle impostazioni di progetto che si applicano a tutti i nuovi progetti SSMA è inoltre possono personalizzare le impostazioni per ogni progetto.In addition to defining the default project settings that apply to all the new SSMA projects you can also customize the settings for each project. Per altre informazioni, vedere impostazione delle opzioni progetto (MySQLToSQL).For more information, see Setting Project Options (MySQLToSQL).

Quando si personalizzano i mapping tra i database di origine e destinazione, è possibile definire i mapping per il progetto, database o a livello di oggetto.When you customize data type mappings between the source and target databases, you can define mappings at the project, database, or object level. Per altre informazioni, vedere Mapping di MySQL e SQL Server Data Types (MySQLToSQL).For more information, see Mapping MySQL and SQL Server Data Types (MySQLToSQL).

Il salvataggio dei progettiSaving Projects

La funzionalità di salvataggio progetti consente all'utente essenzialmente salvare le impostazioni del progetto e, facoltativamente, i metadati del database per il file di progetto SSMA.The Saving Projects feature allows the user to essentially save the project settings and, optionally, the database metadata to the SSMA project file.

Per salvare un progettoTo save a project
  • Nel File dal menu salvare progetto.On the File menu, select Save Project.

Se i database all'interno del progetto sono stati modificati o non sono stati convertiti, SSMA richiederà di caricare e salvare i metadati.If databases within the project have changed or have not been converted, SSMA will prompt you to load and save metadata. Il caricamento e salvataggio dei metadati consente di lavorare offline.Loading and saving metadata lets you work offline. Consente inoltre di inviare un file di progetto completo ad altre persone, ad esempio il personale di supporto tecnico.It also lets you send a complete project file to other people, such as technical support personnel. Se viene chiesto di salvare i metadati, eseguire le operazioni seguenti:If you are prompted to save metadata, do the following:

  1. Per ogni database che viene visualizzato lo stato i metadati mancanti, selezionare la casella di controllo accanto al nome del database.For each database that shows a status of Metadata missing, select the check box next to the database name. Salvataggio di metadati potrebbe richiedere alcuni minuti.Saving metadata might take several minutes. Se non si desidera salvare i metadati a questo punto, non selezionare le caselle di controllo.If you do not want to save metadata at this point, do not select any check boxes.

  2. Fare clic su Salva.Click Save.

Analizza gli schemi di MySQL e salvare i metadati del file di progetto SSMA.SSMA will parse the MySQL schemas and save the metadata to the project file.

Apertura di progettiOpening Projects

Quando si apre un progetto, questo viene disconnesso da MySQL e da SQL Server o SQL Azure.When you open a project, it is disconnected from MySQL and from SQL Server or SQL Azure. Ciò consente di lavorare offline.This lets you work offline. Per aggiornare i metadati, caricare gli oggetti di database in SQL Server o SQL Azure.To update metadata, load database objects into SQL Server or SQL Azure. Per eseguire la migrazione dei dati, è necessario riconnettersi a SQL Server o SQL Azure.To migrate data, you must reconnect to SQL Server or SQL Azure.

Per aprire un progettoTo open a project
  1. Usare una delle procedure riportate di seguito:Use one of the following procedures:

    1. Nel File dal menu progetti recenti.On the File menu, point to Recent Projects.

    2. Selezionare il progetto da aprire.Select the project you want to open.

    3. Nel File dal menu aprire il progetto, individuare il file di progetto .m2ssproj, selezionare il file e quindi fare clic su Open.On the File menu, select Open Project, locate the .m2ssproj project file, select the file, and then click Open.

  2. Per ristabilire la connessione a MySQL nel File dal menu Riconnetti a MySQL.To reconnect to MySQL, on the File menu, select Reconnect to MySQL.

  3. Per ristabilire la connessione a SQL Server, sul File dal menu Riconnetti a SQL Server.To reconnect to SQL Server, on the File menu, select Reconnect to SQL Server.

  4. Per riconnettersi a SQL Azure, nelle File dal menu ristabilire la connessione a SQL Azure.To reconnect to SQL Azure, on the File menu, select Reconnect to SQL Azure.

Passaggio successivoNext Step

Il passaggio successivo del processo di migrazione consiste connessione a MySQL (MySQLToSQL)The next step in the migration process is Connecting to MySQL (MySQLToSQL)

Vedere ancheSee Also

La connessione a MySQL (MySQLToSQL)Connecting to MySQL (MySQLToSQL)
Database di migrazione da MySQL a SQL Server - Azure SQL database (MySQLToSql)Migrating MySQL Databases to SQL Server - Azure SQL DB (MySQLToSql)
La connessione a SQL Server (MySQLToSQL)Connecting to SQL Server (MySQLToSQL)
La connessione al database SQL di Azure (MySQLToSQL)Connecting to Azure SQL DB (MySQLToSQL)