Finestra di dialogo Strumenti esterniExternal Tools Dialog Box

Nella finestra di dialogo Strumenti esterni è possibile aggiungere strumenti esterni, ad esempio SQLCMD o Blocco note, al menu Strumenti.Use the External Tools dialog box to add external tools such as SQLCMD or Notepad to the Tools menu. L'aggiunta di strumenti esterni consente di avviare facilmente altre applicazioni dall'ambiente di MicrosoftMicrosoft SQL Server Management StudioSQL Server Management Studio .Adding external tools allows you to easily launch other applications while working in the MicrosoftMicrosoft SQL Server Management StudioSQL Server Management Studio environment. Durante l'avvio dello strumento, è possibile specificare argomenti e una directory di lavoro.You can specify arguments and a working directory when launching the tool. L'output di alcuni strumenti può inoltre essere visualizzato nella finestra Output .In addition, the output from some tools can be displayed in the Output window. La finestra di dialogo Strumenti esterni è accessibile dal menu Strumenti .The External Tools dialog box is available on the Tools menu.

OpzioniOptions

Contenuto menuMenu contents
Consente di visualizzare l'elenco dei titoli degli elementi attualmente aggiunti al menu Strumenti .Lists the titles of the items currently added to the Tools menu. Usare i pulsanti Sposta su e Sposta giù per cambiare l'ordine di visualizzazione delle voci nel menu.Use the Move Up and Move Down arrows to change the order the items that appear on the menu. Usare il pulsante Elimina per rimuovere una voce dal menu.Use the Delete button to remove an item from the menu.

Sposta suMove Up
Sposta lo strumento selezionato più in alto nell'elenco degli strumenti visualizzati nel menu Strumenti .Move the selected tool higher in the list of tools that appear on the Tools menu.

Sposta giùMove Down
Sposta lo strumento selezionato più in basso nell'elenco degli strumenti visualizzati nel menu Strumenti .Move the selected tool lower in the list of tools that appear on the Tools menu.

AggiungiAdd
Consente di cancellare il contenuto delle caselle di testo e quindi di specificare un nuovo strumento.Clear the text boxes so you can specify a new tool.

EliminaDelete
Rimuove lo strumento o il comando dall'elenco Contenuto menu e dal menu Strumenti .Remove the tool or command from the Menu Contents list as well as from the Tools menu.

TitleTitle
Consente di immettere il nome dello strumento o del comando che verrà visualizzato nel sottomenu Strumenti esterni del menu Strumenti .Enter the name of the tool or command that will appear on the External Tools submenu of the Tools menu. Inserire una e commerciale (&) prima di una lettera contenuta nel nome dello strumento per specificare tale lettera come tasto di scelta rapida.Place an ampersand (&) before a letter in the name of the tool to specify that letter as a keyboard shortcut. Ad esempio, "&SQLCMD" verrà visualizzato come SQLCMD nel menu Strumenti.For example, "&SQLCMD" would display SQLCMD on the Tools menu.

CommandCommand
Specificare il percorso del file da avviare.Specify the path to the file to launch.

ArgomentiArguments
Consente di specificare le variabili passate allo strumento quando questo viene selezionato dal menu.Specify the variables that are passed to the tool when the tool is selected on the menu. Negli argomenti possono essere specificati valori che vengono passati allo strumento o al comando all'avvio.Arguments can specify values that are passed to the tool or command when it is launched. Un valore può ad esempio specificare un nome di file o una directory.For example, a value can specify a file name or directory. Per selezionare un argomento da un elenco di argomenti predefiniti, utilizzare il pulsante freccia.Use the arrow button to select from a list of predefined arguments. È possibile aggiungere più argomenti.You can add more than one. Per un elenco completo degli argomenti predefiniti e delle relative definizioni, vedere Strumenti esterni - Argomenti.For a complete list of predefined arguments and their definitions, see Arguments for External Tools. È inoltre possibile immettere argomenti personalizzati, ad esempio opzioni della riga di comando, a seconda del comando o dello strumento utilizzato.You can also enter custom arguments (for example, command line switches), depending on the command or tool you use.

Usa finestra di outputUse Output window
Consente di aprire la finestra di output di Management StudioManagement Studio per visualizzare l'output del comando in esecuzione.Opens the Management StudioManagement Studio Output window to display output of the command being run. Non tutti gli strumenti hanno un formato di output che può essere visualizzato nella finestra di output.Not all tools present output in a format that can be presented in the Output window. Per altre informazioni, vedere Finestra di output.For more information, see Output Window.

Considera output come UnicodeTreat output as Unicode
Interpreta output come Unicode.Interprets the output as Unicode.

Directory inizialeInitial directory
Consente di specificare la directory di lavoro dello strumento.Specify the working directory of the tool. Per selezionare directory, utilizzare il pulsante freccia.Use the arrow button to select directories. È possibile selezionare più directory.You can select more than one.

Richiedi argomentiPrompt for arguments
Consente di visualizzare la finestra di dialogo Argomenti che permette di immettere o modificare valori per gli argomenti ogni volta che si avvia uno strumento esterno.Display the Arguments dialog box to allow you to enter or edit values for the arguments each time you launch the external tool.

Chiudi all'uscitaClose on exit
Chiude la finestra aperta dallo strumento quando viene chiuso lo strumento stesso.Close the window opened by the tool when the tool is closed.

EsempioExample

Immettendo i seguenti valori nella finestra di dialogo Strumenti esterni verrà creata una voce di menu con etichetta "DAC" che, quando selezionata, consentirà di aprire un prompt dei comandi e di eseguire l'utilità sqlcmd usando la connessione amministrativa dedicata.Entering the following values in the External Tools dialog box will create a menu item labeled "DAC" that when selected, opens a command prompt and runs the sqlcmd utility using the dedicated administrator connection.

messaggioBox ValoreValue
TitleTitle DACDAC
CommandCommand C:\Programmi\Microsoft SQL Server\130\C:\Program Files\Microsoft SQL Server\130\Tools\Binn\SQLCMD.exeTools\Binn\SQLCMD.exe
ArgomentiArguments -A-A

Vedere ancheSee Also

Strumenti esterni - ArgomentiArguments for External Tools
Elementi generali dell'interfaccia utenteGeneral User Interface Elements