Strumenti esterniExternal Tools

Usare questa finestra di dialogo per aggiungere strumenti esterni, ad esempio Gestione configurazione SQL Server o Blocco note, al menu Strumenti .Use this dialog box to add external tools, such as SQL Server Configuration Manager or Notepad, to the Tools menu. Aggiungendo strumenti esterni, sarà più semplice avviare altre applicazioni quando si utilizza SQL Server Management StudioSQL Server Management Studio.Adding external tools allows you to easily launch other applications while working in SQL Server Management StudioSQL Server Management Studio. Durante l'avvio dello strumento, è possibile specificare argomenti e una directory di lavoro.You can specify arguments and a working directory when launching the tool. Gli output generati da alcuni strumenti verranno inoltre visualizzati nella finestra di output.In addition, the outputs from some tools can be displayed in the Output window. La finestra di dialogo Strumenti esterni è accessibile dal menu Strumenti .The External Tools dialog box is available on the Tools menu.

OpzioniOptions

Contenuto menuMenu Contents
Elenca i titoli degli elementi attualmente aggiunti al menu Strumenti .Lists the titles of the items currently added to the Tools menu. Usare i pulsanti Sposta su e Sposta giù per cambiare l'ordine di visualizzazione delle voci nel menu.Use the Move Up and Move Down arrows to change the order the items that appear on the menu. Usare il pulsante Elimina per rimuovere una voce dal menu.Use the Delete button to remove an item from the menu.

Sposta suMove Up
Sposta lo strumento selezionato più in alto nell'elenco degli strumenti visualizzati nel menu Strumenti .Move the selected tool higher in the list of tools that appear on the Tools menu.

Sposta giùMove Down
Sposta lo strumento selezionato più in basso nell'elenco degli strumenti visualizzati nel menu Strumenti .Move the selected tool lower in the list of tools that appear on the Tools menu.

AggiungiAdd
Consente di cancellare il contenuto delle caselle di testo e quindi di specificare un nuovo strumento.Clear the text boxes so you can specify a new tool.

EliminaDelete
Rimuove lo strumento o il comando dall'elenco Contenuto menu e dal menu Strumenti .Remove the tool or command from the Menu Contents list as well as from the Tools menu.

TitleTitle
Nome dello strumento o del comando che verrà visualizzato nel sottomenu Strumenti esterni del menu Strumenti .The name of the tool or command that will appear on the External Tools submenu of the Tools menu. Nel nome dello strumento inserire una "e" commerciale prima della lettera che si desidera utilizzare come tasto di scelta rapida per lo strumento.Place an ampersand before a letter in the name of the tool to use that letter as an accelerator key for the tool. Ad esempio, specificando &Spy++ , nel menu Strumenti verrà visualizzato Spy++ .For example, &Spy++ would display Spy++ on the Tools menu.

CommandCommand
Consente di specificare il percorso del file con estensione exe, com, pif, bat, cmd o di altro tipo che si desidera avviare.Specify the path to the .exe, .com, .pif, .bat, .cmd, or other file that you intend to launch. L'output generato da file .bat, .come file con altre estensioni potrà essere visualizzato nella finestra di output se si seleziona la casella di controllo Usa finestra di output .The output from .bat, .com, and other files can be viewed in the Output window if you select the Use output window check box.

ArgomentiArguments
Consente di specificare le variabili passate allo strumento quando questo viene selezionato dal menu.Specify the variables that are passed to the tool when the tool is selected on the menu. Negli argomenti possono essere specificati valori che vengono passati allo strumento o al comando all'avvio.Arguments can specify values that are passed to the tool or command when it is launched. Un valore può ad esempio specificare un nome di file o una directory.For example, a value can specify a file name or directory. Usare il pulsante Freccia per eseguire una selezione da un elenco di argomenti predefiniti.Use the Arrow button to select from a list of predefined arguments. È possibile aggiungere più argomenti.You can add more than one. Per un elenco completo degli argomenti predefiniti e delle relative definizioni, vedere Strumenti esterni - Argomenti.For a complete list of predefined arguments and their definitions, see Arguments for External Tools. È inoltre possibile immettere argomenti personalizzati, ad esempio opzioni del prompt dei comandi, a seconda del comando o dello strumento in uso.You can also enter custom arguments (command-prompt switches, for example), depending on the command or tool you use.

Directory inizialeInitial directory
Consente di specificare la directory di lavoro dello strumento.Specify the working directory of the tool. Usare il pulsante Freccia per selezionare le directory.Use the Arrow button to select directories. È possibile selezionare più directory.You can select more than one.

Use output WindowUse output Window
Consente di specificare se i risultati generati dallo strumento debbano essere visualizzati nella finestra di output.Specify whether or not results from the tool are displayed in the Output window. L'opzione è disponibile solo per i file, ad esempio file con estensione bat e com, i cui output vengono generalmente visualizzati nella finestra del prompt dei comandi.This option is only available for files, such as .bat and .com files, that normally display output in the command prompt window. Se abilitata, questa opzione semplifica la gestione delle finestre durante l'analisi delle operazioni effettuate da uno strumento.When enabled, this option eases window management when you are following the progress of a tool.

Richiedi argomentiPrompt for arguments
Visualizza la finestra di dialogo Argomenti , in cui è possibile specificare o modificare i valori degli argomenti a ogni avvio dello strumento esterno.Display the Arguments dialog box to enable you to enter or edit values for the arguments each time you launch the external tool.

Considera output come UnicodeTreat output as Unicode
Consente di accettare caratteri Unicode nella finestra di output.Allow the Output window to accept Unicode.

Chiudi all'uscitaClose On Exit
Chiude la finestra aperta dallo strumento quando viene chiuso lo strumento stesso.Close the window opened by the tool when the tool is closed.

EsempioExample

Per aggiungere Gestione configurazione SQL Server al menu StrumentiTo add SQL Server Configuration Manager to the Tools menu

  1. Scegliere Strumenti esterni dal menu Strumenti.On the Tools menu, click External Tools.

  2. Nella casella Titolo digitare Gestione configurazione SQL Server.In the Title box, type SQL Server Configuration Manager.

  3. Nella casella Comando digitare il percorso del file eseguibile di MicrosoftMicrosoft Management Console, ad esempio C:\WINNT\system32\mmc.exeIn the Command box, type the path to the MicrosoftMicrosoft Management Console executable, such as C:\WINNT\system32\mmc.exe

  4. Nella casella Argomenti digitare il percorso del file con estensione msc, ad esempio "C:\WINNT\system32\SQLServerManager.msc"In the Arguments box, type the path to the .msc file, such as "C:\WINNT\system32\SQLServerManager.msc"

Nota

Visualizzare le proprietà del collegamento SQL Server Management StudioSQL Server Management Studio nel menu Avvio per verificare il percorso dei file nel computer.View the properties of the SQL Server Management StudioSQL Server Management Studio shortcut on the Start menu to confirm the location of the files on your computer.