Aggiunta di un report personalizzato a Management StudioAdd a Custom Report to Management Studio

In questo argomento viene descritto come creare un report semplice di Reporting ServicesReporting Services salvato come file con estensione rdl e quindi aggiungere tale file a SQL Server Management StudioSQL Server Management Studio come report personalizzato.This topic describes how to create a simple Reporting ServicesReporting Services report that is saved as an .rdl file, and then add that rdl file to SQL Server Management StudioSQL Server Management Studio as a custom report. SSRSSSRS consente di creare una vasta gamma di sofisticati report. can create a wide variety of sophisticated reports. Per creare un report in base a questo argomento, è necessario che nel computer sia installato SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) .To create a report by using this topic, you must have SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) installed on the computer. Per eseguire un report personalizzato mediante SSRSSSRS non è necessario installare SQL ServerSQL Server in Management StudioManagement Studio.You do not have to install SSRSSSRS on SQL ServerSQL Server to run a custom report using Management StudioManagement Studio.

Per creare un report semplice salvato come file con estensione rdlTo create a simple report saved as an .rdl file

  1. Fare clic su Start, scegliere Tutti i programmi, Microsoft SQL Servere fare clic su SQL Server Data Tools.Click Start, point to Programs, point to Microsoft SQL Server, and then click SQL Server Data Tools.

  2. Scegliere Nuovo dal menu Filee quindi fare clic su Progetto.On the File menu, point to New, and then click Project.

  3. Nell'elenco Tipi progetto fare clic su Progetti Business Intelligence.In the Project Types list, click Business Intelligence Projects.

  4. Nell'elenco Modelli fare clic su Creazione guidata progetto server di report.In the Templates list, click Report Server Project Wizard.

  5. In Nomedigitare ReportConnessionie fare clic su OK.In Name, type ConnectionsReport, and then click OK.

  6. Nella pagina introduttiva di Creazione guidata report fare clic su Avanti.On the Report Wizard introduction page, click Next.

  7. Nella casella Nome della pagina Selezione origine dati digitare un nome per la connessione a Motore di databaseDatabase Enginee fare clic su Modifica.On the Select the Data Source page, in the Name box type a name for this connection to your Motore di databaseDatabase Engine, and then click Edit.

  8. Nella casella Nome server della finestra di dialogo Proprietà connessione digitare il nome dell'istanza di Motore di databaseDatabase Engine.In the Connection Properties dialog box, in the Server name box, type the name of your instance of the Motore di databaseDatabase Engine.

  9. Nella casella Selezionare o immettere un nome di database digitare il nome di uno dei database presenti in SQL ServerSQL Server, ad esempio AdventureWorks2012AdventureWorks2012, e fare clic su OK.In the Select or enter a database name box, type the name of any database on your SQL ServerSQL Server, such as AdventureWorks2012AdventureWorks2012, and then click OK.

  10. Nella pagina Selezione origine dati fare clic su Avanti.On the Select the Data Source page, click Next.

  11. Nella casella Stringa query della pagina Progettazione query digitare l'istruzione Transact-SQLTransact-SQL seguente, che elenca le connessioni correnti a Motore di databaseDatabase Enginee fare clic su Avanti.On the Design the Query page, in the Query string box, type the following Transact-SQLTransact-SQL statement that lists the current connections to your Motore di databaseDatabase Engine, and then click Next. Nella casella Stringa query della Creazione guidata report non è possibile immettere parametri di report.The Report Wizard Query string box will not accept report parameters. La creazione di report personalizzati più complessi dovrà essere eseguita manualmente.More complex custom reports must be created manually.

    SELECT session_id, net_transport FROM sys.dm_exec_connections;SELECT session_id, net_transport FROM sys.dm_exec_connections;

  12. Nella pagina Selezione tipo di report selezionare Tabularee fare clic su Fine.On the Select the Report Type page, select Tabular, and then click Finish.

  13. Nella pagina Completamento procedura guidata digitare ReportConnessioni nella casella Nome reporte fare clic su Fine per creare e salvare il report.On the Completing the Wizard page, in the Report name box, type ConnectionsReport, and then click Finish to create and save the report.

  14. Chiudere SQL Server Data ToolsSQL Server Data Tools.Close SQL Server Data ToolsSQL Server Data Tools.

  15. Copiare ReportConnessioni.rdl in una cartella creata nel server di database per i report personalizzati.Copy ConnectionsReport.rdl to a folder that you created on the database server for custom reports.

Per aggiungere un report a Management StudioTo add a report to Management Studio

  • In Management StudioManagement Studiofare clic con il pulsante destro del mouse su un nodo in Esplora oggetti, scegliere Reporte fare clic su Report personalizzati.In Management StudioManagement Studio, right-click a node in Object Explorer, point to Reports, click Custom Reports. Nella finestra di dialogo Apri file individuare la cartella dei report personalizzati, selezionare il file ReportConnessioni.rdl e fare clic su Apri.In the Open File dialog box, locate the custom reports folder and select the ConnectionsReport.rdl file, and then click Open.

    Alla prima apertura di un nuovo report personalizzato da un nodo di Esplora oggetti, tale report verrà aggiunto all'elenco degli ultimi elementi usati in Report personalizzati nel menu di scelta rapida del nodo.When a new custom report is first opened from an Object Explorer node, the custom report is added to the most recently used list under Custom Reports on the shortcut menu of that node. Analogamente, alla prima apertura, anche un report standard verrà aggiunto all'elenco degli ultimi elementi usati in Report personalizzati.When a standard report is opened for the first time, it will also appear on the most recently used list under Custom Reports. Se viene eliminato un file di un report personalizzato, alla successiva selezione dell'elemento verrà visualizzato un messaggio che chiederà di eliminare la relativa voce dall'elenco degli ultimi elementi utilizzati.If a custom report file is deleted, the next time that the item is selected, a prompt will appear to delete the item from the most recently used list.

    1. Per modificare il numero dei file visualizzati nell'elenco degli ultimi elementi usati, scegliere Opzioni dal menu Strumenti , espandere la cartella Ambiente e fare clic su Generale.To change the number of files that are displayed on the recently used list, on the Tools menu, click Options, expand the Environment folder, and then click General.

    2. Modificare il numero in Display files in recently used list(Visualizza file nell'elenco degli ultimi file usati).Adjust the number for Display files in recently used list.

Vedere ancheSee Also

Report personalizzati in Management StudioCustom Reports in Management Studio
Utilizzo di report personalizzati con proprietà dei nodi di Esplora oggettiUse Custom Reports with Object Explorer Node Properties
Visualizzazione di avvisi relativi all'esecuzione di report personalizzatiUnsuppress Run Custom Report Warnings
SQL Server Reporting ServicesSQL Server Reporting Services