Impossibile trovare il file di database quando si configura Microsoft Dynamics CRM per Microsoft Office Outlook

Questo articolo fornisce una soluzione a un errore che si verifica quando si configura Microsoft Dynamics CRM per Microsoft Office Outlook.

Si applica a: Microsoft Dynamics CRM 2015
Numero KB originale: 3091650

Sintomi

Quando si tenta di configurare Microsoft Dynamics CRM per Microsoft Office Outlook, viene visualizzato il messaggio di errore seguente:

"Si è verificato un problema durante la comunicazione con il server Microsoft Dynamics CRM. Il server potrebbe non essere disponibile. Riprovare più tardi. Se il problema persiste, contattare l'amministratore di sistema."

Quando si selezionano i dettagli, vengono visualizzati i dettagli aggiuntivi seguenti:

Impossibile trovare il file di database. Controllare il percorso del database. [ Origine dati = C:\Users\<user>\AppData\Local\Microsoft\MSCRM\Client\MetadataCache-93d47f8c-8eb3-45a6-98c8-d668f4ff9b4c.sdf ] in System.Data.SqlServerCe.SqlCeConnection.Open(Boolean silent)
in System.Data.SqlServerCe.SqlCeConnection.Open()
in Microsoft.Crm.Application.SMWrappers.CrmSqlCeConnection.Open()
in Microsoft.Crm.Application.SMWrappers.CrmSqlCeConnection.ExecuteInNewConnection[TReturn](String connectionString, Func'2 actions, Func'2 exceptionHandler, Boolean disposeConnection)
in Microsoft.Crm.Application.Outlook.ClientMetadataCache.SqlCeManager.GetObjectsReader(MetadataCollectionInfo info, IList'1 requiredValues)
in Microsoft.Crm.Application.Outlook.ClientMetadataCache.SqlCeManager.GetObjectsReader(MetadataCollectionInfo info)
in Microsoft.Crm.Application.Outlook.ClientMetadataCache.MetadataCacheManager.GetObjectsDataReader(MetadataCollectionInfo info)
in Microsoft.Crm.Application.Outlook.ClientMetadataCache.Collections.OnDemandMetadataCollection'1.CreateEnumerator()
in Microsoft.Crm.Application.Outlook.ClientMetadataCache.Collections.OnDemandBaseCollection'1.System.Collections.IEnumerable.GetEnumerator()
in Microsoft.Crm.Caching.UserEntityUISettingsCache.LookupEntries(Guid userId, contesto IOrganizationContext, cache DynamicMetadataCache)
in Microsoft.Crm.Application.Outlook.Config. OutlookConfigurator.InitializeMapiStoreForFirstTime()
in Microsoft.Crm.Application.Outlook.Config. OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)
in Microsoft.Crm.Application.Outlook.Config. ConfigEngine.Configure(Object stateInfo)

Causa

Microsoft è a conoscenza di uno scenario in cui questo errore può verificarsi dopo aver configurato Microsoft Dynamics CRM per Microsoft Office Outlook e quindi eliminato tale configurazione.

Risoluzione

Chiudere la configurazione guidata Microsoft Dynamics CRM per Outlook e riprovare.

Se si verificano ancora problemi di connessione di CRM per Outlook all'organizzazione CRM Online, è disponibile uno strumento di diagnostica che consente di diagnosticare il problema.