Coerenza degli aggiornamenti della soluzione del portale di Microsoft Dynamics 365 per le distribuzioni multi-portale

Questo articolo fornisce una soluzione a un errore che si verifica quando si passa a un portale associato a un'istanza di Dynamics 365 contenente alcune soluzioni che non sono ancora state aggiornate.

Si applica a: Microsoft Dynamics CRM
Numero KB originale: 4020942

Sintomi

Dopo un aggiornamento alle soluzioni che supportano un componente aggiuntivo del portale nel Centro Dynamics 365 Amministrazione, i clienti che dispongono di più componenti aggiuntivi del portale associati alla stessa istanza di Dynamics 365 potrebbero riscontrare errori se le soluzioni per altri tipi di portale non sono ancora state aggiornate. Gli utenti che accedono a un portale associato a un'istanza di Dynamics 365 contenente alcune soluzioni che non sono ancora state aggiornate potrebbero ricevere un errore simile all'esempio seguente:

Ci dispiace, ma qualcosa è andato storto.
[00000000-0000-0000-0000-000000000000]
Questo problema è stato notificato e verrà esaminato a breve.
Grazie per la pazienza.

Causa

Quando un componente aggiuntivo del portale viene distribuito in un'istanza di Dynamics 365, vengono installate più soluzioni per supportare le funzionalità del portale. Aggiornamenti a queste soluzioni vengono rese disponibili quando vengono rilasciati miglioramenti e correzioni e i clienti possono distribuire tali aggiornamenti eseguendo l'azione appropriata all'interno del Centro Dynamics 365 Amministrazione.

Poiché molte soluzioni sono condivise da più tipi di portale, l'aggiornamento di un singolo tipo di portale senza aggiornare altri tipi di portale distribuiti nella stessa istanza di Dynamics 365 causerà errori e potrebbe rendere inutilizzabili uno o più portali.

Risoluzione

Per evitare problemi di mancata corrispondenza della versione della soluzione, le soluzioni per tutti i tipi di portale distribuiti in una singola istanza di Dynamics 365 devono essere aggiornate in un secondo momento e durante lo stesso intervallo di tempo. Per aggiornare le soluzioni dei componenti aggiuntivi del portale per tutti i tipi di portale distribuiti, è necessario seguire questa procedura:

  1. Accedere al Centro Dynamics 365 Amministrazione con un utente con autorizzazioni sufficienti per aggiornare le soluzioni Dynamics 365.
  2. Nella scheda Istanze selezionare l'istanza in cui sono distribuiti due o più portali.
  3. Con l'istanza selezionata, selezionare l'icona Soluzioni nel riquadro a destra.
  4. Nella visualizzazione Soluzioni selezionare un tipo di portale ,ad esempio Portale della community, distribuito in questa istanza.
  5. Se il pulsante Aggiorna viene visualizzato nel riquadro destro, selezionarlo per aggiornare le rispettive soluzioni nell'istanza di Dynamics 365.
  6. Al termine dell'aggiornamento, selezionare il tipo di portale disponibile successivo nella visualizzazione Soluzioni e ripetere il passaggio 5.

Dopo l'aggiornamento di tutti i tipi di portale, non si verificheranno altri errori di mancata corrispondenza della versione della soluzione.