"Errore del sottosistema Kerberos, il nome dell'istanza di SQL Server deve corrispondere al nome del computer" quando si installa Microsoft Dynamics CRM

Questo articolo consente di risolvere il problema in cui si è verificato un errore nel sottosistema Kerberos. Il nome dell'istanza di SQL Server deve corrispondere al nome del computer.

Si applica a: Microsoft Dynamics CRM 2011
Numero KB originale: 2841195

Sintomi

Quando si installa Microsoft Dynamics CRM server 2011, può verificarsi l'errore seguente:

Il nome dell'istanza SQL Server deve corrispondere al nome del computer.

Causa

Il nome del computer Microsoft SQL Server è stato modificato dopo l'installazione del SQL Server Microsoft

Risoluzione

Usare la procedura seguente per risolvere il messaggio di errore:

  1. In Microsoft SQL Server selezionare Avvia e aprire SQL Server Management Studio.

  2. Connettersi al server e all'istanza che conterrà i database Microsoft Dynamics CRM.

  3. Selezionare Nuova query sulla barra degli strumenti.

  4. Immettere le due righe seguenti e quindi selezionare il pulsante Esegui sulla barra degli strumenti

    Select @@SERVERNAME
    
    Select * from sysservers
    
  5. Osservando i risultati verrà visualizzata una mancata corrispondenza.

  6. Cancellare le righe precedenti e immettere la riga seguente. Sarà necessario sostituire <servername> con il nome nella colonna svrname del passaggio 4.

    sp_dropserver '<servername>'
    
  7. Cancellare la riga precedente e immettere la riga seguente. Sarà necessario sostituire <servername> con il valore di del select @@servername passaggio 4.

    sp_addserver '<servername>', 'local'
    
  8. Immettere le due righe seguenti e quindi selezionare il pulsante Esegui sulla barra degli strumenti:

    sp_helpserver
    
    select @@servername
    
  9. Ultimo riavvio del servizio SQL Server per questa istanza di SQL.