Errore "Problema durante l'aggiunta a Outlook" durante la distribuzione di Microsoft Dynamics 365 App per Outlook

Questo articolo fornisce una soluzione per il problema di errore durante l'aggiunta a Outlook che può verificarsi durante la distribuzione di Microsoft Dynamics 365 App per Outlook.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4528578

Sintomi

Durante la distribuzione dell'app per Outlook da Microsoft Dynamics CE, verrà visualizzato un errore in rosso davanti alla cassetta postale degli utenti durante l'aggiunta a Outlook. Se si seleziona per visualizzare altri dettagli, viene visualizzato il messaggio Operazione origine dati non valida.

Se si passa a Gestisci componenti aggiuntivi dalla cassetta postale di un utente, verrà visualizzato l'errore seguente:

Impossibile individuare l'oggetto directory virtuale accesso client con InternalURl contrassegnato per ECP, servizio.

Nota

Affinché un componente aggiuntivo di Office venga distribuito nella cassetta postale di un utente in Microsoft Exchange Server, AppsForOfficeEnabled deve essere true. È possibile usare il comando seguente per controllare le impostazioni di configurazione tramite Exchange Management Shell (EMS).
Get-OrganizationConfig | Format-List AppsForOfficeEnabled

Causa

Ciò è dovuto alla ricerca di individuazione da Exchange Amministrazione Center (EAC). Ogni volta che la ricerca di individuazione viene eseguita per la prima volta usando EAC in Exchange Server 2013, verificherà la presenza dei 6 URL interni seguenti in background e la memorizza nella cache in locale.

  • URL trovato: https://e15-cas.contoso.com/owa
  • URL trovato: https://e15-cas.contoso.com/ecp
  • URL trovato: https://e15-cas.contoso.com/EWS/Exchange.asmx
  • URL trovato: https://e15-cas.contoso.com/Microsoft-Server-ActiveSync
  • URL trovato: https://e15-cas.contoso.com/OAB
  • URL trovato: https://e15-cas.contoso.com/mapi

[GlobalServiceUrls.DiscoverUrlsIfNeeded] Trovato correttamente tutti i VDir necessari

Risoluzione

Assicurarsi che tutte le directory virtuali necessarie siano presenti e che gli URL interni vengano pubblicati in tali directory virtuali.

Per altre informazioni su come configurare le directory virtuali di Exchange, vedere Configurare il flusso di posta e l'accesso client nei server Exchange Passaggio 4: Configurare gli URL esterni.