Errore "Non si dispone di una licenza" quando si configura Microsoft Dynamics CRM per Microsoft Office Outlook

Questo articolo fornisce una soluzione per l'errore Non si dispone di una licenza per l'uso di Microsoft Dynamics CRM Online errore che può verificarsi quando si configura Microsoft Dynamics CRM per Microsoft Office Outlook.

Si applica a: Microsoft Dynamics CRM
Numero KB originale: 3091628

Sintomi

Quando si tenta di configurare Microsoft Dynamics CRM per Microsoft Office Outlook, viene visualizzato il messaggio di errore seguente:

Non si dispone di una licenza per l'uso di Microsoft Dynamics CRM Online. Contattare l'amministratore Office 365 per assegnare una licenza di Microsoft Dynamics CRM.

Causa

All'account utente non è stata assegnata una licenza Microsoft Dynamics CRM Online.

Nota

Se si dispone di una sottoscrizione Office 365 esistente e successivamente è stata aggiunta una sottoscrizione Microsoft Dynamics CRM Online, una licenza di Microsoft Dynamics CRM Online non viene assegnata automaticamente al record utente. Se l'account utente ha il ruolo Amministratore globale o Amministratore del servizio, è comunque possibile accedere all'applicazione Web Microsoft Dynamics CRM per eseguire azioni amministrative, ma non è possibile creare record come Account, Contatti, Lead e così via. È necessario disporre di una licenza di Microsoft Dynamics CRM Online assegnata per connettersi correttamente Microsoft Dynamics CRM per Microsoft Office Outlook all'istanza di Microsoft Dynamics CRM Online. All'interno dell'applicazione Web Microsoft Dynamics CRM Online, è possibile passare a Impostazioni>Utenti di sicurezza> e modificare la visualizzazione in Utenti accesso amministrativo. In questa visualizzazione vengono visualizzati gli utenti che hanno ruoli amministrativi nel portale di Office 365 ma non hanno una licenza Microsoft Dynamics CRM Online assegnata.

Risoluzione

Accedere a Office 365 Portale come utente con privilegi amministrativi e assegnare una licenza Microsoft Dynamics CRM Online all'account utente. Potrebbero essere necessari alcuni minuti prima che le informazioni sulla licenza vengano sincronizzate da Office 365 a Microsoft Dynamics CRM Online.

Per i passaggi dettagliati su come assegnare una licenza in Office 365, vedere Aggiungere utenti e assegnare licenze contemporaneamente.

Ulteriori informazioni

Quando si seleziona Dettagli nella finestra di dialogo di errore o si visualizza il file di log, viene visualizzato l'errore seguente:

Ora| Errore| Eccezione: all'utente non è stata assegnata alcuna licenza in Microsoft.Crm.Application.Outlook.Config. ServerInfo.RunServerDiagnostics()
in Microsoft.Crm.Application.Outlook.Config. ServerInfo.LoadUserInfo(IClientAuthProvider'1 orgAuthProvider)
in Microsoft.Crm.Application.Outlook.Config. ServerInfo.Initialize(Uri discoveryUri, OrganizationDetail selectedOrg, String displayName, Boolean isPrimary, IClientAuthProvider'1 authenticatedProvider)
in Microsoft.Crm.Application.Outlook.Config. ServerForm.LoadDataToServerInfo()
in Microsoft.Crm.Application.Outlook.Config. ServerForm.<InitializeBackgroundWorkers>b__3(Object sender, DoWorkEventArgs e)
in System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
in System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)