Specifica simboli (PDB) e i file di origine nel debugger di Visual Studio (C#, C++, Visual Basic, F#)Specify symbol (.pdb) and source files in the Visual Studio debugger (C#, C++, Visual Basic, F#)

Database di programma (PDB) i file, chiamati anche file di simboli, eseguire il mapping di identificatori e le istruzioni nel codice sorgente del progetto per gli identificatori corrispondenti e le istruzioni in compilate le app.Program database (.pdb) files, also called symbol files, map identifiers and statements in your project's source code to corresponding identifiers and instructions in compiled apps.

Quando si compila un progetto dall'IDE di Visual Studio con lo standard di configurazione della build di Debug, il compilatore crea i file di simboli appropriati.When you build a project from the Visual Studio IDE with the standard Debug build configuration, the compiler creates the appropriate symbol files. È anche possibile impostare le opzioni dei simboli nel codice.You can also set symbol options in code.

Il PDB file contiene le informazioni sullo stato di progetto e di debug che consentono il collegamento incrementale di una configurazione di Debug dell'app.The .pdb file holds debugging and project state information that allows incremental linking of a Debug configuration of your app. Il debugger di Visual Studio Usa PDB file per determinare i due tipi principali di informazioni durante il debug:The Visual Studio debugger uses .pdb files to determine two key pieces of information while debugging:

  • Il file di origine nome e la riga numero da visualizzare nell'IDE di Visual Studio.The source file name and line number to display in the Visual Studio IDE.
  • Posizione in cui nell'app per arrestare un punto di interruzione.Where in the app to stop for a breakpoint.

I file di simboli mostrano anche il percorso del file di origine e, facoltativamente, per recuperarli dal server.Symbol files also show the location of the source files, and optionally, the server to retrieve them from.

Il debugger carica solo PDB i file che corrispondono esattamente al PDB file creati quando è stata compilata un'app (originale, ovvero PDB copie o file).The debugger only loads .pdb files that exactly match the .pdb files created when an app was built (that is, the original .pdb files or copies). Questa duplicazione esatta è necessaria perché il layout delle App può cambiare anche se il codice non è stato modificato.This exact duplication is necessary because the layout of apps can change even if the code itself has not changed. Per altre informazioni, vedere il post del blog sulla necessità di creare una corrispondenza esatta tra i file di simboli del debugger e i file binari con cui sono stati creati.For more information, see Why does Visual Studio require debugger symbol files to exactly match the binary files that they were built with?

Suggerimento

Per eseguire il debug di codice di fuori del codice sorgente del progetto, ad esempio codice Windows o terze parti chiamato dal progetto di codice, è necessario specificare il percorso al codice esterno PDB file (e, facoltativamente, i file di origine), che deve corrispondere esattamente a le compilazioni nell'app.To debug code outside your project source code, such as Windows code or third-party code your project calls, you must specify the location of the external code's .pdb files (and optionally, the source files), which must exactly match the builds in your app.

Percorsi dei file e il comportamento del caricamento dei simboliSymbol file locations and loading behavior

Nota

Durante il debug di codice gestito in un dispositivo remoto, tutti i file di simboli devono trovarsi nel computer locale o in un luogo specificati nelle opzioni del debugger.When debugging managed code on a remote device, all symbol files must be located either on the local machine, or in a location specified in the debugger options.

Quando si esegue il debug di un progetto nell'IDE di Visual Studio, il debugger carica automaticamente i file di simboli che si trovano nella cartella del progetto.When you debug a project in the Visual Studio IDE, the debugger automatically loads symbol files that are located in the project folder.

Inoltre, il debugger cerca i file di simboli nei percorsi seguenti:The debugger also searches for symbol files in the following locations:

  1. Il percorso specificato nella DLL o del file eseguibile ( .exe) file.The location that is specified inside the DLL or the executable (.exe) file.

    Per impostazione predefinita, se è stata compilata una DLL o un .exe file nel computer, il linker inserisce il percorso completo e il nome dell'oggetto associato PDB file nella DLL o .exe file.By default, if you have built a DLL or an .exe file on your computer, the linker places the full path and filename of the associated .pdb file in the DLL or .exe file. Il debugger verifica se il file di simboli è presente in tale percorso.The debugger checks to see if the symbol file exists in that location.

  2. Nella stessa cartella della DLL o .exe file.The same folder as the DLL or .exe file.

  3. Tutti i percorsi specificati nelle opzioni del debugger per i file di simboli.Any locations specified in the debugger options for symbol files. Per aggiungere e abilitare i percorsi dei simboli, vedere configurare i percorsi dei simboli e le opzioni di caricamento.To add and enable symbol locations, see Configure symbol locations and loading options.

    • Qualsiasi cartella della cache di simboli locale.Any local symbol cache folder.

    • Rete specificata, internet, o i server di simboli locale e posizioni, ad esempio server dei simboli Microsoft se selezionato.Specified network, internet, or local symbol servers and locations, such as the Microsoft Symbol Servers if selected. Visual StudioVisual Studio può scaricare i file di simboli di debug dai server di simboli che implementano il symsrv protocollo.can download debugging symbol files from symbol servers that implement the symsrv protocol. Visual Studio Team Foundation Server e il strumenti di debug per Windows sono due componenti che è possono utilizzare server dei simboli.Visual Studio Team Foundation Server and the Debugging Tools for Windows are two tools that can use symbol servers.

      È possibile utilizzare server dei simboli includono:Symbol servers you might use include:

      Server dei simboli Microsoft pubblici: Per eseguire il debug di un arresto anomalo del sistema che si verifica durante una chiamata a una DLL di sistema o a una libreria di terze parti, spesso è necessario system PDB file.Public Microsoft Symbol Servers: To debug a crash that occurs during a call to a system DLL or to a third-party library, you often need system .pdb files. System PDB contengono i simboli per le DLL di Windows, .exe file e i driver di dispositivo.System .pdb files contain symbols for Windows DLLs, .exe files, and device drivers. È possibile ottenere i simboli per i sistemi operativi Windows, MDAC, IIS, ISA e .NET Framework dal server di simboli Microsoft pubblici.You can get symbols for Windows operating systems, MDAC, IIS, ISA, and the .NET Framework from the public Microsoft Symbol Servers.

      Server di simboli in una rete interna o nel computer locale: Il team o la società può creare server di simboli per i propri prodotti e come cache dei simboli provenienti da origini esterne.Symbol servers on an internal network or on your local machine: Your team or company can create symbol servers for your own products, and as a cache for symbols from external sources. Nel computer potrebbe essere presente un server di simboli.You might have a symbol server on your own machine.

      Server di simboli di terze parti: I provider di terze parti di librerie e applicazioni Windows possono fornire accesso al server di simboli su Internet.Third-party symbol servers: Third-party providers of Windows applications and libraries can provide access to symbol server on the internet.

      Avviso

      Se si usa un server di simboli diverso dal server di simboli Microsoft pubblici, assicurarsi che il server di simboli e il relativo percorso siano attendibili.If you use a symbol server other than the public Microsoft Symbol Servers, make sure that the symbol server and its path are trustworthy. Poiché i file di simboli possono contenere codice eseguibile arbitrario, può essere esposto a rischi di sicurezza.Because symbol files can contain arbitrary executable code, you can be exposed to security threats.

Configurare le opzioni di caricamento e percorsi dei simboliConfigure symbol locations and loading options

Nel degli strumenti > opzioni > debug > simboli pagina, è possibile:On the Tools > Options > Debugging > Symbols page, you can:

  • Specificare e selezionare i percorsi di ricerca e i server di simboli per Microsoft, Windows o i componenti di terze parti.Specify and select search paths and symbol servers for Microsoft, Windows, or third-party components.
  • Specificare i moduli o non desidera il debugger carichi automaticamente simboli.Specify modules that you do or don't want the debugger to automatically load symbols for.
  • Modificare queste impostazioni mentre si esegue attivamente il debug.Change these settings while you are actively debugging. Visualizzare gestire i simboli durante il debug.See Manage symbols while debugging.

Per specificare percorsi dei simboli e opzioni di caricamento:To specify symbol locations and loading options:

  1. In Visual Studio, aprire degli strumenti > opzioni > debug > simboli (o Debug > opzioni > simboli).In Visual Studio, open Tools > Options > Debugging > Symbols (or Debug > Options > Symbols).

    Strumenti di - opzioni - debug - pagina simboliTools - Options - Debugging - Symbols page

  2. Sotto percorsi di file (con estensione pdb) di simboli,Under Symbol file (.pdb) locations,

    • Usare la server dei simboli Microsoft, selezionare la casella di controllo.To use the Microsoft Symbol Servers, select the checkbox.

    • Per aggiungere una nuova posizione di server di simboli,To add a new symbol server location,

      1. Selezionare il + simbolo nella barra degli strumenti.Select the + symbol in the toolbar.
      2. Digitare il percorso URL o la cartella del server di simboli o posizione del simbolo nel campo di testo.Type the URL or folder path of the symbol server or symbol location in the text field. La funzione di completamento delle istruzioni facilita l'individuazione del formato corretto.Statement completion helps you find the correct format.

      Nota

      Viene eseguita la ricerca solo nella cartella specificata.Only the specified folder is searched. È necessario aggiungere voci per eventuali sottocartelle che si desidera eseguire la ricerca.You must add entries for any subfolders that you want to search.

    • Per aggiungere una nuova posizione, il Server di simboli di Visual Studio Team ServicesTo add a new VSTS Symbol Server location,

      1. Selezionare il strumenti/ opzioni/ debug/nuova icona di server dei simboli icona sulla barra degli strumenti.Select the Tools/ Options/ Debugging/Symbols new server icon icon in the toolbar.
      2. Nel Connetti al Server di simboli di VSTS finestra di dialogo, scegliere uno dei server dei simboli disponibili e selezionare Connect.In the Connect to VSTS Symbol Server dialog, choose one of the available symbol servers, and select Connect.
    • Per modificare l'ordine di caricamento per i percorsi dei simboli, usare Ctrl+backup e Ctrl+verso il basso, o il iscrizione e verso il basso icone freccia.To change the loading order for the symbol locations, use Ctrl+Up and Ctrl+Down, or the Up and Down arrow icons.

    • Per modificare un URL o percorso, fare doppio clic sulla voce, oppure selezionarlo e premere F2.To edit a URL or path, double-click the entry, or select it and press F2.

    • Per rimuovere una voce, selezionarlo e quindi selezionare il - icona.To remove an entry, select it, and then select the - icon.

  3. (Facoltativo) Per migliorare le prestazioni di caricamento dei simboli, sotto memorizza nella Cache i simboli in questa directory, un percorso di cartella locale che i server di simboli possono copiare i simboli per tipo.(Optional) To improve symbol loading performance, under Cache symbols in this directory, type a local folder path that symbol servers can copy symbols to.

    Nota

    Cache dei simboli locale non viene inserito in una cartella protetta, ad esempio C:\Windows o una sottocartella.Do not place the local symbol cache in a protected folder, like C:\Windows or a subfolder. Usare invece una cartella di lettura e scrittura.Use a read-write folder instead.

    Nota

    Per i progetti C++, se si dispone di _NT_SYMBOL_PATH set di variabili di ambiente, eseguirà l'override del valore impostato in memorizza nella Cache i simboli in questa directory.For C++ projects, if you have the _NT_SYMBOL_PATH environment variable set, it will override the value set under Cache symbols in this directory.

  4. Specificare i moduli desiderati il debugger deve caricare dal percorsi di file (con estensione pdb) di simboli quando viene avviato.Specify the modules that you want the debugger to load from the Symbol file (.pdb) locations when it starts.

    • Selezionare caricare tutti i moduli, eccetto quelli esclusi (predefinito) per caricare tutti i simboli per tutti i moduli nel percorso del file di simboli, ad eccezione di moduli escludere in modo specifico.Select Load all modules, unless excluded (the default) to load all the symbols for all modules in the symbol file location, except modules you specifically exclude. Per escludere alcuni moduli, selezionare specificare moduli esclusi, selezionare la + icona, digitare i nomi dei moduli per escludere, quindi selezionare OK.To exclude certain modules, select Specify excluded modules, select the + icon, type the names of the modules to exclude, and select OK.

    • Per caricare solo i moduli specificati da percorsi dei file di simboli, selezionare carico solo moduli specificati.To load only modules you specify from the symbol file locations, select Load only specified modules. Selezionare specificare moduli inclusi, selezionare la + icona, digitare i nomi dei moduli da includere e quindi selezionare OK.Select Specify included modules, select the + icon, type the names of the modules to include, and then select OK. I file di simboli per altri moduli non vengono caricati.The symbol files for other modules are not loaded.

  5. Scegliere OK.Select OK.

Altre opzioni di simboli di debugOther symbol options for debugging

È possibile selezionare le opzioni dei simboli aggiuntive nelle degli strumenti > opzioni > debug > generale (o Debug > opzioni > generale):You can select additional symbol options in Tools > Options > Debugging > General (or Debug > Options > General):

  • Carica esportazioni DLL (solo Nativo)Load dll exports (Native only)

    Carica DLL esporta le tabelle per C/C++.Loads DLL export tables for C/C++. Per informazioni dettagliate, vedere tabelle di esportazione DLL.For details, see DLL export tables. Informazioni di esportazione DLL durante la lettura comporta un sovraccarico, in modo che il caricamento delle tabelle di esportazione è stata disattivata per impostazione predefinita.Reading DLL export information involves some overhead, so loading export tables is turned off by default. È anche possibile usare dumpbin /exports in una riga di comando di compilazione di C/C++.You can also use dumpbin /exports in a C/C++ build command line.

  • Attiva debug a livello di indirizzo e Mostra disassembly se l'origine non disponibileEnable address level debugging and Show disassembly if source not available

    Mostra sempre il disassembly quando i file di origine o di simboli non vengono trovati.Always shows the disassembly when source or symbol files are not found.

    Le opzioni / debug / opzioni di disassembly generali Options / Debugging  / General disassembly options

  • Abilita il supporto del server di origineEnable source server support

    Usa il Server di origine per eseguire il debug di un'app quando non è disponibile codice sorgente nel computer locale, o la PDB file non corrisponde al codice sorgente.Uses Source Server to help debug an app when there is no source code on the local machine, or the .pdb file does not match the source code. Server di origine riceve richieste di file e restituisce i file effettivi dal controllo del codice sorgente.Source Server takes requests for files and returns the actual files from source control. Server di origine viene eseguito tramite una DLL denominata SrcSrv dell'app di leggere PDB file.Source Server runs by using a DLL named srcsrv.dll to read the app's .pdb file. Il PDB file contiene i puntatori al repository del codice sorgente, nonché i comandi utilizzati per recuperare il codice sorgente dal repository.The .pdb file contains pointers to the source code repository, as well as commands used to retrieve source code from the repository.

    È possibile limitare i comandi che SrcSrv possono eseguire l'app PDB file eseguendo i comandi consentiti in un file denominato SrcSrv.You can limit the commands that srcsrv.dll can execute from the app's .pdb file by listing the allowed commands in a file named srcsrv.ini. Sul posto di SrcSrv file nella stessa cartella SrcSrv e devenv.exe.Place the srcsrv.ini file in the same folder as srcsrv.dll and devenv.exe.

    Importante

    I comandi arbitrari possono essere incorporati in un'app PDB del file, assicurarsi di inserire solo i comandi da eseguire in un SrcSrv file.Arbitrary commands can be embedded in an app's .pdb file, so make sure to put only the commands you want to execute into a srcsrv.ini file. Eventuali tentativi di eseguire un comando non presente nel file srcsvr.ini causerà la visualizzazione di una finestra di dialogo di conferma.Any attempt to execute a command not in the srcsvr.ini file will cause a confirmation dialog box to appear. Per altre informazioni, vedere avviso di sicurezza: Il debugger deve eseguire un comando non attendibile.For more information, see Security Warning: Debugger Must Execute Untrusted Command.

    Poiché non viene eseguita alcuna convalida sui parametri dei comandi, prestare attenzione nell'utilizzare i comandi attendibili.No validation is done on command parameters, so be careful with trusted commands. Ad esempio, se è elencato cmd.exe nel SrcSrv, un utente malintenzionato potrebbe specificare parametri nel cmd.exe che potrebbe renderlo pericolosi.For example, if you listed cmd.exe in your srcsrv.ini, a malicious user might specify parameters on cmd.exe that would make it dangerous.

    Selezionare questo elemento e gli elementi figlio desiderati.Select this item and the child items you want. Consenti server origine per assembly parzialmente attendibili (solo gestito) e eseguire i comandi del server di origine non attendibili senza chiedere conferma sempre possono aumentare i rischi di sicurezza.Allow source server for partial trust assemblies (Managed only) and Always run untrusted source server commands without prompting can increase the security risks.

    Abilitare le opzioni relative ai server di origineEnable source server options

Opzioni dei simboli del compilatoreCompiler symbol options

Quando si compila un progetto dall'IDE di Visual Studio con lo standard Debug configurazione della build, C++ e compilatori gestiti creano i file di simboli appropriati per il codice.When you build a project from the Visual Studio IDE with the standard Debug build configuration, the C++ and managed compilers create the appropriate symbol files for your code. È anche possibile impostare le opzioni del compilatore nel codice.You can also set compiler options in code.

Opzioni C/C++C/C++ options

  • VC<x > PDB e <progetto > PDB fileVC<x>.pdb and <project>.pdb files

    Oggetto PDB del file per C/C++ viene creato quando si compila con /ZI o /Zi.A .pdb file for C/C++ is created when you build with /ZI or /Zi. Nella Visual C++Visual C++, il /Fd opzione nomi il PDB il compilatore crea file.In Visual C++Visual C++, the /Fd option names the .pdb file the compiler creates. Quando si crea un progetto in Visual StudioVisual Studio utilizza l'IDE, le /Fd opzione è impostata per creare una PDB file denominato <progetto > PDB.When you create a project in Visual StudioVisual Studio using the IDE, the /Fd option is set to create a .pdb file named <project>.pdb.

    Se si compila l'applicazione C/C++ usando un makefile e specifica /ZI oppure /Zi senza usare /Fd, il compilatore crea due PDBi file:If you build your C/C++ application using a makefile, and you specify /ZI or /Zi without using /Fd, the compiler creates two .pdb files:

    • VC<x>.pdb, dove <x> rappresenta la versione di Visual C++, ad esempio VC11.pdbVC<x>.pdb, where <x> represents the version of Visual C++, for example VC11.pdb

      Il VC<x > PDB archivia tutte le informazioni di debug per i file oggetto singoli file e si trova nella stessa directory del progetto makefile.The VC<x>.pdb file stores all debugging information for the individual object files, and resides in the same directory as the project makefile. Ogni volta che viene creato un file oggetto, il compilatore C/C++ unisce le informazioni di debug in VC<x > PDB.Each time it creates an object file, the C/C++ compiler merges debug information into VC<x>.pdb. Pertanto, anche se ogni file di origine include file di intestazione comuni, ad esempio <Windows. h > , i typedef di tali intestazioni vengono archiviati una sola volta, anziché in ogni file oggetto.So even if every source file includes common header files such as <windows.h>, the typedefs from those headers are stored only once, rather than in every object file. Queste includono informazioni sui tipi ma non sui simboli, ad esempio sulle definizioni delle funzioni.The inserted information includes type information, but does not include symbol information, such as function definitions.

    • <project>.pdb<project>.pdb

      Il <progetto > PDB file vengono archiviate tutte le informazioni di debug per il progetto .exe file e si trova nel \debug sottodirectory.The <project>.pdb file stores all debug information for the project's .exe file, and resides in the \debug subdirectory. Il file <project>.pdb contiene non solo le informazioni sui tipi disponibili nel file VC<x>.pdb, ma tutte le informazioni di debug, inclusi i prototipi di funzione.The <project>.pdb file contains full debug information, including function prototypes, not just the type information found in VC<x>.pdb.

    Entrambi i VC<x > PDB e <progetto > PDB file supportano gli aggiornamenti incrementali.Both the VC<x>.pdb and <project>.pdb files allow incremental updates. Il linker incorpora inoltre il percorso per il PDB i file nella .exe o . dll file creato.The linker also embeds the path to the .pdb files in the .exe or .dll file that it creates.

  • Tabelle di esportazione DLLDLL export tables

    Usare dumpbin /exports per visualizzare i simboli disponibili nella tabella di esportazione di una DLL.Use dumpbin /exports to see the symbols available in the export table of a DLL. Informazioni sui simboli delle tabelle di esportazione DLL possono essere utile per l'utilizzo di messaggi di Windows, routine Windows (WindowProc), COM oggetti, marshalling o qualsiasi DLL non si dispone di simboli per.Symbolic information from DLL export tables can be useful for working with Windows messages, Windows procedures (WindowProcs), COM objects, marshaling, or any DLL you don't have symbols for. I simboli sono disponibili per tutte le DLL di sistema a 32 bit.Symbols are available for any 32-bit system DLL. Le chiamate sono elencate nell'ordine di chiamata, con la funzione corrente (al più alto livello di annidamento) all'inizio dell'elenco.The calls are listed in the calling order, with the current function (the most deeply nested) at the top.

    Leggendo la dumpbin /exports di output, è possibile visualizzare i nomi di funzione exact, inclusi i caratteri non alfanumerici.By reading the dumpbin /exports output, you can see the exact function names, including non-alphanumeric characters. Visualizzare i nomi delle funzioni esatta è utile per impostare un punto di interruzione in una funzione, perché i nomi delle funzioni possono essere troncate in altre posizioni nel debugger.Seeing exact function names is useful for setting a breakpoint on a function, because function names can be truncated elsewhere in the debugger. Per altre informazioni, vedere dumpbin /exports.For more information, see dumpbin /exports.

Opzioni di .NET Framework.NET Framework options

Compilazione con /debug per creare un PDB file.Build with /debug to create a .pdb file. È possibile compilare applicazioni con /debug:full o /debug:pdbonly.You can build applications with /debug:full or /debug:pdbonly. Se si usa l'opzione di compilazione /debug:full , verrà generato codice di cui è possibile effettuare il debug.Building with /debug:full generates debuggable code. Se si usa l'opzione di compilazione /debug:pdbonly, vengono generati file con estensione pdb ma non l'attributo DebuggableAttribute che indica al compilatore JIT che sono disponibili informazioni di debug.Building with /debug:pdbonly generates .pdb files, but does not generate the DebuggableAttribute that tells the JIT compiler that debug information is available. Usare /debug:pdbonly per generare file con estensione pdb per una build di rilascio che non si vuole sottoporre a debug.Use /debug:pdbonly if you want to generate .pdb files for a release build that you do not want to be debuggable. Per altre informazioni, vedere /debug (Opzioni del compilatore C#) o /debug (Visual Basic).For more information, see /debug (C# compiler options) or /debug (Visual Basic).

Applicazioni WebWeb applications

Impostare il Web. config file dell'applicazione ASP.NET in modalità debug.Set the web.config file of your ASP.NET application to debug mode. Tramite la modalità di debug, ASP.NET genera simboli per i file generati dinamicamente e il debugger si collega all'applicazione ASP.NET.Debug mode causes ASP.NET to generate symbols for dynamically generated files and enables the debugger to attach to the ASP.NET application. Visual Studio configura automaticamente questa impostazione quando si avvia il debug, se è stato creato il progetto dal modello dei progetti web.Visual Studio sets this automatically when you start to debug, if you created your project from the web projects template.

Gestire i simboli durante il debugManage symbols while debugging

È possibile usare la moduli, Stack di chiamate, variabili locali, Auto, o qualsiasi Watch finestra da caricare i simboli o modifica le opzioni dei simboli durante il debug.You can use the Modules, Call Stack, Locals, Autos, or any Watch window to load symbols or change symbol options while debugging. Per altre informazioni, vedere acquisire maggiore familiarità con la modalità con cui il debugger si connette all'app.For more information, see Get more familiar with how the debugger attaches to your app.

Usare la finestra ModuliUse the Modules window

Durante il debug, il moduli finestra Mostra i moduli di codice il debugger è trattare come codice utente, o My Code e i simboli di caricamento dello stato.During debugging, the Modules window shows the code modules the debugger is treating as user code, or My Code, and their symbol loading status. È anche possibile monitorare lo stato di caricamento dei simboli, caricare i simboli e modificare le opzioni dei simboli nel moduli finestra.You can also monitor symbol loading status, load symbols, and change symbol options in the Modules window.

Per monitorare o modificare percorsi di simboli o opzioni durante il debug:To monitor or change symbol locations or options while debugging:

  1. Per aprire la moduli finestra durante il debug, selezionare Debug > Windows > moduli.To open the Modules window, while debugging, select Debug > Windows > Modules.
  2. Nel moduli finestra, fare doppio clic sul stato simboli oppure File di simboli intestazioni o qualsiasi modulo.In the Modules window, right-click the Symbol Status or Symbol File headers, or any module.
  3. Nel menu di scelta rapida, selezionare una delle opzioni seguenti:In the context menu, select one of the following options:
OpzioneOption DescrizioneDescription
Carica simboliLoad Symbols Viene visualizzata per i moduli con i simboli ignorati, non è stati trovati o non è stati caricati.Appears for modules with skipped, not found, or not loaded symbols. Tenta di caricare i simboli dai percorsi specificati nella le opzioni > debug > simboli pagina.Attempts to load symbols from locations specified on the Options > Debugging > Symbols page. Se il file di simboli non trovato o non caricato, viene avviata Esplora File quindi è possibile specificare un nuovo percorso da cercare.If the symbol file is not found or not loaded, launches File Explorer so you can specify a new location to search.
Informazioni sul caricamento simboliSymbol Load Information Mostra la posizione di un file di simboli caricato o i percorsi cercati se il debugger non è possibile trovare il file.Shows the location of a loaded symbol file, or the locations that were searched if the debugger cannot find the file.
Impostazioni simboliSymbol Settings Apre la le opzioni > debug > simboli pagina, in cui è possibile modificare e aggiungere i percorsi dei simboli.Opens the Options > Debugging > Symbols page, where you can edit and add symbol locations.
Caricare sempre automaticamenteAlways Load Automatically Aggiunge il file di simboli selezionati all'elenco di file che vengono caricati automaticamente dal debugger.Adds the selected symbol file to the list of files that are automatically loaded by the debugger.

Usare le pagine Nessuna simboli Loaded/No origine caricataUse the No Symbols Loaded/No Source Loaded pages

Esistono diversi modi per il debugger inserire un'interruzione nel codice che non esistono file di simboli o di origine disponibili:There are several ways for the debugger to break into code that does not have symbol or source files available:

  • L'istruzione nel codice.Step into code.
  • Inserire un'interruzione nel codice da un punto di interruzione o eccezione.Break into code from a breakpoint or exception.
  • Passare a un altro thread.Switch to a different thread.
  • Cambiare lo stack frame facendo doppio clic su un frame nel Stack di chiamate finestra.Change the stack frame by double-clicking a frame in the Call Stack window.

In questo caso, il debugger visualizza i Nessun simbolo caricato oppure Nessuna origine caricata pagine che consentono di individuare e caricare l'origine o dei simboli necessari.When this happens, the debugger displays the No Symbols Loaded or No Source Loaded pages to help you find and load the necessary symbols or source.

Pagina Nessun simbolo caricatoNo Symbols Loaded page

Per usare la pagina del documento Nessun simbolo caricato per trovare e caricare i simboli mancanti:To use the No Symbols Loaded document page to help find and load missing symbols:

  • Per modificare il percorso di ricerca, selezionare un percorso non selezionato o selezionare nuovo percorso oppure nuovo percorso VSTS e immettere o selezionare un nuovo percorso.To change the search path, select an unselected path, or select New Path or New VSTS Path and enter or select a new path. Selezionare caricare per cercare nuovamente i percorsi e caricare il file di simboli se viene trovato.Select Load to search the paths again and load the symbol file if it is found.
  • Per eseguire l'override di tutte le opzioni dei simboli e ripetere i percorsi di ricerca, selezionare cercare e trovare <nome eseguibile > .To override any symbol options and retry the search paths, select Browse and find <executable-name>. Il file di simboli viene caricato se viene trovato, o Esplora File apre in modo che è possibile selezionare manualmente il file di simboli.The symbol file is loaded if it is found, or File Explorer opens so you can manually select the symbol file.
  • Per aprire la le opzioni > debug > simboli selezionare Cambia impostazioni simboli.To open the Options > Debugging > Symbols page, select Change Symbol Settings.
  • Per visualizzare il disassembly in una nuova finestra una volta, selezionare visualizzare il disassembly, o selezionare finestra di dialogo Opzioni per impostare l'opzione per visualizzare sempre il disassembly quando i file di origine o di simboli non vengono trovati.To show the disassembly in a new window one time, select view disassembly, or select Options dialog to set the option to always show the disassembly when source or symbol files are not found.
  • Per visualizzare i percorsi di ricerca e il risultato, espandere informazioni sul caricamento simboli.To show the locations searched and the outcome, expand Symbol load information.

Se il debugger rileva il PDB file dopo l'esecuzione di una delle opzioni e può recuperare file di origine utilizzando le informazioni contenute nel PDB file, Visualizza l'origine.If the debugger finds the .pdb file after you execute one of the options, and can retrieve the source file using the information in the .pdb file, it displays the source. In caso contrario, viene visualizzato un Nessuna origine caricata pagina che descrive il problema, con collegamenti alle azioni che potrebbero risolvere il problema.Otherwise, it displays a No Source Loaded page that describes the issue, with links to actions that might resolve the issue.

Per aggiungere i percorsi di ricerca di file di origine a una soluzione:To add source file search paths to a solution:

È possibile specificare i percorsi in cui il debugger cerca i file di origine ed escludere i file specifici dalla ricerca.You can specify the locations the debugger searches for source files, and exclude specific files from the search.

  1. Selezionare la soluzione in Esplora soluzioni, quindi selezionare il delle proprietà icona, premere Alt+invio, o Fare doppio clic e selezionare proprietà.Select the solution in Solution Explorer, and then select the Properties icon, press Alt+Enter, or right-click and select Properties.

  2. Selezionare eseguire il Debug di file di origine.Select Debug Source Files.

  3. Sotto directory contenenti codice sorgentedigitare o selezionare i percorsi del codice sorgente per la ricerca.Under Directories containing source code, type or select source code locations to search. Usare la nuova riga icona per aggiungere più posizioni, il backup e verso il basso icone freccia per riordinarli, o il X icona per eliminarli.Use the New Line icon to add more locations, the Up and Down arrow icons to reorder them, or the X icon to delete them.

    Nota

    Il debugger cerca solo nella directory specificata.The debugger searches only the specified directory. È necessario aggiungere voci per qualsiasi sottodirectory da cercare.You must add entries for any subdirectories that you want to search.

  4. Sotto non cercare questi file di origine, digitare i nomi dei file di origine da escludere dalla ricerca.Under Do not look for these source files, type the names of source files to exclude from search.

  5. Selezionare OK oppure applicare.Select OK or Apply.

Vedere ancheSee also