Cercare e sostituire testo

È possibile trovare e sostituire testo nell'editor di Visual Studio usando Trova e sostituisci (CTRL+F o CTRL+H) oppure Find/Replace in Files (Trova/Sostituisci nei file) (CTRL+MAIUSC+F o CTRL+MAIUSC+H). È anche possibile cercare e sostituire solo alcune istanze di un modello usando la selezione di più punti di inserimento.

Suggerimento

Se si stanno rinominando simboli del codice, ad esempio variabili e i metodi, è preferibile effettuarne il refactoring anziché usare la funzionalità di ricerca e sostituzione. Il refactoring è un'opzione avanzata in grado di rilevare l'ambito, mentre con la ricerca e sostituzione vengono sostituite indifferentemente tutte le istanze.

La funzionalità di ricerca e sostituzione è disponibile nell'editor, in alcune altre finestre basate su testo, ad esempio le finestre dei risultati della ricerca, nelle finestre di progettazione, ad esempio la finestra di progettazione XAML e quella di Progettazione Windows Form, e nelle finestre degli strumenti.

È possibile definire l'ambito di ricerca per il documento corrente, la soluzione corrente o un set di cartelle personalizzato. È inoltre possibile specificare un set di estensioni di nomi di file per le ricerche su più file. Personalizzare la sintassi di ricerca usando le espressioni regolari .NET.

Suggerimento

La casella Trova/Comando è disponibile nella barra degli strumenti, ma non è visibile per impostazione predefinita. Per visualizzare la casella Trova/Comando, selezionare Aggiungi o rimuovi pulsanti nella barra degli strumenti Standard e quindi selezionare Trova.

Controllo Trova e sostituisci

  • Premere CTRL + F come tasto di scelta rapida per trovare una stringa nel file corrente.
  • Premere CTRL H come tasto di scelta rapida per trovare + e sostituire una stringa nel file corrente.

Il controllo Trova e sostituisci viene visualizzato nell'angolo superiore destro della finestra dell'editor di codice. Evidenzia immediatamente tutte le occorrenze della stringa di ricerca specificata nel documento corrente. È possibile spostarsi da un'occorrenza all'altra scegliendo il pulsante Trova successivo o Trova precedente nel controllo di ricerca.

Screenshot della finestra di dialogo Trova e sostituisci nell'editor in Visual Studio 2022.

Screenshot della finestra di dialogo Trova e sostituisci nell'editor in Visual Studio 2019 e versioni precedenti.

È possibile accedere alle opzioni di sostituzione scegliendo il pulsante accanto alla casella di testo Trova. Per eseguire una sostituzione per volta, scegliere il pulsante Sostituisci successivo accanto alla casella di testo Sostituisci . Per sostituire tutte le corrispondenze, scegliere il pulsante Sostituisci tutto.

Per modificare il colore di evidenziazione per le corrispondenze, scegliere il menu Strumenti, selezionare Opzioni, quindi scegliere Ambiente e selezionare Tipi di carattere e colori. Nell'elenco Mostra impostazioni per selezionare Editor di testo e quindi nell'elenco Elementi visualizzati selezionare Trova evidenziazione corrispondenza.

Finestre degli strumenti di ricerca

È possibile usare il controllo Trova nelle finestre di codice o del testo, ad esempio le finestre Output e Risultati ricerca, selezionando Modifica > Trova e sostituisci o premendo CTRL+F.

Una versione del controllo Trova è disponibile anche in alcune finestre degli strumenti. Ad esempio, è possibile filtrare l'elenco di controlli nella finestra Casella degli strumenti immettendo il testo nella casella di ricerca. Tra le altre finestre degli strumenti che consentono di cercare il relativo contenuto sono incluse Esplora soluzioni, Proprietà e Team Explorer.

Cerca nei file e Sostituisci nei file

  • Premere CTRL + MAIUSC + F come tasto di scelta rapida per trovare una stringa in più file.
  • Premere CTRL + MAIUSC + H come tasto di scelta rapida per trovare e sostituire una stringa in più file.

Find/Replace in Files (Trova/Sostituisci nei file) funziona come il controllo Trova e sostituisci, con la differenza che è possibile definire un ambito per la ricerca. Non solo è possibile cercare il file aperto corrente nell'editor, ma anche tutti i documenti aperti, l'intera soluzione, il progetto corrente e gli insiemi di cartelle selezionati. È inoltre possibile eseguire la ricerca in base all'estensione del nome file. Per accedere alla finestra di dialogo Find/Replace in Files (Trova/Sostituisci nei file), selezionare Trova e sostituisci dal menu Modifica o premere CTRL+MAIUSC+F.

Screenshot della finestra di dialogo Trova e sostituisci in Visual Studio 20222, con la scheda Cerca nei file aperta.

Screenshot della finestra di dialogo Trova e sostituisci in Visual Studio 2019, con la scheda Cerca nei file aperta.

Importante

Se si usa Visual Studio 2019 versione 16.6 o precedente, la finestra di dialogo Trova e sostituisci potrebbe non essere visualizzata qui. Passare alla versione Visual Studio 2017 di questa pagina per le descrizioni corrispondenti a quanto visualizzato sullo schermo.

Screenshot della finestra di dialogo Trova e sostituisci in Visual Studio 2017, con la scheda Cerca nei file aperta.

Risultati ricerca

Quando si sceglie Find All (Trova tutti), si apre una finestra Risultati ricerca che elenca le corrispondenze della ricerca. Selezionando un risultato nell'elenco viene visualizzato il file associato ed evidenziata la corrispondenza. Se il file non è già aperto per la modifica, viene aperto in una scheda di anteprima a destra della finestra scheda. È possibile utilizzare il controllo Trova per eseguire la ricerca nell'elenco dei Risultati ricerca.

Creare set personalizzati di cartelle di ricerca

È possibile definire un ambito di ricerca scegliendo il pulsante Scegli cartelle di ricerca (simile a ...) accanto alla casella Cerca in. Nella finestra di dialogo Seleziona cartelle di ricerca, è possibile specificare un set di cartelle in cui eseguire la ricerca nonché salvare la specifica in modo da poterla usare di nuovo in un secondo tempo.

Suggerimento

Se è stato eseguito il mapping dell'unità di un computer remoto nel computer locale, è possibile specificare cartelle in cui eseguire la ricerca nel computer remoto.

Creare set di componenti personalizzati

È possibile definire set di componenti nell'ambito di ricerca scegliendo il pulsante Modifica insieme di componenti personalizzato accanto alla casella Cerca in. È possibile specificare i componenti .NET o COM installati, i progetti Visual Studio che sono inclusi nella soluzione, o qualunque assembly o libreria dei tipi (.dll, .tlb, .olb, .exe o .ocx). Per individuare i riferimenti, selezionare la casella Cerca in riferimenti.

Selezione di più punti di inserimento

Nota

Questa sezione si applica a Visual Studio in Windows. Per Visual Studio per Mac, vedere Selezione blocco.

Introdotta in Visual Studio 2017 versione 15.8

Usare la selezione di più punti di inserimento per apportare la stessa modifica apportata in due o più posizioni nello stesso momento. Ad esempio, è possibile inserire lo stesso testo o modificare il testo esistente in più posizioni nello stesso momento.

In Visual Studio 2022 è stata migliorata l'esperienza di copia e incolla con più caret. In precedenza, incollare più righe in più punti di selezione causava la duplicazione di tutti gli Appunti in corrispondenza di ogni punti di selezione. A questo punto, se si incollano più righe nello stesso numero di punti di inserimento, ogni riga verrà inserita in un rispettivo punto di inserimento.

Per usare più cursori, premere ALT + MAIUSC+ clic del + mouse o + ALT+MAIUSC. + e quindi premere CTRL + MAIUSC + per espandere le selezioni. Premere quindi CTRL + C per copiare il testo in più selezioni. Usare + ALT+MAIUSC+clic del mouse per creare + più punti di interruzione per ogni riga da incollare nel punto desiderato. Premere infine CTRL + V per incollare ogni riga in corrispondenza del relativo caret.

Animazione dell'azione di selezione multi-caret in Visual Studio.

Inoltre, è possibile usare ALT MAIUSC freccia SU (o freccia GIÙ) o ALT MAIUSC con trascinamento del mouse per selezionare + + con più punti di + + selezione. In precedenza, questi movimenti creava una selezione di casella. A questo punto, la selezione di una casella si trasforma in più punti di selezione. Questo metodo è più semplice e veloce rispetto alla necessità di fare clic in posizioni precise per inserire singoli punti di inserimento.

Suggerimento

Se si preferisce continuare a usare la selezione di una casella con i tasti di direzione ALT MAIUSC e ALT MAIUSC trascinare il mouse quando si espande una selezione con più cursori, passare a Strumenti Opzioni Editor di testo Avanzate e selezionare Usa selezione + + + + > > > casella.

È anche possibile accedere alla selezione di più punti di selezione dalla barra dei menu selezionando Modifica più punti di selezione e > quindi selezionando l'azione desiderata.

Screenshot del menu a comparsa Più punti di selezione in Visual Studio 2022.

Nello screenshot seguente -0000 è selezionato in tre posizioni; se l'utente preme Elimina, vengono eliminate tutte e tre le selezioni:

Selezione di più punti di inserimento in un file XML in Visual Studio

Per selezionare più punti di inserimento, fare clic o effettuare la prima selezione di testo come di consueto, quindi premere ALT mentre si fa clic o si seleziona il testo in ogni nuova posizione. È anche possibile aggiungere automaticamente il testo corrispondente come selezioni aggiuntive o selezionare una casella di testo per modificare in modo identico ogni riga.

Suggerimento

Se si è scelto ALT come tasto di modifica per il clic del mouse di Vai a definizione in Strumenti > Opzioni, la selezione per più punti di inserimento è disabilitata.

Comandi

Usare i tasti e le azioni seguenti per i comportamenti di selezione di più punti di inserimento:

Tasto di scelta rapida Azione
Ctrl + ALT+ clic Aggiungere un punto di inserimento secondario
Ctrl + ALT+ doppio clic Aggiungere una selezione di parola secondaria
Ctrl + ALT + clic + trascinamento Aggiungere una selezione secondaria
Maiusc + Alt + . Aggiungere il testo successivo corrispondente come selezione
Maiusc + Alt + ; Aggiungere tutto il testo corrispondente come selezione
Maiusc + Alt + , Rimuovere l'ultima occorrenza selezionata
Maiusc + Alt+/ Ignorare l'occorrenza corrispondente successiva
ALT+ clic Aggiungere una selezione di casella
ESC oppure clic Cancellare tutte le selezioni

Alcuni comandi sono disponibili anche nel menu Modifica, in Più punti di inserimento:

Screenshot del menu a comparsa Più punti di selezione in Visual Studio

Vedi anche