Visual Studio Icon Note sulla versione di Visual Studio 2019 per Mac versione 8.0Visual Studio 2019 for Mac version 8.0 Release Notes



Community degli sviluppatori | Requisiti di sistema | Compatibilità | Codice distribuibile | Documentazione | Blog | ManutenzioneDeveloper Community | System Requirements | Compatibility | Distributable Code | Documentation | Blogs | Servicing


DownloadDownload

Fare clic sul pulsante per scaricare la versione più recente di Visual Studio 2019 per Mac.Click the button to download the latest version of Visual Studio 2019 for Mac. Per informazioni sui requisiti di sistema, vedere i requisiti di sistema per Mac e Selezione della piattaforma e compatibilità per Mac.For information on the system requirements see the see Mac System Requirements and Mac Platform Targeting and Compatibility guides.

Per istruzioni sull'installazione e sull'aggiornamento di Visual Studio 2019 per Mac, vedere Installare Visual Studio per Mac.For instructions on installing and updating Visual Studio 2019 for Mac, see the Install Visual Studio for Mac guide.

Download VS for Mac

Per altre informazioni sui download correlati, vedere la pagina Download.To learn more about other related downloads, see the Downloads page.

Importante

Visual Studio 2019 per Mac (versione 8 e successive) non è supportato in Mac OS X 10.11 (El Capitan) o versioni precedenti.Visual Studio 2019 for Mac (version 8 and higher) is not supported on Mac OS X 10.11 (El Capitan) or lower. Se si ha Visual Studio 2017 per Mac (versione 7) l'aggiornamento a Visual Studio 2019 per Mac non viene visualizzato.If you have Visual Studio 2017 for Mac (version 7), you will not be shown an update to Visual Studio 2019 for Mac. Anche l'installazione viene bloccata.Installation will also be blocked. Per risolvere questo problema, eseguire l'aggiornamento a macOS 10.12 (Sierra) o versioni successiveTo resolve this issue, update to macOS 10.12 (Sierra) or higher


Novità di Visual Studio 2019 per MacWhat's New in Visual Studio 2019 for Mac

Note sulla versione di Visual Studio 2019 per Mac (versione 8.0)Visual Studio 2019 for Mac version 8.0 Releases

Blog di Visual Studio 2019 per MacVisual Studio 2019 for Mac Blog

Il blog di Visual Studio 2019 per Mac è la fonte ufficiale di informazioni dettagliate sul prodotto, gestita dal team Visual Studio Engineering.The Visual Studio 2019 for Mac Blog is the official source of product insight from the Visual Studio Engineering Team. È possibile trovare informazioni approfondite sulle versioni di Visual Studio 2019 per Mac nei post seguenti:You can find in-depth information about the Visual Studio 2019 for Mac releases in the following posts:

Elementi salienti della versioneRelease Highlights

  • Questa versione include un'anteprima dell'editor di testo di prossima generazione per Visual Studio per Mac.This release contains a preview of the next generation text editor for Visual Studio for Mac.
  • È stata introdotta una nuova esperienza di avvio.We've introduced a new getting started experience.
  • È stato aggiunto il supporto per l'esecuzione di più istanze dell'IDE.We've added support for easily running multiple instances of the IDE.
  • È stata aggiunta una nuova modalità per impostare più progetti di avvio, grazie alla quale è più semplice creare una configurazione di esecuzione di una soluzione per avviare più progetti durante il debug.We've added a new way to set multiple startup projects, making it easier to create a solution Run Configuration that will launch multiple projects when debugging.
  • Visual Studio per Mac ora riesce a rilevare quando sono disponibili aggiornamenti dei modelli di Funzioni di Azure e visualizza una finestra di dialogo per aggiornarli.Visual Studio for Mac can now detect that updates to Azure Functions templates are available, and will provide you with a dialog to update them.
  • È stata migliorata l'esperienza di debug per i progetti Unity mediante la condivisione del debugger usato da Visual Studio Tools per Unity in Windows.We've improved the debugging experience for Unity projects by sharing the debugger used by Visual Studio Tools for Unity on Windows.
  • È stato aggiunto il supporto per l'autenticazione di account Microsoft con Git e Azure DevOps/Team Foundation Server.We have added support for Microsoft Account authentication with Git and Azure DevOps/Team Foundation Server.
  • Si è passati da tre canali, ovvero Alfa, Beta e Stabile, a solo due canali ovvero Anteprima e Stabile.We've moved from having three channels: Alpha, Beta, Stable to just Preview and Stable. È possibile accedere agli aggiornamenti da Visual Studio > Controlla aggiornamentiYou can access updates from the Visual Studio > Check for Updates… .menu item.

Visual Studio 2019 per Mac versione 8.0 (8.0.9.5)Visual Studio 2019 for Mac version 8.0 (8.0.9.5)

Data di rilascio: 30 maggio 2019released May 30, 2019

In questa versione sono stati risolti i problemi seguenti:We fixed the following issues in this release:

Visual Studio 2019 per Mac versione 8.0 (8.0.8.2)Visual Studio 2019 for Mac version 8.0 (8.0.8.2)

Data di rilascio: 23 maggio 2019released May 23, 2019

Questa versione corregge un problema in cui l'esecuzione di istruzioni durante il debug con Unity non funziona.This release fixes an issue where stepping during debugging with Unity does not work.

Visual Studio 2019 per Mac versione 8.0 (8.0.7.3)Visual Studio 2019 for Mac version 8.0 (8.0.7.3)

Data di rilascio: 21 maggio 2019released May 21, 2019

In questa versione è stato aggiornato il modello di shell Xamarin.Forms per usare la versione più recente della shell.This release updates the Xamarin.Forms Shell template to work with the latest version of Shell.

Visual Studio 2019 per Mac versione 8.0 (8.0.6.4)Visual Studio 2019 for Mac version 8.0 (8.0.6.4)

Data di rilascio: 14 maggio 2019released May 14, 2019

In questa versione è stato affrontato un problema che può causare l'arresto anomalo del sistema durante il rendering dei punti di interruzione nell'editor.This release addresses an issue that can lead to a crash when rendering breakpoints in the editor.

Visual Studio 2019 per Mac versione 8.0 (8.0.5.9)Visual Studio 2019 for Mac version 8.0 (8.0.5.9)

Data di rilascio: 29 aprile 2019released April 29, 2019

In questa versione sono stati risolti i problemi seguenti:We fixed the following issues in this release:

Visual Studio 2019 per Mac versione 8.0 (8.0.4.0)Visual Studio 2019 for Mac version 8.0 (8.0.4.0)

Data di rilascio: 18 aprile 2019released April 18, 2019

In questa versione sono stati risolti i problemi seguenti:We fixed the following issues in this release:

Visual Studio 2019 per Mac versione 8.0 (8.0.3.14)Visual Studio 2019 for Mac version 8.0 (8.0.3.14)

Data di rilascio: 15 aprile 2019released April 15, 2019

In questa versione sono stati risolti i problemi seguenti:We fixed the following issues in this release:

Visual Studio 2019 per Mac versione 8.0 (8.0.2.23)Visual Studio 2019 for Mac version 8.0 (8.0.2.23)

Data di rilascio: 9 aprile 2019released April 9, 2019

Questa versione aggiunge il supporto per Xcode 10.2.This release adds support for Xcode 10.2.

In questa versione sono stati risolti i problemi seguenti:We fixed the following issues in this release:

Visual Studio 2019 per Mac versione 8.0 (8.0.1.1)Visual Studio 2019 for Mac version 8.0 (8.0.1.1)

Data di rilascio: 4 aprile 2019released April 4, 2019

  • È stato risolto un problema per cui l'ambiente di sviluppo integrato (IDE, Integrated Development Environment) potrebbe arrestarsi in modo anomalo se la finestra iniziale viene chiusa durante la creazione di un progetto.We fixed an issue where the IDE would crash if the Start Window was closed while a project was being created.

Visual Studio 2019 per Mac versione 8.0 (8.0.0.3001)Visual Studio 2019 for Mac version 8.0 (8.0.0.3001)

Data di rilascio: 2 aprile 2019released April 2, 2019

Installazione diInstall

  • Il programma di installazione di Visual Studio per Mac ha ora un aspetto più moderno, con icone, schermate iniziali e schermate in sequenza aggiornate con contenuti utili per tutti gli sviluppatori.We've given the Visual Studio for Mac Installer a fresh look with updated icons, splash screens, and carousel screens with useful content for all developers.
  • È stato aggiunto il supporto per la versione minima di macOS richiesta per Visual Studio per Mac (10.12).We added support for a minimum version of macOS required for Visual Studio for Mac (10.12). Se non si esegue macOS 10.12 o versione successiva, ora il programma di installazione richiede di aggiornare la versione di macOS.If you're not on macOS 10.12 of newer the installer now prompts you to upgrade your version of macOS.
  • Le impostazioni predefinite del programma di installazione sono state modificate per consentire un'installazione più piccola e più intelligente.We changed our installer defaults to a smaller and smarter install. Invece di selezionare tutti gli elementi per impostazione predefinita, vengono selezionati l'IDE e .NET Core per tutti gli utenti e viene selezionato solo iOS o Android se viene rilevata qualsiasi versione di Xcode o Android SDK nel computer.Instead of selecting everything by default, we select the IDE and .NET Core for all users, and only select iOS or Android if any version of Xcode or Android SDK is detected on your machine.
  • Per lo sviluppo di app Xamarin.iOS o Xamarin.Mac ora viene richiesto di eseguire l'aggiornamento alla versione più aggiornata di Xcode, se non è già installata.If you are developing Xamarin.iOS or Xamarin.Mac apps, we now prompt you to update to the recommended version of Xcode, if you don't already have it installed.
  • NDK è stato rimosso dal download di Android SDK.We removed the NDK from the Android SDK download.
  • Sono stati apportati numerosi miglioramenti alla finestra di dialogo delle autorizzazioni di Android, tra cui il miglioramento dell'interfaccia utente e la possibilità di deselezionare Xamarin.Android.We made many improvements to the Android permissions dialog, including improving the UI and allowing the user to uncheck Xamarin.Android.

Finestra inizialeStart Window

In questa versione è stato introdotto un modo completamente nuovo di interagire con i progetti e di consentire lo spostamento nei punti necessari nell'IDE.With this release, we've introduced a brand new way of interacting with your projects and getting you to where you need to go in the IDE.

Quando aprono l'IDE, ai nuovi utenti di Visual Studio per Mac, viene chiesto di eseguire l'accesso.If you're a new Visual Studio for Mac user, you'll be prompted to log in when you first open the IDE. In tal modo è possibile attivare l'account Professional o Enterprise oppure connettersi ad Azure.By logging in you can activate your Professional or Enterprise account or connect to Azure. Se non si è pronti per eseguire l'accesso, è possibile premere il pulsante Ignora e accedere tramite la voce di menu Visual Studio > Accedi.If you're not ready to sign in, you can press the Skip button and sign in through the Visual Studio > Sign In menu item.

Sign-in Dialog
Nuova finestra di dialogo AccediNew Sign in dialog

Viene visualizzata la nuova finestra di avvio.You'll then be greeted with the new start window. In questa finestra sono presenti tre sezioni principali in cui è possibile creare o aprire progetti nuovi ed esistenti:This window has three main sections, allowing you to create or open new and existing projects:

New Start Window
Nuova finestra inizialeNew Start window
  • Progetti recenti: in questa sezione è presente un elenco dei 25 progetti più recenti.Recent Projects: Here you can find a list of your 25 most recent projects. È possibile facoltativamente aggiungere il progetto usato più di frequente, se si preferisce mantenerlo nella parte superiore dell'elenco.You can optionally "pin" your most frequently used project, if you'd prefer to keep them at the top of the list. La casella di ricerca può essere usata per filtrare tutti i progetti recenti nell'elenco.The search box can be used to filter through all recent projects in the list.
  • Apri: questo pulsante consente di aprire dalla directory locale i file con estensione csproj, fsproj, sln o di altri tipi supportati.Open: You can open any .csproj, .fsproj, .sln or any other supported file from your local directory using this button.
  • Nuovo: è possibile eseguire una selezione in numerosi modelli pre-popolati, che consentono di iniziare un nuovo progetto.New: You can select from the many pre-populated templates to help you get started with a new project. Nella finestra di dialogo sono disponibili tutte le configurazioni necessarie per iniziare ed essere operativi.The new project dialog will take you through all the necessary configurations to help you get up and running.

Nuovo editor del codiceNew Code Editor

Visual Studio per Mac 2019 include un'anteprima dell'editor di testo di prossima generazione per Visual Studio per Mac.Visual Studio for Mac 2019 contains a preview of the next generation text editor for Visual Studio for Mac! Questo nuovo editor di testo condivide gli stessi componenti di base con Visual Studio per Windows, con un'interfaccia utente nativa completamente nuova.This new text editor shares the same core components with Visual Studio Windows, with an entirely new, native user interface.

New Editor
Funzionalità del nuovo editor in Visual Studio per MacNew editor features in Visual Studio for Mac

Al momento, il nuovo editor supporta solo file C#.At this time, the new editor supports C# files only. Verrà aggiunto il supporto per altri linguaggi nelle versioni future.Additional language support will be added in future releases.

Il nuovo editor di Visual Studio per Mac offre le funzionalità seguenti:The new Visual Studio for Mac editor brings the following features:

  • Interfaccia utente (basata su Cocoa) macOS nativa (descrizioni comandi, area dell'editor, ornamenti dei margini, rendering del testo, IntelliSense)Native macOS (Cocoa-based) user interface (tooltips, editor surface, margin adornments, text rendering, IntelliSense)
  • Supporto per input di testo nativoSupport for native text inputs
  • Supporto del linguaggio RTL/BiDiRTL/BiDi language support
  • Core comune della piattaforma di Visual StudioCommon Visual Studio Platform core
  • Roslyn 3Roslyn 3
  • Supporto di più punti di inserimentoMulti-caret support
  • A capo automaticoWord Wrap
  • Interfaccia utente aggiornata di IntelliSenseUpdate IntelliSense UI
  • Miglioramento di Trova/SostituisciImproved Find/Replace

Le eccezioni ora usano l'interfaccia utente di Cocoa per visualizzare i messaggi, inclusi i dettagli e la notifica dell'eccezione:Exceptions now use the Cocoa UI to display exception messages, including exception notification and details:

New Exceptions in Visual Studio for Mac
Nuove eccezioni in Visual Studio per MacNew exceptions in Visual Studio for Mac

Sono abilitati gli spostamenti tramite menu di scelta rapida.Context Menu Navigation is enabled. È ora possibile usare i comandi di spostamento basati su menu di scelta rapida, come "Vai a dichiarazione" e "Vai all'implementazione".You can now use context menu based navigation commands like "Go to Declaration" and "Go To Implementation". È stata abilitata anche l'opzione "Rimuovi e ordina using".We have also enabled "Remove and Sort Usings".

Come abilitare o disabilitare l'editorHow to enable or disable the editor

Dato che l'editor è una funzionalità di anteprima in Visual Studio per Mac 2019, è necessario acconsentire esplicitamente per abilitare la funzionalità.As the new editor is a preview feature within Visual Studio for Mac 2019, you have to opt-in to use the feature. Passare alla sezione Visual Studio > Preferenze... > Editor di testo > Generale e selezionare la casella di controllo Open C# files in the New Editor (Apri file C# nel nuovo editor).Go to the Visual Studio > Preferences… > Text Editor > General section and check the Open C# files in the New Editor checkbox. Dopo aver selezionato questa opzione, per qualsiasi nuovo file C# aperto verrà usato il nuovo editor.Once this option is checked, any newly opened C# files will be using the new editor. Il nuovo editor è abilitato quando viene visualizzato il pulsante "New Editor Preview" (Anteprima del nuovo editor) in basso a destra nella finestra di modifica.You will know the new editor is enabled when the "New Editor Preview" button appears in the bottom-right of the editing window.

Per disabilitare il nuovo editor, fare clic sul pulsante New Editor Preview (Anteprima del nuovo editor) in basso a destra nel riquadro dell'editor e selezionare Disable the New Editor Preview (Disabilita anteprima nuovo editor) o passare alla sezione Visual Studio > Preferenze... > Editor di testo > Generale e deselezionare la casella di controllo Open C# files in the New Editor (Apri file C# nel nuovo editor).To disable the new editor, either click the New Editor Preview button in the bottom right of the editor pane and select Disable the New Editor Preview or navigate to the Visual Studio > Preferences… > Text Editor > General section and un-check the Open C# files in the New Editor checkbox.

Come segnalare un problema con l'editorHow to Report a Problem with the editor

Per segnalare un problema nel nuovo editor, fare clic sul pulsante "New Editor Preview" (Anteprima del nuovo editor) in basso a destra nel riquadro dell'editor e selezionare "Segnala un problema".To report a problem in the new editor, either click the "New Editor Preview" button in the bottom right of the editor pane and select "Report a Problem". È anche possibile passare direttamente alla community degli sviluppatori.You can also go directly to Developer Community.

Supporto per più istanzeSupport for multiple instances

Visual Studio per Mac supporta ora l'apertura di più istanze dell'IDE dal Dock.Visual Studio for Mac now supports opening multiple instances of the IDE from the dock. Visual Studio per Mac ha sempre incluso il supporto per l'apertura di più soluzioni in un'unica finestra, ma sono arrivate molte richieste per il supporto di più finestre per l'IDE.Visual Studio for Mac has always had support for opening multiple solutions in one window but we’ve heard a lot of requests to support multiple windows for the IDE. Per aprire una nuova istanza, fare clic con il pulsante destro del mouse sull'icona nel Dock e scegliere Nuova istanza:To open a new instance, right-click on the icon in the dock and select New Instance:

Opening a new instance graphic
Apertura di una nuova istanza di Visual Studio per MacOpening a new instance of Visual Studio for Mac

Impostare progetti di avvioSet Startup projects

È disponibile un nuovo comando, Imposta progetti di avvio, che rende più semplice creare una configurazione di esecuzione di una soluzione per avviare più progetti durante il debug.A new command, Set Startup Projects, is available to make it easier to create a solution Run Configuration that will launch multiple projects when debugging. Per informazioni su come impostare più progetti di avvio, vedere la documentazione.For information on setting multiple startup projects, see the documentation.

Set startup projects dialog
Finestra di dialogo Imposta progetti di avvioSet Startup Projects dialog

Miglioramenti apportati al debug per UnityDebugging improvements for Unity

In questa versione il debugger usato per i progetti Unity è stato sostituito con il debugger di Visual Studio Tools per Unity su Windows.In this release we've replaced the debugger that's used for Unity projects with the debugger from Visual Studio Tools for Unity on Windows. Questa modifica favorisce la compatibilità con le versioni precedenti di Unity, migliora il debug di codice C# non sicuro e offre una maggiore affidabilità.This change has better compatibility with older versions of Unity, improvements for debugging unsafe C# code, and provides better reliability.

Miglioramenti per XamarinXamarin Improvements

Gli sviluppatori Xamarin troveranno moltissimi miglioramenti in questa versione.Xamarin developers should find a ton of improvements in this release. Tra le nuove caratteristiche principali rientrano:New highlights include:

Xamarin.AndroidXamarin.Android

Considerando che gli sviluppatori eseguono il ciclo di compilazione-distribuzione-debug innumerevoli volte al giorno, l'obiettivo è quello di abbreviare ulteriormente il ciclo di sviluppo interno.We know that developers run through the build-deploy-debug cycle countless times a day, and we're consistently working towards shortening the inner development loop even more. In questa versione sono stati apportati enormi miglioramenti ottimizzando le compilazioni e le distribuzioni incrementali.In this release, we've made huge gains by optimizing incremental builds and deployments.

Grazie all'app SmartHotel360 per i test, i tempi di compilazione incrementale sono stati ridotti del 29% e i tempi di distribuzione sono due volte più rapidi.Using the SmartHotel360 app for testing, incremental build times have been trimmed by up to 29%, and deployment times are up to twice as fast. Un report completo sulla metodologia e sulla profilatura delle prestazioni di compilazione è disponibile nel wiki di Xamarin.Android. Ecco una breve panoramica:A full report of build performance profiling and methodology is available on the Xamarin.Android wiki, but here’s a quick overview:

PassaggioStep Visual Studio 2017Visual Studio 2017 Visual Studio 2019Visual Studio 2019 DeltaDelta
Prima compilazioneFirst build 01:04.2001:04.20 00:50.1300:50.13 -21,95%-21.95%
Compilazione incrementale (modifica XAML)Incremental Build (XAML Change) 00:10.6200:10.62 00:07.4700:07.47 -29,66%-29.66%
Distribuzione (modifica XAML)Deploy (XAML Change) 00:09.0300:09.03 00:04.4400:04.44 -50,83%-50.83%

Nell'intento di continuare ad aumentare l'affidabilità della compilazione, sono state introdotte ottimizzazioni nell'area degli aggiornamenti delle risorse Android.Our mission to continually increase build reliability continues and one area we've made optimizations to is Android resource updates. Riducendo al minimo gli scenari in cui avvengono aggiornamenti delle risorse in fase di compilazione, si dovrebbe riscontrare una riduzione significativa dei problemi di compilazione causati da conflitti in quest'area.By minimizing scenarios where resource updates would occur at build time, there should be a significant reduction of build issues stemming from conflicts in this area.

In un passo avanti verso la parità con Android in Visual Studio nell'ambito dell'esperienza Windows, il processo di distribuzione è stato ulteriormente semplificato e l'emulatore Android verrà ora avviato quando si avvia una compilazione.In a step towards parity with the Android in Visual Studio on Windows experience, the deployment process has been further streamlined and the Android emulator will now launch when starting a build.

Xamarin.FormsXamarin.Forms

È ora disponibile un nuovo modello per i progetti shell di Xamarin.Forms e, per un'esperienza più uniforme tra gli ambienti IDE, questa versione include anche nuovi modelli di file precedentemente disponibili solo in Visual Studio in Windows.The brand-new template for Xamarin Forms Shell projects is now available, and for a more uniform experience across IDEs, this release also includes new file templates previously available only in Visual Studio on Windows. È ora possibile usare i nuovi file XAML passando a File > Nuovo file... > Forms nel menu di Visual Studio 2019 per Mac.You can use the new XAML files today by navigating to File > New File… > Forms in the Visual Studio 2019 for Mac menu. I nuovi elementi file sono:The new file items are:

  • XAML per Forms ListViewPageForms ListViewPage XAML
  • XAML per Forms MasterDetailPageForms MasterDetailPage XAML
  • XAML per Forms TabbedPageForms TabbedPage XAML
  • XAML per Forms ViewCellForms ViewCell XAML

E per contribuire a migliorare la produttività, è ora disponibile il supporto per Intellisense nei file XAML di Xamarin.Forms per FontFamily:And to help make productivity a touch better, Intellisense in Xamarin.Forms XAML files for FontFamily support is now available:

New Xamarin.Forms XAML files
Nuovi file XAML di Xamarin.FormsNew Xamarin.Forms XAML files

Android DesignerAndroid Designer

È ora disponibile il supporto per Android Pie (9.0).We now have support for Android Pie (9.0)! Sono state inoltre apportate ottimizzazioni per migliorare il tempo di avvio di Android Designer e il supporto dello scorrimento del widget.Additionally, we made enhancements to increase Android Designer start up time and improved scrolling widget support.

Questa versione include inoltre il supporto per l'aggiunta di spazi dei nomi XML "standard" ai documenti quando è impostato un attributo corrispondente, nonché il supporto per sequenze di escape come '@', '?' e sequenze di escape Unicode.This release also ships support for adding “standard” XML namespaces to documents when a corresponding attribute is set, as well as support for escape sequences like '@', '?' and Unicode escape sequences.

iOS DesigneriOS Designer

È stato aggiunto il supporto per il formato PDF per le immagini ed è stato migliorato il supporto per gli spazi e la precisione del colore.We’ve added support for PDF as an image format, and improved support for color spaces and color precision. Inoltre, è ora possibile selezionare colori denominati nei cataloghi di risorse come il valore per le proprietà del colore.Additionally, you can now select named colors from asset catalogs as the value for color properties.

È anche disponibile il supporto per i controlli personalizzati che devono caricare librerie dinamiche native o framework (si noti che le librerie statiche non sono supportate).We now have support for custom controls that need to load native dynamic libraries or frameworks (note that static libraries are not supported). Inoltre, le proprietà personalizzate di tipo CGSize ora vengono visualizzate nel pannello delle proprietà per i controlli personalizzati.Additionally, custom properties of type CGSize will now appear in the property panel for custom controls

Miglioramenti di Funzioni di AzureAzure Functions improvements

In questa versione sono stati aggiornati il runtime e i modelli di Funzioni di Azure (interfaccia della riga di comando).We have updated Azure Functions runtime and templates (CLI) in this release. Visual Studio per Mac offre anche la possibilità di aggiornare i modelli di funzione, se sono disponibili nuovi modelli quando si crea un nuovo progetto di Funzioni di Azure.In addition, Visual Studio for Mac will offer you the ability to update your function templates if new templates are available when creating a new Functions project. Per aggiornare i modelli di Funzioni di Azure selezionare il pulsante di aggiornamento accanto al testo "I modelli aggiornati sono disponibili":To update Azure Functions templates, select the update button next to the text "Updated templates are available":

Update Azure Fucntions templates
Aggiornare i modelli e l'interfaccia della riga di comando di Funzioni di AzureUpdate Azure Functions templates and CLI

Visual Studio per Mac supporta anche l'installazione dell'interfaccia della riga di comando di Funzioni di Azure tramite HomeBrew e sceglierà l'istanza con la versione più recente individuata.Visual Studio for Mac also supports Azure Functions CLI installed via HomeBrew and will choose the instance with the highest discovered version.

Problemi correttiIssues Fixed

In questa versione di anteprima sono stati risolti anche i problemi seguenti.The following issues have also been fixed in this release.

Editor di codiceCode Editor

ProgettiProjects

IDEIDE

  • È stato risolto un problema in base al quale viene usato il colore del testo non corretto in una riga selezionata ma senza stato attivo nella finestra di output di compilazione strutturata.We fixed an issue where the wrong text color is used in an unfocused but selected row in the structured build output window.
  • È stato risolto un problema in base al quale la creazione di una nuova cartella in Esplora soluzioni non consente di denominare contemporaneamente la cartella.We fixed an issue where creating a new folder in the Solution Explorer does not let you name the folder at the same time.
  • L'opzione Avvia debug dopo l'opzione Avvia senza eseguire debug genera un'eccezione per i progetti ASP.Net.Start Debugging after Start without Debugging results in an exception for ASP.Net projects.
  • Il comando Esegui elemento in Esplora soluzioni è stato rinominato in Esegui progetto.The Run Item command on the Solution Explorer has been renamed to Run Project.
  • Visual Studio per Mac userà ora HttpClient e l'API di rete Mac nativa quando si effettuano richieste Web per quasi tutte le richieste.Visual Studio for Mac will now use HttpClient and the native Mac networking API when making web requests for nearly all its requests. Alcune aree non sono ancora state aggiornate per l'uso di HttpClient e dell'API di rete Mac disponibili tramite NSUrlSession di Xamarin.Mac.Some areas have not yet been updated to use HttpClient and the Mac networking API available through Xamarin.Mac's NSUrlSession. L'API di rete Mac offre supporto predefinito per i proxy.The Mac's networking API provides its own built in support for proxies. Visual Studio per Mac può anche essere configurato per usare l'API di rete di Mono come alternativa.Visual Studio for Mac can also be configured to use Mono's networking API as an alternative. Alcune aree non sono ancora supportate, ad esempio la finestra di dialogo di accesso, e continueranno a usare l'API di rete di Mono.Some areas are not yet supported such as the sign in dialog, and will continue to use Mono's networking API.
  • È stato risolto un problema a causa del quale non vengono visualizzati i criteri di formattazione del codice nell'interfaccia utente.We fixed an issue where not seeing Code Formatting policies in the UI.
  • È stato risolto un problema per cui Visual Studio per Mac non può modificare i progetti passando da C# a F# o viceversa.We fixed an issue where VisualStudio for Mac cannot change projects from C# -> F# or vice versa.
  • È stato risolto un problema per cui non era possibile eliminare le voci da Sequenza Appunti in Casella degli strumenti per i file XAML.We fixed an issue where it was not possible to delete entries from Toolbox Clipboard Ring for XAML files.
  • È stato risolto un problema per il quale la deselezione e quindi la selezione di Visual Studio come applicazione attiva cambia l'elemento attivo predefinito nell'interfaccia utente.We fixed an issue where focusing out/into Visual Studio changes the default focused element on the UI.
  • È stato risolto un problema a causa del quale la cronologia di navigazione rimuove file dalla cronologia.We fixed an issue where navigation history removes files from history.
  • Sono stati aggiornati elementi nel menu della Guida.We updated items in the help menu.
  • È stato risolto un problema a causa del quale non è possibile impostare lo stato attivo nella modalità di modifica a 2 colonne con 2 soluzioni aperte.We fixed an issue where you cannot set focus in 2 column edit mode with 2 solutions open.
  • È stato aggiornato il titolo della finestra di dialogo "Informazioni su" per renderlo più leggibile.We updated the "About" dialog window title to be more human readable.
  • È stato risolto un problema a causa del quale alcune finestre vengono visualizzate posizionate in modo non corretto.We fixed an issue where some windows appear positioned incorrectly.
  • È stato risolto un problema a causa del quale la finestra modale di stato per l'aggiunta di file oscura le finestre modali per copia/spostamento.We fixed an issue where Adding Files modal progress window obscures copy/move modal.

.NET Core.NET Core

ASP.NET CoreASP.NET Core

  • È stato risolto un problema a causa del quale i modelli forniti con un back-end API non hanno una configurazione di esecuzione che consente di avviare entrambi i progetti.We fixed an issue where templates that come with an API backend did not have a run configuration that launches both projects.
  • È stato risolto un problema a causa del quale Esplora -> Membri di implementazione in un progetto ASP.NET Core non funziona.We fixed an issue where Navigate -> Implementing Members in ASP.NET Core project doesn't work.
  • È stato risolto un problema a causa del quale Converti formato della soluzione non esegue alcuna operazione per una soluzione con un'app Web ASP.NET Core.We fixed an issue where Convert Solution Format doesn't do anything for a solution with an ASP.NET Core web app.

NuGetNuGet

Strumenti WebWeb Tools

  • È stato risolto un problema a causa del quale i file con estensione ts non funzionano in VSMac.We fixed an issue where .ts files are not working in VSMac.
  • È stato risolto un problema a causa del quale Visual Studio per Mac 2019 non consente l'apertura di progetti Docker.We fixed an issue where Visual Studio for Mac 2019 cannot open Docker projects.
  • È stato risolto un problema a causa del quale la descrizione comando Informazioni rapide JavaScript viene visualizzata all'esterno della finestra dell'editor.We fixed an issue where JavaScript quick info tooltip is showing up outside the editor window.
  • È stato risolto un problema a causa del quale si verifica un arresto anomalo di Visual Studio per Mac quando si eseguono operazioni Copia/Incolla in launchSettings.json.We fixed an issue where Visual Studio for Mac crashes on copy & paste in launchSettings.json.

XamarinXamarin

  • Live Player è stato rimosso da Visual Studio per Mac.We have removed the Live Player from Visual Studio for Mac.
  • È stato risolto un problema a causa del quale il collegamento Guida -> Note sulla versione rimanda a una posizione errata.We fixed an issue where the Help -> Release Notes linked to the wrong place.

Finestre di progettazioneDesigners

Android DesignerAndroid Designer

Xamarin.FormsXamarin.Forms

Xamarin.iOSXamarin.iOS

Xamarin.AndroidXamarin.Android

  • È stato rimosso il supporto per elencare e visualizzare gli emulatori di Xamarin Android Player.We have removed support for listing and showing Xamarin Android Player emulators.
  • È stato risolto un problema in base al quale le nuove app Android hanno lettere maiuscole nel nome del pacchetto.We fixed an issue where new Android apps have uppercase letters in the package name.
  • È stato risolto un problema in base al quale l'uso delle maiuscole e minuscole di strings.xml non è coerente per i nuovi progetti.We fixed an issue where the casing of strings.xml was inconsistent for new projects.
  • È stato risolto un problema in base al quale l'apertura della finestra di dialogo per segnalare un problema provoca anche l'apertura della finestra di dialogo per installare JDK.We fixed an issue where opening the Report A Problem dialog also displays "Install JDK" dialog.
  • È stato risolto un problema a causa del quale nei nuovi progetti non vengono impostate correttamente l'API minima e di destinazione.We fixed an issue where new projects do not have the min and target API set correctly.
  • È stato risolto un problema a causa del quale il modello Android 'App WebView' non include l'opzione 'Sviluppo moderno' nella finestra di dialogo di creazione del progetto.We fixed an issue where the Android ‘WebView App’ template does not have a ‘Modern Development’ option in project creation dialog.
  • È stato risolto un problema a causa del quale l'avvio dell'emulatore Android in Visual Studio per Mac è molto lento.We fixed an issue where the Android Emulator Launch in Visual Studio for Mac is extremely slow.
  • È stato risolto un problema a causa del quale l'esecuzione dell'app per Android non inizia con "HAXM" in Visual Studio per Mac 2019.We fixed an issue where running the Android app does not start with "HAXM" on Visual Studio for Mac 2019.
  • L'emulatore Android viene ora avviato quando si inizia a compilare il progetto.We now start the Android emulator when starting to build the project.
  • Gli utenti possono ora scegliere tra AAPT e AAPT2 nelle impostazioni di progetto di Xamarin.Android.Users can now choose between AAPT and AAPT2 in Xamarin.Android project settings.
  • È stato risolto un problema per cui la distribuzione nel dispositivo si blocca sul 100%.We fixed an issue where deploying to device hangs at 100%.
  • È stato risolto un problema per cui non era possibile annullare l'avvio di un emulatore Android ed era necessario forzare la chiusura di Visual Studio per Mac in caso di interruzione dell'immagine.We fixed an issue where it was not possible to cancel starting an Android emulator, and having to force quit Visual Studio for Mac if the image was broken.
  • È stato risolto un problema per cui, se erano presenti più file con estensione csproj Android per un progetto (in cui erano usati manifesti Android diversi con nomi di pacchetti diversi), veniva generato un archivio non corretto o non valido e la pubblicazione aveva esito negativo.We fixed an issue where, if there were multiple Android .csproj files for a project (using different Android Manifests with differing package names), would produce incorrect or invalid archive and would fail to publish.
  • È stato risolto un problema per cui veniva visualizzata la notifica JDK nella home page, anche per i progetti non Android.We fixed an issue where the JDK notification was shown on the welcome page, even for non-Android projects.
  • È stato risolto un problema per il quale l'aggiornamento della risorsa Android poteva verificarsi contemporaneamente a una compilazione, con conseguenti possibili problemi di compilazione.We fixed an issue where the Android resource update could occur at the same time as a build which could then cause build issues.

Xamarin.MacXamarin.Mac

  • È stato risolto un problema in base al quale non è possibile modificare la versione del framework di destinazione per Xamarin.Mac completo alla riapertura delle opzioni di progetto.We fixed an issue where it is not possible to change the target framework version for Xamarin.Mac full on re-opening project options.
  • È stato risolto un problema in base al quale sembra che per i modelli con estensione xib sia necessario customObjectInstantitationMethod="direct" aggiungere.We fixed an issue where .xib templates seem to need customObjectInstantitationMethod="direct" added.
  • È stato risolto un problema per cui macOS 10.13 non viene visualizzato come destinazione della distribuzione.We fixed an issue where macOS 10.13 doesn't show up as a deployment target.
  • È stato risolto un problema per cui la piattaforma predefinita dei progetti macOS è x86 invece di AnyCPU.We fixed an issue where the default platform of macOS projects is x86, but should be AnyCPU.

Strumenti di testTest Tools

AccessibilitàAccessibility

  • In questa versione sono stati risolti numerosi problemi di accessibilità, ad esempio diversi problemi di VoiceOver nel debugger e nella creazione di certificati per gli sviluppatori iOS, nonché problemi relativi alla tastiera in Android SDK Manager.We fixed a number of accessibility issues in this release, including several VoiceOver issues in the Debugger and in creating iOS developer certificates, and Keyboard issues in the Android SDK Manager.

Controllo del codice sorgenteSource Control

È stato aggiunto il supporto per l'autenticazione di account Microsoft con Git e Azure DevOps/Team Foundation Server, che in precedenza richiedeva continuamente le credenziali senza riuscire a stabilire la connessione.We have added support for Microsoft Account authentication with Git and Azure DevOps/Team Foundation Server, which previously would continually prompt for credentials without successfully connecting.

GitGit

DebuggerDebugger

  • È stato risolto un problema in base al quale l'uso del visualizzatore di debug per i colori provoca un arresto anomalo dell'IDE.We fixed an issue where using the debugging visualizer for color crashes the IDE.
  • È stato risolto un problema in base al quale non è possibile creare punti di interruzione dopo aver usato il comando per eseguire il debug di un'applicazione.We fixed an issue where you can't create breakpoints after using the "Debug an Application" command.
  • È stato risolto un problema a causa del quale il debugger provoca un arresto anomalo di Visual Studio per Mac.We fixed an issue where the debugger caused Visual Studio for Mac to crash.
  • È stato risolto un problema a causa del quale le operazioni di debug C# vengono ignorate automaticamente se si punta a una directory non esistente per l'esecuzione.We fixed an issue where C# debugging operation is silently ignored if you point to non-existent directory to run.
  • È stato risolto un problema a causa del quale un'immagine da Xamarin.Forms.UriImageSource non viene visualizzata nella finestra del visualizzatore del debugger durante il debug di un'applicazione Xamarin.Forms.We fixed an issue where an image from Xamarin.Forms.UriImageSource is not displayed in the debugger’s visualiser window when debugging a Xamarin.Forms application.
  • È stato risolto un problema per il quale l'esecuzione del debugger non riusciva se eseguito in una console esterna su Mojave.We fixed an issue where the debugger would fail when running on an external console on Mojave.
  • È stato risolto un problema per il quale Roslyn genera un'eccezione irreversibile (System.ArgumentOutOfRangeException).We fixed an issue where Roslyn fatal exception (System.ArgumentOutOfRangeException).

Strumenti di AzureAzure Tools

  • Funzioni di Azure è ora composto da tre parole nella finestra di dialogo Nuovo progetto.Azure functions is now two words in the New Project Dialog.

ProfilerProfiler

  • È stato risolto un problema a causa del quale viene generata un'eccezione NullReferenceException dopo l'eliminazione delle preferenze VSMac.We fixed an issue where a NullReferenceException is thrown after deleting VSMac preferences.

InstallerInstaller

  • È stato risolto un problema a causa del quale le autorizzazioni di Android provocavano il blocco dell'applicazione.We fixed an issue where the Android Permissions were causing the application to hang.
  • È stata migliorata la segnalazione errori per i singoli componenti e la pagina di errore non verrà visualizzata immediatamente.We improved the error reporting for individual components and will not show the error page right away.
  • È stato corretto il bug per cui i symlink venivano interrotti quando veniva copiata una versione meno recente di Visual Studio per Mac per il backup.We fixed bug where symlinks were breaking when an older Visual Studio for Mac version was copied for backup.
  • È stato corretto un bug per cui vengono visualizzate ovunque icone non Retina/a bassa risoluzione.We fixed a bug where non-retina/low-res icons are being displayed everywhere.

UpdaterUpdater

  • È stato risolto un problema a causa del quale la verifica della disponibilità degli aggiornamenti può comportare più richieste di accesso.We fixed an issue where checking for updates can result in multiple prompts to sign in.
  • È stato risolto un problema a causa del quale l'aggiornamento senza riavvio del computer può causare strani errori di MSBuild.We fixed an issue where updating without restarting can cause strange MSBuild errors.

AltroOther


Commenti e suggerimentiFeedback and Suggestions

Le opinioni dei nostri clienti sono molto importanti per noi.We would love to hear from you! È possibile segnalare un problema tramite l'opzione Segnalare un problema dell'IDE di Visual Studio per Mac.You can report a problem through the Report a Problem option in Visual Studio for Mac IDE. È possibile tenere traccia dei commenti e dei suggerimenti inviati nel portale della Community degli sviluppatori.You can track your feedback, including suggestions, in the Developer Community portal.


Problemi notiKnown Issues

Di seguito è riportato un elenco di tutti i problemi noti esistenti di Visual Studio 2019 per Mac versione 8.0:The following is a list of all existing known issues in Visual Studio 2019 for Mac version 8.0:


Cronologia delle note sulla versione di Visual Studio per MacVisual Studio for Mac Release Notes History

È possibile visualizzare le versioni precedenti delle note sulla versione di Visual Studio 2017 per Mac nella pagina Cronologia delle note sulla versione.You can view prior versions of Visual Studio 2017 for Mac release notes on the Release notes history page.


In alto
Top of Page