Visual Studio Icon Note sulla versione di Visual Studio 2019 versione 16.5Visual Studio 2019 version 16.5 Release Notes



Developer Community | Requisiti di sistema | Compatibilità | Codice distribuibile | Condizioni di licenza | Blog | Novità di Visual Studio DocsDeveloper Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Whats New in Visual Studio Docs


Fare clic su un pulsante per scaricare la versione più recente di Visual Studio 2019.Click a button to download the latest version of Visual Studio 2019. Per istruzioni sull'installazione e sull'aggiornamento di Visual Studio 2019, vedere Aggiornare Visual Studio 2019 alla versione più recente.For instructions on installing and updating Visual Studio 2019, see the Update Visual Studio 2019 to the most recent release. Vedere anche le istruzioni su come eseguire l'installazione offline.Also, see instructions on how to install offline.

Community Download Button Professional Download Button Enterprise Download Button


Novità in Visual Studio 2019 versione 16.5What's New in Visual Studio 2019 version 16.5

Release di Visual Studio 2019 versione 16.5Visual Studio 2019 version 16.5 Releases

Blog di Visual Studio 2019Visual Studio 2019 Blog

Il blog di Visual Studio 2019 è la fonte ufficiale di informazioni dettagliate sul prodotto da parte del team Visual Studio Engineering.The Visual Studio 2019 Blog is the official source of product insight from the Visual Studio Engineering Team. È possibile trovare informazioni approfondite sulle versioni di Visual Studio 2019 nei post seguenti:You can find in-depth information about the Visual Studio 2019 releases in the following posts:

Partecipare alla discussione sulle note sulla versioneJoin the Release Note Discussion


Release Notes Icon Visual Studio 2019 versione 16.5.5Visual Studio 2019 version 16.5.5 New release icon

Data di rilascio: 12 maggio 2020released May 12, 2020

Correzioni in Visual Studio 2019 versione 16.5Fixed In This Release of Visual Studio 2019 version 16.5

Avviso di sicurezzaSecurity Advisory Notice

CVE-2020-1108 Vulnerabilità Denial Of Service .NET Core CVE-2020-1108 .NET Core Denial of Service Vulnerability

Un utente malintenzionato non autenticato remoto potrebbe sfruttare questa vulnerabilità inviando richieste appositamente predisposte all'applicazione .NET Core.A remote unauthenticated attacker could exploit this vulnerability by issuing specially crafted requests to the .NET Core application. L'aggiornamento della sicurezza risolve la vulnerabilità correggendo il modo in cui l'applicazione Web .NET Core gestisce le richieste Web.The security update addresses the vulnerability by correcting how the .NET Core web application handles web requests.

CVE-2020-1161 Vulnerabilità Denial Of Service .NET Core CVE-2020-1161 .NET Core Denial of Service Vulnerability

Un utente malintenzionato non autenticato remoto potrebbe sfruttare questa vulnerabilità inviando richieste appositamente predisposte all'applicazione ASP.NET Core.A remote unauthenticated attacker could exploit this vulnerability by issuing specially crafted requests to the ASP.NET Core application. L'aggiornamento della sicurezza risolve la vulnerabilità correggendo il modo in cui l'applicazione Web ASP.NET Core gestisce le richieste Web.The security update addresses the vulnerability by correcting how the ASP.NET Core web application handles web requests.


Release Notes Icon Visual Studio 2019 versione 16.5.4Visual Studio 2019 version 16.5.4

Data di rilascio: 14 aprile 2020released April 14, 2020

Correzioni in Visual Studio 2019 versione 16.5Fixed In This Release of Visual Studio 2019 version 16.5

Avviso di sicurezzaSecurity Advisory Notice

CVE-2020-0899 Vulnerabilità di elevazione dei privilegi in Microsoft Visual Studio CVE-2020-0899 Microsoft Visual Studio Elevation of Privilege Vulnerability

Esiste una vulnerabilità di elevazione dei privilegi quando il servizio di aggiornamento di Microsoft Visual Studio gestisce in modo errato le autorizzazioni per i file.An elevation of privilege vulnerability exists when Microsoft Visual Studio updater service improperly handles file permissions. Un utente malintenzionato che riesce a sfruttare questa vulnerabilità potrebbe sovrascrivere contenuto di file arbitrario nel contesto di sicurezza del sistema locale.An attacker who successfully exploited this vulnerability could overwrite arbitrary file content in the security context of the local system.

CVE-2020-0900 Vulnerabilità di elevazione dei privilegi del servizio di installazione delle estensioni di Visual Studio CVE-2020-0900 Visual Studio Extension Installer Service Elevation of Privilege Vulnerability

Esiste una vulnerabilità di elevazione dei privilegi quando il servizio di installazione delle estensioni di Visual Studio gestisce in modo errato le operazioni su file.An elevation of privilege vulnerability exists when the Visual Studio Extension Installer Service improperly handles file operations. Un utente malintenzionato che riesce a sfruttare questa vulnerabilità potrebbe eliminare file in posizioni arbitrarie con autorizzazioni elevate.An attacker who successfully exploited the vulnerability could delete files in arbitrary locations with elevated permissions.

CVE-2020-5260 Vulnerabilità di perdita delle credenziali in Git per Visual Studio a causa di convalida insufficiente degli URL CVE-2020-5260 Git for Visual Studio Credential Leak Vulnerability due to insufficient validation on URLs

Esiste una vulnerabilità di perdita delle credenziali quando gli URL creati appositamente vengono analizzati e inviati ai programmi di supporto per le credenziali.A credential leak vulnerability exists when specially crafted URLs are parsed and sent to credential helpers. Questa condizione può portare all'invio di credenziali all'host errato.This can lead to credentials being sent to the wrong host.


Release Notes Icon Visual Studio 2019 versione 16.5.3Visual Studio 2019 version 16.5.3

Data di rilascio: 7 aprile 2020released April 7, 2020

Correzioni in Visual Studio 2019 versione 16.5Fixed In This Release of Visual Studio 2019 version 16.5


Release Notes Icon Visual Studio 2019 versione 16.5.2Visual Studio 2019 version 16.5.2 New release icon

Data di rilascio: 31 marzo 2020released March 31, 2020

Correzioni in Visual Studio 2019 versione 16.5Fixed In This Release of Visual Studio 2019 version 16.5


Release Notes Icon Visual Studio 2019 versione 16.5.1Visual Studio 2019 version 16.5.1 New release icon

Data di rilascio: 24 marzo 2020released March 24, 2020

Correzioni in Visual Studio 2019 versione 16.5Fixed In This Release of Visual Studio 2019 version 16.5


Release Notes Icon Visual Studio 2019 versione 16.5.0Visual Studio 2019 version 16.5.0

Data di rilascio: 16 marzo 2020released March 16, 2020

In questa release di Visual Studio 2019 versione 16.5In This Release of Visual Studio 2019 version 16.5


IDE di Visual StudioVisual Studio IDE


  • Al passaggio del mouse viene visualizzato un pulsante Chiudi per ogni documento nell'elenco di overflow del gruppo di schedeOn-hover a close button appears for each document in the tab group overflow list
  • Selezione multipla di più directory di AzureMulti-selection of Azure directories
  • Nelle schede verticali sono stati implementati i miglioramenti suggeriti dagli utentiImplemented user suggested improvements in vertical tabs

DebugDebugging


Strumenti di AzureAzure Tools


C++C++


Linguaggio F# e relativi strumentiF# language and tools


  • Miglioramenti delle prestazioni per soluzioni di grandi dimensioniPerformance improvements for large solutions
  • Funzionalità di FSharp.Core in anteprima ora protette dal flag LangVersionPreview FSharp.Core features are now guarded by the LangVersion flag
  • Diverse correzioni di bug e vari miglioramentiVarious bug fixes and enhancements

Produttività .NET.NET Productivity


TestTesting


JavaScript/TypeScriptJavaScript/TypeScript


SQLSQL


Strumenti UWP/WPFUWP/WPF Tooling


XamarinXamarin


Dettagli sulle novità di Visual Studio versione 16.5Details of What's New in Visual Studio version 16.5

IDE di Visual StudioVisual Studio IDE

È ora possibile filtrare gli account in base al subset specifico delle istanze di Azure Active Directory che si vuole rendere disponibili per Visual StudioYou can now filter accounts to the specific subset of the Azure Active Directories you want to make available to Visual Studio

DebugDebugging

  • È ora possibile decompilare il codice gestito anche se non si dispone dei simboli. Ciò consente di esaminare il codice, controllare le variabili e impostare punti di interruzione.You can now decompile managed code even if you don't have the symbols, allowing you to look at code, inspect variables and set breakpoints.

  • È ora possibile connettersi ai processi in esecuzione nei contenitori Docker Windows tramite la finestra di dialogo Connetti a processo.You can now attach to processes running in Docker Windows containers via the Attach to Process dialog window.

Attach to process in Docker Windows container Enclave debugging
  • Sono stati apportati numerosi miglioramenti alla visualizzazione Allocazione nello strumento Verifica allocazione oggetti .NET.There have been several improvements to the Allocation view in the .NET Object Allocation Tracking tool. In primo luogo, la visualizzazione backtrace è stata spostata in un pannello separato per distinguere più facilmente tra il tipo di allocazione e le funzioni chiamate.First, the backtrace view has been moved to a separate panel to more easily distinguish between allocation type and functions called. In secondo luogo, gli alberi delle chiamate nella visualizzazione backtrace sono stati capovolti per diagnosticare più facilmente le funzioni che allocano la maggior parte della memoria.Second, the call trees in the backtrace view have been flipped to more easily diagnose what functions are allocating the most memory. Infine, sono state aggiunte icone che indicano i tipi valore e riferimento e altre due icone per le raccolte di valori e riferimenti saranno presto disponibili.Finally, icons indicating value and reference types have been added and two more icons for value and reference collections are coming soon!
Allocation View

C++C++

  • Gli sviluppatori C++ possono ora eseguire il training dei modelli IntelliCode nelle proprie codebase.C++ developers can now train IntelliCode models on their own codebases. Questa condizione è denominata modello di team per i completamenti, perché consente di sfruttare i vantaggi delle procedure consolidate dei team.We call this a Team Completions model because you benefit from your team's practices. Sono stati inoltre migliorati i suggerimenti IntelliCode per le variabili membro.Additionally, we've improved IntelliCode suggestions for member variables.

  • IntelliSense ora visualizza i nomi dei tipi in modo più leggibile quando si utilizza la libreria standard.IntelliSense now displays more readable type names when dealing with the Standard Library.

  • È stata aggiunta la possibilità di attivare/disattivare il funzionamento di INVIO, BARRA SPAZIATRICE e TAB come caratteri di commit e di attivare/disattivare l'uso di TAB per inserire un frammento di codice.We've added the ability to toggle whether Enter, Space, and Tab function as commit characters, and to toggle whether Tab is used to Insert Snippet. Queste impostazioni sono disponibili in Strumenti > Opzioni > Editor di testo > C/C++ > Avanzate > IntelliSense.Find these settings under Tools > Options > Text Editor > C/C++ > Advanced > IntelliSense. Disabling autocomplete options

  • È ora possibile usare il supporto nativo di Visual Studio per WSL quando si separa il sistema di compilazione dal sistema di distribuzione remoto.You can now leverage Visual Studio's native support for WSL when separating your build system from your remote deploy system. In questo modo è possibile eseguire la compilazione nativa in WSL e distribuire gli artefatti della compilazione in un secondo sistema remoto per il debug.This allows you to build natively on WSL and deploy the build artifacts to a second remote system for debugging. Questo flusso di lavoro è supportato sia dai progetti CMake che dai progetti Linux basati su MSBuild.This workflow is supported by both CMake projects and MSBuild-based Linux projects.

  • È ora possibile interagire con le connessioni remote archiviate tramite la riga di comando.You are now able to interact with your stored remote connections over the command line. Questa funzionalità risulta utile per le attività come il provisioning di un nuovo computer di sviluppo o la configurazione di Visual Studio nell'integrazione continua.This is useful for tasks such as provisioning a new development machine or setting up Visual Studio in continuous integration. C++ Connection Manager

  • Visual Studio ora supporta la modalità di compatibilità FIPS 140-2 quando si sviluppano applicazioni C++ destinate a un sistema Linux remoto.Visual Studio now supports FIPS 140-2 compliance mode when developing C++ applications that target a remote Linux system.

  • La copia dei file di origine per i progetti CMake destinati a un sistema Linux remoto è stata ottimizzata.The source file copy for CMake projects targeting a remote Linux system has been optimized. Visual Studio ora conserva un "file di impronte digitali" dell'ultimo set di origini copiate in modalità remota e ottimizza il comportamento in base al numero di file modificati.Visual Studio now keeps a "fingerprint file" of the last set of sources copied remotely and optimizes behavior based on the number of files that have changed.

  • Le funzionalità di esplorazione del codice, ad esempio Vai alla definizione e Trova tutti i riferimenti sono ora supportate per funzioni, variabili e destinazioni nei file di script CMake.Code navigation features such as Go To Definition and Find All References are now supported for functions, variables, and targets in CMake script files. Language services for CMake scripts

  • È possibile aggiungere, rimuovere e rinominare i file di origine e le destinazioni nei progetti CMake dall'IDE senza modificare manualmente gli script CMake.Add, remove, and rename source files and targets in your CMake projects from the IDE without manually editing your CMake scripts. Quando si aggiungono o rimuovono file con Esplora soluzioni, Visual Studio modifica automaticamente il progetto CMake.When you add or remove files with the Solution Explorer, Visual Studio will automatically edit your CMake project. È anche possibile aggiungere, rimuovere e rinominare le destinazioni del progetto dalla visualizzazione Destinazioni di Esplora soluzioni.You can also add, remove, and rename the project's targets from the Solution Explorer's Targets View. 'Add' menu in CMake Targets View

Linguaggio F# e relativi strumentiF# language and tools

In questa versione l'attenzione è stata rivolta principalmente al miglioramento delle prestazioni e della scalabilità delle codebase F# di grandi dimensioni in Visual Studio.The primary focus of this release has been improving the performance and scalability of large F# codebases in Visual Studio. Su questo lavoro ha influito la collaborazione diretta con clienti dotati di codebase di dimensioni molto grandi.This work was influenced by working directly with customers who have very large codebases. Per quanto riguarda le prestazioni, il lavoro è ancora in corso, ma se si ha una codebase di dimensioni medio-grandi, si dovrebbe notare una riduzione dell'utilizzo della memoria.The performance work is still ongoing, but if you have a medium-to-large sized codebase, you should see reduced memory usage.

Oltre ai miglioramenti relativi alle prestazioni, questa versione include un'ampia gamma di altre correzioni, a molte delle quali ha contribuito la splendida community OSS di F#.Beyond performance enhancements, this release includes a variety of other fixes, many of which were contributed by our wonderful F# OSS community.

Linguaggio F#F# language

Alcune funzionalità del linguaggio F# in anteprima sono state unite.Several F# preview language features have been merged. È possibile provarle impostando LangVersion su preview nel file di progetto.You can try them out by setting your LangVersion to preview in your project file.

F# (compilatore)F# compiler

Libreria principale di F#F# core library

Strumenti F# per Visual StudioF# tools for Visual Studio

Esperienza di sviluppo open source F#F# open source development experience

  • La build FSharp.Compiler.Service nel repository F# è passata all'uso di .NET SDK grazie al contributo di Chet HuskThe FSharp.Compiler.Service build in the F# repository has been moved to use the .NET SDK, contributed by Chet Husk

Produttività .NET.NET Productivity

È ora possibile trasformare un frammento di codice da un metodo esistente in una funzione locale.You can now turn a fragment of code from an existing method into a local function. Evidenziare il codice che si vuole estrarre.Highlight the code you want extracted. Premere (Ctrl+ . ) per attivare il menu Azioni rapide e refactoring.Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selezionare Estrai funzione locale.Select Extract local function.

Extract local function

È ora possibile rendere statici i membri.You can now make members static. Posizionare il cursore sul nome del membro.Place your cursor on the member name. Premere (Ctrl+ . ) per attivare il menu Azioni rapide e refactoring.Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selezionare Imposta come statici.Select Make static.

Make members static

Si possono ora semplificare le interpolazioni di stringhe, se possibile.You can now simplify string interpolations when possible. Posizionare il cursore sull'interpolazione di stringhe.Place your cursor on the string interpolation. Premere (Ctrl+ . ) per attivare il menu Azioni rapide e refactoring.Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selezionare Semplifica l'interpolazione.Select Simplify interpolation.

Simplify-string-interpolation

È ora possibile escludere i file o le cartelle generate durante l'esecuzione degli analizzatori.You now have the option to exclude generated files or folders when running analyzers. Creare un file EditorConfig e contrassegnare i file o le cartelle necessarie come generate con la sintassi seguente:Create an EditorConfig file and mark the required files or folders as generated with the following syntax:

EditorConfig option to exclude generated files or folders

Gli autori di analizzatori possono ora distribuire i refactoring di codice personalizzato come pacchetto NuGet, mentre in precedenza potevano essere distribuiti solo come VSIX.Analyzer authors can now distribute custom code refactorings as a NuGet package when previously it could only be distributed as a VSIX.

TestTesting

È ora possibile profilare un test .NET Core.You can now profile a .NET Core test. Si noti che i prerequisiti per la profilatura prevedono che i progetti .NET Core siano configurati per generare file PDB completi.Note that the prerequisites for profiling are that your .NET Core projects are configured to generate Full PDB’s. È anche consigliabile eseguire l'aggiornamento alla versione minima 16.4 per Microsoft.Test.SDK.It is also recommended that you upgrade to minimum version of 16.4 for the Microsoft.Test.SDK. In questo modo è possibile profilare i test nelle impostazioni dell'architettura x86 e x64.This will allow you to profile tests in both x86 and x64 architecture settings. Per profilare un test, selezionare "Profilo" dal menu di scelta rapida in Esplora test.To profile a test, select “Profile” from the context menu in the Test Explorer. La profilatura dei test è supportata tramite la strumentazione statica e il documento Esplora prestazioni (VSP) in Visual Studio.Test profiling is supported through static instrumentation and Performance Explorer (.vsp) document in Visual Studio.

L'impostazione predefinita per l'architettura del processore per i test ora ha una terza opzione "Automatica" oltre alle opzioni x64 e x86.The default setting for processor architecture for tests now has a third option ‘Auto’ in addition to the x64 and x86 options. L'opzione "Automatica" supporta architetture predefinite diverse per i test che hanno come destinazione .NET Framework rispetto ai test .NET Core.‘Auto’ supports different default architectures for tests targeting .NET Framework vs. .NET Core tests. Per impostazione predefinita, in .NET Framework vengono eseguiti test x86, mentre in .NET Core vengono eseguiti test x64..NET Framework tests default to x86 test execution and .NET Core tests default to x64. L'opzione "Automatica" consente all'utente di lasciare non impostata l'architettura e supporta impostazioni predefinite diverse per questi Framework.‘Auto’ allows the architecture choice to be left unset by the user and supports different defaults for these frameworks. In precedenza, x86 era l'impostazione predefinita in tutti i casi, tuttavia per i test .NET Core è stata introdotta l'impostazione predefinita x64 ed è stato quindi necessario fare in modo che l'impostazione predefinita fosse diversa.Previously x86 was the default in all cases, however .NET Core tests were introduced defaulting to x64 and thus the need for the default setting to diverge.

Questa versione contiene importanti miglioramenti delle prestazioni nell'individuazione e nell'esecuzione dei test, soprattutto nelle soluzioni di grandi dimensioni con un numero elevato di test.This release contains significant perf improvements in test discovery and execution, especially in large solutions with lots of tests. Si consiglia di eseguire i propri benchmark per valutare quanto ciò sia importante.We encourage you to run your own benchmarks to evaluate how valuable this is. Con la base di codice Roslyn (compilatore C# e Visual Basic), Esplora test ha ridotto il consumo di memoria dal 50 al 60% e i tempi di caricamento fino al 60%.With the Roslyn code base (the C# and Visual Basic compiler), the test explorer reduced memory consumption from 50 to 60% and cut load time by up to 60%.

Miglioramento della diagnostica per Live Unit Testing.Better diagnostics are now available for Live Unit Testing. Quando una compilazione di Live Unit Testing non riesce, informazioni di diagnostica aggiuntive vengono stampate nell'output, inclusi i log di MSBuild.When a Live Unit Testing build fails additional diagnostic info will print to the output including MSBuild logs. Vengono anche segnalati i casi in cui il percorso dell'output è hardcoded.It will also report cases where the output path is hardcoded.

JavaScript/TypeScriptJavaScript/TypeScript

Ricerca di Visual Studio ora supporta la ricerca di tipi e membri nei file TypeScript e JavaScript.VS Search now supports the ability to search for types and members in TypeScript and JavaScript files. È supportata anche la ricerca di blocchi JavaScript nei file di markup aperti (ad esempio HTML, CSHTML)There is also support for searching JavaScript blocks in open markup files (i.e. HTML, CSHTML)

Visual Studio supporta ora ESLint per i file TypeScript: è disponibile una configurazione globale con un set di regole consigliate. In alternativa, ESLint può essere configurato in locale su un progetto con personalizzazione completa.Visual Studio now supports ESLint for Typescript files: there is a global configuration with a set of recommended rules or ESLint can be set up locally to a project with full customization. Per altre informazioni e istruzioni, vedere la pagina di GitHubMore information and instructions available on our GitHub page

XamarinXamarin

  • Con Ricaricamento rapido XAML le modifiche vengono ora aggiornate in più destinazioni Xamarin.Forms contemporaneamente.With XAML Hot Reload, you can now see your changes updated on multiple Xamarin.Forms targets at once. Eseguire il debug dell'app con progetti di avvio multipli, modificare il codice XAML e fare clic su Salva per visualizzare contemporaneamente le modifiche in Android e iOS.Debug your app with multiple startup projects, change your XAML, and hit Save to show the changes on Android and iOS simultaneously.

  • È ora possibile visualizzare una gerarchia dei controlli Xamarin.Forms nel riquadro Struttura documento.You can now see a hierarchy of your Xamarin.Forms controls in the Document Outline pane. In Windows è possibile aprirlo con CTRL+ALT+T (Visualizza > Altre finestre > Struttura documento).On Windows, it can be opened with Ctrl+Alt+T (View > Other Windows > Document Outline). In Mac è possibile aprirlo tramite Visualizzazioni > Riquadri > Struttura documento.On Mac, you can open it via Views > Pads > Document Outline.

  • È ora possibile applicare le modifiche alle risorse Android in fase di esecuzione usando Applica modifiche - Android.You can now apply Android resource changes at runtime using Android Apply Changes. Questa funzionalità consente di visualizzare rapidamente le modifiche apportate ai file di risorse Android (layout XML, risorse drawable e così via) in un dispositivo o un emulatore Android senza dover riavviare l'applicazione.This feature allows you to quickly see changes made to your Android resource files (XML layouts, drawables, etc) on an Android device or emulator without requiring the application to be restarted.

Android Apply Changes
  • È ora possibile generare profili personalizzati quando si usa la traccia di avvio nell'applicazione Android.You can now generate your own custom profiles when using startup tracing in your Android application. In questo modo l'esperienza di avvio risulterà ancora più efficace con un aumento minimo delle dimensioni del pacchetto dell'applicazione Android.This provides you an even more performant startup experience with a minimal increase to APK size.
  • È ora possibile generare i binding Xamarin.Android nelle librerie di Kotlin.You can now generate Xamarin.Android bindings against Kotlin libraries.
  • È ora possibile usare l'utilità di unione dei manifesti di Google quando si uniscono file AndroidManifest.xml nei progetti Android.You can now use the Google Manifest Merger when merging AndroidManifest.xml files in your Android projects. In questo modo è possibile personalizzare il modo in cui ogni manifesto e il relativo contenuto verranno uniti.This allows you to customize how each manifest and its contents will be merged. Per altre informazioni sulle regole applicabili, vedere Merge multiple manifest files (Unire più file manifesto).For more details on rules that can be applied, please see Merge multiple manifest files.
  • È ora possibile acconsentire esplicitamente a una nuova opzione che ricaricherà automaticamente tutte le aree di progettazione aperte quando vengono apportate modifiche alla codebase.You can now opt-into a new option which will automatically reload all opened designer surfaces when any modification is done to your codebase.
Custom Control Quick Changes for Android Layouts
  • Sfruttare i vantaggi delle funzionalità consolidate dell'editor per rendere IntelliSense ancora più reattivo e preciso.Take advantage of consolidated editor functionality to offer more responsive and precise IntelliSense. Le modifiche apportate includono un completamento più efficiente dei costrutti XML comuni, ad esempio le virgolette per gli attributi, e l'aggiornamento automatico dei nomi dei tag di fine.This includes many changes such as improved completion for common XML constructions such as attribute quotes and updating end tag names automatically. È possibile controllare questi comportamenti tramite le preferenze dell'editor XML di Android:You can control these behaviors via Android XML editor preferences:
Android XML IntelliSense Options

Strumenti UWP/WPFUWP/WPF Tooling

  • Il trascinamento di un'immagine dal progetto in Esplora soluzioni all'editor XAML ora genera un tag immagine XAML con la proprietà Source impostata sul percorso dell'immagine corretto.Dragging an image from your project solution explorer into the XAML editor will now generate a XAML image tag with the Source property set to the correct image path.

  • La modifica del colore "Sfondo tavola da disegno" per la finestra di progettazione XAML ora funziona con i progetti .NET Core WPF (Opzioni > Ambiente > Tipi di carattere e colori, quindi passare alle impostazioni della finestra di progettazione XAML e aggiornare Sfondo tavola da disegno)Changing “Artboard Background” color for the XAML Designer now works with WPF .NET Core projects (Options > Environment > Fonts and Colors, then change to XAML Designer settings and update Artboard Background)

  • La finestra di progettazione XAML ora supporta il caricamento di progetti .NET Core 3.x che includono le impostazioni PublishSingleFile, RuntimeIdenfier e PublishTrimmed nel file di progetto (csproj).XAML Designer now supports loading .NET Core 3.x Projects that include PublishSingleFile, RuntimeIdenfier and PublishTrimmed settings in their project file (csproj). Tenere presente che queste impostazioni rallentano le prestazioni della finestra di progettazione.Note that including these settings slows down designer performance.

Problemi principali dalla Developer CommunityTop Issues From Developer Community



Problemi notiKnown Issues

Vedere tutti i problemi e le soluzioni alternative disponibili in Visual Studio 2019 versione 16.5 facendo clic sul collegamento seguente.See all issues and available workarounds in Visual Studio 2019 version 16.5 by following the below link.

Visual Studio 2019 Known Issues Visual Studio 2019 Known Issues


Feedback e suggerimentiFeedback and suggestions

Le opinioni dei nostri clienti sono molto importanti per noi.We would love to hear from you! È possibile segnalare un problema tramite l'opzione Segnala un problema disponibile nell'angolo superiore destro del programma di installazione o dell'IDE di Visual Studio.For issues, let us know through the Report a Problem option in the upper right-hand corner of either the installer or the Visual Studio IDE itself. Alla classeThe Feedback Icon L'icona si trova nell'angolo superiore destro.icon is located in the upper right-hand corner. È possibile inviare un suggerimento sul prodotto o monitorare lo stato dei problemi nella community degli sviluppatori di Visual Studio, dove è possibile porre domande, trovare risposte e proporre nuove funzionalità.You can make a product suggestion or track your issues in the Visual Studio Developer Community, where you can ask questions, find answers, and propose new features. È anche possibile usufruire gratuitamente del supporto per l'installazione con Assistenza live chat.You can also get free installation help through our Live Chat support.


BlogBlogs

Sfruttare i vantaggi delle informazioni dettagliate e delle raccomandazioni disponibili nel sito dei blog sugli strumenti di sviluppo per mantenersi aggiornati su tutte le nuove versioni con post di approfondimento su una vasta gamma di funzionalità.Take advantage of the insights and recommendations available in the Developer Tools Blogs site to keep you up-to-date on all new releases and include deep dive posts on a broad range of features.


Cronologia delle note sulla versione di Visual Studio 2019Visual Studio 2019 Release Notes History

Per altre informazioni relative a versioni precedenti di Visual Studio 2019, vedere la pagina Cronologia delle note sulla versione di Visual Studio 2019.For more information relating to past versions of Visual Studio 2019, see the Visual Studio 2019 Release Notes History page.


Inizio pagina

Top of Page