SecurityCriticalAttribute SecurityCriticalAttribute SecurityCriticalAttribute SecurityCriticalAttribute Constructors

定義

オーバーロード

SecurityCriticalAttribute() SecurityCriticalAttribute() SecurityCriticalAttribute()

SecurityCriticalAttribute クラスの新しいインスタンスを初期化します。Initializes a new instance of the SecurityCriticalAttribute class.

SecurityCriticalAttribute(SecurityCriticalScope) SecurityCriticalAttribute(SecurityCriticalScope) SecurityCriticalAttribute(SecurityCriticalScope) SecurityCriticalAttribute(SecurityCriticalScope)

指定したスコープを使用して、SecurityCriticalAttribute クラスの新しいインスタンスを初期化します。Initializes a new instance of the SecurityCriticalAttribute class with the specified scope.

SecurityCriticalAttribute() SecurityCriticalAttribute() SecurityCriticalAttribute()

SecurityCriticalAttribute クラスの新しいインスタンスを初期化します。Initializes a new instance of the SecurityCriticalAttribute class.

public:
 SecurityCriticalAttribute();
public SecurityCriticalAttribute ();
Public Sub New ()

SecurityCriticalAttribute(SecurityCriticalScope) SecurityCriticalAttribute(SecurityCriticalScope) SecurityCriticalAttribute(SecurityCriticalScope) SecurityCriticalAttribute(SecurityCriticalScope)

指定したスコープを使用して、SecurityCriticalAttribute クラスの新しいインスタンスを初期化します。Initializes a new instance of the SecurityCriticalAttribute class with the specified scope.

public:
 SecurityCriticalAttribute(System::Security::SecurityCriticalScope scope);
public SecurityCriticalAttribute (System.Security.SecurityCriticalScope scope);
new System.Security.SecurityCriticalAttribute : System.Security.SecurityCriticalScope -> System.Security.SecurityCriticalAttribute
Public Sub New (scope As SecurityCriticalScope)

パラメーター

scope
SecurityCriticalScope SecurityCriticalScope SecurityCriticalScope SecurityCriticalScope

属性のスコープを指定する列挙値の 1 つ。One of the enumeration values that specifies the scope of the attribute.

注釈

このコンストラクターは、.NET Framework バージョン2.0 の透過性モデルとの互換性のために用意されています。This constructor is provided for compatibility with the .NET Framework version 2.0 transparency model. には.NET Framework 4.NET Framework 4適用されません。It does not apply to the .NET Framework 4.NET Framework 4. 詳細については、「透過的セキュリティコード、レベル 2」を参照してください。For more information, see Security-Transparent Code, Level 2.

適用対象