テスト用に iPad と Mac で Office アドインをサイドロードするSideload Office Add-ins on iPad and Mac for testing

Office for iOS でアドインを実行するしくみを確認するには、iTunes を利用し、アドインのマニフェストを iPad にサイドロードするか、Office for Mac で直接、アドインのマニフェストをサイドロードします。このアクションでは、実行中、ブレークポイントを設定したり、アドインのコードをデバッグしたりできませんが、その動作を確認したり、UI が使えることと適切にレンダリングされることを確認できます。To see how your add-in will run in Office for iOS, you can sideload your add-in's manifest onto an iPad using iTunes, or sideload your add-in's manifest directly in Office for Mac. This action won't enable you to set breakpoints and debug your add-in's code while it's running, but you can see how it behaves and verify that the UI is usable and rendering appropriately.

Office for iOS の前提条件Prerequisites for Office for iOS

  • iTunes がインストールされた Windows または Mac コンピューター。A Windows or Mac computer with iTunes installed.

  • iPad 用 Excel がインストールされた iOS 8.2 以上の iPad と同期ケーブル。An iPad running iOS 8.2 or later with Excel for iPad installed, and a sync cable.

  • テスト対象アドインのマニフェスト .xml ファイル。The manifest .xml file for the add-in you want to test.

Office for Mac の前提条件Prerequisites for Office for Mac

  • OS X v10.10 "Yosemite" 以降が動作し、 Office for Mac がインストールされている Mac。A Mac running OS X v10.10 "Yosemite" or later with Office for Mac installed.

  • Word for Mac バージョン 15.18 (160109)。Word for Mac version 15.18 (160109).

  • Excel for Mac バージョン 15.19 (160206)。Excel for Mac version 15.19 (160206).

  • PowerPoint for Mac バージョン 15.24 (160614)PowerPoint for Mac version 15.24 (160614)

  • テスト対象アドインのマニフェスト .xml ファイル。The manifest .xml file for the add-in you want to test.

iPad 用 Excel または Word のアドインをサイドロードするSideload an add-in on Excel or Word for iPad

  1. 同期ケーブルを使用し、iPad をコンピューターに接続します。iPad を初めてコンピューターに接続する場合、[このコンピューターを信頼しますか?] と問われます。[信頼する] を選択して続行します。Use a sync cable to connect your iPad to your computer. If you're connecting the iPad to your computer for the first time, you'll be prompted with Trust This Computer?. Choose Trust to continue.

  2. iTunes で、メニュー バーの下にある [iPad] のアイコンをクリックします。In iTunes, choose the iPad icon below the menu bar.

    iTunes の iPad アイコン

  3. iTunes の左側の [設定] で、 [App] をクリックします。Under Settings on the left side of iTunes, choose Apps.

    iTunes アプリの設定

  4. iTunes の右側で、 [ファイル共有] までスクロールしてから、 [アドイン] 列で [Excel] または [Word] をクリックします。On the right side of iTunes, scroll down to File Sharing, and then choose Excel or Word in the Add-ins column.

    iTunes のファイル共有

  5. [Excel] 列または [Word ドキュメント] 列の下部で、 [ファイルの追加] をクリックしてから、サイドロードするアドインのマニフェスト .xml ファイルを選択します。At the bottom of the Excel or Word Documents column, choose Add File, and then select the manifest .xml file of the add-in you want to sideload.

  6. iPad で Excel または Word アプリを開きます。Excel または Word アプリがすでに実行されている場合は、 [ホーム] ボタンを選択して、アプリを閉じて再起動します。Open the Excel or Word app on your iPad. If the Excel or Word app is already running, choose the Home button, and then close and restart the app.

  7. ドキュメントを開きます。Open a document.

  8. [挿入] タブで [アドイン] をクリックします。 [アドイン] UI の [開発者] という見出しの下に、サイドロードしたアドインが表示され、挿入のために選択できるようになっています。Choose Add-ins on the Insert tab. Your sideloaded add-in is available to insert under the Developer heading in the Add-ins UI.

    Excel アプリでアドインを挿入

Office for Mac でアドインをサイドロードするSideload an add-in on Office for Mac

注意

Outlook for Mac アドインをサイドロードするには、「テスト用に Outlook アドインをサイドロードする」を参照してください。To sideload Outlook 2016 for Mac add-in, see Sideload Outlook add-ins for testing.

  1. Terminal を開き、次のフォルダーの 1 つに移動します。そこにアドインのマニフェスト ファイルを保存します。wef フォルダーがコンピューターにない場合、作成します。Open Terminal and go to one of the following folders where you'll save your add-in's manifest file. If the wef folder doesn't exist on your computer, create it.

    • Word の場合: /Users/<username>/Library/Containers/com.microsoft.Word/Data/documents/wefFor Word: /Users/<username>/Library/Containers/com.microsoft.Word/Data/documents/wef
    • Excel の場合: /Users/<username>/Library/Containers/com.microsoft.Excel/Data/documents/wefFor Excel: /Users/<username>/Library/Containers/com.microsoft.Excel/Data/documents/wef
    • PowerPoint の場合: /Users/<username>/Library/Containers/com.microsoft.Powerpoint/Data/documents/wefFor PowerPoint: /Users/<username>/Library/Containers/com.microsoft.Powerpoint/Data/documents/wef
  2. Finderopen . コマンドを使用してフォルダーを開きます (ピリオドまたはドットを含みます)。アドインのマニフェスト ファイルをこのフォルダーにコピーします。Open the folder in Finder using the command open . (including the period or dot). Copy your add-in's manifest file to this folder.

    Office for Mac の Wef フォルダー

  3. Word を起動し、ドキュメントを開きます。既に起動している場合は、Word を再起動します。Open Word, and then open a document. Restart Word if it's already running.

  4. Word で、[挿入] > [アドイン] > [個人用アドイン] (ドロップダウン メニュー) を選択し、アドインを選択します。In Word, choose Insert > Add-ins > My Add-ins (drop-down menu), and then choose your add-in.

    Office for Mac のマイ アドイン

    重要

    サイドロードしたアドインは [個人用アドイン] ダイアログには表示されません。ドロップダウン メニュー内にのみ表示されます ([挿入] タブの [個人用アドイン] の右にある小さい下向き矢印)。サイドロードしたアドインは、このメニューの見出し [開発者向けアドイン] の下に一覧表示されます。Sideloaded add-ins will not show up in the My Add-ins dialog box. They are only visible within the drop-down menu (small down-arrow to the right of My Add-ins on the Insert tab). Sideloaded add-ins are listed under the Developer Add-ins heading in this menu.

  5. アドインが Word に表示されることを確認します。Verify that your add-in is displayed in Word.

    Office for Mac に表示される Office アドイン

    注意

    Office for Mac では、パフォーマンス上の理由でアドインがよくキャッシュされます。Add-ins are cached often in Office for Mac, for performance reasons. アドインの開発中にそれを再読み込みする必要がある場合は、Users/<usr>/Library/Containers/com.Microsoft.OsfWebHost/Data/ フォルダーをクリアにすることが可能です。Add-ins are cached often in Office for Mac, for performance reasons. If you need to force a reload of your add-in while you're developing it, you can clear the Users/<usr>/Library/Containers/com.Microsoft.OsfWebHost/Data/ folder. フォルダーが存在しない場合、com.microsoft.Office365ServiceV2/Data/Caches/com.microsoft.Office365ServiceV2/ フォルダーのファイルをクリアします。If that folder doesn't exist, clear the files in the com.microsoft.Office365ServiceV2/Data/Caches/com.microsoft.Office365ServiceV2/ folder.

関連項目See also