Power BI のスライサー

適用対象: ✔️ Power BI Desktop ✔️ Power BI サービス

レポートを見る人が売り上げ全体の指標を調べることができるだけでなく、個々の地域マネージャーや異なる期間の実績に注目することもできるようにしたい場合があります。 個別のレポートや比較グラフを作成してもかまいません。 [フィルター] ペインにフィルターを追加することもできます。 または、"スライサー" を使用することもできます。 スライサーは、フィルター処理を行うもう 1 つの方法です。 これらを使うと、レポートの他の視覚化に表示されるデータセットの部分を絞り込むことができます。

Animation of Slicer in action.

この記事では、無料の小売りの分析のサンプルを使用して、基本的なスライサーを作成して書式設定する手順を説明します。 また、スライサーによって影響を受ける視覚エフェクトの制御、他のページのスライサーとの同期、スライサーのフィルター処理と書式設定についても説明します。

次の別の記事では、特定の種類のスライサーを作成する方法について説明しています。

スライサーを使用する場合

スライサーは、次のような場合に最適です。

  • レポート キャンバスによく使うフィルターまたは重要なフィルターを表示してアクセスしやすくする。
  • ドロップダウン リストを開くことなく、現在のフィルターされた状態を簡単に表示する。
  • データ テーブル内の不要で非表示になっている列でフィルター処理する。
  • 重要な視覚化の横にスライサーを配置して、より絞り込まれたレポートを作成する。

Power BI スライサーでは次の機能はサポートされていません。

  • 入力フィールド
  • ドリルダウン オプション

スライサーの作成

このスライサーでは、地区マネージャーによってデータをフィルター処理します。 この手順に従って作業する場合は、小売りの分析のサンプル PBIX ファイルをダウンロードしてください。

  1. Power BI Desktop を開き、メニュー バーの [ファイル]>[レポートを開く] を選択します。

  2. Retail Analysis Sample PBIX.pbix ファイルを参照し、[開く] を選択します。

  3. 左側のペインで、[レポート] アイコン を選択し、レポート ビューでファイルを開きます。

  4. Overview ページを開き、レポート キャンバスで何も選択されていない状態で、[視覚化] ウィンドウの [スライサー] アイコン を選択して新しいスライサーを作成します。

  5. 新しいスライサーを選択した状態で、 [フィールド] ペインから District テーブルを展開し、 [DM] を選択してスライサーを設定します。

    これで、新しいスライサーに地区マネージャーの名前とその選択ボックスの一覧が設定されます。

    Screenshot of Slicer populated with district manager names.

  6. キャンバス上の要素のサイズを変更してドラッグし、スライサーのスペースを確保します。 スライサーのサイズを小さくしすぎると、項目が切れてしまいます。

  7. スライサーの名前を選択し、ページ上の他の視覚エフェクトに与える影響を確認します。 名前を再び選んで選択を解除したり、Ctrl キーを押しながら複数の名前を選択したりします。 すべての名前を選ぶと、何も選ばない場合と同じ効果になります。

  8. または、 [視覚化] ペインで [書式] (ペイント ローラー アイコン) を選択して、スライサーの書式を設定します。

    オプションは非常に多いため、ここですべてを説明することはできません。いろいろ試して最適なスライサーを作成してください。 次の図の 1 番目のスライサーは、横方向に配置され、項目の背景が色付きになっていいます。 2 番目のスライサーは、縦方向の配置で色付きのテキストと、より標準的な外観になっています。

    Screenshot of Formatted slicer.

    ヒント

    スライサーのリスト項目は、既定では昇順に並べられます。 並べ替え順序を逆の降順にするには、スライサーの右上隅にある省略記号 ( ... ) を選択し、ドロップダウン リストで [降順で並べ替え] を選択します。

スライサーによって影響を受けるページ ビジュアルを制御する

既定では、レポート ページ上のスライサーは、他のスライサーも含めて、そのページ上にある他のすべての視覚エフェクトに影響します。 作成したリストと日付スライサーで値を選択して、他の視覚エフェクトへの影響を確認してください。 フィルター選択されるデータは、両方のスライサーで選択した値の積集合です。

一部のページ視覚エフェクトを他のスライサーの影響から除外するには、ビジュアル対話を使用します。 Overview ページの Total Sales Variance by FiscalMonth and District Manager グラフには、月ごとの地区マネージャーの全体的な比較データが表示されており、これは表示したままにする必要がある情報です。 ビジュアル対話を使用して、スライサーを選択してもこのグラフがフィルター処理されないようにします。

  1. レポートの Overview ページに移動し、前に作成した DM スライサーを選択します。

  2. Power BI Desktop のメニューで、 [ビジュアル ツール][書式] メニューを選択し、 [相互作用を編集] を選択します。

    それぞれに [フィルター] オプションと [なし] オプションが含まれるフィルター コントロール が、ページ上のすべてのビジュアルの上に表示されます。 最初は、すべてのコントロールの [フィルター] オプションがあらかじめ選択されています。

  3. Total Sales Variance by FiscalMonth and District Manager グラフの上のフィルター コントロールで [なし] オプションを選択して、DM スライサーのフィルター処理を停止します。

相互作用の編集について詳しくは、「Power BI レポート内でのビジュアルの相互作用を変更する」をご覧ください。

他のページでスライサーを同期して使用する

スライサーを同期して、レポート内の任意のページまたはすべてのページで使用できます。

現在のレポートの District Monthly Sales ページには District Manager スライサーがありますが、そのスライサーが New Stores ページでも必要な場合はどうでしょうか。 New Stores ページにはスライサーがありますが、Store Name 情報のみが提供されています。 [スライサーの同期] ペインでは、いずれかのページでスライサーを選択すると、3 つすべてのページの視覚エフェクトに反映されるよう、District Manager スライサーをこれらのページと同期できます。

  1. Power BI Desktop の [表示] リボンで [スライサーの同期] を選択します。

    Screenshot of Sync slicers selection in Power BI Desktop.

    または、Power BI サービスで、[表示] メニューの [スライサー ウィンドウの同期][オン] に設定します。

    Screenshot of Sync slicers selection in the Power BI service.

    [スライサーの同期] ペインが、 [フィルター] ペインと [視覚化] ペインの間に表示されます。

    Screenshot of Sync slicers pane.

  2. レポートの District Monthly Sales ページで、District Manager スライサーを選択します。

    Overview ページに District Manager (DM) スライサーを既に作成してあるため、 [スライサーの同期] ペインは次のように表示されます。

    Screenshot of Sync District Monthly Sales slicer.

  3. [スライサーの同期] ペインの [同期] 列で、OverviewDistrict Monthly SalesNew Stores の各ページを選択します。

    この選択により、District Monthly Sales スライサーが、これら 3 つのページ間で同期されます。

  4. [スライサーの同期] ペインの [表示] 列で、New Stores ページを選択します。

    この選択により、District Monthly Sales スライサーが、これら 3 つのページで表示されるようになります。 [スライサーの同期] ペインの表示は次のようになります。

    Screenshot of Select pages in Sync slicers.

  5. スライサーの同期の効果を観察し、他のページで表示されるようにします。 District Monthly Sales ページで、District Manager スライサーに Overview ページと同じ選択が表示されるようになったことに注意してください。 New Stores ページでは、District Manager スライサーが表示されるようになり、その選択により、Store Name スライサーに表示される選択が影響を受けます。

    ヒント

    同期されたページのスライサーは、最初は元のページと同じサイズおよび位置に表示されますが、各ページで個別に、同期されたスライサーを移動したり、サイズや書式設定を変更したりできます。

    注意

    他のページへのスライサーの同期だけを設定して、表示を設定しない場合でも、他のページで行われたスライサーの選択により、そのページのデータがフィルター処理されます。

個別のスライサーを同期する

また、2 つ以上の個別のスライサーを同期することもできます。 ソースをまたがるグループの関係に依存せずに、複数のソースで同じ選択を行うことが必要な場合があるため、これは複合モデルを使用するときに特に便利です。 2 つ以上の別々のスライサーを同期するには、それらのスライサーをグループの一部としてマークします。

  1. [表示] メニューから選択することにより、 [スライサーの同期] ペインが表示されるようにします。

    Screenshot of Sync slicers pane.

  2. グループに含めるスライサーの 1 つを選択します。 [スライサーの同期] ペインで [詳細オプション] を展開し、グループの名前を入力します。 任意の名前を付けることができます。

    Screenshot of entering a group name in the Advanced section of the Sync slicers pane.

  3. 次に、最初のスライサーと同期する別のスライサーを選択し、 [グループ名] ボックスに同じ名前を入力します。 必ず正確に入力してください。

  4. シナリオに応じて、 [フィールドの変更を他のスライサーと同期する][フィルター変更を他のスライサーと同期する] の一方または両方を選択します。

    • スライサーによって設定されたフィルターが同期されるように、スライサーの同期だけを維持する場合は、 [フィルター変更を他のスライサーと同期する] を選択します。
    • スライサーの基になっているフィールドに対する変更もグループ間で同期されるようにする場合は、 [フィールドの変更を他のスライサーと同期する] を選択します。
  5. スライサーのいずれかで選択を変更して、意図したように同期が動作することをテストします。 グループの他のスライサーでそれが更新されるのを確認します。

スライサーのフィルター処理

ビジュアル レベルのフィルターをスライサーに適用すれば、スライサーに一覧表示される値の数を減らすことができます。 たとえば、リスト スライサーから空白値をフィルターで除外したり、範囲スライサーから特定の日付をフィルターで除外したりすることができます。 これを行う場合、影響を受けるのは "スライサーに表示される値" のみであり、選択時に "スライサーによって他のビジュアルに適用されるフィルター" は影響を受けません。 たとえば、特定の日付のみを表示するように、範囲スライサーにフィルターを適用するとします。 スライサー上の選択では、その範囲の最初と最後の日付しか表示されませんが、他の視覚エフェクトには引き続き他の日付が表示されます。 スライサーで選択範囲を変更すると、他のビジュアルが更新されるのがわかります。 スライサーをクリアすると、すべての日付が再度表示されます。

ビジュアル レベルのフィルターの詳細については、フィルターの種類に関するページを参照してください。

スライサーの書式設定

スライサーの種類に応じて、異なる書式設定オプションを使用できます。 方向、レスポンシブ レイアウト、および項目の色分けを使用して、標準の一覧項目ではなくボタンやタイルを生成し、異なる画面サイズやレイアウトに合わせてスライサー項目のサイズが変化するようにできます。

  1. いずれかのページで [District Manager] スライサーを選択した状態で、[視覚化] ウィンドウで [書式] アイコン Screenshot of Format icon. を選択して書式設定コントロールを表示します。

    Screenshot of Format selection.

  2. 各カテゴリの横にあるドロップダウン矢印を選択してオプションを表示し、編集します。

[全般] オプション

  1. [書式][全般] を選択し、 [輪郭の色] で赤を選択してから、 [輪郭の太さ]2 に変更します。

    この設定により、ヘッダーと項目の輪郭と下線の色と太さが変更されます。

  2. [方向] では、 [縦] が既定で選択されます。 [横] を選択すると、タイルやボタンが横方向に配置され、スライサーに収まらない項目にアクセスするためのスクロール矢印が付いた、スライサーが作成されます。

    Screenshot of General selections.

  3. ビュー画面とスライサーのサイズに応じて、スライサーの項目のサイズと配置を変更するには、 [レスポンシブ] レイアウトを [オン] にします。

    リスト スライサーの場合、レスポンシブ レイアウトは小さい画面で項目が切り取られるのを防ぎます。 横方向でのみ使用できます。 範囲スライダー スライサーのレスポンシブ書式設定では、スライダーのスタイルが変更されて、より柔軟なサイズ変更を提供します。 どちらの種類のスライサーも、小さいサイズではフィルター アイコンになります。

    Screenshot of Set responsive layout.

    注意

    レスポンシブ レイアウトの変更により、ユーザーが設定した特定の見出しと項目の書式設定がオーバーライドされることがあります。

  4. [X 方向の位置][Y 方向の位置][幅][高さ] でスライサーの位置とサイズを数値で指定するか、キャンバス上で直接スライサーを移動およびサイズ変更します。

    項目のサイズと配置を変えてテストし、それに従ってレスポンシブ書式設定がどのように変化するかを確認してください。 これらのオプションは、横方向を選択した場合にのみ使用できます。

    Screenshot of Horizontal options.

横方向およびレスポンシブ レイアウトについて詳しくは、「Power BI でサイズを変更することが可能なレスポンシブ スライサーの作成」をご覧ください。

[選択範囲のコントロール] のオプション (リスト スライサーのみ)

  1. [選択範囲のコントロール] で、[[すべて選択] オプションを表示する][オン] にして、スライサーに [すべて選択] 項目を追加します。

    [[すべて選択] オプションを表示する] は、既定では [オフ] になっています。 このオプションを有効にして替えると、すべての項目が選択または選択解除されます。 すべての項目を選択してから、1 つの項目の選択を解除すると、"ではないもの" タイプのフィルターを設定できます。

    Screenshot of Selection controls.

  2. Ctrl キーを押し続けなくても複数の項目を選択できるようにするには、 [単一選択][オフ] にします。

    [単一選択] は、既定では [オン] になっています。 1 つの項目を選択し、Ctrl キーを押しながら複数の項目を選択します。 項目を再度選択すると、選択が解除されます。

タイトルのオプション

[タイトル] は、既定で [オン] になります。 この選択により、スライサーの上部にデータ フィールド名が表示されます。 タイトルも編集できます。これは階層スライサーで特に役立ちます。 詳細については、記事「階層スライサーに複数のフィールドを追加する」の「タイトルを変更する」をご覧ください。

  • この記事では、タイトルのテキストを次のように書式設定します。
    • フォントの色: 赤
    • 文字のサイズ:14 pt
    • 配置: 中央
    • フォント ファミリ:Arial Black

[項目] オプション

[項目] オプションは、リスト スライサーでのみ使用できます。

  1. この記事では、 [項目] のオプションを次のように書式設定します。

    • フォントの色: 黒
    • 背景: 明るい赤
    • 文字のサイズ:10 pt
    • フォント ファミリ:Arial
  2. [アウトライン][フレーム] を選択し、 [全般] オプションで設定したサイズと色で各項目を境界線で囲みます。

    Screenshot of Frame outline options.

    ヒント

    • [全般]>[方向]>[横] を選択した場合、選択されていない項目には選択したテキストと背景色が表示されます。 選択された項目にはシステムの既定値 (通常は黒い背景に白いテキスト) が使用されます。
    • [全般]>[方向] > [縦] を選択した場合は、項目は常に選択したした色で表示され、チェック ボックスはオンの場合は常に黒で表示されます。

日付/数値入力とスライダーのオプション

日付/数値入力とスライダーのオプションは、範囲スライダー スライサーでのみ使用できます。

  • リスト スライサーの場合、日付/数値入力のオプションは、アウトラインまたは下線がないことを除けば、 [項目] オプションと同じです。
  • [スライダー] オプションでは、範囲スライダーの色を設定でき、スライダーを [オフ] にすると数値入力だけが表示されます。

その他の書式設定オプション

その他の書式設定オプションは、既定では [オフ] です。 これらのオプションを制御するには [オン] にします。

  • [背景]: スライサーに背景色を追加し、透過性を設定します。
  • 縦横比を固定する: スライサーのサイズが変更された場合に、その相対的な高さと幅を保持します。
  • [罫線]: スライサーの周囲に枠線を追加し、その色を設定します。 このスライサーの枠線は、 [全般] の設定とは別であり影響を受けません。
  • シャドウ:スライダーにドロップ シャドウを追加します。

次のステップ

スライサーの詳細については、次の記事を参照してください。