Project Online のカスタマイズされたユーザー アイテムと Project Server ユーザー エクスポート データの検索Find customized user items in Project Online and Project Server user export data

この記事では、project Online または Project Server でユーザーデータのエクスポートを行うときに、特定のユーザーのカスタマイズされたアイテム (ビュー、フィルター、添付ファイル、テーブル、およびマクロ) をプロジェクトで検索する方法について説明します。This article describes how to search for a specific users customized items (views, filters, attachments, tables, and macros) in a project when you do an export of the users data in Project Online or Project Server. これには以下が含まれます。This includes:

この記事の手順では、次のものが必要です。The procedures in this article require you to have the following:

  • プロジェクトの MPP ファイルThe MPP file for the project

  • プロジェクトの XML ファイルThe XML file for the project

Project Online では、「 Project online からユーザーデータをエクスポートする」の手順に従ってユーザーデータをエクスポートしたときに、両方のファイルが提供されていました。For Project Online, both files were provided to you when you exported the user data through the procedures in Export user data from Project Online.

Project Server では、XML ファイルを作成するために特定のプロジェクトファイルを XML 形式で保存する必要があります。For Project Server, you will need to save the specific project file to XML format to create the XML file.

注意

Project Professional を使用してプロジェクトファイルを XML 形式で保存する場合は、最新の更新プログラムが適用されていることを確認してください。When saving a project file to XML format with Project Professional, make sure that you have applied the latest updates.

カスタマイズしたビューを検索して保存するにはTo find and save customized views

  1. 特定のプロジェクトの XML ファイルをテキストエディターで開きます。Open the specific project's XML file in a text editor.

  2. テキストで、[] を検索して、 <Views> プロジェクトのユーザービューの一覧を検索します。In the text, search for <Views> to find a list of user views for the project.

  3. ビューの一覧で、 Iscustomized プロパティが trueに設定されているビューを探します。In the list of Views, look for any views that have the IsCustomized property set to true. たとえば、次の例では、[アクティブなタスク] という名前のビューが、グローバルテンプレートまたは既定のテンプレートからカスタマイズされています。For example, the following means a View named Active Tasks has been customized from the global/default template:

<View>
<Name>Task Sheet</Name>
<IsCustomized>true</IsCustomized>
</View>

  1. Project Online デスクトップクライアントまたは Project Professional 2016 で、プロジェクトの MPP ファイルを開きます。Now open the project's MPP file in the Project Online Desktop Client or Project Professional 2016.

  2. [ 表示 ] メニューをクリックしてリボンを開き、リボンの [ その他のビュー ] ドロップダウンメニューを選択して、[その他の ビュー] をクリックします。Click the View menu to open the ribbon, and in the ribbon select the Other View dropdown menu, and then click More Views.

  3. [ その他のビュー ] ウィンドウで、[ビュー] ボックスの一覧から目的のビューを選択し、[ 適用] をクリックします。In the More Views window, in the Views list, select the view you are looking for, and then click Apply.

    その他のフィルター

  4. 選択したビューが表示されます。The selected view will display. ビューのスクリーンショットを取り、保存します。Take a screenshot of the view and save it.

  5. XML ファイルに含まれている残りのすべてのカスタムビューに対して同じ手順を使用します。Use the same procedure for all remaining custom views you found in the XML file.

ユーザーのカスタマイズされたビューを検索するプロジェクトごとに、この手順を繰り返すことができます。You can repeat this procedure on each project in which you want to search for your user's customized views.

カスタマイズしたフィルターを検索して保存するにはTo find and save customized filters

  1. 特定のプロジェクトの XML ファイルをテキストエディターで開きます。Open the specific project's XML file in a text editor.

  2. テキストで、[] を検索して、 <Filters> プロジェクトのユーザーフィルターの一覧を検索します。In the text, search for <Filters> to find a list of user filters for the project.

  3. フィルターの一覧で、 Iscustomized プロパティが trueに設定されているすべてのフィルターを検索します。In the list of Filters, look for all filters that have the IsCustomized property set to true. たとえば、次の例では、[アクティブなタスク] という名前のフィルターを、グローバルテンプレートまたは既定のテンプレートからカスタマイズしています。For example, the following means a filter named Active Tasks has been customized from the global/default template:

<Filters>
<Name>Active Tasks</Name>
<IsCustomized>true</IsCustomized>
</Filter>

  1. ビューを保存するには、project Online デスクトップクライアントまたは Project Professional 2016 でプロジェクトの MPP ファイルを開きます。To save the view, open the project's MPP file in the Project Online Desktop Client or Project Professional 2016.

  2. [ 表示 ] メニューをクリックし、[* * Filters * *] ドロップダウンメニューで [ その他のフィルター] を選択します。Click the View menu, and in the ** Filters ** dropdown menu, select More Filters.

  3. * * その他のフィルター * * メニューで、検索するフィルターを選択し、[* * 編集] * * をクリックします。In the ** More Filters ** menu, select the filter you are looking for, and then click ** Edit **.

    その他のフィルター

  4. 選択したフィルターのフィルター定義が表示されます。The filter definition for the selected filter will display. フィルター定義のスクリーンショットを取得して保存することができます。You can take a screenshot of the filter definition and save it.

  5. XML ファイルで検出された残りのすべてのカスタムフィルターに対して同じ手順を使用します。Use the same procedure for all remaining custom filters you found in the XML file.

ユーザーのカスタマイズフィルターを検索するプロジェクトごとに、この手順を繰り返すことができます。You can repeat this procedure on each project in which you want to search for your user's customize filters.

添付ファイルを検索して保存するにはTo find and save attachments

  1. 特定のプロジェクトの XML ファイルをテキストエディターで開きます。Open the specific project's XML file in a text editor.

  2. テキストで、[] を検索して、 <Tasks> プロジェクトのユーザータスクの一覧を検索します。In the text, search for <Tasks> to find a list of user tasks for the project.

  3. タスクの一覧で、 NoteContainsObjects プロパティが trueに設定されているすべてのタスクを検索します。In the list of tasks, look for all tasks that have the NoteContainsObjects property set to true. たとえば、タスク18に添付ファイルが含まれていると、次のようになります。For example, the following means that task 18 contains an attachment:

<Task>
<UID>18</UID>
<NoteContainsObjects>true</NoteContainsObjects>
</Task>

  1. 添付ファイルを保存するには、project Online デスクトップクライアントまたは Project Professional 2016 でプロジェクトの MPP ファイルを開きます。To save the attachment, open the project's MPP file in the Project Online Desktop Client or Project Professional 2016.

  2. [ タスク ] メニューをクリックし、添付ファイルに関連付けられているタスク (たとえば、タスク #18) を開きます。Click the Tasks menu, and open the task associated with the attachment (for example, task #18).

  3. [ タスク情報 ] 画面で、[ メモ ] タブを選択します。添付ファイルアイテムが一覧表示されます。In the Task Information screen, select the Notes tab. You should see the attachment item listed.

    タスクへの添付ファイル

  4. 添付ファイルアイテムを開いて保存します。Open the attachment item and save it.

  5. XML ファイルに含まれている残りの添付ファイルすべてに対して同じ手順を使用します。Use the same procedure for all remaining attachments you found in the XML file.

ユーザーの添付ファイルを検索するプロジェクトごとに、この手順を繰り返すことができます。You can repeat this procedure on each project in which you want to search for your user's attachments.

カスタマイズしたテーブルを検索して保存するにはTo find and save customized tables

  1. 特定のプロジェクトの XML ファイルをテキストエディターで開きます。Open the specific project's XML file in a text editor.

  2. テキストで、を検索して、プロジェクト内のテーブルを検索し <Tables> ます。In the text, search for <Tables> to find the tables in the project.

  3. テーブルの一覧で、 Iscustomized プロパティが trueに設定されているテーブルを探します。In the list of tables, look for any tables that have the IsCustomized property set to true. たとえば、次の例は、エントリテーブルがグローバル/既定のテンプレートからカスタマイズされていることを意味します。For example, the following means the Entry table has been customized from the global/default template:

<Tables>
<Table>Entry</Name>
<IsCustomized>true</IsCustomized>
</Table>

  1. Project Online デスクトップクライアントまたは Project Professional 2016 で、プロジェクトの MPP ファイルを開きます。Now open the project's MPP file in the Project Online Desktop Client or Project Professional 2016.

  2. [ 表示 ] メニューをクリックしてリボンを開き、リボンの [ テーブル ] ドロップダウンメニューを選択して、[ その他のテーブル] をクリックします。Click the View menu to open the ribbon, and in the ribbon select the Tables dropdown menu, and then click More Tables.

  3. [* * その他のテーブル * *] ウィンドウの [テーブル] ボックスの一覧で、検索するテーブルを選択し、[ 編集] をクリックします。In the ** More Tables ** window, in the Tables list, select the table you are looking for, and then click Edit.

    テーブル定義

  4. 選択したテーブルのテーブル定義が表示されます。The Table definition will display for the selected table. [定義] ウィンドウ内のすべての情報のスクリーンショットを取得して保存します。Take a screenshot of all the information in the definition window and save it.

  5. XML ファイルに含まれている、他のすべてのカスタマイズされたテーブルに対しても同じ手順を使用します。Use the same procedure for all remaining customized tables you found in the XML file.

ユーザーのカスタマイズしたテーブルを検索するプロジェクトごとに、この手順を繰り返すことができます。You can repeat this procedure on each project in which you want to search for your user's customized tables.

ユーザーマクロを検索して保存するにはTo find and save user macros

注意

プロジェクトの XML ファイルには、VBA マクロが含まれている場合はフラグが設定されません。A project's XML files will not flag if it contains VBA macros. VBA マクロが含まれているかどうかを確認するには、ユーザーのプロジェクトを手動で開く必要があります。You will need to manually open the user's projects to verify if it contains a VBA macro.

  1. プロジェクトの MPP ファイルを、Project Online デスクトップクライアントまたは Project Professional 2016 で開きます。Open the project's MPP file in the Project Online Desktop Client or Project Professional 2016.

  2. [ 表示 ] メニューをクリックしてリボンを開き、リボンの [ マクロ ] ドロップダウンメニューを選択して、[ マクロの表示] をクリックします。Click the View menu to open the ribbon, and in the ribbon select the Macros dropdown menu, and then click View Macros.

  3. [ マクロ ] ページで、[ visual basic ] を選択して、visual basic Editor を開きます。On the Macros page, select Visual Basic to open the Visual Basic Editor.

  4. Visual Basic エディターでは、ユーザー独自の VBA ファイルを保存できます。In the Visual Basic editor, you can save each of the users custom VBA files.

ユーザーのカスタマイズマクロを検索するプロジェクトごとに、この手順を繰り返すことができます。You can repeat this procedure on each project in which you want to search for your user's customize macros.

関連項目See also

Project Online からユーザー データをエクスポートするExport user data from Project Online

Project Server からユーザー データをエクスポートするExport user data from Project Server