SharePoint Online または OneDrive for Business にアクセスしようとするときに発生するエラー

現象

ユーザーが SharePoint Online または OneDrive for Business にアクセスしようとすると、次のエラー メッセージのいずれかが表示されます。

  • アクセス拒否
  • このサイトにアクセスするためのアクセス許可が必要です
  • ディレクトリにユーザーが見つかりません

原因

多くのシナリオで、これらのエラー メッセージが生成される場合があります。 最も頻繁な原因は、ユーザーまたは管理者のアクセス許可が正しく構成されていないか、まったく構成されていないことです。

解決方法

エラー メッセージが表示される SharePoint サイトまたは OneDrive サイトに適した方法を使用します。

SharePoint サイトにアクセスする

  1. ユーザーが サイトに対 して必要とするアクセス許可レベル (メンバー、所有者など) を決定します。 さらに、次のように、[権限の 確認] 機能で 権限を確認します。

    1. User.aspx ページに移動します。 これを行うには、右上隅にあるギア アイコンを選択し、[サイトの権限] を 選択して、[高度なアクセス許可の設定 ] を選択します

      たとえば、完全な URL は次のようになります。https://contoso.sharepoint.com/_layouts/15/user.aspx

    2. リボンで [アクセス許可の確認 ] を選択します

    3. [ユーザー ] または [ グループ ] フィールド に、ユーザー名を入力し、[今すぐチェックイン ] を選択します

      注意

      このコマンドは、ユーザーがサイトに対して持つアクセス許可の種類と、アクセス許可の派生元となるセキュリティ グループを表示します (該当する場合)。

  2. ユーザーが適切なアクセス許可を持っていない場合は、そのユーザーに対してファイルまたはサイトへのアクセス許可を付与します。

  3. ユーザーが引き続きエラー メッセージを受信する場合は、次の手順に従ってサイトからそのユーザーを削除します。

    注意

    このオプションは、ユーザーが以前にサイト コレクションを参照した場合にのみ使用できます。 ユーザーにはアクセス権は付与されているがサイトにアクセスしない場合は表示されません。

    1. サイトを参照し、URL の末尾に次の文字列を追加して編集します。 /_layouts/15/people.aspx?MembershipGroupId=0

      たとえば、完全な URL は次のようになります。 https://contoso.sharepoint.com/_layouts/15/people.aspx/membershipGroupId=0

    2. 一覧でユーザーを選択し、[アクション] メニューを開き、[サイト コレクションからユーザー の削除] を選択します

    3. ファイルまたはサイトへのアクセス許可をユーザーに付与します

OneDrive サイトにアクセスする

  • ユーザーが OneDrive サイトの所有者である場合

    この問題は、ユーザーの削除後に同じユーザー プリンシパル名 (UPN) を使用してユーザーを再作成した場合に最も頻繁に発生します。 新しいアカウントは、別の Passport 一意 ID (PUID) 値を使用して作成されます。 ユーザーがサイト コレクションや OneDrive サイトにアクセスしようとすると、ユーザーの PUID は間違っています。 もう 1 つのシナリオには、Active Directory 組織単位 (OU) とのディレクトリ同期が関連します。 この問題が発生する可能性があるのは、ユーザーが既に SharePoint にサインインしていて、現在 Office365 と同期されていない別の OU に移動され、その後 SharePoint と再同期されます。

    1. この問題を解決するには、新しい UPN (存在する場合) を削除し、元の UPN を復元します。

      1. 新しい UPN を削除するには、Azure Active Directory を使用 してユーザーを追加または削除する手順に従います
      2. 新しいユーザーが削除されたら、Azure Active Directory を使用して削除されたユーザーを復元または削除する手順に従 って元のユーザーを復元します
    2. 元のユーザーを復元できない場合に、問題が解決しない場合は、次のようにサポート要求を作成します。

      1. https://admin.microsoft.com に移動します。

      2. ナビゲーション ウィンドウで、[新しいサービス要求のサポート > ] を選択します

        注意

        これにより、画面の 右側の [ヘルプ が必要な場合] ウィンドウがアクティブ化されます。

      3. [問題 ] 領域を簡単に説明する 場合は 、OneDrive サイトで PUID の不一致を入力します

      4. [サポートに問い合わせる] を選択します。

        注意

        以前の M365 管理センターを使用している場合、[説明] フィールドは存在しないため、 次の手順を スキップできます。

      5. [ 説明] フィールド、OneDrive サイトでの PUID の不一致を入力します

      6. 残りの情報を入力し、[連絡先] を 選択します

      7. チケットが開いたら、問題が発生している UPN と OneDrive URL をサポート エージェントに提供します。

  • ユーザーが別のユーザーの OneDrive サイトにアクセスしようとしている場合

    1. ユーザーが サイトに対 して必要とするアクセス許可レベル (メンバー、所有者など) を決定します。 さらに、次のように、[権限の確認] 機能で権限を確認します。

      1. User.aspx ページに移動します。 たとえば、完全な URL は次のようになります。

        https://contoso-my.sharepoint.com/personal/admin_contoso_onmicrosoft_com/_layouts/15/user.aspx.

      2. リボンで [アクセス許可の確認 ] を選択します

      3. [ユーザー ] または [ グループ ] フィールド に、ユーザー名を入力し、[今すぐチェックイン ] を選択します

        注意

        このコマンドは、ユーザーがサイトに対して持つ権限の種類と、アクセス許可の派生元となるセキュリティ グループ (該当する場合) を表示します。

    2. ユーザーが適切なアクセス許可を持っていない場合は、ファイルまたはサイト へのアクセス 許可 を usre に付与します

    3. ユーザーが引き続きエラー メッセージを受信する場合は、次の手順に従ってサイトからそのユーザーを削除します。

      注意

      このオプションは、ユーザーが以前にサイト コレクションを参照した場合にのみ使用できます。 ユーザーにはアクセス権は付与されているがサイトにアクセスしない場合は表示されません。

      1. サイトを参照し、URL の末尾に次の文字列を追加して編集します。

        /_layouts/15/people.aspx?MembershipGroupId=0

        たとえば、完全な URL は次のようになります。

        https://contoso-my.sharepoint.com/personal/admin_contoso_onmicrosoft_com/_layouts/15/people.aspx/membershipGroupId=0

      2. 一覧でユーザーを選択し、[アクション] メニューを き、[サイト コレクションからユーザー の削除] を選択します

      3. ファイルまたはサイトへのアクセス許可をユーザーに付与します

詳細情報

SharePoint Online のアクセス許可レベルの詳細については、「アクセス許可レベル について」を参照してください

SharePoint または OneDrive for Business での "アクセスが拒否されました" エラーの詳細については、次の記事を参照してください。

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