[アクセス要求] リストにアクセスしようとするとエラーが発生する
現象
SharePoint Online または OneDrive for Business の [アクセス要求] リストにアクセスしようとすると、次のいずれかのメッセージが表示されます。
- アクセス拒否
- このサイトにアクセスするためのアクセス許可が必要です
- ユーザーがディレクトリに見つかりません
原因
多くのシナリオでは、これらのメッセージの1つを生成できます。 最も頻繁な原因は、ユーザーまたは管理者のアクセス許可が正しく構成されていないか、まったく構成されていないことです。
解決方法
この問題を解決するには、ユーザーはサイトの管理者、またはサイトの Owners グループのメンバーである必要があります。 所有者グループには、アクセス要求リストにアクセスするためのアクセス許可も必要 です。
特定の構成に適した方法を使用します。
ユーザーはサイト管理者である必要があります。
影響を受けるユーザーがサイトコレクション管理者である必要がある場合は、「サイト コレクション管理者を管理 する」を参照して、サイトの管理者を管理する方法について確認してください。
ユーザーはサイトの所有者である必要があります。
ユーザーがサイトの所有者である必要がある場合は、次の手順を使用して、そのユーザーをサイトの Owners グループに追加します。
- 影響を受けたサイトまたはサイトコレクションを参照します。
- [設定] メニューの歯車アイコンをクリックし、[サイトの設定] をクリックします。
- [ サイトの権限] を選択します。
- サイトの 所有者グループをクリックします。
- [ 新規] を選択します。
- [共有] ダイアログ ボックスで、グループに追加するユーザーのユーザー アカウントを入力します。 次に、[共有]を選択します。
- テストして、ユーザーがリストにアクセスし、要求を承認または拒否できることを確認します。
Owners グループにアクセス要求リストへのアクセス許可があることを確認する
[ アクセス要求 ] リストから owners グループが変更または削除された場合は、リストの所有者グループのアクセス許可を追加します。 影響を受けるユーザーが次のように Owners 一覧に含まれていることを確認してください。
注意
影響を受けたサイトに対する [ 権限の管理] アクセス許可レベル へのアクセス と 、 アクセス要求 リスト (サイト管理者など) へのアクセスの両方が必要です。
エッジまたは Internet Explorer で アクセス要求 リストを参照します。
F12キーを押して、[F12 開発者ツール] ウィンドウを開きます。
[ ネットワーク ] タブを選択し、 F5 キーを押してネットワークトラフィックのキャプチャを有効にします。
ブラウザーの [ アクセス要求 ] ページを更新します。 ページが読み込まれたら、Shift キーを押しながら F5 キーを押して、ネットワーク トラフィックのキャプチャを停止します。
[ 開発者ツール ] ウィンドウで、[URL] ボックスの最初の結果をダブルクリックします ("pendingreq" で終わる必要があります)。
[ 開発者ツール ] ウィンドウで、[ 応答本文] を選択します。
検索ボックスに「 pagelistid:」と入力し、enter キーを押します。
注意
検索では、pageListId テキストが強調表示されます。
pageListId の後に続く GUID をコピーします。 GUID は、次のように左中かっこ ( { ) 文字と右中かっこ (}) 文字の間になります。
インターフェイス
注意
GUID をコピーするときに、左中かっこと右中かっこの文字を含めます。 この GUID は、組織の SharePoint Online アクセス要求リストの識別子です。
ブラウザーのアドレスバーに「 https:// <URL of affected site, or site collection> /_layouts/15/listedit.aspx?」と入力します。List = { <GUID> } と入力し、enter キーを押します。
注意
このアドレスは、 <URL of affected site or site collection> アクセス要求を変更するサイトコレクションの URL を表します (例:
https://contoso.sharepoint.com
)。 また、 { <GUID> } は、手順8でコピーした GUID を表します。[ 設定 ] ページで、[ このリストに対する権限] を選択します。
サイトの所有者グループが、アクセス要求の一覧に含まれていることを確認します。 サイト コレクションの所有者グループが存在しない場合は、[アクセス許可の付与] を選択し、[共有] ダイアログ ボックスでサイトの所有者グループの名前を入力 して、[共有]を選択します。
「サイトの所有者グループにユーザーを追加する」セクションの手順に従って、ユーザーが所有者グループに含まれていることを確認します。
詳細
この問題は、サイト管理者またはサイトコレクションの Owners グループのメンバーであるユーザーのみが、 アクセス要求 リストで保留中の要求を承認または拒否するアクセス許可を持っているために発生します。 ユーザーがサイトの所有者グループのメンバーである場合、 アクセス要求リストにアクセスするには、Owners グループにもフル コントロールのアクセス許可が必要です。
アクセス要求のセットアップと管理の詳細については、「 アクセス要求をセットアップおよび管理する」を参照してください。
F12 開発者ツールの使用方法の詳細については、「 f12 開発者ツールの使用」を参照してください。
SharePoint Online でのアクセス許可レベルの詳細については、「 アクセス許可レベルについて」を参照してください。
SharePoint または OneDrive for business での "アクセスが拒否されました" エラーの詳細については、以下の記事を参照してください。
- SharePoint Online または OneDrive for Business にアクセスしようとするとエラーが発生する
- 外部ユーザーが SharePoint Online または OneDrive for Business にアクセスしようとするとエラーが発生する
- SharePoint 承認ワークフロータスクを承認しようとするとエラーが発生する
- ユーザーが Share Point Online の共有フォルダーにアクセスできない
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