リモート デバッガーのポートの割り当てRemote Debugger Port Assignments

Visual Studio リモート デバッガーは、アプリケーションまたはバック グラウンド サービスとして実行できます。The Visual Studio Remote Debugger can run as an application or as a background service. アプリケーションとして実行される際には、次のように既定で割り当てられているポートを使用します。When it runs as an application, it uses a port that is assigned by default as follows:

  • Visual Studio 2019:4024Visual Studio 2019: 4024
  • Visual Studio 2017:4022Visual Studio 2017: 4022

  • Visual Studio 2015:4020Visual Studio 2015: 4020

  • Visual Studio 2013:4018Visual Studio 2013: 4018

  • Visual Studio 2012:4016Visual Studio 2012: 4016

つまり、リモート デバッガーに割り当てられるポート番号はリリースごとに 2 つずつ増えます。In other words, the number of the port assigned to the remote debugger is incremented by 2 for each release. 必要であれば、別のポート番号を設定できます。You can set a different port number if you like. ポート番号の設定方法は、後のセクションで説明します。We will explain how to set port numbers in a later section.

32 ビット オペレーティング システムのリモート デバッガーのポートThe Remote Debugger Port on 32-bit Operating Systems

TCP 4024 (Visual Studio 2019 の場合) がメイン ポートであり、すべてのシナリオにこれが必要です。TCP 4024 (in Visual Studio 2019) is the main port, and is required for all scenarios. これは、コマンド ラインまたはリモート デバッガー ウィンドウのいずれかから構成できます。You can configure this from either the command line or the remote debugger window.

TCP 4022 (Visual Studio 2017 の場合) がメイン ポートであり、すべてのシナリオにこれが必要です。TCP 4022 (in Visual Studio 2017) is the main port, and is required for all scenarios. これは、コマンド ラインまたはリモート デバッガー ウィンドウのいずれかから構成できます。You can configure this from either the command line or the remote debugger window.

リモート デバッガー ウィンドウでは、 [ツール] > [オプション] の順にクリックし、TCP/IP ポート番号を設定します。In the remote debugger window, click Tools > Options, and set the TCP/IP port number.

コマンド ラインでは、 /port スイッチを使用して「msvsmon /port <port number> 」と入力して、リモート デバッガーを開始します。On the command line, start the remote debugger with the /port switch: msvsmon /port <port number>.

リモート デバッグのヘルプに、リモート デバッガーのすべてのコマンド ライン スイッチが記載されています (リモート デバッガー ウィンドウで F1 キーを押すか、または [ヘルプ] > [使い方] の順にクリックします)。You can find all the remote debugger command line switches in the remote debugging help (press F1 or click Help > Usage in the remote debugger window).

64 ビット オペレーティング システムのリモート デバッガーのポートThe Remote Debugger Port on 64-bit Operating Systems

64 ビット バージョンのリモート デバッガーを開始すると、既定でメイン ポート (4024) が使用されます。When the 64-bit version of the remote debugger is started, it uses the main port (4024) by default. 32 ビット プロセスをデバッグする場合は、64 ビット バージョンのリモート デバッガーにより、ポート 4025 (メイン ポート番号から 1 増分される) で 32 ビット バージョンのリモート デバッガーが開始されます。If you debug a 32-bit process, the 64-bit version of the remote debugger starts a 32-bit version of the remote debugger on port 4025 (the main port number incremented by 1). 32 ビットのリモート デバッガーを実行する場合は、4024 が使用され、4025 は使用されません。If you run the 32-bit remote debugger, it uses 4024, and 4025 is not used.

64 ビット バージョンのリモート デバッガーを開始すると、既定でメイン ポート (4022) が使用されます。When the 64-bit version of the remote debugger is started, it uses the main port (4022) by default. 32 ビット プロセスをデバッグする場合は、64 ビット バージョンのリモート デバッガーにより、ポート 4023 (メイン ポート番号から 1 増分される) で 32 ビット バージョンのリモート デバッガーが開始されます。If you debug a 32-bit process, the 64-bit version of the remote debugger starts a 32-bit version of the remote debugger on port 4023 (the main port number incremented by 1). 32 ビットのリモート デバッガーを実行する場合は、4022 が使用され、4023 は使用されません。If you run the 32-bit remote debugger, it uses 4022, and 4023 is not used.

このポートは、次のように入力して、コマンド ラインから構成できます。Msvsmon /wow64port <port number>This port is configurable from the command line: Msvsmon /wow64port <port number>.

検出ポートThe Discovery Port

実行中のリモート デバッガーのインスタンスをネットワークで検出するには (たとえば、 [プロセスにアタッチ] ダイアログの [検索] ダイアログ)、UDP 3702 が使用されます。UDP 3702 is used for finding running instances of the remote debugger on the network (for example, the Find dialog in the Attach to Process dialog). これが使用されるのは、リモート デバッガーを実行しているコンピューターを検出する場合だけです。つまり、ターゲット コンピューターのコンピューター名または IP アドレスが他の方法でわかれば省略できます。It is used only for discovering a machine running the remote debugger, so it is optional if you have some other way of knowing the machine name or IP address of the target computer. これは検出用の標準ポートなので、ポート番号を構成することはできません。This is a standard port for discovery, so the port number cannot be configured.

検出を有効にしない場合は、コマンド ラインから検出を無効にして msvsmon を開始できます。次のように入力します。Msvsmon /nodiscoveryIf you do not want to enable discovery, you can start msvsmon from the command line with discovery disabled: Msvsmon /nodiscovery.

Azure でのリモート デバッガーのポートRemote Debugger Ports on Azure

Azure のリモート デバッガーでは次のポートが使用されます。The following ports are used by the remote debugger on Azure. クラウド サービス上のポートは、個々の VM 上のポートにマップされます。The ports on the cloud service are mapped to the ports on the individual VM. すべてのポートは TCP です。All ports are TCP.

接続Connection クラウド サービス上のポートPort on Cloud Service VM 上のポートPort on VM
Microsoft.WindowsAzure.Plugins.RemoteDebugger.ConnectorMicrosoft.WindowsAzure.Plugins.RemoteDebugger.Connector 3040030400 3039830398
Microsoft.WindowsAzure.Plugins.RemoteDebugger.ForwarderMicrosoft.WindowsAzure.Plugins.RemoteDebugger.Forwarder 3140031400 3139831398
Microsoft.WindowsAzure.Plugins.RemoteDebugger.Forwarderx86Microsoft.WindowsAzure.Plugins.RemoteDebugger.Forwarderx86 3140131401 3139931399
Microsoft.WindowsAzure.Plugins.RemoteDebugger.FileUploadMicrosoft.WindowsAzure.Plugins.RemoteDebugger.FileUpload 3240032400 3239832398

関連項目See also