イミディエイト ウィンドウImmediate window

[イミディエイト] ウィンドウは、式のデバッグと評価、ステートメントの実行、変数値の出力のために使用します。Use the Immediate window to debug and evaluate expressions, execute statements, and print variable values. [イミディエイト] ウィンドウでは、現在選択されているプロジェクトをビルドして使用することで式を評価します。The Immediate window evaluates expressions by building and using the currently selected project.

[イミディエイト] ウィンドウを表示するには、編集用にプロジェクトを開いて、[デバッグ] > [ウィンドウ] > [イミディエイト] の順に選択するか、Ctrl+Alt+I キーを押します。To display the Immediate window, open a project for editing, and then choose Debug > Windows > Immediate or press Ctrl+Alt+I. また、[コマンド] ウィンドウに「Debug.Immediate」と入力することもできます。You can also enter Debug.Immediate in the Command window.

[イミディエイト] ウィンドウは、IntelliSense をサポートしています。The Immediate window supports IntelliSense.

変数の値を表示するDisplay the values of variables

[イミディエイト] ウィンドウは、アプリをデバッグするときに特に役に立ちます。The Immediate window is particularly useful when you're debugging an app. たとえば、varA 変数の値を確認するには、Print コマンドを使用します。For example, to check the value of a variable varA, you can use the Print command:

>Debug.Print varA

疑問符 (?) はDebug.Print のエイリアスであるため、このコマンドは次のように書き換えることもできます。The question mark (?) is an alias for Debug.Print, so this command can also be written:

? varA

コマンドをどちらで入力した場合でも、変数 varA の値が返されます。Both versions of this command return the value of the variable varA.

ヒント

[イミディエイト] ウィンドウで Visual Studio コマンドを発行するには、コマンドの先頭に大なり記号 (>) を付ける必要があります。To issue a Visual Studio command in the Immediate window, you must preface the command with a greater than sign (>). 複数のコマンドを入力するには、コマンド ウィンドウに切り替えます。To enter multiple commands, switch to the Command window.

デザイン時の式評価Design-time expression evaluation

[イミディエイト] ウィンドウを使用すると、デザイン時に関数またはサブルーチンを実行できます。You can use the Immediate window to execute a function or subroutine at design time.

デザイン時に関数を実行するExecute a function at design time

  1. 次のコードを Visual Basic コンソール アプリにコピーします。Copy the following code into a Visual Basic console app:

    Module Module1
    
        Sub Main()
            MyFunction(5)
        End Sub
    
        Function MyFunction(ByVal input as Integer) As Integer
            Return input * 2
        End Function
    
    End Module
    
  2. [デバッグ] メニューの [ウィンドウ] > [イミディエイト] の順に選択します。On the Debug menu, choose Windows > Immediate.

  3. [イミディエイト] ウィンドウに「?MyFunction(2)」と入力し、Enter キーを押します。Type ?MyFunction(2) in the Immediate window and press Enter.

    [イミディエイト] ウィンドウで MyFunction が実行され、4 と表示されます。The Immediate window runs MyFunction and displays 4.

関数またはサブルーチンにブレークポイントが含まれている場合、適切なポイントで実行が中断されます。If the function or subroutine contains a breakpoint, Visual Studio breaks execution at the appropriate point. デバッガー ウィンドウを使用して、プログラムの状態を確認できます。You can then use the debugger windows to examine your program state. 詳細については、「チュートリアル:デザイン時のデバッグ」をご覧ください。For more information, see Walkthrough: Debugging at Design Time.

デザイン時の式の評価は、実行時環境の起動を必要とするプロジェクトの種類 (Visual Studio Tools for Office プロジェクト、Web プロジェクト、スマート デバイス プロジェクト、SQL プロジェクトなど) には使用できません。You can't use design-time expression evaluation in project types that require starting up an execution environment, including Visual Studio Tools for Office projects, web projects, Smart Device projects, and SQL projects.

デザイン時の式の評価 (複数のプロジェクトから成るソリューションの場合)Design-time expression evaluation in multi-project solutions

デザイン時の式の評価におけるコンテキストを設定する際、Visual Studio はソリューション エクスプローラーで現在選択されているプロジェクトを参照します。When establishing the context for design-time expression evaluation, Visual Studio references the currently selected project in Solution Explorer. ソリューション エクスプローラーでプロジェクトが選択されていない場合、Visual Studio はスタートアップ プロジェクトで関数を評価します。If no project is selected in Solution Explorer, Visual Studio attempts to evaluate the function against the startup project. 現在のコンテキストで関数を評価できない場合は、エラー メッセージが表示されます。If the function cannot be evaluated in the current context, you'll receive an error message. ソリューションのスタートアップ プロジェクト以外のプロジェクトで関数を評価しようとしていたときにエラーを受け取った場合は、ソリューション エクスプローラーで評価対象プロジェクトを選択し、再度評価を試みてください。If you're attempting to evaluate a function in a project that's not the startup project for the solution and you receive an error, try selecting the project in Solution Explorer and attempt the evaluation again.

コマンドを入力するEnter commands

[イミディエイト] ウィンドウで Visual Studio コマンドを発行するときは、大なり記号 (>) を入力する必要があります。Enter the greater than sign (>) when issuing Visual Studio commands in the Immediate window. 上方向 キーおよび 下方向 キーを使用して、以前に使用したコマンドの間をスクロールします。Use the Up arrow and Down arrow keys to scroll through your previously used commands.

タスクTask 解決策Solution Example
式を評価する。Evaluate an expression. 式の先頭に疑問符 (?) を付けます。Preface the expression with a question mark (?). ? a+b
イミディエイト モードの場合に、一時的にコマンド モードに移行して 1 つのコマンドを実行する。Temporarily enter Command mode while in Immediate mode (to execute a single command). 先頭に不等号 (>) を付けてコマンドを入力します。Enter the command, prefacing it with a greater than sign (>). >alias
[コマンド] ウィンドウに切り替る。Switch to the Command window. 先頭に不等号 (>) を付けて、ウィンドウに「cmd」と入力します。Enter cmd into the window, prefacing it with a greater than sign (>). >cmd
[イミディエイト] ウィンドウに戻る。Switch back to the Immediate window. 不等号 (>) を付けずにウィンドウに「immed」と入力します。Enter immed into the window without the greater than sign (>). immed

マーク モードMark mode

[イミディエイト] ウィンドウで、既に出力されている任意の行をクリックすると、自動的にマーク モードに切り替わります。When you click on any previous line in the Immediate window, you shift automatically into Mark mode. これにより、テキスト エディターでの操作と同じように、既に入力されたコマンドのテキストを選択、編集、およびコピーし、現在の行に貼り付けることができます。This allows you to select, edit, and copy the text of previous commands as you would in any text editor, and paste them into the current line.

Examples

次の例は、Visual Basic プロジェクトの [イミディエイト] ウィンドウの 4 つの式とその結果を示しています。The following example shows four expressions and their result in the Immediate window for a Visual Basic project.

j = 2
Expression has been evaluated and has no value

? j
2

j = DateTime.Now.Day
Expression has been evaluated and has no value

? j
26

初回例外通知First-chance exception notifications

設定の構成によっては、[イミディエイト] ウィンドウに初回例外通知が表示されることがあります。In some settings configurations, first-chance exception notifications are displayed in the Immediate window.

[イミディエイト] ウィンドウで初回例外通知を切り替えるToggle first-chance exception notifications in the Immediate window

  1. [表示] メニューの [その他のウィンドウ] をポイントし、[出力] をクリックします。On the View menu, click Other Windows, and click Output.

  2. [出力] ウィンドウのテキスト領域で右クリックし、[例外メッセージ] をクリックして選択または選択解除します。Right-click on the text area of the Output window, and then select or deselect Exception Messages.

関連項目See also