複数のコンピューター間で Visual Studio 設定を同期するSynchronize Visual Studio settings across multiple computers

複数のコンピューターで同じ個人アカウントを使用して Visual Studio にサインインした場合、コンピューター間で設定が同期されます。When you sign in to Visual Studio on multiple computers using the same personalization account, your settings can be synchronized across the computers.

同期された設定Synchronized settings

既定では、次の設定が同期されます。By default, the following settings are synchronized:

  • 開発設定。Development settings. Visual Studio を初めて実行するときに設定を選択する必要がありますが、選択内容はいつでも変更できます。You have to select a set of settings the first time you run Visual Studio, but you can change the selection anytime. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

  • ユーザー定義のコマンド エイリアス。User-defined command aliases. コマンド エイリアスを定義する方法について詳しくは、「Visual Studio コマンドの定義済みのエイリアス」をご覧ください。For more information about how to define command aliases, see Visual Studio command aliases.

  • [ウィンドウ] > [ウィンドウ レイアウトの管理] ページのユーザー定義のウィンドウ レイアウト。User-defined window layouts in Window > Manage Window Layouts page.

  • [ツール] > [オプション] ページの次のオプション。The following options in the Tools > Options pages:

    • [環境] > [全般] オプション ページの [テーマ] とメニュー バー枠の設定。Theme and menu bar casing settings on the Environment > General options page.

    • [環境] > [フォントおよび色] オプション ページのすべての設定。All settings on the Environment > Fonts and Colors options page.

    • [環境] > [キーボード] オプション ページのすべてのキーボード ショートカット。All keyboard shortcuts on the Environment > Keyboard options page.

    • [環境] > [タブとウィンドウ] オプション ページのすべての設定。All settings on the Environment > Tabs and Windows options page.

    • [環境] > [スタートアップ] オプション ページのすべての設定。All settings on the Environment > StartUp options page.

    • [テキスト エディター] オプション ページのすべての設定。All settings on the Text Editor options pages.

    • [XAML デザイナー] オプション ページのすべての設定。All settings on the XAML Designer options pages.

特定のコンピューター上の同期された設定の無効化Turn off synchronized settings on a particular computer

Visual Studio の同期された設定は、既定でオンになっています。Synchronized settings for Visual Studio are turned on by default. あるコンピューター上の同期された設定をオフにするには、[ツール] > [オプション] > [環境] > [アカウント] ページに移動して、[Visual Studio にサインインしたときにデバイス間の設定を同期する] チェック ボックスをオフにします。You can turn off synchronized settings on a computer by going to the Tools > Options > Environment > Accounts page and unchecking Synchronize settings across devices when signed into Visual Studio. たとえば、コンピューター "A" 上の Visual Studio の設定を同期しないようにすると、コンピューター "A" で行った設定変更がコンピューター "B" やコンピューター "C" に表示されなくなります。For example, if you decide not to synchronize Visual Studio's settings on computer "A", any setting changes made on computer "A" do not appear on computer "B" or computer "C". コンピューター "B" と "C" は、引き続き相互に同期しますが、コンピューター "A" とは同期しなくなります。Computers "B" and "C" will continue to synchronize with each other, but not with computer "A".

リセット設定Reset settings

次の手順で、すべての設定を既定に戻すことができます。You can reset all settings to a collection of default settings by following these steps:

  1. Visual Studio で、[ツール] > [設定のインポートとエクスポート] の順にクリックし、設定のインポートとエクスポート ウィザードを開始します。In Visual Studio, select Tools > Import and Export Settings to open the Import and Export Settings Wizard.

  2. [設定のインポートとエクスポート] で、[すべての設定をリセット][次へ] の順に選択します。In the Import and Export Settings Wizard, select Reset all settings and then select Next.

    Visual Studio の設定のインポートとエクスポート ウィザード

  3. [現在の設定の保存] ページで、[はい] または [いいえ] を選択し、[次へ] を選択します。On the Save Current Settings page, select either Yes or No and then select Next.

  4. [設定の既定のコレクションの選択] ページで、コレクションを選択し、[完了] を選択します。On the Choose a Default Collection of Settings page, choose a collection and then select Finish.

    Visual Studio の設定コレクション

  5. [リセットの完了] ページで [閉じる] を選択します。On the Reset Complete page, select Close.

Visual Studio ファミリ製品およびエディション間での設定の同期Synchronize settings across Visual Studio family products and editions

Community エディションを含む Visual Studio の任意のエディション間で、設定を同期できます。Settings can be synchronized across any edition of Visual Studio, including Community edition. Visual Studio ファミリ製品の間でも設定が同期されます。Settings are also synchronized across Visual Studio family products. ただし、各ファミリ製品には Visual Studio で共有されない独自の設定が含まれる場合があります。However, each of these family products may have its own settings that aren't shared with Visual Studio. たとえば、コンピューター "A" 上の 1 つの製品に固有の設定は、コンピューター "B" 上の別の製品と共有されますが、コンピューター "A" または "B" 上の Visual Studio とは共有されません。For example, settings specific to one product on computer "A" are shared with another product on computer "B", but not with Visual Studio on computers "A" or "B".

サイド バイ サイドで同期された設定Side-by-side synchronized settings

Visual Studio 2017 バージョン 15.3 以降では、Visual Studio 2017 の異なるサイド バイ サイド インストールの間で、ツール ウィンドウ レイアウトなど、特定の設定が共有されません。In Visual Studio 2017 version 15.3 and later, certain settings like tool window layout aren't shared between different side-by-side installations of Visual Studio 2017. %userprofile%\Documents\Visual Studio 2017\SettingsCurrentSettings.vssettings ファイルはインストール固有フォルダーに置かれています。このフォルダーは、%localappdata%\Microsoft\VisualStudio\15.0_xxxxxxxx\Settings のようなフォルダーになります。The CurrentSettings.vssettings file in %userprofile%\Documents\Visual Studio 2017\Settings is in an installation-specific folder that is similar to %localappdata%\Microsoft\VisualStudio\15.0_xxxxxxxx\Settings.

注意

新しいインストール固有設定を使用するには、新しくインストールを行います。To use the new installation-specific settings, do a fresh installation. 既存の Visual Studio 2017 インストールを最新の更新プログラムにアップグレードするとき、既存の共有フォルダーが使用されます。When you perform an upgrade of an existing Visual Studio 2017 installation to the most current update, it uses the existing shared location.

現在、Visual Studio 2017 がサイド バイ サイド インストールされているとき、新しいインストール固有設定ファイル用フォルダーを使用する場合、次の手順に従ってください。If you currently have side-by-side installations of Visual Studio 2017 and want to use the new installation-specific settings file location, follow these steps:

  1. Visual Studio 2017 バージョン 15.3 以降にアップグレードします。Upgrade to Visual Studio 2017 version 15.3 or later.

  2. 設定のインポート/エクスポート ウィザードを利用し、すべての既存設定を %localappdata%\Microsoft\VisualStudio\15.0_xxxxxxxx フォルダーから別の場所にエクスポートします。Use the Import\Export settings wizard to export all your existing settings to some location outside of the %localappdata%\Microsoft\VisualStudio\15.0_xxxxxxxx folder.

  3. アップグレードした Visual Studio で VS 2017 用の開発者コマンド プロンプトを開き、devenv /resetuserdata を実行します。Open the Developer Command Prompt for VS 2017 of the upgraded Visual Studio installation and run devenv /resetuserdata.

  4. Visual Studio を起動し、エクスポートした設定ファイルから保存済みの設定をインポートします。Launch Visual Studio and import the saved settings from the exported settings file.

関連項目See also

IDE をカスタマイズするPersonalize the IDE