多言語アプリ ツールキット 4.0 の使用Use the Multilingual App Toolkit 4.0

多言語アプリ ツールキット (MAT) 4.0 は、翻訳サポート、翻訳ファイル管理、およびエディター ツールを使用して UWP アプリを提供する、Microsoft Visual Studio 2019 と統合します。The Multilingual App Toolkit (MAT) 4.0 integrates with Microsoft Visual Studio 2019 to provide UWP apps with translation support, translation file management, and editor tools. ツールキットの価値提案の一部を次に示します。Here are some of the value propositions of the toolkit.

  • 開発時のリソースの変更や翻訳の状態を管理できます。Helps you manage resource changes and translation status during development.
  • 構成済みの翻訳プロバイダーに基づいて言語を選ぶための UI を提供します。Provides a UI for choosing languages based on configured translation providers.
  • ローカライズ業界標準 XLIFF ファイル形式をサポートしています。Supports the localization industry-standard XLIFF file format.
  • 擬似言語エンジンを使って、開発中に翻訳の問題点を見つけだすことができます。Provides a pseudo-language engine to help identify translation issues during development.
  • Microsoft Language Portal に接続して、翻訳された文字列や用語に容易にアクセスできます。Connects with the Microsoft Language Portal to easily access translated strings and terminology.
  • Microsoft Translator に接続して、翻訳候補をすばやく調べることができます。Connects with the Microsoft Translator for quick translation suggestions.

ツールの使用方法How to use the toolkit

手順 1.Step 1. グローバリゼーションとローカライズのためのアプリの設計Design your app for globalization and localization

多言語アプリ ツールキットを効果的に使用する前に、まずアプリをローカライズする必要があります。Before you can use the MAT effectively, your app needs to be localizable. 具体的には、プロジェクトには、既定の言語でのアプリの文字列を含む 1 つまたは複数のリソース ファイル (.resw) を含める必要があります。Specifically, your project should contain one or more Resources Files (.resw) containing your app's strings in the default language. 詳細については、「UI とアプリ パッケージ マニフェスト内の文字列をローカライズする」を参照してください。For details, see Localize strings in your UI and app package manifest. 処理が完了したら、ツールキットにより、言語を迅速かつ簡単に追加できます。Once you've done that, the toolkit makes adding additional languages quick and easy.

グローバリゼーションとローカリゼーションの価値提案の—、用語の定義とグローバリゼーションローカライズ、およびローカリゼーション—を参照してくださいグローバリゼーションとローカリゼーションします。For the value proposition of globalization and localization—as well as definitions of the terms globalization, localizability, and localization—see Globalization and localization.

グローバリゼーションのガイドライン」と「アプリをローカライズ可能にする」も参照してください。Also see Guidelines for globalization and Make your app localizable.

手順 2.Step 2. 多言語アプリ ツールキット 4.0 のダウンロードおよびインストールDownload and install the Multilingual App Toolkit 4.0

多言語アプリ ツールキット 4.0 (MAT 4.0) は 2 つの部分から構成され、それぞれ独自のインストーラーがあります。There are two parts to the Multilingual App Toolkit 4.0 (MAT 4.0), each with its own installer.

Visual Studio 2017 または Visual Studio 2019 を使用する場合は、ダウンロードして、1 つずつ両方のインストーラーを実行します。If you use Visual Studio 2017 or Visual Studio 2019, then download and run both installers, one after the other. Visual Studio 2015 または Visual Studio 2013 を使用している場合は、.msi インストーラーをダウンロードして実行します。If you use Visual Studio 2015 or Visual Studio 2013, then download and run the .msi installer.

手順 3.Step 3. プロジェクトの多言語アプリ ツールキットを有効にします。Enable the Multilingual App Toolkit for your project

多言語アプリ ツールキットは、アプリをローカライズする前に、プロジェクトで使用できるようにする必要があります。The MAT must be enabled for your project before you can begin to localize the app. ツールキットを有効にするには、次の手順に従います。Here's how to enable the toolkit.

  • Visual Studio でプロジェクト ソリューションを開きます。Open the project solution in Visual Studio.
  • ソリューション エクスプローラーで、目的のプロジェクトを選びます。Select the desired project in Solution Explorer.
  • [ツール] メニューで、 [多言語アプリ ツールキット] > [選択を有効にする] の順に選択します。On the Tools menu, select Multilingual App Toolkit > Enable selection.

(多言語アプリ ツールキットからの出力を表示する) 出力ウィンドウで、Project '<project-name>' was enabled. The project's source culture is '<language-tag>' <language-name> というメッセージを監視します。In the Output window (showing output from Multilingual App Toolkit), watch for the message Project '<project-name>' was enabled. The project's source culture is '<language-tag>' <language-name>. このメッセージが表示された場合、多言語アプリ ツールキットが使用可能です。If this message appears, then the MAT is ready to use.

手順 4.Step 4. プロジェクトへの言語の追加Add languages to your project

次の手順に従って、プロジェクトに言語を追加します。Follow these steps to add languages to your project.

  1. ソリューション エクスプローラーでプロジェクト ノードを右クリックします。Right-click the project node in Solution Explorer.
  2. [多言語アプリ ツールキット] > [Add translation languages...] (翻訳言語の追加) の順にクリックします。Click Multilingual App Toolkit > Add translation languages....
  3. [Translation Languages] (翻訳言語) ダイアログで、サポートする言語を選んで [OK] をクリックします。In the Translation Languages dialog, select the language(s) you want to support, and click OK.

ツールキットは、応答としてこれらを実行します。The toolkit does these things in response.

  • 追加した言語ごとに、言語の BCP-47 言語タグ の名前が付いた新しいフォルダーが作成されます。For each language you added, a new folder is created named for the BCP-47 language tag of the language. そのフォルダー内に、既定の言語の文字列が含まれているものと一致する新しいリソース ファイル (.resw) が作成されます。Inside that folder, new Resources File(s) (.resw) are created to match the one(s) that contain the default language strings.
  • 初めて言語を追加した場合は、MultilingualResources という名前の新しいフォルダーがプロジェクトに追加されます。If this is the first time you've added a language, a new folder named MultilingualResources is added to the project. そのフォルダー内で、言語ごとに .xlf ファイルが追加されます。Inside that folder, an .xlf file is added for each language. .xlf ファイルには、プロジェクトの各リソース ファイル (.resw) 内の文字列ごとに翻訳単位が含まれます。The .xlf files contain a translation unit for each string in each Resources File (.resw) in your project.
  • 出力ウィンドウには、追加した言語の追加を確認するメッセージが表示されます。The Output window confirms the addition of the language(s) that you added.

既定の言語のリソース ファイル (.resw) を追加または削除するたびに、または既定の言語のリソース ファイル (.resw) 内の文字列を追加または削除するたびに、.xlf ファイルを再同期するようにプロジェクトをリビルドします。Whenever you add/remove a default language Resources File (.resw), or you add/remove a string inside a default language Resources File (.resw), rebuild the project to re-synchronize the .xlf files. これにより、.xlf ファイルに既定の言語の統合した文字列が含まれるようになります。This ensures that the .xlf files contain the union of the strings in the default language.

翻訳サービスがインストールされている—など、 Microsoft ランゲージ ポータルMicrosoft Translator—アプリのリソースを翻訳するために使用できます。Installed Translation Providers—such as the Microsoft Language Portal and Microsoft Translator—can be used to translate your app's resources. プロバイダーが特定の言語をサポートしている場合、プロバイダーのアイコンが [Translation Languages] (翻訳言語) ダイアログの言語名の横に表示されます。When a provider supports a specific language, the provider's icon is displayed next to the language name in the Translation Languages dialog.

[Translation Languages] (翻訳言語) ダイアログでは、ツールキットで検出可能な .xlf ベースの言語は、選択ボックスがあらかじめオンになり、その言語がプロジェクトに既に含まれていることを示しています。In the Translation Languages dialog, any existing .xlf-based languages that are discovered by the toolkit have their selection box pre-checked to indicate that the language is already included the project.

プロジェクトに追加した言語は、[Translation Languages] (翻訳言語) ダイアログのチェック ボックスをオフにしても削除できません。Once a language is added to the project, it cannot be removed by un-checking the box in the Translation Languages dialog. 言語を削除するには、言語固有の .xlf ファイルを右クリックし、 [削除] を選びます。To remove a language, right-click on the language-specific .xlf file and select Delete. 確定すると、対応するリソース ファイル (.resw) も削除されます。If you confirm, then this will also delete the corresponding Resources File (.resw).

手順 5.Step 5. 擬似言語を使ったアプリのテストTest your app using pseudo language

擬似言語とは、実際の言語翻訳をシミュレートすることを目的としたソフトウェア製品に加えられる人為的な変更のことで、ネイティブ スピーカーはこれを読み取ることができます。Pseudo language is an artificial modification of the software product intended to simulate real language localization, but remaining readable to native speakers. 擬似言語を使うと、文字が置き換えられ、リソース文字列の長さが拡張されて、本格的にローカライズを始める前のプロジェクト サイクルの初期段階で、ローカライズの可否に関する問題やバグを検出できます。Pseudo translation replaces characters and expands the resource string length to detect potential localizability issues or bugs early in the project cycle and before localization starts in earnest.

次の手順に従って、プロジェクトを擬似言語でローカライズしてテストします。Follow these steps to pseudo-localize and test your project.

  1. [Translation Languages] (翻訳言語) ダイアログを使って 擬似言語 (Pseudo) [qps-ploc] をプロジェクトに追加します。Use the Translation Languages dialog to add Pseudo Language (Pseudo) [qps-ploc] to your project.
  2. ソリューション エクスプローラーで <project-name>.qps-ploc.xlf ファイルを右クリックし、 [多言語アプリ ツールキット] > [Generate machine translations] (機械翻訳の生成) の順にクリックします。Right-click the <project-name>.qps-ploc.xlf file in Solution Explorer and click Multilingual App Toolkit > Generate machine translations.
  3. [設定] > [時刻と言語] > [地域と言語] > [言語] で、 [言語の追加] をクリックします。In Settings > Time & Language > Region & language > Languages, click Add a language.
  4. 検索ボックスに「qps-ploc」と入力します。In the search box, type qps-ploc.
  5. [English (qps-ploc)] をクリックして追加します。Click English (qps-ploc) to add it.
  6. 言語の一覧から [English (qps-ploc)] を選択し、 [既定に設定] をクリックします。From the language list, select English (qps-ploc) and click Set as default.
  7. 擬似言語でローカライズしたアプリをテストします。Test your pseudo-localized app. たとえば、一部の文字列が表示されない (文字列が切り捨てられている) または文字列が翻訳されていない (代わりにハード コーディングされている) という UI レイアウトに関する問題を探します。For example, look for UI layout issues where not all of a string is displayed (the string is truncated), or strings that are not translated (but instead hard-coded).

文字の置き換えと拡張だけでなく、擬似エンジンは各リソースに対して固有の追跡 ID を提供します。In addition to character replacement and expansion, the pseudo engine provides a unique tracking identifier for each resource. このトラッカーは、各文字列の先頭に追加され、角かっこで囲まれます ([xxxxx])。This tracker is prepended to the start of every string and enclosed within brackets [xxxxx]. これらのトラッカーは、視覚的な UI の検査テスト時に使うことができます。You can use these trackers during visual UI inspection testing. これらのトラッカーは、特に複数のリソースに類似するテキストや重複するテキストが含まれている場合、製品の特定のリソースを調べるのに役立ちます。They can help track down specific resources in the product, especially if multiple resources have similar or duplicate text.

次の "Hello, World!" というIn this "Hello, World!" テキストの例では、擬似翻訳が画面の約 30% 広いスペースを占めるまで拡張され、リソース トラッカーが適用されます。text example, the pseudo translation expands to take about 30 percent more screen space, and then applies the resource tracker.

"Hello World" -> "Ĥèĺļõ Ŵòŗłđ" -> "[!!_Ĥèĺļõ Ŵòŗłđ_!!]" -> "[hJ8s1][!!_Ĥèĺļõ Ŵòŗłđ_!!]"

手順 6.Step 6. 選んだ言語へのアプリの翻訳Translate your app into selected languages

多言語アプリ ツールキットは、ビルド プロセスに統合されています。The Multilingual App Toolkit is integrated into the build process. ビルド時に、更新された文字列が各言語の .xlf ファイルに自動で追加されます。During a build, updated strings are automatically added to each language .xlf file. 擬似言語を使ってアプリをテストした後は、アプリをリリース用言語に翻訳します。その方法には 3 種類あります。After you've tested your app by using Pseudo language, there are three options to translate your app into other languages for release.

オプション 1.Option 1. 自分で文字列を翻訳するTranslate the strings yourself

多言語エディターを使用して、文字列を個別に翻訳することができます。You can use the Multilingual Editor to translate strings individually. 既に説明したように、これは .msi インストーラー に含まれています。As already mentioned, this is included in The .msi installer.

  • 翻訳する .xlf ファイルを右クリックします。Right-click the .xlf file that you want to translate.
  • [ファイルを開くアプリケーションの選択] をクリックして多言語エディターを選択します。Click Open With... and select Multilingual Editor. 必要に応じて、 [既定値として設定] をクリックすることもできます。You can optionally click Set as Default.
  • 各文字列名について、 [ソース] には既定の言語での元の文字列が表示されます。For each string, Source shows the original string in the default language. [翻訳] に、編集している .xlf ファイルの適切な言語に翻訳された文字列を入力します。In Translation, type the string translated into the appropriate language for the .xlf file that you're editing.
  • 完了したら、ファイルを保存して閉じます。When you're done, save and close the file.

翻訳された文字列が、編集していた .xlf ファイルに対応するリソース ファイル (.resw) にコピーされるようにプロジェクトをリビルドします。Rebuild your project to cause the translated strings to be copied into the Resources File (.resw) that corresponds to the .xlf file you were just editing.

次のように、多言語エディターを起動することもできます。You can also launch the Multilingual Editor like this. [スタート] に移動してすべてのアプリを表示し、多言語アプリ ツールキット フォルダーを開き、[Multilingual Editor] (多言語エディター) をクリックして起動します。Go to Start, show all apps, open the Multilingual App Toolkit folder, and click Multilingual Editor to launch it.

オプション 2.Option 2. .xlf ファイルをサード パーティに送付して翻訳を依頼するSend the .xlf files to a third party for translation

翻訳と編集の作業をローカライズ業者に委託するには、ソリューション エクスプローラーで必要な .xlf ファイルを選択して右クリックし、 [多言語アプリ ツールキット] > [Export translations...] (翻訳をエクスポート...) をクリックします。To outsource the translation and editing work to localizers, select the desired .xlf files in Solution Explorer, right-click them, and click Multilingual App Toolkit > Export translations....

選択出力。メールの宛先エクスポート文字列リソースのダイアログ ボックスをクリックして、ok をクリックし、ファイルは圧縮し、新しいメールに添付します。Select Output: Mail recipient in the Export string resources dialog, and click OK, and your files will be zipped and attached to a new email. 選択出力。ファイル フォルダーの場所、ブラウザー フォルダーとクリックを必要に応じて用に選択ファイルを圧縮するには、[ok] を再度クリックし、ファイル (zip 形式と)、プロジェクトの名前が付いた新しいフォルダーの中に、選択した場所に保存します。Select Output: File folder location, browser for a folder and click OK, optionally choose for the files to be zipped, click OK again, and your files will be (zipped and) saved at the location you chose, inside a new folder named for your project.

ローカライズ担当者が翻訳作業を完了して翻訳済みの xlf ファイルが送られてきたら、それをプロジェクトにインポートすることができます。After your localizers complete the translation work and send you the translated .xlf files, you can import them into your project. ソリューション エクスプ ローラーで目的の .xlf ファイルを選択し、右クリック、をクリックしてMultilingual App Toolkit > 翻訳のインポート/リサイクルしています. .クリックして追加、.xlf または .zip ファイルに移動し、クリックして、インポートします。Select the desired .xlf files in Solution Explorer, right-click them, and click Multilingual App Toolkit > Import/recycle translations.... Click Add, navigate to the .xlf or .zip files, and click Import.

インポート前にはインポート プロセスによって基本事項が検証されます。Note The import process performs basic validation before importing. これは、インポートするファイル内の対象となるカルチャ情報が現在の .xlf ファイルのカルチャ情報と一致することを確認するためのものです。This ensures that the target culture information in the files being imported matches that in the existing .xlf files.

翻訳された文字列が、インポートした .xlf ファイルに対応するリソース ファイル (.resw) にコピーされるようにプロジェクトをリビルドします。Rebuild your project to cause the translated strings to be copied into the Resources File(s) (.resw) that corresponds to the .xlf file(s) you just imported.

次のサード パーティ プロバイダーはローカライズ サービスを提供していて、ユーザーを支援できる可能性があります。These third party providers offer localization services, and may be able to assist you.

注意

上記のリストは情報提供のみを目的としており、推奨するものではありません。The list above is provided for informational purposes only and is not an endorsement. Microsoft は、これらのベンダーやそのサービスに関し、いかなる表明および保証もするものではありません。また、どのような状況でも、Microsoft はそれらのベンダーやサービスの使用に関し、いかなる責任も負いません。Microsoft does not make any representation or warranty regarding these vendors or their services, and under no circumstances will Microsoft have any liability for your use of such vendors or services. それらのベンダーまたはそのサービスに関する論争、苦情、請求については、それぞれのベンダーに問い合わせる必要があります。Any questions, complaints, or claims regarding such vendors or their services must be directed to the appropriate vendor.

オプション 3.Option 3. 統合された翻訳サービスを使うUse the integrated translation services

多言語エディターに加えて Visual Studio IDE にも翻訳サービスが統合されています。Translation services are integrated into the Visual Studio IDE as well as into the Multilingual Editor. これによって、リソースをローカライズするときだけではなく、製品の開発中にも翻訳サービスに容易にアクセスできます。This provides easy access to translation services while developing your product as well as localizing your resources. このサービスには、「Microsoft Translator Moves to the Azure portal (Microsoft Translator が Azure portal に移行)」に記述されている Azure アカウントのサブスクリプションが必要になります。For this service, you'll need an Azure account subscription, as described in Microsoft Translator Moves to the Azure portal.

Visual Studio 内で翻訳サービスにアクセスするには、ソリューション エクスプローラーで 1 つ以上の .xlf ファイルを選択して右クリックし、 [Generate machine translations] (機械翻訳の生成) をクリックします。To access the translation services inside Visual Studio, select and right-click one or more .xlf files in Solution Explorer and click Generate machine translations.

多言語エディターを使用する場合も、対話形式で翻訳候補を追加する同様の翻訳サポートが提供され、リソース文字列に最適な翻訳を選ぶことができます。The Multilingual Editor provides the same translation support, as well as adding interactive translation suggestions, which enable you to select the translation that best fits your resource strings. 翻訳候補が挿入されたら、各自の翻訳スタイルに合わせて文字列を調整することができます。After the translation suggestion is provided, you can fine-tune the string for your translation style.

多言語アプリ ツールキットには、2 種類のプロバイダーが付属しています。Two providers are shipped with the Multilingual App Toolkit.

  • Microsoft Language Portal プロバイダーは、Microsoft の製品やサービスのユーザー インターフェイス テキストの翻訳に基づいて、翻訳のリサイクルおよび用語の検索を可能にします。The Microsoft Language Portal provider enables translation-recycling and terminology-matching support based on translations of the user interface text for Microsoft products and services.
  • Microsoft Translator プロバイダーは、オンデマンドの機械翻訳サービスを実現します。The Microsoft Translator provider enables on-demand machine translation services.

多言語エディターでは、翻訳に確信が持てない箇所を後で確認できるよう、翻訳の状態を管理することができます。You and your translator(s) can manage the status of translations in the Multilingual Editor to review uncertain translations later. 各文字列の状態を設定することができます、プロパティタブ。状態値は次のとおりです。新しいNeeds review翻訳最終的な、およびサインオフします。You can set the status of each string in the Properties tab. Status values are: New, Needs review, Translated, Final, and Signed off. 行の左にあるインジゲーターに状態が示されます。The indicator at the left of the row shows the status. 多言語エディターですべての行が緑色になれば、翻訳作業は終了となります。When all rows show green in the Multilingual Editor, then your translation work is done.

翻訳された文字列が、編集した .xlf ファイルに対応するリソース ファイル (.resw) にコピーされるようにプロジェクトをリビルドします。Rebuild your project to cause the translated strings to be copied into the Resources File(s) (.resw) that corresponds to the .xlf file(s) you just edited.

手順 7.Step 7. Microsoft Store へのアプリのアップロードUpload your app to the Microsoft Store

Microsoft Store の認定プロセスを開始する前に、<project-name>.qps-ploc.xlf ファイルをプロジェクトから除外する必要があります。Before you start the Microsoft Store Certification process, you must exclude the <project-name>.qps-ploc.xlf file from your project. 擬似言語を使うと、ローカライズの可否に関して起きる可能性のある問題やバグを検出できますが、擬似言語は有効な Microsoft Store の言語ではありません。Pseudo language is used to detect potential localizability issues or bugs, but it is not a valid Microsoft Store language. 除外しなかった場合、Microsoft Store の認定プロセスでアプリが不合格になります。If it is not removed then your app will fail during the Microsoft Store Certification process.

ダウンロードDownloads

翻訳サービスTranslation services