보고서 작성기 - Power BI에서 페이지를 매긴 보고서에 직접 데이터 입력Enter data directly in a paginated report in Report Builder - Power BI

적용 대상:APPLIES TO: ✔️ Power BI 서비스✔️ Power BI service ✔️ Power BI 페이지를 매긴 보고서✔️ Power BI paginated reports ✔️ Power BI Premium✔️ Power BI Premium ❌ Power BI Desktop❌ Power BI Desktop적용 대상:APPLIES TO: ✔️ Power BI 서비스✔️ Power BI service ✔️ Power BI 페이지를 매긴 보고서✔️ Power BI paginated reports ✔️ Power BI Premium✔️ Power BI Premium ❌ Power BI Desktop❌ Power BI Desktop

이 문서에서는 포함된 데이터 세트로 RDL 보고서에 직접 데이터를 입력할 수 있는 Microsoft Power BI Report Builder의 새 버전 기능에 대해 알아봅니다.In this article, you learn about a feature in the new version of Microsoft Power BI Report Builder that lets you enter data directly into an RDL report as an embedded dataset. 이 기능은 Power BI Desktop과 비슷합니다.This feature is similar to Power BI Desktop. 보고서의 데이터 세트에 직접 데이터를 입력하거나 Microsoft Excel과 같은 다른 프로그램에서 붙여넣을 수 있습니다.You can type the data directly in a dataset in your report, or paste it from another program like Microsoft Excel. 데이터를 입력하여 데이터 세트를 만든 후에는 다른 포함된 데이터 세트와 마찬가지로 데이터 세트를 사용할 수 있습니다.After you've created a dataset by entering data, you can use it just like you would any other embedded dataset you've created. 또한 둘 이상의 테이블을 추가하고 하나를 다른 테이블을 위한 필터로 사용할 수 있습니다.Plus you can add more than one table and use one as a filter for the other. 이 기능은 보고서 매개 변수처럼 보고서에서 사용해야 할 수 있는 작고 정적인 데이터 세트에 특히 유용합니다.This feature is especially useful for small, static datasets you might need to use in your report, like report parameters.

필수 조건Prerequisites

데이터 원본 및 데이터 세트 만들기Create a data source and dataset

보고서 작성기를 다운로드하고 설치한 후에는 포함된 데이터 원본과 데이터 세트를 보고서에 추가하는 데 사용하는 것과 동일한 워크플로를 수행합니다.After you’ve downloaded and installed Report Builder, you follow the same workflow you use to add an embedded data source and dataset to your report. 다음 프로시저에서는 데이터 원본 아래에 새 옵션인 데이터 입력 이 표시됩니다.In the following procedure, under Data Sources you see a new option: Enter Data. 이 데이터 원본은 보고서에 한 번만 설정하면 됩니다.You only need to set up this data source once in a report. 그런 다음, 입력된 데이터의 여러 테이블을 별도의 데이터 세트로 만들 수 있으며, 모두 해당 단일 데이터 원본을 사용합니다.After that, you can create multiple tables of entered data as separate datasets, all using that single data source.

  1. 보고서 데이터 창에서 새로 만들기 > 데이터 세트 를 선택합니다.In the Report Data pane, select New > Dataset.

    Report Builder 새 데이터 세트의 스크린샷.

  2. 데이터 세트 속성 대화 상자에서 내 보고서에 포함된 데이터 세트 사용 을 선택합니다.In the Dataset Properties dialog box, select Use a dataset embedded in my report.

  3. 데이터 원본 옆에 새로 만들기 를 선택합니다.Next to Data source, select New.

    새 포함된 데이터 원본의 스크린샷.

  4. 데이터 원본 속성 대화 상자에서 내 보고서에 포함된 연결 사용 을 선택합니다.In the Data Source Properties dialog box, select Use a connection embedded in my report.

  5. 연결 유형 선택 상자에서 ENTER DATA > 확인 을 선택합니다.In the Select connection type box, select ENTER DATA > OK.

    ENTER DATA 데이터 원본의 스크린샷.

  6. 데이터 세트 속성 대화 상자로 돌아가서 쿼리 디자이너 를 선택합니다.Back in the Dataset Properties dialog box, select Query Designer.

  7. 쿼리 디자이너 창에서 데이터를 마우스 오른쪽 단추로 클릭하고 테이블에 데이터를 붙여넣습니다.In the Query Designer pane, right-click and paste your data in the table.

    쿼리 디자이너에 데이터 입력의 스크린샷.

  8. 열 이름을 설정하려면 각 NewColumn 을 두 번 클릭하고 열 이름을 입력합니다.To set the column names, double-click each NewColumn and type the column name.

    열 이름 설정의 스크린샷.

  9. 첫 번째 행에 원래 데이터의 열 머리글이 포함된 경우 마우스 오른쪽 단추로 클릭하고 삭제합니다.If the first row contains column headings from the original data, right-click and delete it.

  10. 기본적으로 각 열의 데이터 형식은 문자열입니다.By default, the data type for each column is String. 데이터 형식을 변경하려면 열 머리글 > 형식 변경 을 마우스 오른쪽 단추로 클릭하고 날짜 또는 Float와 같은 다른 데이터 형식으로 설정합니다.To change the data type, right-click the column header > Change Type, and set it to another data type, such as Date or Float.

    데이터 형식 변경의 스크린샷.

  11. 테이블 만들기를 완료한 경우 확인 을 선택합니다.When you’ve finished creating the table, select OK.

    생성되는 쿼리는 XML 데이터 원본에서 볼 수 있는 것과 동일합니다.The query that’s generated is the same as you’d see with an XML data source. 내부적으로 XML을 데이터 공급자로 사용하고 있습니다.Under the covers, we’re using XML as the data provider. 이 시나리오에도 사용하도록 용도를 변경했습니다.We’ve repurposed it to enable this scenario as well.

    XML 데이터 구조의 스크린샷.

  12. 데이터 세트 속성 대화 상자에서 확인 을 선택합니다.In the Dataset Properties dialog box, select OK.

  13. 보고서 데이터 창에 데이터 원본 및 데이터 세트가 표시됩니다.You see your data source and dataset in the Report Data pane.

    보고서 데이터 창에 있는 데이터 세트의 스크린샷.

데이터 세트를 보고서의 데이터 시각화를 위한 기초로 사용할 수 있습니다.You can use your dataset as the basis for data visualizations in your report. 다른 데이터 세트를 추가하고 동일한 데이터 원본을 사용할 수도 있습니다.You can also add another dataset and use the same data source for it.

보고서 디자인Design the report

이제 데이터 원본 및 데이터 세트가 있으므로 보고서를 만들 준비가 되었습니다.Now that you have a data source and dataset, you're ready to create your report. 다음 절차에서는 이전 섹션의 데이터를 기반으로 간단한 보고서를 만듭니다.The following procedure creates a simple report based on the data in the previous section.

  1. 삽입 메뉴에서 테이블 > 테이블 마법사 를 선택합니다.On the Insert menu, select Table > Table Wizard.

    테이블 마법사 옵션을 선택하는 스크린샷.

  2. 방금 만든 데이터 세트 > 다음 을 선택합니다.Select the dataset you just created > Next.

    데이터 세트 선택 대화 상자의 스크린샷.

  3. 필드 정렬 페이지의 사용 가능한 필드 상자에서 행 그룹 상자로 그룹화할 필드를 끌어 옵니다.In the Arrange fields page, drag fields you want to group by from the Available fields box to the Row groups box. 이 예제에서는 다음이 적용됩니다.In this example:

    • CountryRegionCountryRegion
    • SalesYearSalesYear
  4. 사용 가능한 필드 상자에서 상자로 집계하려는 필드를 끌어 옵니다.Drag the fields you want to aggregate from the Available fields box to the Values box. 이 예제에서는 다음이 적용됩니다.In this example:

    • SalesAmountSalesAmount

    기본적으로 Report Builder는 상자의 필드 합계를 계산하지만 다른 집계를 선택할 수 있습니다.By default, Report Builder sums the fields in the Values box, but you can choose another aggregation.

    선택할 다양한 집계의 스크린샷.

  5. 다음 을 선택합니다.Select Next.

  6. 레이아웃 선택 페이지에서 모든 기본 설정을 유지하되 그룹 확장/축소 는 선택 취소합니다.In the Choose the layout page, keep all the default settings, but clear Expand/collapse groups. 일반적으로 그룹을 확장 및 축소하는 것이 좋지만 이번에는 모든 데이터를 보려고 합니다.In general, expanding and collapsing groups is great, but this time we want to see all the data.

  7. 다음 > 마침 을 선택합니다.Select Next > Finish. 테이블이 디자인 화면에 표시됩니다.The table is displayed on the design surface.

    디자인 뷰에 있는 보고서의 스크린샷.

보고서 실행Run the report

실제 값을 확인하고 보고서를 미리 보려면 보고서를 실행합니다.To see the actual values and preview the report, you run it.

  1. 리본에서 실행 을 선택합니다.Select Run in the Home ribbon.

    홈 리본에서 실행을 선택하는 스크린샷.

    이제 값이 표시됩니다.Now you see the values. 행렬에는 디자인 뷰에 표시되는 것보다 더 많은 행이 있습니다.The matrix has more rows than you saw in Design view! 로컬 컴퓨터에 저장하거나 서비스에 게시하기 전에 기본 설정을 사용하도록 결정하거나 페이지 서식을 지정할 수 있습니다.You can either format the page or decide to use the default settings before saving to your local computer or publishing to the service.

  2. 보고서를 인쇄할 때 표시되는 모양을 보려면 인쇄 레이아웃 을 선택합니다.To see how your report will look when you print it, select Print Layout.

    인쇄 레이아웃을 선택하는 스크린샷.

    이제 인쇄된 페이지에 표시되는 것처럼 보입니다.Now you see it as it will look on a printed page.

    인쇄 모양 보기의 보고서 스크린샷.

Power BI 서비스에 페이지를 매긴 보고서 업로드Upload the paginated report to the Power BI service

이제 Power BI 서비스에서 페이지를 매긴 보고서가 지원되므로, 페이지를 매긴 보고서를 프리미엄 용량으로 업로드할 수 있습니다.Now that paginated reports are supported in the Power BI service, you can upload your paginated report to a Premium capacity. 자세한 정보는 페이지를 매긴 보고서 업로드를 참조하세요.See Upload a paginated report for details.

보고서 서버에 페이지를 매긴 보고서 업로드Upload the paginated report to a report server

Power BI Report Server, SQL Server Reporting Services 2016 또는 2017 보고서 서버에 페이지를 매긴 보고서를 업로드할 수도 있습니다.You can also upload your paginated report to a Power BI Report Server or SQL Server Reporting Services 2016 or 2017 report server. 수행하기 전에 RsReportServer.config에 다음 항목을 추가 데이터 확장으로 추가해야 합니다.Before you do, you need to add the following item to your RsReportServer.config as an additional data extension. 문제가 발생할 경우를 대비하여 변경하기 전에 RsReportServer.config 파일을 백업하세요.Back up your RsReportServer.config file before you make the change, in case you run into any issues.

<Extension Name="ENTERDATA" Type="Microsoft.ReportingServices.DataExtensions.XmlDPConnection,Microsoft.ReportingServices.DataExtensions">
    <Configuration>
        <ConfigName>ENTERDATA</ConfigName>
    </Configuration>
</Extension>

편집한 후 구성 파일의 데이터 공급자의 목록이 다음과 같이 표시되어야 합니다.After you've edited it, here's what the list of data providers in the config file should look like:

RsReportServer 구성 파일의 스크린샷.

끝났습니다. 이제 이 새로운 기능을 사용하는 보고서를 보고서 서버에 게시할 수 있습니다.That’s it – you can now publish reports that use this new functionality to your report server.

다음 단계Next steps