자습서: 페이지를 매긴 보고서를 만들어 Power BI 서비스에 업로드Tutorial: Create a paginated report and upload it to the Power BI service

적용 대상:APPLIES TO: ✔️ Power BI 서비스✔️ Power BI service ✔️ Power BI 페이지를 매긴 보고서✔️ Power BI paginated reports ✔️ Power BI Premium✔️ Power BI Premium ❌ Power BI Desktop❌ Power BI Desktop적용 대상:APPLIES TO: ✔️ Power BI 서비스✔️ Power BI service ✔️ Power BI 페이지를 매긴 보고서✔️ Power BI paginated reports ✔️ Power BI Premium✔️ Power BI Premium ❌ Power BI Desktop❌ Power BI Desktop

이 자습서에서는 사용자가 샘플 Azure SQL Database에 연결합니다.In this tutorial, you connect to a sample Azure SQL database. 그런 다음 Power BI 보고서 작성기에서 마법사를 사용하여 여러 페이지에 걸쳐 있는 테이블을 사용하여 페이지를 매긴 보고서를 만듭니다.Then you use a wizard in Power BI Report Builder to create a paginated report with a table that wraps to multiple pages. 그런 다음, Power BI 서비스에 있는 프리미엄 용량의 작업 영역에 페이지를 매긴 보고서를 업로드합니다.Then you upload the paginated report to a workspace in a Premium capacity in the Power BI service.

Power BI 서비스의 페이지를 매긴 보고서

이 자습서에서 수행하는 단계는 다음과 같습니다.Here are the steps you complete in this tutorial:

  • Azure 샘플 데이터베이스를 만듭니다.Create an Azure sample database.
  • 마법사를 사용하여 Power BI 보고서 작성기에서 행렬을 만듭니다.Create a matrix in Power BI Report Builder with the help of a wizard.
  • 각 페이지에 제목, 페이지 번호, 열 제목이 포함되도록 보고서 형식을 지정합니다.Format the report with title, page numbers, and column headings on each page.
  • 통화 형식을 지정합니다.Format the currency.
  • Power BI 서비스에 보고서를 업로드합니다.Upload the report to the Power BI service.

Azure 구독이 아직 없는 경우 시작하기 전에 체험 계정을 만듭니다.If you don't have an Azure subscription, create a free account before you begin.

사전 요구 사항Prerequisites

페이지를 매긴 보고서를 만드는 데 필요한 필수 조건은 다음과 같습니다.Here are the prerequisites for creating the paginated report:

Power BI 서비스로 페이지를 매긴 보고서를 업로드하는 데 필요한 필수 조건은 다음과 같습니다.Here are the prerequisites for uploading your paginated report to the Power BI service:

마법사를 사용하여 행렬 만들기Create the matrix with a wizard

  1. 컴퓨터에서 Power BI Report Builder를 시작합니다.Start Power BI Report Builder from your computer.

    시작 대화 상자가 열립니다.The Getting Started dialog box opens.

    보고서 작성기 시작

  2. 왼쪽 창에서 새 보고서 가 선택되어 있는지 확인하고, 오른쪽 창에서 테이블 또는 행렬 마법사 를 선택합니다.In the left pane, verify that New Report is selected, and in the right pane, select Table or Matrix Wizard.

  3. 데이터 세트 선택 페이지에서 데이터 세트 만들기 > 다음 을 선택합니다.In the Choose a dataset page, select Create a dataset > Next.

    데이터 세트 만들기

  4. 데이터 원본에 대한 연결 선택 페이지에서 새로 만들기 를 선택합니다.In the Choose a connection to a data source page, select New.

    새 데이터 원본

    데이터 원본 속성 대화 상자가 열립니다.The Data Source Properties dialog box opens.

  5. 문자 및 밑줄을 사용하여 원하는 대로 데이터 원본의 이름을 지정할 수 있습니다.You can name a data source anything you want, using characters and underscores. 이 자습서에서는 이름 상자에 MyAzureDataSource 를 입력합니다.For this tutorial, in the Name box, type MyAzureDataSource.

  6. 연결 형식 선택 상자에서 Microsoft Azure SQL Database 를 선택합니다.In the Select connection type box, select Microsoft Azure SQL Database.

  7. 연결 문자열 상자 옆에 있는 작성 을 선택합니다.Select Build next to the Connection string box.

    데이터 원본 속성 - 빌드

  8. Azure에서: Azure Portal로 다시 돌아가 SQL 데이터베이스 를 선택합니다.In Azure: Go back to the Azure portal and select SQL databases.

  9. 이 문서의 필수 조건 섹션에 있는 빠른 시작 “Azure Portal에서 Azure SQL Database 샘플 만들기”에서 만든 Azure SQL Database를 선택합니다.Select the Azure SQL database you created in the quickstart "Create an Azure SQL database sample in the Azure portal" in the Prerequisites section of this article.

  10. 개요 탭에서 서버 이름 상자에 값을 복사합니다.On the Overview tab, copy the value in the Server name box.

  11. 보고서 작성기에서 : 연결 속성 대화 상자의 서버 이름 아래에 복사한 서버 이름을 붙여넣습니다.In Report Builder : In the Connection Properties dialog box, under Server name paste the server name you copied.

  12. 서버에 로그온 하려면 SQL Server 인증 사용 이 선택되어 있는지 확인하고 Azure에서 샘플 데이터베이스에 대해 만든 사용자 이름과 암호를 입력합니다.For Log on to the server , make sure Use SQL Server Authentication is selected, then type the user name and password you created in Azure for the sample database.

  13. 데이터베이스에 연결 아래에서 드롭다운 화살표를 선택하고 Azure에서 만든 데이터베이스 이름을 선택합니다.Under Connect to a database , select the drop-down arrow and select the database name you created in Azure.

    데이터 원본 연결 속성

  14. 연결 테스트 를 클릭합니다.Select Test Connection. 연결 테스트에 성공했습니다.****테스트 결과 메시지가 표시됩니다.You see the Test results message that Test connection succeeded.

  15. 확인 > 확인 을 선택합니다.Select OK > OK.

    이제 보고서 작성기는 연결 문자열 상자에 방금 만든 연결 문자열을 표시합니다.Now in the Connection string box, Report Builder displays the connection string you just created.

    데이터 원본 연결 문자열

  16. 확인 을 선택합니다.Select OK.

  17. 데이터 원본에 대한 연결 선택 페이지에 있는 방금 만든 데이터 원본 연결 아래에 “(이 보고서)”가 표시됩니다.In the Choose a connection to a data source page, you see "(in this Report)" under the data source connection you just created. 해당 데이터 원본 > 다음 을 선택합니다.Select that data source > Next.

    내 Azure 데이터 원본

  18. 동일한 사용자 이름 및 암호를 상자에 입력합니다.Type the same user name and password in the box.

  19. 쿼리 디자인 페이지에서 SalesLT, 테이블을 차례로 확장하고 다음 테이블을 선택합니다.In the Design a query page, expand SalesLT, expand Tables, and select these tables:

    • 주소Address
    • CustomerCustomer
    • ProductProduct
    • ProductCategoryProductCategory
    • SalesOrderDetailSalesOrderDetail
    • SalesOrderHeaderSalesOrderHeader

    관계 > 자동 검색 이 선택되어 있으므로 보고서 작성기가 해당 테이블 간 관계를 검색합니다.Because Relationships > Auto Detect is selected, Report Builder detects the relationships between these tables.

    쿼리 디자인

  20. 쿼리 실행 을 선택합니다.Select Run Query. 보고서 작성기가 쿼리 결과 를 표시합니다.Report Builder displays the Query results.

    쿼리 결과

  21. 다음 을 선택합니다.Select Next.

  22. 데이터 세트 선택 페이지에서 방금 만든 데이터 세트 > 다음 을 선택합니다.In the Choose a dataset page, choose the dataset you just created > Next.

    데이터 세트 선택

  23. 필드 정렬 페이지의 사용 가능한 필드 상자에서 행 그룹 상자로 다음 필드를 끌어 옵니다.In the Arrange fields page, drag these fields from the Available fields box to the Row groups box:

    • CompanyNameCompanyName
    • SalesOrderNumberSalesOrderNumber
    • Product_NameProduct_Name
  24. 사용 가능한 필드 상자에서 상자로 다음 필드를 끌어 옵니다.Drag these fields from the Available fields box to the Values box:

    • OrderQtyOrderQty
    • 단가UnitPrice
    • LineTotalLineTotal

    보고서 작성기가 자동으로 상자에 있는 필드의 합계를 냅니다.Report Builder automatically made the fields in the Values box sums.

    필드 정렬

  25. 레이아웃 선택 페이지에서 모든 기본 설정을 유지하되 그룹 확장/축소 는 선택 취소합니다.In the Choose the layout page, keep all the default settings, but clear Expand/collapse groups. 일반적으로 그룹 확장/축소 기능은 매우 유용하지만 여기에서는 테이블이 여러 페이지로 래핑되도록 하려고 합니다.In general, the expand/collapse groups feature is great, but this time you want the table to wrap to multiple pages.

  26. 다음 > 마침 을 선택합니다.Select Next > Finish. 테이블이 디자인 화면에 표시됩니다.The table is displayed on the design surface.

만든 항목What you've created

잠시 진행을 멈추고 마법사의 결과를 살펴보겠습니다.Let's pause for a moment to look at the results of the wizard.

행렬 마법사 결과

  1. 보고서 데이터 창에는 포함된 Azure 데이터 원본과 이를 기반으로 한 포함된 데이터 세트가 표시됩니다. 데이터 원본과 데이터 세트 모두 직접 만든 것입니다.In the Report Data pane, you see the embedded Azure data source and the embedded dataset based on it, both of which you created.

  2. 디자인 화면은 너비가 약 6인치입니다.The design surface is about 6 inches wide. 디자인 화면에서 열 제목과 자리 표시자 값이 표시된 행렬을 볼 수 있습니다.On the design surface, you see the matrix, displaying column headings and placeholder values. 행렬은 열이 6개 있으며 5개 행만 표시되는 높이로 나타납니다.The matrix has six columns and appears to be only five rows tall.

  3. 주문 수량, 단가 및 라인 합계는 모두 합계이며 각 행 그룹에는 소계가 있습니다.Order Qty, Unit Price, and Line Total are all sums, and each row group has a subtotal.

    실제 데이터 값은 아직 표시되지 않습니다.You still don't see actual data values. 해당 값을 보려면 보고서를 실행해야 합니다.You need to run the report to see them.

  4. 속성 창에서 선택한 행렬은 Tablix1이라고 합니다.In the Properties pane, the selected matrix is called Tablix1. 보고서 작성기의 ‘테이블릭스’는 행과 열로 데이터를 표시하는 데이터 영역입니다.A tablix in Report Builder is a data region that displays data in rows and columns. 테이블이거나 행렬입니다.It can be either a table or a matrix.

  5. 그룹화 창에는 마법사에서 만든 다음 세 개의 행 그룹이 표시됩니다.In the Grouping pane, you see the three row groups you created in the wizard:

    • CompanyNameCompanyName
    • Sales OrderSales Order
    • 제품 이름Product Name

    이 매트릭스에는 열 그룹이 없습니다.This matrix doesn't have any column groups.

보고서 실행Run the report

실제 값을 보려면 보고서를 실행해야 합니다.To see the actual values, you need to run the report.

  1. 도구 모음에서 실행 을 선택합니다.Select Run in the Home toolbar.

    이제 값이 표시됩니다.Now you see the values. 행렬에는 디자인 뷰에 표시되는 것보다 훨씬 더 많은 행이 있습니다.The matrix has many more rows than you saw in Design view! 보고서 작성기에 1 / 2? 페이지로 표시된 것에 유의하세요.Note that Report Builder says it's page 1 of 2?. 보고서 작성기는 가능한 한 빠르게 보고서를 로드하므로 소수의 페이지를 표시하는 데 충분한 데이터만 한 번에 검색합니다.Report Builder loads the report as quickly as possible, so it only retrieves enough data for a few pages at a time. 물음표는 보고서 작성기가 아직 일부 데이터를 로드하지 않았음을 나타냅니다.The question mark indicates that Report Builder hasn't loaded all the data yet.

    보고서 실행

  2. 인쇄 레이아웃 을 선택합니다.Select Print Layout. 보고서를 인쇄하면 해당 형식이 됩니다.The report will be in this format when you print it. 이제 보고서 작성기는 보고서에 33페이지가 있음을 알고 있으며 바닥글에 날짜 및 시간 스탬프를 자동으로 추가했습니다.Report Builder now knows the report has 33 pages, and has automatically added a date and time stamp in the footer.

보고서 형식 지정Format the report

이제 33페이지로 래핑된 행렬이 있는 보고서가 있습니다.Now you have a report with a matrix that wraps to 33 pages. 몇 가지 다른 기능을 추가하여 보고서 모양을 개선해 보겠습니다.Let's add some other features and improve how it looks. 각 단계를 마칠 때마다 보고서를 실행하여 각 단계가 보고서에 어떻게 적용되었는지 확인할 수 있습니다.You can run the report after every step, if you want to see how it's coming along.

  • 리본의 실행 탭에서 디자인 을 선택하여 수정을 계속할 수 있습니다.On the Run tab of the Ribbon, select Design , so you can continue modifying it.

페이지 너비 설정Set page width

일반적으로 페이지를 매긴 보고서는 인쇄용으로 형식 지정되며 일반적인 페이지는 8.5 X 11인치입니다.Typically a paginated report is formatted for printing, and a typical page is 8 1/2 X 11 inches.

  1. 눈금자를 끌어 디자인 화면 너비가 7인치가 되도록 합니다.Drag the ruler to make the design surface 7 inches wide. 기본 여백은 양쪽 모두 각각 1인치이므로 양쪽 여백을 더 좁혀야 합니다.The default margins are 1 inch on each side, so the side margins need to be narrower.

  2. 디자인 화면 주위의 회색 영역을 클릭하여 보고서 속성을 표시합니다.Click in the gray area around the design surface to show the Report properties.

    속성 창이 표시되지 않으면 보기 탭 > 속성 을 클릭합니다.If you don’t see the Properties pane, click the View tab > Properties.

  3. 여백 을 확장하고 왼쪽오른쪽 을 1인치에서 0.75인치로 변경합니다.Expand Margins and change Left and Right from 1in to 0.75in.

    페이지 여백 설정

보고서 제목 추가Add a report title

  1. 페이지 맨 위에서 제목을 추가하려면 클릭 을 선택하고 회사별 판매액 을 입력합니다.Select the words Click to add title at the top of the page, then type Sales by Company.

  2. 제목 텍스트를 선택하고 글꼴 아래 속성 창에서 파란색 으로 변경합니다.Select the title text, and in the Properties pane under Font , change Color to Blue.

페이지 번호 추가Add a page number

보고서 바닥글에 날짜 및 시간 스탬프가 있는 것을 알 수 있습니다.You noticed the report has a date and time stamp in the footer. 바닥글에 페이지 번호도 추가할 수 있습니다.You can add a page number to the footer, too.

  1. 디자인 화면 아래쪽 바닥글의 오른쪽에 [&ExecutionTime]이 표시되어 있습니다.At the bottom of the design surface, you see [&ExecutionTime] on the right in the footer.

  2. 보고서 데이터 창에서 기본 제공 필드 폴더를 확장합니다.In the Report Data pane, expand the Built-in Fields folder. 페이지 번호 를 바닥글 왼쪽 [&ExecutionTime]과 같은 높이로 끌어 옵니다.Drag Page Number to the left side of the footer, at the same height as [&ExecutionTime].

  3. [&PageNumber] 상자 오른쪽을 끌어 정사각형으로 만듭니다.Drag the right side of the [&PageNumber] box to make it square.

  4. 삽입 탭에서 입력란 을 선택합니다On the Insert tab, select Text Box.

  5. [&PageNumber] 오른쪽을 클릭하고 “/”를 입력한 후 텍스트 상자를 정사각형으로 지정합니다.Click to the right of [&PageNumber], type "of", then make the text box square.

  6. 전체 페이지 수 를 바닥글 “/” 오른쪽으로 끌어온 후 오른쪽 측면을 끌어 정사각형으로 만듭니다.Drag Overall Total Pages to the footer, to the right of "of", then drag its right side to make it square, too.

    페이지 번호 끌기

테이블 더 넓게 만들기Make the table wider

이제 페이지 너비를 채우도록 행렬 너비를 충분히 넓게 하고 이름을 별로 스크롤하지 않아도 되도록 텍스트 열을 넓게 합니다.Now you can make the matrix wide enough to fill the width of the page, and make the text columns wider so the names don't scroll as much.

  1. 행렬을 선택한 후 회사 이름 열을 선택합니다.Select the matrix, then select the Company Name column.

  2. 행렬 맨 위의 회사 이름 열 오른쪽 가장자리에 있는 회색 막대 위에 마우스를 올립니다.Hover over the gray bar at the top of the matrix at the right edge of the Company Name column. 열이 1과 3/8인치에서 끝날 때까지 오른쪽으로 끕니다.Drag to the right, until the column ends at 1 3/8 inches.

    열의 오른쪽 가장자리 끌기

  3. 열이 3과 3/4인치에서 끝날 때까지 제품 이름의 오른쪽 가장자리를 끕니다.Drag the right edge of Product name until the column ends at 3 3/4 inches.

이제 행렬이 인쇄 영역과 너비가 거의 비슷합니다.Now the matrix is almost as wide as the print area.

통화 형식 지정Format the currency

보고서를 실행했을 때 알 수 있었던 것처럼 달러 금액이 아직 통화로 형식 지정되지 않았습니다.If you noticed when you ran the report, the dollar amounts aren't formatted as currency yet.

  1. 왼쪽 상단 [Sum(OrderQty)] 셀을 선택하고 Shift 키를 누른 채 오른쪽 하단 [Sum(LineTotal)] 셀을 선택합니다.Select the upper-left [Sum(OrderQty)] cell, hold down the Shift key, and select lower-right [Sum(LineTotal)] cell.

    통화 값이 있는 셀 선택

  2. 탭에서 달러 기호( $ ) 통화 기호를 선택하고 자리 표시자 > 보기 값 옆에 있는 화살표를 선택합니다.On the Home tab, select the dollar sign ( $ ) currency symbol, then select the arrow next to Placeholder styles > Sample Values.

    샘플 값 표시

    이제 값이 통화로 형식 지정된 것을 볼 수 있습니다.Now you can see the values are formatted as currency.

    통화 샘플 값

각 페이지에서 열 머리글 추가Add column headers on each page

Power BI 서비스에 보고서를 게시하기 전에 한 가지 더 형식 지정 사항을 개선하여 열 머리글이 보고서의 각 페이지에 표시되도록 하겠습니다.One more formatting improvement before publishing the report to the Power BI service: making the column headers show up on each page in the report.

  1. 그룹화 창 위쪽 막대 맨 오른쪽 끝에서 드롭다운 화살표 > 고급 모드 를 선택합니다.In the far-right end of the top bar in the Grouping pane, select the drop-down arrow > Advanced Mode.

    고급 모드 켜기

  2. 행 그룹 에서 맨 위 정적 막대를 선택합니다.Select the top Static bar in the Row Groups. 행렬에서 회사 이름 셀이 선택되어 있는 것을 알 수 있습니다.You see that the Company Name cell in the matrix is selected.

    정적 그룹 선택

  3. 속성 창에 테이블릭스 멤버 속성이 표시되어 있습니다.In the Properties pane, you're looking at the properties for Tablix Member. KeepWithGroupAfter 로 설정하고 RepeatOnNewPageTrue 로 설정합니다.Set KeepWithGroup to After and RepeatOnNewPage to True.

    RepeatOnNewPage 설정

    이제 보고서를 실행하여 어떻게 표시되는지 확인합니다.It's time to run the report and see how it looks now.

  4. 탭에서 실행 을 선택합니다.Select Run on the Home tab.

  5. 인쇄 레이아웃 이 아직 선택되어 있지 않은 경우 선택합니다.Select Print Layout , if it's not already selected. 이제 보고서는 29페이지로 구성되어 있습니다.Now the report has 29 pages. 몇 페이지를 스크롤합니다.Scroll through a few pages. 통화가 형식 지정되었고, 모든 페이지의 열에 제목이 있고, 보고서의 모든 페이지에 페이지 번호와 날짜 및 시간 스탬프로 된 바닥글이 있는 것을 볼 수 있습니다.You see the currency is formatted, the columns have headings on every page, and the report has a footer with page numbers and date and time stamp on every page.

    완료된 페이지

  6. 보고서를 컴퓨터에 저장합니다.Save the report to your computer.

서비스에 보고서 업로드Upload the report to the service

페이지를 매긴 보고서를 만들었으므로 이제 Power BI 서비스에 이 보고서를 업로드합니다.Now that you've created this paginated report, it's time to upload it to the Power BI service.

  1. Power BI 서비스(https://app.powerbi.com)의 탐색 창에서 작업 영역 > 작업 영역 만들기 를 선택합니다.In the Power BI service (https://app.powerbi.com) in the nav pane, select Workspaces > Create workspace.

  2. 작업 영역 이름을 Azure AW 또는 다른 고유한 이름으로 지정합니다.Name your workspace Azure AW , or other unique name. 지금까지는 사용자가 유일한 구성원입니다.You're the only member for now.

  3. 고급 옆에 있는 화살표를 선택하고 전용 용량 을 켭니다.Select the arrow next to Advanced and turn on Dedicated capacity.

    프리미엄 용량에 작업 영역 만들기

    켤 수 없는 경우 전용 프리미엄 용량에 작업 영역을 추가할 수 있는 권한을 부여해 달라고 Power BI 관리자에게 요청해야 합니다.If you can't turn it on, you need to ask your Power BI admin to give you permission to add the workspace to the dedicated Premium capacity.

  4. 이 작업 영역에 사용 가능한 전용 용량 을 선택하고 필요한 경우 > 저장 을 선택합니다.Choose an available dedicated capacity for this workspace , if necessary > Save.

    Premium 다이아몬드 아이콘

    작업 영역이 프리미엄 용량에 없는 경우 보고서를 업로드하려고 하면 “페이지를 매긴 보고서를 업로드할 수 없음” 메시지가 표시됩니다.If the workspace isn't in a Premium capacity, when you try to upload your report you see the message, "Unable to upload paginated report." Power BI 관리자에게 문의하여 작업 영역을 이동하세요.Contact your Power BI administrator to move the workspace.

  5. 새 작업 영역에서 데이터 가져오기 를 선택합니다.In your new workspace, select Get Data.

  6. 파일 상자에서 > 가져오기 를 선택합니다.In the Files box > Get.

  7. 로컬 파일 을 선택하고 파일을 저장한 위치로 이동하여 > 열기 를 선택합니다.Select Local File , navigate to where you saved the file > Open.

    Power BI가 파일을 가져오면 앱 목록 페이지의 보고서 아래에 표시됩니다.Power BI imports your file, and you see it under Reports on the App list page.

    앱 목록의 보고서

  8. 보려는 보고서를 선택합니다.Select the report to view it.

  9. 오류가 발생하는 경우 자격 증명을 다시 입력해야 할 수도 있습니다.If you get an error, you may need to reenter your credentials. 관리 아이콘을 선택합니다.Select the Manage icon.

    보고서 관리

  10. 자격 증명 편집 을 선택하고 Azure 데이터베이스를 만들 때 Azure에서 사용한 자격 증명을 입력합니다.Select Edit credentials and enter the credentials you used in Azure when you created the Azure database.

    보고서 자격 증명 편집

  11. 이제 Power BI 서비스에서 페이지를 매긴 보고서를 볼 수 있습니다.Now you can view your paginated report in the Power BI service.

    Power BI 서비스의 페이지를 매긴 보고서

다음 단계Next steps

Power BI Premium에서 페이지를 매긴 보고서란?What are paginated reports in Power BI Premium?